Subject: [pim] WGLC draft-ietf-pim-rpf-vector-05

From: "Mike McBride (mmcbride)" <[email-masked]>
Date: Mon, 7 Jan 2008 09:08:20 -0800

Today starts a two week wglc for draft-ietf-pim-rpf-vector-05. Please
review the draft and send comments to this list.

http://www.ietf.org/internet-drafts/draft-ietf-pim-rpf-vector-05.txt

thanks,
mike

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Su Haiyang <[email-masked]>
Date: Wed, 09 Jan 2008 12:09:29 +0800

Dear All,
1.  In the section 3.3.3 description about the existence of the PRF vector
and assert is ambiguous. It's first said that upstream should trigger assert
depending on route to PRF_Vector rather than route to source. But then it's
said that downstream route shouldn't carry any RPF_Vetor to the assert
winner: 
"However a Vector Attribute should not be sent in a PIM Join to an upstream
neighbor which is chosen as the result of processing the Assert messages."
So it seems like the downstream router will act as the following:
1).The downstream router send a (S,G)/(*,G) join with RPF_Vector.
2).Assert happens at the RPF_Interface(RPF_Vector) and the assert winner may
be the RPF_NBR(RPF_Vector) as for the downstream router or any other routes.
3).But anyway, the downstream shouldn't carry (*,G)/(S,G) join with any
RPF_Vector.
4).As for the upstream assert winner, shouldn't it discard the RPF_Vector
that won't be carried at the successive (*,G)/(S,G) join? But unfortunately,
the assert winner doesn't have the route to source/RP, it may fail to
refresh the assert winner timer. And finally, the assert winner transition
to NO_INFO and may cause another round assert procedure.

2. It's should be explicitly stated that the RPF_Vector should be carried
with the periodic (*, G) Join and (S,G) RPT Prune pairs. Suppose if the
RPF_NBR(RPF_Vector(RP)) just reboot and lost all previous (*,G) join and
(S,G,RPT) prune state, it's helpful for it to reestablish those state.
Otherwise the data may flow along the RPT tree.
Have a nice day
Su Haiyang

-----Original Message-----
From: Mike McBride (mmcbride) [mailto:[email-masked]] 
Sent: Tuesday, January 08, 2008 1:08 AM
To: [email-masked]
Subject: [pim] WGLC draft-ietf-pim-rpf-vector-05

thanks,
mike

---

From: IJsbrand Wijnands <[email-masked]>
Date: Mon, 14 Jan 2008 11:29:29 +0100

Hi Su,

>> From: Su Haiyang [mailto:[email-masked]]
>> Sent: Tuesday, January 08, 2008 8:09 PM
>> To: Mike McBride (mmcbride); [email-masked]
>> Subject: RE: [pim] WGLC draft-ietf-pim-rpf-vector-05
>>
>> Dear All,
>> 1.  In the section 3.3.3 description about the existence of
>> the PRF vector and assert is ambiguous. It's first said that
>> upstream should trigger assert depending on route to
>> PRF_Vector rather than route to source. But then it's said
>> that downstream route shouldn't carry any RPF_Vetor to the assert
>> winner:
>> "However a Vector Attribute should not be sent in a PIM Join
>> to an upstream neighbor which is chosen as the result of
>> processing the Assert messages."

Ok, I'll clarify this. It should not include a vector to the assert  
winner if this is not the RPF neighbor of the vector. Would that  
solve your problem?

>> 2).Assert happens at the RPF_Interface(RPF_Vector) and the
>> assert winner may be the RPF_NBR(RPF_Vector) as for the
>> downstream router or any other routes.
>> 3).But anyway, the downstream shouldn't carry (*,G)/(S,G)
>> join with any RPF_Vector.
>> 4).As for the upstream assert winner, shouldn't it discard
>> the RPF_Vector that won't be carried at the successive
>> (*,G)/(S,G) join? But unfortunately, the assert winner
>> doesn't have the route to source/RP, it may fail to refresh
>> the assert winner timer. And finally, the assert winner
>> transition to NO_INFO and may cause another round assert procedure.
>>
>> 2. It's should be explicitly stated that the RPF_Vector
>> should be carried with the periodic (*, G) Join and (S,G) RPT
>> Prune pairs. Suppose if the

Why is this different from (S,G), the vector should also be included  
with periodic (S,G) joins, right?

Thx,

Ice.

>> Today starts a two week wglc for
>> draft-ietf-pim-rpf-vector-05. Please review the draft and
>> send comments to this list.
>>

---

From: "Mike McBride (mmcbride)" <[email-masked]>
Date: Tue, 22 Jan 2008 10:03:18 -0800

And today ends the wglc for draft-ietf-pim-rpf-vector-05. Ice will
provide an update to include comments from Su Haiyang and we'll then
forward to IESG for review.

thanks,
mike

> From: Mike McBride (mmcbride) 
> Sent: Monday, January 07, 2008 9:08 AM
> To: [email-masked]