Subject: [pim] draft-farinacci-pim-pop-count-02.txt as wg draft

From: Stig Venaas <[email-masked]>
Date: Sat, 14 Jun 2008 22:02:40 +0200

The PIM Pop Count draft was presented at the last wg meeting. At
the meeting there were 15 people in favour of making it a wg work
item, and 4 against. The draft is available at
http://www.ietf.org/internet-drafts/draft-farinacci-pim-pop-count-02.txt

To determine whether we should adopt it, we need your input. Please
review the draft and respond to the list with opinions on wg adoption
by Saturday June 28th.

Stig
_______________________________________________
pim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pim

---

From: Leonard Giuliano <[email-masked]>
Date: Mon, 23 Jun 2008 10:57:24 -0700 (PDT)

I thought the count was closer than 15-4, but my memory isn't what it used 
to be.

Anyway, I do not support adoption of this draft as a WG item.  I do not 
believe billing and accounting should be a function of a unicast or mcast 
routing protocol (it certainly isn't in unicast).  And much of the 
debugging data doesn't sound particularly useful in tshooting most mcast 
issues.

-Lenny

On Sat, 14 Jun 2008, Stig Venaas wrote:

-) The PIM Pop Count draft was presented at the last wg meeting. At
-) the meeting there were 15 people in favour of making it a wg work
-) item, and 4 against. The draft is available at
-) http://www.ietf.org/internet-drafts/draft-farinacci-pim-pop-count-02.txt
-) 
-) To determine whether we should adopt it, we need your input. Please
-) review the draft and respond to the list with opinions on wg adoption
-) by Saturday June 28th.
-) 
-) Stig
-) _______________________________________________
-) pim mailing list
-) [email-masked]
-) https://www.ietf.org/mailman/listinfo/pim
-) 
_______________________________________________
pim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pim

---

From: "Greg Shepherd" <[email-masked]>
Date: Mon, 23 Jun 2008 12:12:11 -0700

On Mon, Jun 23, 2008 at 10:57 AM, Leonard Giuliano <[email-masked]> wrote:
> routing protocol (it certainly isn't in unicast).

I agree in as much as billing and accounting does not NEED to be part
of the routing protocol. But the nature of PIM itself does make is a
relatively natural location to accumulate this information.

Additionally, I feel the value of POP is far more significant to
multicast network statistics, stat accounting, and debugging. Perhaps
we should remove the reference to billing from the draft.

Oh, I do support adoption of this draft.

Thanks,
Greg

> And much of the

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 23 Jun 2008 15:49:35 -0700

> relatively natural location to accumulate this information.

Well I think it very much so should be in the protocol. If you want  
the efficiencies it brings, there is no other mechanism that can do it  
better. We have seen how SNMP doesn't scale for router devices. The  
CPU spent at the embedded level putting counters in a JP message is  
far more efficient than any other out of band mechanism.

At the end of the day, that is what matters. Getting the right data to  
the user at low cost. Hence, why we went this route.

> we should remove the reference to billing from the draft.

Well the spec really doesn't mention this mechanism as a billing  
mechanism. And the spec does say that accuracy is not a goal. The word  
"billing" only shows up in the abstract. So we can certainly strike  
that.

> Oh, I do support adoption of this draft.

So do I and so do many enterprise customers we have talked to.

Dino

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 24 Jun 2008 06:37:44 -0700

> routing protocol (it certainly isn't in unicast).

Be careful in comaring apples and oranges. PIM is a tree building protocol,
and the functions presented do provide additional information about the
sub-branches of the tree in each node. 

The mechanisms themselves do not provide a full billing and accounting
system. Instead they provide means of aggregation of information.
Instead of billing and accounting, this could as well be used for
admission control based on "weight" of branches (number of receivers).

To me such a use would be quite similar to eg: permitting/denying
BGP prefixes from neighbors based on prefix-length ("prefix too long -
not worth processing").

Cheers
    Toerless

> And much of the debugging data doesn't sound particularly useful in
> tshooting most mcast issues.
> 
> -Lenny
> 

-- 
---
Toerless Eckert, [email-masked]
Cisco NSSTG Systems & Technology Architecture
"The strategy is what you do, not what you write" - Wesley Clark
"Vision without ressources is hallucination" - James L. Jones
_______________________________________________
pim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pim

---

From: <[email-masked]>
Date: Tue, 24 Jun 2008 15:50:55 +0200

I also support the adoption of this draft by the pim WG.

Cheers,

Christian. 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Greg Shepherd
Envoyé : lundi 23 juin 2008 21:12
À : Leonard Giuliano
Cc : Stig Venaas; [email-masked]
Objet : Re: [pim] draft-farinacci-pim-pop-count-02.txt as wg draft

On Mon, Jun 23, 2008 at 10:57 AM, Leonard Giuliano <[email-masked]> wrote:
>
> I thought the count was closer than 15-4, but my memory isn't what it 
> used to be.
>
> Anyway, I do not support adoption of this draft as a WG item.  I do 
> not believe billing and accounting should be a function of a unicast 
> or mcast routing protocol (it certainly isn't in unicast).

I agree in as much as billing and accounting does not NEED to be part of the routing protocol. But the nature of PIM itself does make is a relatively natural location to accumulate this information.

Additionally, I feel the value of POP is far more significant to multicast network statistics, stat accounting, and debugging. Perhaps we should remove the reference to billing from the draft.

Thanks,
Greg

> And much of the
> debugging data doesn't sound particularly useful in tshooting most 
> mcast issues.
>
> -Lenny
>

*********************************
This message and any attachments (the "message") are confidential and intended solely for the addressees. 
Any unauthorised use or dissemination is prohibited.
Messages are susceptible to alteration. 
France Telecom Group shall not be liable for the message if altered, changed or falsified.
If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
********************************
_______________________________________________
pim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pim

---

From: "janardhan kulkarni" <[email-masked]>
Date: Tue, 24 Jun 2008 20:08:30 +0530

I am also supporting adoption of this draft by WG.

On Tue, Jun 24, 2008 at 7:20 PM, <[email-masked]>
wrote:

> I agree in as much as billing and accounting does not NEED to be part of
> the routing protocol. But the nature of PIM itself does make is a relatively
> natural location to accumulate this information.
>
> Additionally, I feel the value of POP is far more significant to multicast
> network statistics, stat accounting, and debugging. Perhaps we should remove
> the reference to billing from the draft.
>

-- 
_________________________________________
Thank You,
Janardhan.
http://channel.nationalgeographic.com/channel/human-footprint/comcast/
_______________________________________________
pim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pim

---

From: "NAPIERALA, MARIA H, ATTLABS" <[email-masked]>
Date: Tue, 24 Jun 2008 10:39:39 -0400

I support the adoption of the draft by PIM WG.

Maria

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, June 24, 2008 9:51 AM
To: Greg Shepherd; Leonard Giuliano
Cc: Stig Venaas; [email-masked]
Subject: Re: [pim] draft-farinacci-pim-pop-count-02.txt as wg draft

Cheers,

Christian. 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Greg Shepherd
Envoyé : lundi 23 juin 2008 21:12
À : Leonard Giuliano
Cc : Stig Venaas; [email-masked]
Objet : Re: [pim] draft-farinacci-pim-pop-count-02.txt as wg draft

Thanks,
Greg

---

From: "PAPADIMITRIOU Dimitri" <[email-masked]>
Date: Tue, 24 Jun 2008 17:29:01 +0200

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Leonard Giuliano
> Sent: Monday, June 23, 2008 7:57 PM
> To: Stig Venaas
> Cc: [email-masked]
> I thought the count was closer than 15-4, but my memory isn't 
> what it used to be.

from minutes <http://www.ietf.org/proceedings/08mar/minutes/pim.txt>

Can we make this a WG draft? (15 people)
How many against? (4 people)

so count from Stig is as recorded in the minutes. 

> Anyway, I do not support adoption of this draft as a WG item. 

I concur.

> I do not believe billing and accounting should be a function 
> of a unicast or mcast routing protocol (it certainly isn't in 
> unicast).  And much of the debugging data doesn't sound 
> particularly useful in tshooting most mcast issues.

In brief using routing protocol to exchange out-of-band info
that does not result in any protocol real-time trigger and/or
action - so basically this info should not be incorporated in
the routing protocol messaging.

I'd also add coupling effect (correlation of accounting with 
Join/Prune messaging) and timing (how fast the link capacity
is going to change wrt number of exchanged msg -> overhead)

-dimitri.