Subject: [pim] draft-ietf-pim-registry-01 wglc

From: "Mike McBride (mmcbride)" <[email-masked]>
Date: Mon, 29 Nov 2010 14:07:59 -0800

Today begins a two week wglc for draft-ietf-pim-registry-01. A type for
experimental use was not reserved in this draft. Please speak up to
support or not support.

http://www.ietf.org/id/draft-ietf-pim-registry-01.txt

thanks,
mike

---

From: "Papadimitriou, Dimitri (Dimitri)" <[email-masked]>
Date: Tue, 30 Nov 2010 00:12:44 +0100

I am in favor of reserving a code-point for experimental use (subject to experimental RFC) over limited period of experiment.  

Thanks,
-dimitri.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Mike McBride (mmcbride)
> Sent: Monday, November 29, 2010 11:08 PM
> To: [email-masked]
> Subject: [pim] draft-ietf-pim-registry-01 wglc
> 
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim
>

---

From: zhoudi <[email-masked]>
Date: Tue, 30 Nov 2010 11:02:46 +0800

I support it.
More and more new multicast applications would emerge in the future. 
So new types of PIM messages would be needed later.

Regards
ZhouDi

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 30 Nov 2010 02:57:25 -0500

Yes/support

Regards,
Jeff

---

From: Stig Venaas <[email-masked]>
Date: Tue, 30 Nov 2010 08:22:36 -0800

> I am in favor of reserving a code-point for experimental use (subject to experimental RFC) over limited period of experiment.

Note that currently the draft says "IETF Review" per RFC 5226, which
means that an RFC is needed. It can be an experimental RFC. So maybe
the current version states what you want?

It has been suggested that one type could be reserved for experimental
use (see RFC 5226 for that as well). That means that the type is
available for private/local use for the purpose of experimentation.
This is typically for short term use where you want to ensure it
doesn't conflict with assigned types.

If you (or anyone else) think we should reserve one for the latter,
then please let us know. If there is significant interest, this can
be added. It could also be added later if there is a need (but that
would then require a new RFC) according to this document (IETF Review).

Stig

---

From: Stig Venaas <[email-masked]>
Date: Tue, 30 Nov 2010 09:15:42 -0800

On 11/30/2010 8:22 AM, Stig Venaas wrote:
>> I am in favor of reserving a code-point for experimental use (subject
>> to experimental RFC) over limited period of experiment.
>

To be clear, when I say "the latter", I mean as in that last paragraph.
A type for private/local use for the purpose of experimentation.

Stig

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 30 Nov 2010 09:44:43 -0800

I am for moving this forward without trying to resolve the experimental
issue in this registry - but resolve it in a future document via extension
code points whenever necessary.

The reason is that in my evaluation, experimental is really ONLY
useful for researchers targeting limited lab type deployments. As someone
whose paycheck depends on stuff working in multiple customer networks,
a single experimental code point is more a pain than a benefit:

As a researcher i could pick the experimental type, don't worry about
the rest of the world and be at least safe none of the production
features will bread due to my experiment.

As a vendor i may be faced with two research communities asking me to
support their directions of extensions and/or i may want to innovate myself.
Unless i can be sure i can signal all of these without collisions i have
no productizeable solution. And i do not want customers having to configure
the semantics of experiemntal code-points via nerd knobs.

As a vendor i need either a vendor assigned code point space or a standards
code point space. And if there is a vendor assigned space, then i am pretty
sure the cool researchers could also get a vendor-code point so that even
their experimental stuff would never collide.

Cheers
    Toerless

---

From: "Papadimitriou, Dimitri (Dimitri)" <[email-masked]>
Date: Tue, 30 Nov 2010 18:56:41 +0100

> Behalf Of Stig Venaas
> Sent: Tuesday, November 30, 2010 6:16 PM
> To: [email-masked]
> Subject: Re: [pim] draft-ietf-pim-registry-01 wglc
> 

The demand here is to reserve the code point for the msg type to which the Exp.RFCs would apply.

> > doesn't conflict with assigned types.

That's the purpose indeed.

> A type for private/local use for the purpose of experimentation.

The difficulty of the discussion is of course that this is a matter of convention inline with the remaining code-points;

I take just a short-term look at what will happen when experiments will start on fast re-routing the full space will be exhausted by interim assignments even if they won't be invited to interoperate. The only alternative is that the "supplementary" space is being defined upfront and left up to experimenters.

Thanks,
-dimitri.

---

From: Stig Venaas <[email-masked]>
Date: Tue, 30 Nov 2010 10:29:15 -0800

> The demand here is to reserve the code point for the msg type to which the Exp.RFCs would apply.

Once there is an experimental RFC, IANA can assign it a type.
That is what has been done in the past, and nothing changes
with this document as it is written now.

> That's the purpose indeed.

If we do this, then anyone is free to use this type for their short
term experiments. No document or anything else is required. The key
thing here is that it is short term.

If there is an experimental draft and there are deployments using it
on the Internet, then getting an RFC and an IANA assignment might be
better.

> I take just a short-term look at what will happen when experiments will start on fast re-routing the full space will be exhausted by interim assignments even if they won't be invited to interoperat…

Right, so I agree it may be useful. This is a reasonable argument for
reserving a type. Do you believe a single type would be sufficient then?
Is there a danger that different experiments will conflict with
each other?

I want to see what others think too. We can always reserve it later
once there is a clear need. But maybe there is a sufficiently clear
need now...

So I hope that as part of this wglc people can state whether they want
an experimental type reserved at this point. And whether they support
the current document, or if they support it provided it is revised to
reserve an experimental type.

Stig

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 30 Nov 2010 16:58:54 -0500

I agree with Toerless.

I imagine that eventually both the type-reserved and type-experiment (and/or type-vendor/private) would need subtypes to handle more message types. We can have that (subtype format) standardized when the need comes, and then update the registry to include type-experiment/private/vendor/whatever.

Jeffrey

> Behalf Of Toerless Eckert
> Sent: Tuesday, November 30, 2010 12:45 PM
> To: Stig Venaas
> Cc: [email-masked]

---

From: Vero Zheng <[email-masked]>
Date: Wed, 01 Dec 2010 11:48:54 +0800

Yes/Support

BR,
Vero

--------------------------------------------------
From: "Mike McBride (mmcbride)" <[email-masked]>
Sent: Tuesday, November 30, 2010 6:07 AM
To: <[email-masked]>
Subject: [pim] draft-ietf-pim-registry-01 wglc