Subject: Re: [pim] pop-count ready for wglc?

From: Mike McBride <[email-masked]>
Date: Mon, 10 Oct 2011 16:17:36 -0500

Today begins a two week wglc for draft-ietf-pim-pop-count-04. Please review the draft. Please then comment, on the list, with a thumbs up or a thumbs down.

thanks,
mike

http://www.ietf.org/id/draft-ietf-pim-pop-count-04.txt

> -----Original Message-----
> From: Mike McBride
> Sent: Tuesday, September 27, 2011 8:06 PM
> To: [email-masked]
> Subject: pop-count ready for wglc?
> 
> We had consensus (5-0) in the Quebec pimwg meeting to issue a wglc for
> the pim-pop-count draft:
> 
> http://www.ietf.org/id/draft-ietf-pim-pop-count-04.txt
> 
> 
> Before doing so we'd like to bring it to the list. If you feel this
> draft is not ready for wglc please speak up. Otherwise we will begin a
> wglc next week.
> 
> thanks,
> mike
NOTICE OF CONFIDENTIALITY:  
The information contained in this email transmission is confidential information which may contain information that is legally privileged and prohibited from disclosure under applicable law or by contractual agreement.  The information is intended solely for the use of the individual or entity named above.  
If you are not the intended recipient, you are hereby notified that any disclosure, copying, distribution or taking of any action in reliance on the contents of this email transmission is strictly prohibited.  
If you have received this email transmission in error, please notify us immediately by telephone to arrange for the return of the original transmission to us.

---

From: Stig Venaas <[email-masked]>
Date: Mon, 24 Oct 2011 10:12:35 -0700

> Today begins a two week wglc for draft-ietf-pim-pop-count-04. Please review the draft. Please then comment, on the list, with a thumbs up or a thumbs down.

I haven't seen any comments on the list, and the WGLC is about to end.
Please provide your comments and whether you support the draft or not.

Since I'm now an author of the draft, please regard this request as
coming from an author and not a chair.

I'll leave to Mike to figure out what to do with the draft, I'm just
urging you to provide comments.

Stig

> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim

---

From: Mike McBride <[email-masked]>
Date: Tue, 25 Oct 2011 16:27:31 -0500

We need to hear something. Anything. It's difficult to justify, to the IESG, that the wg is rallying behind the draft when there is zero response during the wglc. So I'm going to extend this wglc for another 2 weeks. Please speak up. If there continues to be zero response, we will assume there is no interest in progressing the draft and will shelve the wglc for the time being.

thanks,
mike

> From: Stig Venaas [mailto:[email-masked]]
> Sent: Monday, October 24, 2011 10:13 AM
> To: Mike McBride
> Cc: [email-masked]
> Subject: Re: [pim] pop-count ready for wglc?
> 
> > Today begins a two week wglc for draft-ietf-pim-pop-count-04. Please
> review the draft. Please then comment, on the list, with a thumbs up or
> a thumbs down.
> 
> > The information contained in this email transmission is confidential
> information which may contain information that is legally privileged
> and prohibited from disclosure under applicable law or by contractual
> agreement.  The information is intended solely for the use of the
> individual or entity named above.
> > If you are not the intended recipient, you are hereby notified that
> any disclosure, copying, distribution or taking of any action in
> reliance on the contents of this email transmission is strictly
> prohibited.
> > If you have received this email transmission in error, please notify
> us immediately by telephone to arrange for the return of the original
> transmission to us.
> >

---

From: Leonard Giuliano <[email-masked]>
Date: Wed, 26 Oct 2011 14:52:20 -0700

I would support shelving the work.  We would never use OSPF/ISIS to carry 
unicast accounting info, so why do so in mcast?  Better to leave this up 
to the application layer.

-Lenny

On Tue, 25 Oct 2011, Mike McBride wrote:

-) We need to hear something. Anything. It's difficult to justify, to the 
-) IESG, that the wg is rallying behind the draft when there is zero 
-) response during the wglc. So I'm going to extend this wglc for another 
-) 2 weeks. Please speak up. If there continues to be zero response, we 
-) will assume there is no interest in progressing the draft and will 
-) shelve the wglc for the time being.
-) 
-) thanks,
-) mike
-) 
-) > -----Original Message-----
-) > From: Stig Venaas [mailto:[email-masked]]
-) > Sent: Monday, October 24, 2011 10:13 AM
-) > To: Mike McBride
-) > Cc: [email-masked]
-) > Subject: Re: [pim] pop-count ready for wglc?
-) > 
-) > On 10/10/2011 2:17 PM, Mike McBride wrote:
-) > > Today begins a two week wglc for draft-ietf-pim-pop-count-04. Please
-) > review the draft. Please then comment, on the list, with a thumbs up or
-) > a thumbs down.
-) > 
-) > I haven't seen any comments on the list, and the WGLC is about to end.
-) > Please provide your comments and whether you support the draft or not.
-) > 
-) > Since I'm now an author of the draft, please regard this request as
-) > coming from an author and not a chair.
-) > 
-) > I'll leave to Mike to figure out what to do with the draft, I'm just
-) > urging you to provide comments.
-) > 
-) > Stig
-) > 
-) > > thanks,
-) > > mike
-) > >
-) > > http://www.ietf.org/id/draft-ietf-pim-pop-count-04.txt
-) > >
-) > >> -----Original Message-----
-) > >> From: Mike McBride
-) > >> Sent: Tuesday, September 27, 2011 8:06 PM
-) > >> To: [email-masked]
-) > >> Subject: pop-count ready for wglc?
-) > >>
-) > >> We had consensus (5-0) in the Quebec pimwg meeting to issue a wglc
-) > for
-) > >> the pim-pop-count draft:
-) > >>
-) > >> http://www.ietf.org/id/draft-ietf-pim-pop-count-04.txt
-) > >>
-) > >>
-) > >> Before doing so we'd like to bring it to the list. If you feel this
-) > >> draft is not ready for wglc please speak up. Otherwise we will begin
-) > a
-) > >> wglc next week.
-) > >>
-) > >> thanks,
-) > >> mike
-) > > NOTICE OF CONFIDENTIALITY:
-) > > The information contained in this email transmission is confidential
-) > information which may contain information that is legally privileged
-) > and prohibited from disclosure under applicable law or by contractual
-) > agreement.  The information is intended solely for the use of the
-) > individual or entity named above.
-) > > If you are not the intended recipient, you are hereby notified that
-) > any disclosure, copying, distribution or taking of any action in
-) > reliance on the contents of this email transmission is strictly
-) > prohibited.
-) > > If you have received this email transmission in error, please notify
-) > us immediately by telephone to arrange for the return of the original
-) > transmission to us.
-) > >
-) > > _______________________________________________
-) > > pim mailing list
-) > > [email-masked]
-) > > https://www.ietf.org/mailman/listinfo/pim
-) 
-) NOTICE OF CONFIDENTIALITY:  
-) The information contained in this email transmission is confidential information which may contain information that is legally privileged and prohibited from disclosure under applicable law or by contractual agreement.  The information is intended solely for the use of the individual or entity named above.  
-) If you are not the intended recipient, you are hereby notified that any disclosure, copying, distribution or taking of any action in reliance on the contents of this email transmission is strictly prohibited.  
-) If you have received this email transmission in error, please notify us immediately by telephone to arrange for the return of the original transmission to us.
-) 
-) _______________________________________________
-) pim mailing list
-) [email-masked]
-) https://www.ietf.org/mailman/listinfo/pim
-)

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 26 Oct 2011 17:58:14 -0400

+1
-- 
Regards,
Jeff

On 10/26/11 2:52 PM, "Leonard Giuliano" <[email-masked]> wrote:

>-) The information contained in this email transmission is confidential
>information which may contain information that is legally privileged and
>prohibited from disclosure under applicable law or by contractual
>-) If you are not the intended recipient, you are hereby notified that
>any disclosure, copying, distribution or taking of any action in reliance
>on the contents of this email transmission is strictly prohibited.
>-) If you have received this email transmission in error, please notify

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 26 Oct 2011 18:02:41 -0400

Given the Experimental Intended status I'd like to withdraw my previous
comment. 
-- 
Regards,
Jeff

---

From: Greg Shepherd <[email-masked]>
Date: Thu, 27 Oct 2011 08:30:34 -0700

Lenny,

I have to disagree with you this time. Pop-count isn't about PIM
carrying accounting information, it's more about PIM distributing
topology (tree) information upstream. And in this case, it IS much
like OSPF and ISIS where every router has a full topology DB which can
be poled out of band if desired. We're just trying to give
PIM/multicast some parity where it's lacking.

I do support this work, if it wasn't already clear. :)

Greg

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 27 Oct 2011 10:57:33 -0700

Short version:

I support this work to become experimental RFC. 

Comment on Lennys point:

IGP Route prefixes are not per application flow state.
Multicast (*,G) and (S,G) state is per-application-flow state.
PIM is thereby a much more logical option to carry per-flow application
awareness than IGPs.  That's why i think the comparison PIM with IGPs is
not very strong here.

But even if i went down your argument: How about the free bandwidth
attributes in IGPs that where introduced for RSVP-TE CSPF operations into
IGP LSAs ? And i am not even aware of all LSA carried "additional" information,
but i think there is active work to actually do more in that area.

Long rant version:

I do very much like the idea of continuing to work on solutions
that allows to keep the value of the overall service inside the network
devices and minimize the total number of layers required for the
network operator to do her/his job. Especially when it also reduces the
overall complexity of the solution, improve visilibity and enables
more simply implemented intelligence in the network. 

Pop count does provide a very elegant and simple to implement solution
to provide a set of very crucial eleements of visibility  to the network
operator without relying on however many layers of additional outside 
tools. 

What is the alternative to pop count ? Openflow for multicast with some
controller or an NMS utilizing 5 different MIBs trying to figure out all
this information ?? give me a break!!!. You would never ever be able to
improve the ease-of-use perception of IP multicast as a network service
that way. At best you would create the perception of "IP multicast sucks,
but i found this cool tool from NMS/Controller vendor 'FOO' that made it
actually quite nice to use". 

Layering the solution becomes even more difficult when we try to
utilize pop count type information to drive intelligent actions in the
network.  Admission control based on "tree with smallest number of eyeballs
gets dropped". Or automatic upstream fragmentation or transrating or the
like. And i think nobody has even tried to enlist/brainstom all possible
intelligence that could build on top of it when necessary/beneficial.

Once you mandate that the situation awareness that pop count gives you
only exists at a higher level than the network layer, then all the
intelligence that would depends on it can also only be built outside of
the network layer and routers could not do them autonomously anymore unless
you throw a lot of more complexity into the mix (higher level standardized
coordination between routers).

I think it is an incorrect mantra trying to push up functionality to
higher layers as much as possible. You just create more overall
complexity and more layers. This approach is not a mantra but a type
of reverse engineered justification to what happens when lower layers of
the stack are not innovating (fast enough) and you MUST layer stuff on
top of it to move ahead. 

The correct mantra IMHO is still the same as it was always
in layered systems: Do the work in the layer where it is best suited
to simplify, scale, standardize and drive adoption of the solution.
For pop count type information that seems clearly to be the network layer
with PIM. 

End of longer rant 

Cheers
    Toerless

-- 
---
Toerless Eckert, [email-masked]
Cisco NSSTG Systems & Technology Architecture
Network Agnostic: Applications that work best on cheap, stupid networks.
Suicide: Devaluating the intelligent network with network agnostic apps.