Subject: [pim] Reg - PIMSM - Registration state machine

From: Sundara Moorthy M <[email-masked]>
Date: Fri, 6 Jan 2012 10:59:30 +0530

Hi ,

I have doubt in PIM-SM Registration State machine.

As per the state machine, there is a delay of random (30,90)seconds from one register packet to another. This is done to reduce the frequent register packets at the rate of wire speed.

But if there is a leave and then a join happens at RP  immediately, the mcast data flow gets delayed to a maximum of 90 seconds.

There occurs a two kind of behavior.

1.       When Join happens at the first time  --> Here mcast data flows immediately

2.       When Join happens after a Leave  -->Here it takes delay of random (30, 90) seconds. Is this behavior acceptable?
How can we correct the second behavior , So that mcast data flows immediately after Join packet received by RP.?

Thanks and Regards,
Sundara Moorthy M

===============================================================================
Please refer to http://www.aricent.com/legal/email_disclaimer.html
for important disclosures regarding this electronic communication.
===============================================================================

---

From: Rishabh Parekh <[email-masked]>
Date: Sat, 7 Jan 2012 06:36:20 -0800

Sundara,
CouldRegister --> TRUE event of Register FSM in Section 4.4.1 implies that
the first-hop DR should register encapsulate all packets from a directly
connected source till the RP responds with a "Register-Stop". Of course,
implementations can optimize this to avoid encapsulation overhead for every
packet. In the case when there are no receivers at the RP ( (*,G)inherited
olist is NULL), the RP would respond with a Register-Stop immediately but
would create and maintain (S,G) state which is refreshed by Null Registers.
Later, when a receiver joins the RP tree, inheritance from (*,G) to (S,G)
state triggers a (S,G) Join which would bring multicast packets down to the
RP and onto the RP tree. So the join latency for the late receiver is
definitely not in the order of 30 to 90 seconds.

Regards,
-Rishabh

On Thu, Jan 5, 2012 at 9:29 PM, Sundara Moorthy M <
[email-masked]> wrote:

>  Hi ,****
>
> ** **
>
> I have doubt in PIM-SM Registration State machine.****
>
> ** **
>
> As per the state machine, there is a delay of random (30,90)seconds from
> one register packet to another. This is done to reduce the frequent
> register packets at the rate of wire speed.****
>
> ** **
>
> But if there is a leave and then a join happens at RP  immediately, the
> mcast data flow gets delayed to a maximum of 90 seconds.****
>
> ** **
>
> There occurs a two kind of behavior.****
>
> **1.       **When Join happens at the first time  à Here mcast data flows
> immediately****
>
> **2.       **When Join happens after a Leave  àHere it takes delay of
> random (30, 90) seconds. Is this behavior acceptable?****
>
> How can we correct the second behavior , So that mcast data flows
> immediately after Join packet received by RP.?****
>
> ** **
>
> ** **
>
> Thanks and Regards,****
>
> Sundara Moorthy M****
>
> ** **
>
>
>
>
>
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim
>
>