Subject: [pim] pim WGLC for draft-ietf-pim-rfc4601-update-survey-report-00

From: Stig Venaas <[email-masked]>
Date: Tue, 21 May 2013 09:56:39 -0700

Hi

We, the chairs, want to speed up the process of updating RFC 4601
and as a next step we want to make sure that you, the working group,
are happy with the implementation report. Once the group is happy, we
want to get the report published, and then finalize the updates to
4601 based on that.

The report results have been presented to the group. There were some
comments in the adoption call, and the adopted version took them into
account. The draft is available at
http://tools.ietf.org/html/draft-ietf-pim-rfc4601-update-survey-report-00

With this email we're starting a working group last call, ending
Sunday June 2nd. This is important work and we need your review. It
is the bases for updating one of our core RFCs, please read through
the report and tell us whether it is ready to be published.

Stig

---

From: William Atwood <[email-masked]>
Date: Wed, 22 May 2013 23:28:12 -0400

Hello,

I am happy with the report, with the exception of some grammatical
issues that I have sent to the authors off-list.

Once these are corrected, I believe that the draft will be ready to publish.

  Bill

On 21/05/2013 12:56 PM, Stig Venaas wrote:
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim

-- 
Dr. J.W. Atwood, Eng.             tel:   +1 (514) 848-2424 x3046
Distinguished Professor Emeritus  fax:   +1 (514) 848-2830
Department of Computer Science
   and Software Engineering
Concordia University EV 3.185     email:[email-masked]
1455 de Maisonneuve Blvd. West    http://users.encs.concordia.ca/~bill
Montreal, Quebec Canada H3G 1M8

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Thu, 23 May 2013 15:31:00 +0000

Bill,

Thank you very much for your detailed review and catching those issues. I've fixed them and posted -01 version:

URL:             http://www.ietf.org/internet-drafts/draft-ietf-pim-rfc4601-update-survey-report-01.txt
Status:          http://datatracker.ietf.org/doc/draft-ietf-pim-rfc4601-update-survey-report
Htmlized:        http://tools.ietf.org/html/draft-ietf-pim-rfc4601-update-survey-report-01
Diff:            http://www.ietf.org/rfcdiff?url2=draft-ietf-pim-rfc4601-update-survey-report-01
 
Jeffrey

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> William Atwood
> Sent: Wednesday, May 22, 2013 11:28 PM
> To: [email-masked]
> Subject: Re: [pim] pim WGLC for draft-ietf-pim-rfc4601-update-survey-
> report-00
> 
> Hello,
>

---

From: Stig Venaas <[email-masked]>
Date: Tue, 28 May 2013 11:27:56 -0700

This last call ends Sunday, we need more people to review this.

Stig

---

From: Bharat Joshi <[email-masked]>
Date: Wed, 29 May 2013 03:37:42 +0000

I think the document is ready for publication. However I have few edits to suggest:

1. In "and a detailed summary of the responses", detailed and summary together does not look right.

2. "Join Suppression" -> "Join suppression". This is how it is used in RFC 4601.

Thanks,
Bharat
________________________________________
From: [email-masked] [[email-masked]] on behalf of Stig Venaas [[email-masked]]
Sent: Tuesday, May 28, 2013 11:57 PM
To: [email-masked]
Subject: [pim] Reminder: pim WGLC for   draft-ietf-pim-rfc4601-update-survey-report-00

Stig

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely 
for the use of the addressee(s). If you are not the intended recipient, please 
notify the sender by e-mail and delete the original message. Further, you are not 
to copy, disclose, or distribute this e-mail or its contents to any other person and 
any such actions are unlawful. This e-mail may contain viruses. Infosys has taken 
every reasonable precaution to minimize this risk, but is not liable for any damage 
you may sustain as a result of any virus in this e-mail. You should carry out your 
own virus checks before opening the e-mail or attachment. Infosys reserves the 
right to monitor and review the content of all messages sent to or from this e-mail 
address. Messages sent to or from this e-mail address may be stored on the 
Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***

---

From: Stig Venaas <[email-masked]>
Date: Fri, 31 May 2013 09:57:54 -0700

> This last call ends Sunday, we need more people to review this.

Here are my comments. Hope more people will respond.

In 1.1 it says:

    2006.  Considering its multiple independent implementations developed
    and sufficient successful operational experience gained, the IETF has
    decided to advance the PIM-SM protocol to Internet Standard.

Maybe this is OK, but the IETF hasn't decided to advance PIM-SM yet.
Perhaps just say that the PIM WG wants to advance PIM-SM to Internet
Standard, and that the survey and this document is part of that work.

At the end of 1.2 we have:

    Optional features that do not meet the aforesaid criteria have been
    identified by the PIM Working Group and will be removed.  This
    document intends to provide supporting documentation to advance the
    Protocol Independent Multicast - Sparse Mode (PIM-SM)
    protocol from IETF Proposed Standard to Standard.
                                           ^^^^^^^^^^

Standard should be Internet Standard.

In 2.1 it says:

    22nd Oct 2012.  The responses are kept strictly confidential and
    only combined results are published here.  The raw questionnaire is
    shown in Appendix A, and a detailed summary of the responses is
    included in the following section.

Worth noting that while the details were kept confidential (are they?),
the responders chose whether they wanted the affiliations to be
confidential. It seems a bit strange saying it is strictly confidential,
and then listing names of responders.

Once these issues are taken care of I believe the document is ready to
be sent on to the IESG.

Stig