Subject: Re: [pim] ip pim register-source on pimd?

From: Joachim Nilsson <[email-masked]>
Date: Wed, 08 Apr 2015 07:07:28 +0200

Hi Thomas,

sorry for the late reply.  Like you already noticed,
there is no register-source setting in pimd.

You can probably add this functionality if you hack
the following two functions in pim_proto.c:

	send_pim_register()
	send_pim_null_register()

I imagine the following setting in pimd.conf:

	register_source <ifname>

Which can be used to find the vifi_t in the above
functions.  Notice how both the IP address and the
MTU is read from the vifi_t.

Regards
 /Joachim

On 2015-03-31 16:55, Thomas Lau wrote:
> ​Hi all,
> 
> on Cisco router I could use ip pim register-source to specific
> which source IP / interface should I use to "announce" to neighbor,
> but I can't see this option exists on PIMD, may I know how could I
> implement this? ​

---

From: Joachim Nilsson <[email-masked]>
Date: Wed, 08 Apr 2015 09:48:35 +0200

Hi again,

I've added your feature request to the pimd GitHub
issue tracker:

	https://github.com/troglobit/pimd/issues/38

Regards
 /Joachim

On 2015-04-08 08:01, [email-masked] wrote:
> Hi Joachim,
> 
> I am glad that someone would actually response. Personally I am not
> a coder, maybe other people could help a bit please?
> 
> Joachim Nilsson wrote, on Wednesday, 8 April, 2015 1:07 PM:
>> Hi Thomas,
>> 
>> sorry for the late reply. Like you already noticed, there is no
>> register-source setting in pimd.
>> 
>> You can probably add this functionality if you hack the following
>> two functions in pim_proto.c:
>> 
>> send_pim_register() send_pim_null_register()
>> 
>> Which can be used to find the vifi_t in the above functions.
>> Notice how both the IP address and the MTU is read from the
>> vifi_t.
>> 
>> 
>> Regards /Joachim
>> 
>>> which source IP / interface should I use to "announce" to
>>> neighbor, but I can't see this option exists on PIMD, may I
>>> know how could I implement this? ​
>> 
>>