Subject: [pim] Comments on draft-ietf-pim-dr-improvement

From: "Deepika Mulani (dmulani)" <[email-masked]>
Date: Fri, 4 Nov 2016 23:09:48 +0000

Hi,
I had some comments on this draft which documents the technique to have a Backup DR elected :

  *   Is there a real need for the New PIM Hello Options which mention the current DR and the BDR. The BDR can be elected using the current technique in place for DR election expect that it's the second best router. (or as the draft tries to maintain stickiness on the existing DR; the best possible router in position to become a DR).
  *   Draft tries to maintain stickiness to the currently elected DR even when there is a new router with a better DR priority coming up. This actually defies the purpose of having a Higher DR priority option. If there is no case of failure; the higher priority DR would just stay Idle forever.
  *   There is no mention of how fast the switching of roles will take place once the current DR goes down. This implies  traffic loss until the time the loss of PIM neighbor acting as the DR is identified which could very well run upto the default value of 105secs. Probably a mention of some technique like BFD or any other protocol of choice by the implementors will help to identify the immediate loss of the DR and a sooner role switching.

Regards,
Deepika

---

From: [email-masked]
Date: Mon, 7 Nov 2016 08:47:21 +0800

Hi Deepika,

    Thanks for your comments. Please see in line.

Best Regards,
Sandy

"Deepika Mulani (dmulani)" <[email-masked]> 写于 2016/11/05 07:09:48:

> Is there a real need for the New PIM Hello Options which mention the
> current DR and the BDR. The BDR can be elected using the current 
> technique in place for DR election expect that it’s the second best 
> router. (or as the draft tries to maintain stickiness on the 
> existing DR; the best possible router in position to become a DR). 

---Sandy: The explicit DR and BDR are used to indicate the current 
network status. If the DR and BDR are not shown in the hello packet, 
individual node elects the DR and BDR separately. Then the result 
maybe not unify. The explicit format will help the unification.

> Draft tries to maintain stickiness to the currently elected DR even 
> when there is a new router with a better DR priority coming up. This
> actually defies the purpose of having a Higher DR priority option. 
> If there is no case of failure; the higher priority DR would just 
> stay Idle forever. 

---Sandy: If the DR has been elected, the network should not change to 
a new DR easily. Otherwise the stability of network will be influenced. 
Obviously the existed multicast service will be influenced. So it is 
necessary to maintain the DR stability. Of course in some network that 
has no time-sensitive service such as IPTV and network-meeting, the 
network may ignore the DR/BDR option and use the algorithm in PIM draft. 
And yes, if the DR does not failure, the new candidate who has the higher 
priority will not be DR. If it is necessary that the new candidate must 
be DR, maybe the manual configuration can be used.

> There is no mention of how fast the switching of roles will take 
> place once the current DR goes down. This implies  traffic loss 
> until the time the loss of PIM neighbor acting as the DR is 
> identified which could very well run upto the default value of 
> 105secs. Probably a mention of some technique like BFD or any other 
> protocol of choice by the implementors will help to identify the 
> immediate loss of the DR and a sooner role switching.

---Sandy: Yes, BFD should be used to monitor the DR failure. I will add 
it in the draft. Thank you for your reminder.

---

From: "Deepika Mulani (dmulani)" <[email-masked]>
Date: Tue, 8 Nov 2016 20:31:33 +0000

Hi Sandy,
Thanks for getting back. Though I would like to suggest the inclusion of the DR priority also in the New Hello options being suggested for both the DR and the BDR.
Lets say you a setup with 3 routers on a LAN (10.1.0/24)

DR Priority :  100 80 60
Address  .11 .12 .13
Router-Names :  A B C

Lets say to begin with initially only A and B are the 2 routers coming up at the same time. And because of the priorities, the DR and BDR selection would be (A,B).
Now if C comes up after some time; and it sends out it’s Hello message for which it receives the Hello message only from A but for some reason the one from B is delayed. In that case; C will see the Hello from A declaring (A,B) in the Hello Option. C has not yet learned of B and doesn’t know the priority of B so it will try to mark itself as the BDR since it has a higher IP address (.13) than B(.12). Once marked as BDR it’s next Hello message will declare (A,C) as the set and whenever it receives the Hello from B; it will again change back to (A,B).

Hence one can avoid the unnecessary switching of BDRs (and (*,G) or (S,G) state creation/deletions); had the DR priority of B been known in the first Hello message received from A.
Let me know if this sounds reasonable.
Regards,
Deepika

From: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Sunday, November 6, 2016 at 4:47 PM
To: "Deepika Mulani (dmulani)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Comments on draft-ietf-pim-dr-improvement

Hi Deepika,

Best Regards,
Sandy

---

From: [email-masked]
Date: Wed, 9 Nov 2016 17:16:17 +0800

Hi Deepika,

    Thanks for your suggestion.
    In case C only receives the hello packet from A, C should wait for 
a while for the other router's hello packets. So C should not elect 
itself to be BDR immediately. Otherwise the situation that you say 
will happen. In case C still does not receive the B's hello packet 
after the delay expiration, C elects itself to be BDR. In this 
situation, B may have trouble in connect. Is it right?
    The delay may be the same value with hello-holdtime. Sorry that 
this part is not described clearly in the draft. I will modify it in 
next version.

Best Regards,
Sandy

"Deepika Mulani (dmulani)" <[email-masked]> 写于 2016/11/09 04:31:33:

> Hi Sandy,
> Thanks for getting back. Though I would like to suggest the 
> inclusion of the DR priority also in the New Hello options being 
> suggested for both the DR and the BDR. 
> Lets say to begin with initially only A and B are the 2 routers 
> coming up at the same time. And because of the priorities, the DR 
> and BDR selection would be (A,B). 
> Now if C comes up after some time; and it sends out it’s Hello 
> message for which it receives the Hello message only from A but for 
> some reason the one from B is delayed. In that case; C will see the 
> Hello from A declaring (A,B) in the Hello Option. C has not yet 
> learned of B and doesn’t know the priority of B so it will try to 
> mark itself as the BDR since it has a higher IP address (.13) than 
> B(.12). Once marked as BDR it’s next Hello message will declare (A,
> C) as the set and whenever it receives the Hello from B; it will 
> again change back to (A,B). 
> 
> Hence one can avoid the unnecessary switching of BDRs (and (*,G) or 
> (S,G) state creation/deletions); had the DR priority of B been known
> in the first Hello message received from A. 
> From: "[email-masked]" <[email-masked]>
> To: "Deepika Mulani (dmulani)" <[email-masked]>
> Cc: "[email-masked]" <draft-ietf-pim-dr-
> [email-masked]>, "[email-masked]" <[email-masked]>