Subject: Re: [pim] WGLC for draft-ietf-pim-msdp-yang-02

From: Stig Venaas <[email-masked]>
Date: Thu, 1 Mar 2018 08:14:46 -0800

The 2 weeks are almost up. Please respond to this last call and state
whether you think it is ready for publication, or what concerns you have.

Stig

On Feb 15, 2018 17:14, "Michael McBride" <[email-masked]> wrote:

> Hi PIMers,
>
>
>
> The chairs have reviewed draft-ietf-pim-msdp-yang-02 and feel it is ready
> for WGLC. What do you think? This email begins a 2 week WGLC for this
> draft. Please review and comment.
>
>
>
> Thanks,
>
> mike
>
>
>
> https://tools.ietf.org/html/draft-ietf-pim-msdp-yang-02
>
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim
>
>

---

From: "Holland, Jake" <[email-masked]>
Date: Thu, 1 Mar 2018 20:51:03 +0000

Hello authors and chairs,

A couple of comments and questions:

1. I didn’t notice anything broken in the model, but I generally have concerns about endorsing these models when I don’t know how they were tested, or have some insight into the set of deployment scenarios that were confirmed as “definitely configurable with this schema”.

Is there a report anywhere on the methodology for how the model was checked for completeness? (Or is it some kind of standard of best practices that I’m just not familiar with?)

2. The “Security Considerations” section contains (I think?) an incomplete sentence fragment at the end of the third paragraph:
The security
   considerations of MSDP [RFC3618<https://tools.ietf.org/html/rfc3618>].

3. Should the “password” field be listed as a sensitive readable configuration option in the security considerations?

4. It looks like the MIB document’s security considerations section mentions several fields that aren’t mentioned in this doc’s security considerations, but some (all?) seem to have parallels:
https://tools.ietf.org/html/rfc4624#section-5

I would have thought those should likewise be included here?

5. I noticed 2 nits in the last paragraph in security considerations:
“support” -> “supports”
“too” -> “to”

   control access to these operations.  The MSDP Yang module support the

   "clear-peer" and "clear-sa-cache" RPCs.  If access too either of

   these is compromised, they can result in unexpected MSDP peer

   breakdown and unexpected SA information deletion.

Best,
Jake

On 3/1/18, 8:14 AM, "Stig Venaas" <[email-masked]<mailto:[email-masked]>> wrote:

The 2 weeks are almost up. Please respond to this last call and state whether you think it is ready for publication, or what concerns you have.

Stig

On Feb 15, 2018 17:14, "Michael McBride" <[email-masked]<mailto:[email-masked]>> wrote:
Hi PIMers,

The chairs have reviewed draft-ietf-pim-msdp-yang-02 and feel it is ready for WGLC. What do you think? This email begins a 2 week WGLC for this draft. Please review and comment.

Thanks,
mike

https://tools.ietf.org/html/draft-ietf-pim-msdp-yang-02<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dpim-2Dmsdp-2Dyang-2D02&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=bqnFROivDo_4iF8Z3R4DyNWKbbMeXr0LOgLnElT1Ook&m=pMUf98V8FUNqA5wzUMDfjCmwe3JFsO3axfZkyxvv_OA&s=LbgVggF3v6tyP6PmEvc0kqxPWmQh_Inw8qqoq6SoOvk&e=>

_______________________________________________
pim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pim<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_pim&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=bqnFROivDo_4iF8Z3R4DyNWKbbMeXr0LOgLnElT1Ook&m=pMUf98V8FUNqA5wzUMDfjCmwe3JFsO3axfZkyxvv_OA&s=7XKNu8AC-3wc5d7ofjcx_F9Z5WDexR7sSxFCKW1OQPM&e=>

---

From: <[email-masked]>
Date: Wed, 7 Mar 2018 09:48:29 +0800 (CST)

Hi Jake,

Sorry for the late response. 

Thank you very much for your comments! :-)

Please see in line below.

Thanks,

Sandy

原始邮件

发件人：Holland,Jake <[email-masked]>
收件人：Stig Venaas <[email-masked]>Michael McBride <[email-masked]>
抄送人：[email-masked] <[email-masked]>
日 期 ：2018年03月02日 04:51
主 题 ：Re: [pim] WGLC for draft-ietf-pim-msdp-yang-02

 

 

[Sandy]: MSDP has been used for several years, and many vendors has been worked on MSDP YANG models for years. So in fact, this YANG model is a mixture of multi-vendor implementation. But IMO your concern is making sense. The verification should be common consideration for all the element YANG models that will be/ has been published.

The security

   considerations of MSDP [RFC3618].

[Sandy]: Thank you for point out it. We will fix it.

[Sandy]: OK. We will add some description about it.

[Sandy]: Because the bearers of YANG model is different from SNMP, like NETCONF, RESTCONF, we use general description to explain it. 

“support” -> “supports”

“too” -> “to”

   control access to these operations.  The MSDP Yang module support the    "clear-peer" and "clear-sa-cache" RPCs.  If access too either of    these is compromised, they can result in unexpected MSDP peer    breakdown and unexpected SA information deletion. 
[Sandy]: Thank you for point out it. We will fix it.

Best,

Jake

On 3/1/18, 8:14 AM, "Stig Venaas" <[email-masked]> wrote:

 

Stig

 

Hi PIMers,

 

Thanks,

mike