Subject: Re: [pim] Apply for WGLC about draft-ietf-pim-igmp-mld-snooping-yang

From: "Holland, Jake" <[email-masked]>
Date: Tue, 18 Dec 2018 04:22:49 +0000

Hi Hongji,

I support wglc.

It looks mostly good to me, assuming the schema is well-tested by operators. I like the examples and the network diagrams to support them, thanks.

A few minor comments and questions:

1.
I was unclear on the meaning here (it appears several times):
      leaf last-reporter {
        type inet:ipv4-address;
        description
          "Address of the last host which has sent report to join
           the multicast group.";
      }

Is this the most recent host that newly became a member of the group, or the last host to send any membership report indicating it’s a member of the group? (The “report to join” clause could be read either way, I think.)

2.
I saw some instances of wrong capitalization, with “IPV4” and “IPV6” instead of “IPv4” and “IPv6”.

From: Hongji Zhao <[email-masked]>
Date: 2018-12-17 at 18:10
To: Stig Venaas <[email-masked]>, Michael McBride <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [pim] Apply for WGLC about draft-ietf-pim-igmp-mld-snooping-yang

Hi Stig & Mike,

I have addressed all the YANG DOCTOR’s comments about draft-ietf-pim-igmp-mld-snooping-yang-05.  I also referred to the comments for draft-ietf-pim-igmp-mld-yang.

Now the latest version is  draft-ietf-pim-igmp-mld-snooping-yang-06.  Apply for WGLC here. Thanks a lot!

Message: 1

Date: Mon, 10 Dec 2018 19:00:52 -0800

From: [email-masked]<mailto:[email-masked]>

To: <[email-masked]<mailto:[email-masked]>>

Cc: [email-masked]<mailto:[email-masked]>

Subject: [pim] I-D Action:

                draft-ietf-pim-igmp-mld-snooping-yang-06.txt

Message-ID: <[email-masked]<mailto:[email-masked]>>

Content-Type: text/plain; charset="utf-8"

A New Internet-Draft is available from the on-line Internet-Drafts directories.

This draft is a work item of the Protocols for IP Multicast WG of the IETF.

        Title           : A Yang Data Model for IGMP and MLD Snooping

        Authors         : Hongji Zhao

                          Xufeng Liu

                          Yisong Liu

                          Mahesh Sivakumar

                          Anish Peter

                Filename        : draft-ietf-pim-igmp-mld-snooping-yang-06.txt

                Pages           : 43

                Date            : 2018-12-10

Abstract:

   This document defines a YANG data model that can be used to configure and manage Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) Snooping devices. The YANG module in this document conforms to Network Management Datastore Architecture (NMDA).

The IETF datatracker status page for this draft is:

https://datatracker.ietf.org/doc/draft-ietf-pim-igmp-mld-snooping-yang/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dpim-2Digmp-2Dmld-2Dsnooping-2Dyang_&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=bqnFROivDo_4iF8Z3R4DyNWKbbMeXr0LOgLnElT1Ook&m=3D3UYz7TpX8iO-jwphwb8u-fkGiUqnpUKrybxF1gBUY&s=NpJQms3GSrEmK7bQLPh8AYpjRsHqJePlxmCIWBtXHOk&e=>

BR/Hongji
赵宏吉

---

From: Hongji Zhao <[email-masked]>
Date: Tue, 18 Dec 2018 06:28:51 +0000

Hi Holland,

Thanks a lot for your supporting.  Please see inlines.

BR/Hongji
赵宏吉

From: Holland, Jake <[email-masked]>
Sent: Tuesday, December 18, 2018 12:23 PM
To: Hongji Zhao <[email-masked]>; Stig Venaas <[email-masked]>; Michael McBride <[email-masked]>
Cc: [email-masked]
Subject: Re: [pim] Apply for WGLC about draft-ietf-pim-igmp-mld-snooping-yang

Hi Hongji,

I support wglc.

1.

Is this the most recent host that newly became a member of the group, or the last host to send any membership report indicating it’s a member of the group? (The “report to join” clause could be read either way, I think.)
                      -----------------The last-reporter means the last host to send membership report for this group.  It refers to the “set flag” and "clear flag" in RFC 2236.

2.
I saw some instances of wrong capitalization, with “IPV4” and “IPV6” instead of “IPv4” and “IPv6”.
                      -------------------Thanks, I will update them.

From: Hongji Zhao <[email-masked]<mailto:[email-masked]>>
Date: 2018-12-17 at 18:10
To: Stig Venaas <[email-masked]<mailto:[email-masked]>>, Michael McBride <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [pim] Apply for WGLC about draft-ietf-pim-igmp-mld-snooping-yang

Hi Stig & Mike,

Message: 1

        Authors         : Hongji Zhao

                          Xufeng Liu

                          Yisong Liu

                          Mahesh Sivakumar

                          Anish Peter

                Pages           : 43

                Date            : 2018-12-10

Abstract:

BR/Hongji
赵宏吉