Subject: Re: [pim] pim WGLC for draft-ietf-pim-igmp-mld-snooping-yang-07

From: Hongji Zhao <[email-masked]>
Date: Tue, 4 Jun 2019 06:40:51 +0000

As a co-author I'm not aware of any IPR claims related to the draft.

BR/Hongji
赵宏吉

Message: 1
Date: Mon, 3 Jun 2019 13:32:21 -0700
From: Stig Venaas <[email-masked]>
To: Xiejingrong <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [pim] pim WGLC for
	draft-ietf-pim-igmp-mld-snooping-yang-07
Message-ID:
	<[email-masked]>
Content-Type: text/plain; charset="UTF-8"

Hi

It would have been good to see more responses to the WGLC, but given that we have at least a few non-authors supporting it, and we have authors from a broad set of vendors, the document passed WGLC. In order to proceed with publication, we need each of the authors to state whether they are aware of any IPR claims related to the draft.

Thanks,
Stig

On Wed, May 22, 2019 at 6:53 PM Xiejingrong <[email-masked]> wrote:
> Support
> Thanks
> Jingrong

---

From: Hongji Zhao <[email-masked]>
Date: Tue, 4 Jun 2019 07:16:04 +0000

Hi Stig,

Please check inline, thanks!

BR/Hongji

Message: 2
Date: Mon, 3 Jun 2019 13:46:05 -0700
From: Stig Venaas <[email-masked]>
To: Xiejingrong <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [pim] pim WGLC for
	draft-ietf-pim-igmp-mld-snooping-yang-07
Message-ID:
	<CAHANBtKzHfVMNo_1=[email-masked]>
Content-Type: text/plain; charset="UTF-8"

Hi

We might actually need another version before proceeding.

In the description of the explicit-tracking leaf it says "Track the IGMP & MLD snooping v3 membership reports". Shouldn't it say "IGMP v3 and MLD v2" snooping membership reports or something?
[Hongji] ok, I will update it.

I also see at https://datatracker.ietf.org/doc/draft-ietf-pim-igmp-mld-snooping-yang/
that there are 6 validation errors! They seem to be mostly that modules are not found, is this expected? Authors, please have a look.
[Hongji] The 6 yang validation errors are all the tool's issues.  The pyang 1.7.8 couldn't find module "ietf-l2vpn", "ietf-pseudowires", "ieee802-dot1q-bridge".  The yanglint 0.14.80 couldn't find "ietf-l2vpn".
               In fact the module "ietf-l2vpn" and "ietf-pseudowires" are both defined in draft-ietf-bess-l2vpn-yang-09.
               "ieee802-dot1q-bridge" belongs to IEEE.
                We expect the tools could fix the issues.

Stig