Subject: Re: [pim] draft-ietf-pim-reserved-bits wglc

From: William Atwood <[email-masked]>
Date: Sat, 1 Jun 2019 22:40:51 -0400

I support this document.

I have the following nits:

Section 1, para 2, line 5.  "the the" -> "the"

Section 5, para 1, line 3.  "allowing for 48 additional types by for
each of the three types"  I cannot parse this.  I assume that you want
to do something with 16*3 = 48, but this does not cut it.

Line 6.  "15.15 where" -> "15.15, where"

  Bill

On 2019-05-31 8:00 p.m., Mike McBride wrote:
> Hello good people of pim.
> 
> Today begins a two week wglc for draft-ietf-pim-reserved-bits. Please
> review the draft and reply with your support/non support. And have a
> great weekend.
> 
> https://datatracker.ietf.org/doc/draft-ietf-pim-reserved-bits/
> 
> thanks,
> mike
> 
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim
> 

-- 
Dr. J.W. Atwood, Eng.             tel:   +1 (514) 848-2424 x3046
Distinguished Professor Emeritus  fax:   +1 (514) 848-2830
Department of Computer Science
   and Software Engineering
Concordia University EV 3.185     email:[email-masked]
1455 de Maisonneuve Blvd. West    http://users.encs.concordia.ca/~bill
Montreal, Quebec Canada H3G 1M8

---

From: "Mankamana Mishra (mankamis)" <[email-masked]>
Date: Sun, 2 Jun 2019 04:00:00 +0000

Support progressing this document . 

Sent from my iPhone

> On May 31, 2019, at 17:00, Mike McBride <[email-masked]> wrote:
>

---

From: "Duncan, Ian" <[email-masked]>
Date: Sun, 2 Jun 2019 18:06:36 +0000

Hello --

I too support this document, at least in its goals. Also I concur with Bill that section 5 requires work. 

Suggest that:

 " This document defines types 13, 14 and 15 (Type Space Extension) each then allowing for up to 16 additional subtypes in each of these three types, ..." could be better way to begin, and then follow form throughout. Use of "subtype" is consistent with the bit-blocked illustration, and seems helpfully unambiguous.

Best .. Ian

On 2019-06-01, 22:41, "pim on behalf of William Atwood" <[email-masked] on behalf of [email-masked]> wrote:

    I support this document.

    

      Bill

---

From: <[email-masked]>
Date: Tue, 4 Jun 2019 08:47:29 +0800 (CST)

Support.

Sandy

原始邮件

发件人：MikeMcBride <[email-masked]>
收件人：[email-masked] <[email-masked]>;
日 期 ：2019年06月01日 08:00
主 题 ：[pim] draft-ietf-pim-reserved-bits wglc

thanks,
mike

---

From: "Ramakrishnan Chokkanathapuram (ramaksun)" <[email-masked]>
Date: Tue, 4 Jun 2019 00:53:58 +0000

I support adoption of this draft..

Thanks,
Ramki

On 5/31/19, 5:00 PM, "pim on behalf of Mike McBride" <[email-masked] on behalf of [email-masked]> wrote:

    
    
    thanks,
    mike

---

From: "Vengada Prasad Govindan (venggovi)" <[email-masked]>
Date: Tue, 4 Jun 2019 15:55:10 +0000

I support adoption of this draft.
Thanks
Prasad

    

    thanks,
    mike

---

From: Xufeng Liu <[email-masked]>
Date: Wed, 5 Jun 2019 07:49:42 -0400

Support.

Thanks,
- Xufeng

---

From: Stig Venaas <[email-masked]>
Date: Tue, 25 Jun 2019 12:59:27 -0700

Hi

I really appreciate the support, and in particular the careful reviews and
comments by Bill and Ian.

I agree the language regarding the 48 subtypes was rather clumsy. I've now
submitted version 02 that I hope addresses your concerns. The new text is:

   The type space defined by the existing PIM specifications is almost
   exhausted.  This document defines types 13, 14 and 15, such that each
   of these types has 16 subtypes, providing a total of 48 subtypes
   available for future pim extensions.  This is achieved by for each of
   the types 13, 14 and 15, using the four most significant flag bits
   (bits 4-7) as a new field to store the extended type.  These types
   are referred to as types 13.0 to 13.15, 14.0 to 14.15 and 15.0 to
   15.15, where the number after the dot denotes the value stored in the
   new field.

Let me know if you still have concerns.
Thanks,
Stig

On Wed, Jun 5, 2019 at 4:50 AM Xufeng Liu <[email-masked]> wrote:
>> Hello good people of pim..
>>

---

From: William Atwood <[email-masked]>
Date: Tue, 25 Jun 2019 22:24:25 -0400

Works for me.  One small suggestion:

achieved by for each of the types 13, 14 and 15, using the four most
significant flag bits

-->

achieved by using, for each of the types 13, 14 and 15, the four most
significant flag bits

  Bill

---

From: Mike McBride <[email-masked]>
Date: Thu, 27 Jun 2019 11:23:46 -0700

Thank you all for your comments and support. We have consensus to
progress the draft to the iesg for publication.

I'll take it from here unless someone would like to volunteer to
shepherd the draft.

mike