Subject: [pim] pim-bdr and pim-dr-improvement status

From: Michael McBride <[email-masked]>
Date: Wed, 16 Feb 2022 04:57:26 +0000

Hello authors of pim-bdr and pim-dr-improvement,

Both drafts are expiring this week and Stig and I were hoping to get a status update and plan soon. Has anyone started a comparison between them? It would be good to decide this year whether both drafts really are needed to progress as separate solutions or whether they should be combined. We are willing to help as needed.

Thanks,
mike

-----Original Message-----
From: pim <[email-masked]> On Behalf Of Michael McBride
Sent: Wednesday, July 07, 2021 11:37 AM
To: [email-masked]
Subject: Re: [pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM DR, should it be added to PIM DR improvements or different draft

Howdy,

Stig and I feel we have consensus to adopt this draft. Thank you for the responses.

Authors please submit a new draft-ietf-pim version and let's plan to discuss at 111.

mike

-----Original Message-----
From: pim <[email-masked]> On Behalf Of Michael McBride
Sent: Monday, June 28, 2021 3:13 PM
To: [email-masked]
Subject: Re: [pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM DR, should it be added to PIM DR improvements or different draft

Hello again,

It's been a week with no response to this adoption call. We will give it another week and if still no response we won't adopt at this time.

thanks,
mike

-----Original Message-----
From: pim <[email-masked]> On Behalf Of Michael McBride
Sent: Monday, June 21, 2021 6:11 PM
To: [email-masked]
Subject: [pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM DR, should it be added to PIM DR improvements or different draft

Hello all,

We are picking back up on this thread and using it as a call for adoption. During IETF 110 we had 9 in favor and 2 against adoption. Please read the draft: https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-mankamana-pim-bdr%2F&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C78e71bb8473b4dc0b3ea08d941764114%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637612798428177836%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=3FhZ6DWqj0M%2BcIYTUcGpIlPBR%2Fsmv9EwvaCtMLeJgyc%3D&amp;reserved=0 and indicate if you support adoption. 

If you don't support adoption please indicate whether you would support merging with draft-ietf-pim-dr-improvement or have other suggestions. The minutes are included below to show the options with progressing this draft.

thanks,
mike

draft-mankamana-pim-bdr - Mankamana
Lenny - this concept of priority and preemption is not unique to pim: vrrp, rsvp with backup paths, etc. can we leverage from those? Was it protocol level stuff or vendor implementations, those could be good examples. leave it up to implementations?
Alvaro - what has me confused is talking about two solutions that are basically the same thing. A good argument has been made on how the previous draft isn't needed. It would be nice if all the solutions was considered in one draft. We seem to be circuling around implementations, first resolve if we want single or multiple solutions. And then understand how they interact.
Stig - I agree. We initially only had one sticky DR in other draft, now we have two proposals. Do we actually need two solutions? Are there different use cases where one is better then the other?
Alvaro - I'm not advocating for one or two, the wg to decide. maybe we define multiple use cases. Needs more coordination. 
Stig - if the wg decides we only need one solution that covers all the use cases we probably only want to publish one of them.
Mike - some may want to have a hello option and others may not. And right now we only have one wg document. Let's say we do adopt this draft, should we hold off on progressing both documents until they are both progressed together?
Alvaro - That would be nice. they are not dependent on each other. they don't have to progress together. progressing close would be nice. 
Stig - we shouldn't progress any document until we carefully decide what solution is best or if we want both solutions. Lets compare both options.
Mike - let's poll for adoption. 
Stig - just because we adopt both documents doesn't mean we publish both documents.
Poll - 9 in favor and 2 against. Will take to the list.

-----Original Message-----
From: pim <[email-masked]> On Behalf Of Mankamana Mishra (mankamis)
Sent: Wednesday, January 06, 2021 11:29 AM
To: Alvaro Retana <[email-masked]>; zhang.zheng <[email-masked]>; Stig Venaas <[email-masked]>
Cc: Sridhar Santhanam (sridsant) <[email-masked]>; [email-masked]
Subject: Re: [pim] Sticky PIM DR, should it be added to PIM DR improvements or different draft

Thanks every one for input. So I would update Sticky PIM DR without capability option in draft-mankamana-pim-bdr. Will ask for adoption in coming IETF. 

Mankamana 

On 12/4/20, 9:04 AM, "Alvaro Retana" <[email-masked]> wrote:

    On December 4, 2020 at 11:03:22 AM, Stig Venaas wrote:

    Stig:

    Hi!

    > Thoughts? Do you see this differently?

    I'm ok with whatever the WG decides, as long as the relationship and
    interaction between multiple potential solutions is clear.

    This is what I wrote in my review of draft-ietf-pim-dr-improvement-09:

    ===
    (2) As far as I can see draft-mankamana-pim-bdr has not been adopted yet.
        Assuming that is the plan, how would the two mechanisms interact?  Given
        that draft-mankamana-pim-bdr doesn't add options, and §5 says that if no
        options are received then the routers MUST use rfc7761, how does a router
        implementing this specification tell the difference?

        I realize that some of these questions may be better directed at
        draft-mankamana-pim-bdr, but because the WG agreed that a statement
        relating the two should be included in this document [1], then I'm
        asking now.  I would really like to understand what the WG expects.
    ===

    The WG is already aware of both drafts.  Assuming
    draft-mankamana-pim-bdr is adopted, I would prefer it if both
    solutions are progressed together (one or two documents is ok with
    me).

    Thanks!

    Alvaro.

_______________________________________________
pim mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fpim&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C78e71bb8473b4dc0b3ea08d941764114%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637612798428177836%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=GXirkcnys6MXCsYZQCDCMVkqTIv49dKPSOLMMMDuqT4%3D&amp;reserved=0
_______________________________________________
pim mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fpim&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C78e71bb8473b4dc0b3ea08d941764114%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637612798428187826%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=OnyNVjzLNwMCS6DDLGF%2B79PmqOkEpoI%2BvSu4o1gX7so%3D&amp;reserved=0
_______________________________________________
pim mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fpim&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C78e71bb8473b4dc0b3ea08d941764114%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637612798428187826%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=OnyNVjzLNwMCS6DDLGF%2B79PmqOkEpoI%2BvSu4o1gX7so%3D&amp;reserved=0
_______________________________________________
pim mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fpim&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C78e71bb8473b4dc0b3ea08d941764114%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637612798428187826%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=OnyNVjzLNwMCS6DDLGF%2B79PmqOkEpoI%2BvSu4o1gX7so%3D&amp;reserved=0

---

From: "Mankamana Mishra (mankamis)" <[email-masked]>
Date: Wed, 16 Feb 2022 06:28:29 +0000

Hi mike ,
Will be presenting BDR draft this IETF .

Mankamana
________________________________
From: Michael McBride <[email-masked]>
Sent: Tuesday, February 15, 2022 8:57:26 PM
To: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: pim-bdr and pim-dr-improvement status

Thanks,
mike

-----Original Message-----
From: pim <[email-masked]> On Behalf Of Michael McBride
Sent: Wednesday, July 07, 2021 11:37 AM
To: [email-masked]
Subject: Re: [pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM DR, should it be added to PIM DR improvements or different draft

Howdy,

mike

-----Original Message-----
From: pim <[email-masked]> On Behalf Of Michael McBride
Sent: Monday, June 28, 2021 3:13 PM
To: [email-masked]
Subject: Re: [pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM DR, should it be added to PIM DR improvements or different draft

Hello again,

thanks,
mike

-----Original Message-----
From: pim <[email-masked]> On Behalf Of Michael McBride
Sent: Monday, June 21, 2021 6:11 PM
To: [email-masked]
Subject: [pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM DR, should it be added to PIM DR improvements or different draft

Hello all,

thanks,
mike

-----Original Message-----
From: pim <[email-masked]> On Behalf Of Mankamana Mishra (mankamis)
Sent: Wednesday, January 06, 2021 11:29 AM
To: Alvaro Retana <[email-masked]>; zhang.zheng <[email-masked]>; Stig Venaas <[email-masked]>
Cc: Sridhar Santhanam (sridsant) <[email-masked]>; [email-masked]
Subject: Re: [pim] Sticky PIM DR, should it be added to PIM DR improvements or different draft

Mankamana

    Stig:

    Hi!

    ===

    Thanks!

    Alvaro.

---

From: <[email-masked]>
Date: Wed, 16 Feb 2022 17:29:06 +0800 (CST)

Hi Mike, 
Thank you for your reminder! 
Will update the PIM DR Improvement draft with co-author as soon as possible. 
There is much difference between the two solutions, detailed comparison in the mailing list or meeting will be provided. 
Thanks,
Sandy
------------------原始邮件------------------
发件人：MichaelMcBride
收件人：[email-masked];[email-masked];
抄送人：[email-masked];
日 期 ：2022年02月16日 12:58
主 题 ：[pim] pim-bdr and pim-dr-improvement status
Hello authors of pim-bdr and pim-dr-improvement,
Both drafts are expiring this week and Stig and I were hoping to get a status update and plan soon. Has anyone started a comparison between them? It would be good to decide this year whether both drafts really are needed to progress as separate solutions or whether they should be combined. We are willing to help as needed.
Thanks,
mike
-----Original Message-----
From: pim <[email-masked]> On Behalf Of Michael McBride
Sent: Wednesday, July 07, 2021 11:37 AM
To: [email-masked]
Subject: Re: [pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM DR, should it be added to PIM DR improvements or different draft
Howdy,
-----Original Message-----
From: pim <[email-masked]> On Behalf Of Michael McBride
Sent: Monday, June 28, 2021 3:13 PM
To: [email-masked]
Subject: Re: [pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM DR, should it be added to PIM DR improvements or different draft
Hello again,
-----Original Message-----
From: pim <[email-masked]> On Behalf Of Michael McBride
Sent: Monday, June 21, 2021 6:11 PM
To: [email-masked]
Subject: [pim] mankamana-pim-bdr adoption call. Was: RE: Sticky PIM DR, should it be added to PIM DR improvements or different draft
Hello all,
-----Original Message-----
From: pim <[email-masked]> On Behalf Of Mankamana Mishra (mankamis)
Sent: Wednesday, January 06, 2021 11:29 AM
To: Alvaro Retana <[email-masked]>; zhang.zheng <[email-masked]>; Stig Venaas <[email-masked]>
Cc: Sridhar Santhanam (sridsant) <[email-masked]>; [email-masked]
Subject: Re: [pim] Sticky PIM DR, should it be added to PIM DR improvements or different draft
https://www.ietf.org/mailman/listinfo/pim

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 16 Feb 2022 07:11:36 -0500

On February 15, 2022 at 11:57:49 PM, Michael McBride wrote:

Hi!

> Both drafts are expiring this week and Stig and I were hoping to get a status
> update and plan soon. Has anyone started a comparison between them? It would
> be good to decide this year whether both drafts really are needed to progress
> as separate solutions or whether they should be combined. We are willing to
> help as needed.

This is part of what I wrote when I returned draft-ietf-pim-dr-improvement to the WG, in Oct/2020 [A].  At the time pim-bdr hadn't been adopted, so I edited that part out.

=====
Stig/Mike:  I looked at the archive [1] and the minutes [3], and it
looks (in the minutes) like I said "clearly state why there are two
different drafts for the same problem and why they aren't combined".
:-(  The text in §5 does mention the difference, but it simply opens
up more questions...and there is not a clear differentiation of when
to use one or the other.  At first glance, they just seem to be two
different solutions for the same problem.

...

The other question in the minutes is about whether the 2 drafts should
be merged, or even if that was discussed.  Was it considered?  What
are the WG expectations when defining two solutions?  Are there really
different use cases, or is the intent to simply let the market choose?
 This document is on the Standards Track, but draft-mankamana-pim-bdr
is marked as Informational -- are those the right statuses to use?
Should they be Experimental instead?

...

[1] mailarchive.ietf.org/arch/msg/pim/hWi6rDIbbhcEjEuQ_y3z1o6Wulw
[3] https://datatracker.ietf.org/doc/minutes-104-pim/
=====

Thanks!

Alvaro. 

[A] https://mailarchive.ietf.org/arch/msg/pim/eo-udOxoKXhBiGhOV0zgqyZ8Uzs/

---

From: Stig Venaas <[email-masked]>
Date: Mon, 28 Feb 2022 10:01:05 -0800

Hi all

Here is my take on this. Previously the two drafts were solving
different problems. dr-improvement was focusing on sticky DR, which is
a useful concept. The bdr draft was focusing on backup-DR and did not
address sticky DR at all.

However, the bdr draft now includes a sticky DR solution as well. I
think the main thing we need to figure out now is which sticky DR
solution we think is best, or is there a need for both the solutions?

To make progress on this we should see what the pros and cons are for
each solution and their applicability. Are there certain cases where
only one of the solutions would work, or one has clear advantages? I
certainly hope the authors of the drafts can provide details on this,
but also hope to hear from the rest of the WG. It would be great to
have more discussion before the upcoming meeting. It would also be
great to have presentations and discussion at the meeting itself.
These drafts have been around for a while and we need to make progress
on this.

Regards,
Stig

---

From: "Mankamana Mishra (mankamis)" <[email-masked]>
Date: Mon, 28 Feb 2022 22:45:01 +0000

Sure, we can have discussion in this IETF over this topic. And it would help us to make progress .

From: Stig Venaas <[email-masked]>
Date: Monday, February 28, 2022 at 10:01 AM
To: Alvaro Retana <[email-masked]>
Cc: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, Michael McBride <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: [pim] pim-bdr and pim-dr-improvement status
Hi all

Regards,
Stig