Subject: The Average User (Was: RE: ASN.1 vs XML (used to be RE: I-DACTIO N:draft-ietf-pkix-scvp-00.txt))

From: "Flanigan, Bill" <[email-masked]>
Date: Wed, 14 Jul 1999 08:29:07 -0400

Hello Steve,

	Boy, have you ever got that one right!  The *average user* in a
large organization's PKI is often just barely computer literate, and doesn't
know (or care) what a browser is much less how it works.  It's just
point-and-click, point-and-click, etc.  And this is how it should be.  If
you don't "hide all technology from all life forms," it won't be used (or
used correctly).  For those who are interested (less than five percent of
end users?), they can, of course, view the windows proffered by their
favorite browser or download the binary from the repository.

Bill

> ----------
> From: 	Stephen Kent[SMTP:[email-masked]]
> Sent: 	Wednesday, July 14, 1999 2:19 AM
> To: 	Timothy Fisher
> Cc: 	[email-masked]'
> Subject: 	Re: ASN.1 vs XML (used to be RE:
> I-DACTION:draft-ietf-pkix-scvp-00.txt)
> 
> Tim,
> 
> I think it is a rare user indeed who ever wants to look at a certificate.
> Experience suggests that the certificate viewing feature of browsers is
> rarely invoked by the average user.
> 
> Steve
>

---

From: Daniel Finkelstein <[email-masked]>
Date: Fri, 16 Jul 1999 16:39:28 -0400

"Flanigan, Bill" wrote:

Hello Steve,

Boy, have you ever got that
one right!  The *average user* in a

large organization's PKI is often just barely computer literate, and
doesn't

know (or care) what a browser is much less how it works.  It's
just

point-and-click, point-and-click, etc.  And this is how it should
be.  If

you don't "hide all technology from all life forms," it won't be used
(or

used correctly).  For those who are interested (less than five
percent of

I think this makes a strong case for centralized policy mechanisms, a la
Mission Control for Netscape (browsers), that users don't need to know
about nor maintain. But how about override?

The balance between central control and user control shifts depending
on, as you mentioned, the knowledge/intelligence of the user, the requirements
of the application and environment, and the capabilities of the infrastructure.

--
Daniel Alex Finkelstein
New Technologies
phone   212-383-2951
pager   917-427-1630
fax     212-383-3289
Securities Industry Automation Corporation