Subject: RFC 2527 revision

From: "Juan Rodriguez-Torrent" <[email-masked]>
Date: Thu, 8 Jul 1999 01:32:38 -0400

RFC 2527 (Certificate Policy and Certification Practices Framework) Revision.

The Internet Engineering Task Force (IETF) Request for Comments (RFC) 2527, originally known as PKIX4 and also as "The Chokhani-Ford Framework" was developed from two different projects funded by the U.S. and Canadian governments. The IETF PKIX group iterated the draft for about a year, then was approved as an informal RFC. The final version is dated April 1998 and the formal RFC number was granted in March 1999.

At some point, the original draft was used as a starting document by many individuals and organizations developing Certificate Policies (CPs) and Certification Practices Statements (CPSs) and began to be used in a number of different forums. Feedback has indicated that the document in its present state does not meet all the needs from the different communities it is supposed to help. As a result of this feedback an effort to revise this document coalesced. The broad acceptance and interest garnered by this work from the business, legal, government, and technical communities motivated widening the editorial group to include members of several interest groups. The original authors of RFC 2527, S. Chokhani -CygnaCom- and W. Ford -VeriSign- joined forces with J. Larimer -NACHA-, C. Merrill -ABA-, M. Power - Gov. of Canada-, J. Rodriguez-Torrent -IBM- and R. Sabett -Spyrus- forming an editorial group and initiating a formal revision of the RFC 2527 to make changes to the General Provisions and Certificate Life-Cycle aspects of the RFC.

To bring forward to the IETF open process a revised draft of RFC 2527 promptly, while keeping the instructional value and the completeness of the original work intact, the editorial group decided to obtain comments from the various communities of interest. These comments, gathered in open meetings, will be the first posting to the PKIX4 revision public mail list as it initiates operations today. Individuals can bring forth comments and requirements by joining this public mail list -see how to join below- or sending a note to the chair of the editorial group ([email-masked]). A coherent first draft will be released shortly after the July meeting of the IETF in Oslo (Several items pending at this late date).

To join the PKIX4 mailing list, send a request to [email-masked] with "subscribe pkix4" in the body of the message or to [email-masked] with only the word "subscribe" in the body of the message. In either case DO NOT include the quotation marks on your request.

Thank you

The Editorial Group for the Revision of RFC 2527

PS  I'm behind schedule with the draft but the list is open for business and I will start posting stuff (feedback collected from open meetings) sometime today. 

JRT

Juan Rodriguez-Torrent
[email-masked]

"It is better to sleep on things beforehand than lie awake about them afterwards." Baltasar Gracian

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 8 Jul 1999 11:22:10 -0700

Juan, can you clarify the plans for promulgating the document(s) in question to the various other organizations that need to buy into it, and any plans by the creator's to address this.

Todd

  ----- Original Message ----- 
  From: Juan Rodriguez-Torrent 
  To: [email-masked] ; [email-masked] ; [email-masked] ; [email-masked] ; [email-masked] ; [email-masked] ; [email-masked] ; [email-masked] 
  Sent: Wednesday, July 07, 1999 10:32 PM
  Subject: RFC 2527 revision

  Thank you

  JRT

  Juan Rodriguez-Torrent
  [email-masked]