Subject: RE: ASN.1 vs XML (used to be RE: I-D ACTION:draft-ietf-pkix-scvp- 00.txt)

From: [email-masked]
Date: Fri, 9 Jul 1999 14:38:59 -0400

ASN.1 is a syntax that enables protocol engineers to communicate abstractly
about bits that may travel down a wire, including the qualities:

optional elements
default values
inheritance (using object classes)
constraints

XML is markup language that can be used to format (or encode) bits that
travel down a wire.

There is no reason why ASN.1-defined data can not be formatted as XML.

For those of you advocating the use of XML, does XML provide a rich set a
abstract qualities for engineers to use when communicating about bits that
may travel down a wire?

Frank Balluffi
CertCo

-----Original Message-----
From: Ambarish Malpani [mailto:[email-masked]]
Sent: Thursday, July 08, 1999 7:43 PM
To: 'PKIX-List'
Subject: ASN.1 vs XML (used to be RE: I-D
ACTION:draft-ietf-pkix-scvp-00.txt)

Can we please change the subject on this discussion?

Thanks,
Ambarish

---------------------------------------------------------------------
Ambarish Malpani
Architect					         650.567.5457
ValiCert, Inc.				        [email-masked]
1215 Terra Bella Ave.		              http://www.valicert.com
Mountain View, CA 94043-1833

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Thursday, July 08, 1999 3:56 PM
> To: Anders Rundgren; PKIX-List; Stephen Kent;
> [email-masked]; William Z Pope
> Subject: Re: I-D ACTION:draft-ietf-pkix-scvp-00.txt
> 
> 
> 
> ----- Original Message -----
> From: Anders Rundgren <[email-masked]>
> To: PKIX-List <[email-masked]>; Stephen Kent <[email-masked]>;
> [email-masked] 
> <[email-masked]>; William Z
> Pope <[email-masked]>
> Sent: Thursday, July 08, 1999 3:31 PM
> Subject: Re: I-D ACTION:draft-ietf-pkix-scvp-00.txt
> 
> 
> > Well,
> > sorry for bringing this up.  For certificates with huge 
> informational
> contents I
> > see some gain by wrapping an XML information object into ASN.1 X509
> > wrapper.  If PKI goes big, certificates proliferate the 
> decoding part (RP
> debugging)
> > will be helped by using XML rather than ASN.1.  Particularly if XML
> becomes
> > the lingua franca of the Web.   But of course XML is not 
> required, it is
> just
> > something that could be worth considering for lets say X509.v4
> 
> Actually if that is your intent,  I would think that the real 
> win here is
> having a number of different cert representation formats that include
> ASN.1/BER-DER, Binary, XML, and SMIME, myself.
> 
> and have the approved Cert Management Protocols support these
> inter-deployment interoperability issues directly.
> 
> Todd.
> 
> 
> 
>

---

From: Paul Koning <[email-masked]>
Date: Fri, 9 Jul 1999 14:51:47 -0400

>>>>> "BalluffiF" == BalluffiF  <[email-masked]> writes:

 BalluffiF> ASN.1 is a syntax that enables protocol engineers to
 BalluffiF> communicate abstractly about bits that may travel down a
 BalluffiF> wire, ...

True.

I think when people say "ASN.1" they really mean "ASN.1 and BER and
DER" -- and in fact most of the objections are to the latter two, not
to ASN.1 as an abstract notation.

	paul

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 9 Jul 1999 16:34:50 -0700

Frank - good point on the XML encoding of ASN.1 Structures - I like it.

Add 'the about to be proposed' preprocessor to resolve all the persistent
objects, their policy, and authentication requirements and who-ha!

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>; <>
Sent: Friday, July 09, 1999 11:38 AM
Subject: RE: ASN.1 vs XML (used to be RE: I-D

> ASN.1 is a syntax

technically its a language. It has a syntax.

> that enables protocol engineers to communicate abstractly

after being interpreted by an BER or DER encoder it does.

> There is no reason why ASN.1-defined data can not be formatted as XML.

Absolutely True !!! Actually this is an interesting observation to make.
That there is really no reason that you cannot write ASN.1 in XML... Imagine
being able to have one framework that encapsulates all service models.

> abstract qualities for engineers to use when communicating about bits that

Sure it does, or "it could" is a better answer -  becuase there is really no
reason you or anyone else cannot write an XML encoder (ala BER or DER) to
produce this said same datastream.

XML, like ASN.1 is a language and a related syntax to support the conveyance
of certain abstractions. Nothing more. Without the BER or DER encoders to
reduce ASN.1 to its data form.

The fact that no one has one of these tools floating about today is merely
an inconvience in the bigger picture.

> CertCo

Todd

---SNIP---