Subject: RE: I-D ACTION:draft-ietf-pkix-scvp-00.txt

From: "Ambarish Malpani" <[email-masked]>
Date: Thu, 1 Jul 1999 03:40:40 -0700

Unsigned requests are *not* insecure, as long as they contain
the RequestHash and the client verifies that it gets the same
RequestHash in the signed response.

(Paul, I think our example is broken - it doesn't reflect the
RequestHash in the response).

Ambarish

---------------------------------------------------------------------
Ambarish Malpani
Architect					         650.567.5457
ValiCert, Inc.				        [email-masked]
1215 Terra Bella Ave.		              http://www.valicert.com
Mountain View, CA 94043-1833

> -----Original Message-----
> From: Paul Hoffman / IMC [mailto:[email-masked]]
> Sent: Monday, June 28, 1999 8:17 PM
> To: [email-masked]
> Subject: Re: I-D ACTION:draft-ietf-pkix-scvp-00.txt
> 
> 
> At 08:07 PM 6/28/1999 -0700, Aram Perez wrote:
> > > It has the public key of the server built-in without a 
> cert. Remember, you
> > > don't need certs for root keys.
> >
> >This is fine but implies a limited number of SCVP servers.
> 
> A limited number that the client trusts. Absolutely. You 
> aren't going to 
> trust just anyone. Our expectation is that a typical client 
> might trust one 
> or two servers at a time. Of course, there's nothing in the 
> protocol that 
> limits the client to this.
> 
> >Believe me, I agree with specifying just one algorithm for 
> simplicity (and
> >interoperability) sake. It's just that I wanted someone else 
> to get beat up
> >like I was ;-)
> 
> We're open to such beating, and changing if necessary.
> 
> > >>4) Section 3.19 RequestSignature, 2nd paragraph. I would 
> suggest rewording
> > >>it as "Requests MUST include a RequestSignature item 
> unless the request is
> > >>done over an authenticated channel, such as..."
> > >
> > > That wording is equivalent to what we have, I think. I 
> prefer SHOULD to
> > > "MUST with exceptions" as a stylistic choice.
> >
> >I don't think that it is equivalent. With the original 
> wording I can send an
> >unsigned request over an unauthenticated channel and be 
> compliant but with
> >my wording I can't be compliant.
> 
> If you want to be insecure, you can. Again, our expectation is that 
> companies relying on SCVP will have their own SCVP servers. 
> They might want 
> to risk running the requests and responses over their 
> corporate networks. 
> Dumb, yes (given the small overhead of signing), but it should be 
> acceptable if they really want to do it even after the warnings.
> 
> > > We very explicitly did the opposite. *All* of the 
> semantics are in sections
> > > 2, 3, and 4; *only* the syntax is in sections 5 and 6. 
> The reason for this
> > > is to reduce confusion between the two syntaxes.
> >
> >In my cursory reading I missed this point. I would recommend 
> you highlight
> >this point to make it very clear and make sure all understand it.
> 
> Will do.
> 
> --Paul Hoffman, Director
> --Internet Mail Consortium
> 
>

---

From: Paul Hoffman / IMC <[email-masked]>
Date: Thu, 01 Jul 1999 08:56:38 -0700

>RequestHash in the response).

Yipes! You're right. I had the RequestHash in the request but not in the 
response, which goes against the second MUST in section 3.18. I'll fix this.

--Paul Hoffman, Director