Subject: RE: Removing expired certificates from CRLs.....

From: Ambarish Malpani <[email-masked]>
Date: Thu, 13 Sep 2001 16:26:31 -0700

Mike, it is unclear to me why you consider CRLs to be a bad
mechanism for passing revocation data to OCSP responders.

The 2 big problems with CRLs are:
a.  distribution of full CRL data to a large number of clients. 
b. notifying all relying clients whenever a new (unexpected) CRL
has been produced due to a revocation event (ie. a CRL produced
earlier than the nextUpdate period on an old CRL).

We have deployed responders in a large number of places, where
we have used a push mechanism to send CRLs to our VA (our
OCSP server). This method has worked very well, even for pretty
large installations - the time to produce 100K CRLs isn't very
large. Neither is the time to get it from the CA to the VA.

The final relying parties are using OCSP and therefore getting
up to date responses, without needing to incur the overhead of
downloading full CRLs every time.

The CRL is just a standards based data
format for getting revocation information from the CA to the
VA - think of it as a database snapshot that is created
whenever the database changes.

Regards,
Ambarish

---------------------------------------------------------------------
Ambarish Malpani
Architect                                                650.567.5457
ValiCert, Inc.                                  [email-masked]
339 N. Bernardo Ave.                          http://www.valicert.com
Mountain View, CA 94043

> -----Original Message-----
> From: Michael Myers [mailto:[email-masked]]
> Sent: Thursday, September 13, 2001 11:26 AM
> To: Denis Pinkas
> Cc: IETF-PKIX
> Subject: RE: Removing expired certificates from CRLs.....
> 
> 
> 
> Denis,
> 
> Thank you for your consideration of historic aspect of 
> digital signatures.
> I'm sure more work remains to be done in this area.  I for one however
> remain more concerned of our broad assumptions regarding the 
> use of periodic
> CRLs as the basis for aperiodic OCSP-based services that 
> deliver on-demand
> class timeliness.  Several systems-level issues are 
> under-explored in this
> context.  Within closed environments there might exist data exchange
> mechanisms that are fully responsive to the security requirements CRLs
> satisfy but do so in a means that enables not only the timely 
> inter-domain
> exchange of revocation status, but validation status as well.
> 
> Mike
> 
> 
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Denis Pinkas
> > Sent: Thursday, September 13, 2001 1:31 AM
> > To: Michael Myers
> > Cc: IETF-PKIX
> > Subject: Re: Removing expired certificates from CRLs.....
> >
> >
> >
> > Michael,
> >
> > > Denis,
> > >
> > > What are your thoughts on the timeliness characteristic 
> between OCSP and
> > > CRLs?
> >
> > Well ...
> >
> > I must admit that the definition of the archive cutofff (section
> > 4.4.4) from
> > RFC 2560 has always been very strange for me, since it 
> defines a time
> > interval rather then an absolute time. I read several times 
> the text and
> > could not figure out how in practice it would be used.
> >
> > The text talks about a retention interval without saying
> > explictly to which
> > event it is relative to.
> >
> > Is it the time interval beyond the notAfter date from a 
> certificate ?
> > The text does not say so.
> >
> > In addition, the text is talking, as an example, of a retention
> > interval of
> > 7 years (!) whereas in the context of that thread we are 
> only talking of
> > about a month.
> >
> > If I had to define from scratch the extension I would 
> simply define an
> > absolute date (e.g. called 
> ExtendedRevocationInformationDate, quite a
> > long name, but explicit) that could directly override the 
> notAfter field
> > from the Validity field of a certificate. This would mean that this
> > extension allows to know until when the revocation information is
> > maintained. It is not directly related to the produceAt 
> time. The only
> > condition is that, when it is present, it is always later 
> than produceAt.
> >
> > This is a problem because, if I understand correctly RC 
> 2560, we have the
> > following equation:
> >
> > ArchiveCutoff = producedAt - retention interval.
> >
> > I do not see a clear relationship between these two concepts.
> >
> > Unless you see one, it would mean that an extension different from
> > ArchiveCutoff would be necessary for OCSP responses so that 
> we can have
> > identical concepts for CRLs and OCSP responses.
> >
> > Thanks for raising the question.
> >
> > Denis
> >
> > > Mike
> > >
> > > Michael Myers
> > > t: +415.819.1362
> > > e: mailto:[email-masked]
> > > w: http://www.traceroutesecurity.com
> > >
> > > > -----Original Message-----
> > > > From: Denis Pinkas [mailto:[email-masked]]
> > > > Sent: Wednesday, September 12, 2001 12:35 AM
> > > > To: Michael Myers
> > > > Cc: IETF-PKIX
> > > > Subject: Re: Removing expired certificates from CRLs.....
> > > >
> > > >
> > > >
> > > > > All,
> > > > >
> > > > > I think a unique extension creates the least impact.
> > > > >
> > > > > More broadly though, what's really bothering me is my sense
> > that we're
> > > > > backing into the notion of a 1-1 between CRLs and 
> online status
> > > > mechanisms.
> > > > >
> > > > > Assume an environment that both publishes CRLs and 
> offers OCSP-based
> > > > > services against the same set of certificates.  What if:
> > > > >
> > > > > a) The CA receives a revocation request at T1;
> > > > >
> > > > > b) A database state variable is flipped at T1+N;
> > > > >
> > > > > c) An OCSP request is received at T1+N+M;
> > > > >
> > > > > d) An OCSP response is transmitted at T1+N+M+K;
> > > > >
> > > > > e) Yet the next CRL cycle won't run (i.e. the cron
> > > > >    job won't fire) until T1+X where X >> (N+M+K).
> > > > >
> > > > > Thus relying parties are enabled to pick and choose between
> > CRLs or OCSP
> > > > > depending on how it might benefit their argument for remedy
> > > > under digital
> > > > > signature laws.
> > > > >
> > > > > Thoughts, anyone?
> > > >
> > > > Some validation policies, like Signature policies are able to
> > say whether
> > > > CRLs or OCSP responses shall be used.
> > > >
> > > > As an example see: draft-ietf-smime-espolicies-01.txt
> > > >
> > > > EnuRevReq  ::= ENUMERATED {
> > > >       clrCheck        (0),
> > > >                    --Checks must be made against current CRLs
> > > >                  -- (or authority revocation lists (ARL))
> > > >       ocspCheck       (1), -- The revocation status 
> must be checked
> > > >                   -- using the Online Certificate 
> Status Protocol
> > > >                   -- (OCSP),RFC 2450.
> > > >       bothCheck       (2),
> > > >                   -- Both CRL and OCSP checks must be 
> carried out
> > > >       eitherCheck     (3),
> > > >                   -- At least one of CRL or OCSP checks must be
> > > >                   -- carried out
> > > >       noCheck         (4),
> > > >                   -- no check is mandated
> > > >       other           (5)
> > > >                   -- Other mechanism as defined by 
> signature policy
> > > >                   -- extension
> > > >         }
> > > >
> > > > If either CRL (i.e.clrCheck) or OCSP (i.e. ocspCheck) is
> > mandated, then
> > > > there is no conflict between the two mechanisms.
> > > >
> > > > Denis
> > > >
> > > >
> > > > > Mike
> > > > >
> > > > > Michael Myers
> > > > > t: +415.819.1362
> > > > > e: mailto:[email-masked]
> > > > > w: http://www.traceroutesecurity.com g
> > > >
> >
>

---

From: "Michael Myers" <[email-masked]>
Date: Fri, 14 Sep 2001 08:21:32 -0700

Ambarish,

Actually I'm far less concerned about CRLs per se than the timeliness issue
that Carlisle and I discussed a few years back when he and I argued the
notions underlying OCSP.  What concerns me are the systems-level
requirements that derive from assuming CRLs are the only and best means to
deliver OCSP-based (or equivalent) services.

It seems to me we are heading in that direction.  That's not necessarily a
bad thing.  I can see that in some instances CRLs are sufficient, especially
in very large-scale commercial deployments involving ad-hoc interactions
between autonomous trust domains.  I can also see that in certain
deployments, high-frequency deltas can effectively address the timeliness
requirements OCSP might otherwise satisfy.

Yet a requirement on a more closed trust domain that it MUST produce a CRL
in order to deliver OCSP-based services seems to me to unduly burdensome.
Further, the exchange of equivalent information in support of delegated
validation (vice revocation) still remains an open issue in this context.
Lastly, there exists obvious issues when the periodicity of CRLs (as
generally practiced) is put up against the aperiodic and on-demand nature of
OCSP (or equivalent).

So, basically, I just think there's some issues to discuss.  As I've heard
repeatedly in the IETF, current market practices and shipping products
should not be permitted to constrain our consideration of the best technical
solution going forward.  I remain especially concerned that several
under-examined systems-level issues will cause problems down the road.
These are easily predictable today; we should be developing answers in a
concomitant fashion.

Mike

Michael Myers
t: +415.819.1362