Subject: AW: AW: pseudonym : small typo

From: Fantou Patrick <[email-masked]>
Date: Fri, 19 Oct 2001 09:32:10 +0200

Russ,

you certainly wanted to write

    id-at-pseudonym      AttributeType ::= { id-at 65 }

and not
    id-at-localityName      AttributeType ::= { id-at 65 }

Additional typo : title of Appendix A.

		Appendix A. Pseudo-ASN.1 ...
and not 	Appendix A. Psuedo-ASN.1 ...
Patrick
> -----Ursprüngliche Nachricht-----
> Von: Housley, Russ [mailto:[email-masked]]
> Gesendet: Dienstag, 16. Oktober 2001 21:31
> An: Fantou Patrick
> Cc: [email-masked]
> Betreff: Re: AW: I-D ACTION:draft-ietf-pkix-new-part1-09.txt
> 
> 
> Patrick:
> 
> >1. pseudonym should be supported in issuer and subject names,
> >  but the oid for pseudonym is missing in this document 
> (id-at-pseudonym : 
> > id-at 65 from X.520 2000)
> 
> Section 4.1.2.4 lists pseudonym as one of the attributes that 
> SHOULD be 
> supported.  However, pseudonym is missing from the ASN.1 
> module.  We need 
> to add:
> 
>     -- Naming attributes of type X520Pseudonym
> 
>     id-at-localityName      AttributeType ::= { id-at 65 }
> 
>     X520Pseudonym ::= CHOICE {
>        teletexString     TeletexString   (SIZE (1..ub-pseudonym)),
>        printableString   PrintableString (SIZE (1..ub-pseudonym)),
>        universalString   UniversalString (SIZE (1..ub-pseudonym)),
>        utf8String        UTF8String      (SIZE (1..ub-pseudonym)),
>        bmpString         BMPString       (SIZE (1..ub-pseudonym)) }
> 
>     ub-pseudonym INTEGER ::= 128
>

---

From: "Housley, Russ" <[email-masked]>
Date: Fri, 19 Oct 2001 09:15:50 -0400

>     id-at-localityName      AttributeType ::= { id-at 65 }

You are obviously correct.  I caught this error right after new-part1-10 
was sent to the Internet-Draft repository.  We will correct it in new-part1-11.

Russ