Subject: WG Last Call: Logotypes

From: [email-masked]
Date: Sat, 21 Sep 2002 10:07:39 -0400 (EDT)

This email initiates working group Last Call For "Internet X.509 Public Key 
Infrastructure: Logotypes in X.509 certificates", which is available at 

  http://www.ietf.org/internet-drafts/draft-ietf-pkix-logotypes-05.txt

Working Group Last Call will complete on or after October 5, 2002.  This 
document would be recommended as a standards track document.

---

From: David Maurus <[email-masked]>
Date: Sun, 22 Sep 2002 18:33:37 +0200

Two comments to the current draft:

*** 3rd paragraph on page 7: There's a typo
"...Compliant application MUST display and play more just one (or none) of the images and one (or none) of the audio sequences at the same time."

Presumably this should be "display and play just one", or perhaps "display and play more than just one" ?

*** 4th paragraph on page 9: Unfortunate use of patent-encumbered formats
'Implementations that support audio MUST support the MP3 audio format (with a MIME type of "audio/mpeg").'

I would propose to make MP3 optional, and make OGG VORBIS ("audio/x-vorbis") a MUST

Proposed wording:
'Implementations that support audio MUST support the OGG Vorbis format (with a MIME type of "audio/x-vorbis"), and might support the MP3 audio format (with a MIME type of "audio/mpeg")'

The reasoning behind my proposal is that otherwise
=> Selling any software capable of playing this extension would be subject to mp3 licensing terms, i.e. would require obtaining a license from Thomson.
=> While currently, Thomson does not charge licensing fees for *freely* distributed player software, this might change in the future. This would make it illegal to use free / Open Source software supporting the logo extension without having a license from Thomson.
=> Selling hardware (Personal Trusted Devices?) playing logotype-audio would be commercially unattractive 

Ogg Vorbis is considered patent free, offers better quality than mp3 according to recent studies, and is available in numerous free implementations and as source code with a BSD style license.

Best Regards,
David

---

From: "Housley, Russ" <[email-masked]>
Date: Mon, 23 Sep 2002 08:28:35 -0400

>Two comments to the current draft:

Thanks for reading the draft.

>"...Compliant application MUST display and play more just one (or none) of 
>the images and one (or none) of the audio sequences at the same time."
>

I tried to reword the paragraph.  Let me know if I did not resolve the problem.

    If a logotype is represented by more than one image file, then the
    image files MUST contain variants of the roughly the same image.
    Likewise, if a logotype is represented by more than one audio file,
    then the audio files MUST contain variants of the roughly the same
    audio sequence. Compliant applications MUST display more just one (or
    none) of the images and play just one (or none) of the audio
    sequences at the same time.

>'Implementations that support audio MUST support the OGG Vorbis format 
>(with a MIME type of "audio/x-vorbis"), and might support the MP3 audio 
>format (with a MIME type of "audio/mpeg")'
>
>=> Selling any software capable of playing this extension would be subject 
>to mp3 licensing terms, i.e. would require obtaining a license from Thomson.
>=> While currently, Thomson does not charge licensing fees for *freely* 
>distributed player software, this might change in the future. This would 
>make it illegal to use free / Open Source software supporting the logo 
>extension without having a license from Thomson.
>Ogg Vorbis is considered patent free, offers better quality than mp3 
>according to recent studies, and is available in numerous free 
>implementations and as source code with a BSD style license.

The authors selected MP3 because every media player seems to support it.

Before receiving your note, I had never heard of OGG Vorbis.  I did a 
Google search, and I found lots of information.

What do others think about this proposed change?

Russ