Subject: RE: What happened to the OCSPv2 draft?

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 16 Sep 2002 08:04:18 -0700

Has any party commercial or non-comercial endorsed the 
proposed 'standard' and committed to supporting it?

It is one thing to get a bunch of people to agree to
a proposal, quite another to persuade an industry to
deploy.

I fail to see the value of an XML expression of deployed
X.509 semantics. I fail to see the value of an ASN.1
encoding to rival deployed XML specifications.

		Phill

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, September 13, 2002 4:19 PM
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: What happened to the OCSPv2 draft?
> 
> 
> Of course, there already is a more efficient encoding for XML
> markup. The example at http://asn-1.com/EncodeBiometricSyntaxSets.htm
> shows that an X9.84/XCBF object can be encoded in 500+ bytes in XML,
> and that exactly the same abstract values can be encoded in 
> 50+ bytes in
> DER. The obvious conclusion is that for every canonical DER 
> value there
> is a canonical XER encoding that yields an XMl markup 
> representation of 
> that same value. Clearly messages can be stored and transferrd in DER
>  (which is not a particularly compact ASN.1 encoding, but  
> which enjoys
>  tools are cheap  and readily available) and exploded into 
> XML markup in 
> resource rich environments.
> 
> This is the thrust of the OASIS XML Common Biometric Format, the 2002
> revision of the X9.84 biometric information management and security , 
> the X9.96 XML Cryptographic Message Syntax, and the  X9.95 
> Trusted Time 
> Stamp standards. It is also the core of the NWI proposal in 
> ISO TC68/SC2 
> based on the XMLEncoding Rules and the schema defined in the ASC X9.68
> compressed domain certificate standard that moved forward in 
> ISO this week.
> If passed, this will result in a DER encoded certificate that is much
> smaller
> than the X.509 certificate format it is based on, and a 
> completely XML 
> certificate as well. The possibilities this will create to 
> stir the pot
> will be
>  interesting.
>  
> The idea of this approach is compelling for several reasons. 
> It provides a
> migration path into the XML space for ASN.1 defined specifications, it
> allows
> systems to be built  like my Biolojava tool kit that provide 
> support  for
> both XML
> aware and ASN.1 aware applications, and it provides 
> compression for XML
> values. 
> 
> But the really sweet  fallout of this is the simplicity of the XML
> signature 
> processing. It turns out to be almost equivalent  to the processing
> description used currently for DER in the IETF SMIME standard. 
> Anyone that can do SignedData using DER can, without nearly a
> thought, do the same with XML markup and leverage the browser.
> 
> And there are tools like mine emerging to support  these concepts, and
> standards that will use them.
> 
> Phil

---

From: Phil Griffin <[email-masked]>
Date: Mon, 16 Sep 2002 13:35:12 -0400

> proposed 'standard' and committed to supporting it?

There are at least two firms that I am aware of that are
building support for this into their tools. Note that
X9.68 has only recently become a US national standard.
It is now being "proposed" as an international standard.

> a proposal, quite another to persuade an industry to

Very true.

> encoding to rival deployed XML specifications.

I see much value in X.509 semantics, regardless of the
form of their expression. XML markup is just another
encoding rule for ASN.1 values.

Phil

---

From: Denis Pinkas <[email-masked]>
Date: Tue, 17 Sep 2002 09:37:13 +0200

Phill and Phil,

I would appreciate that you change the subject of the e-mails 
when you change topic.

Regards,

Denis