Subject: RE: Standards for Web-signing II

From: "James Jing" <[email-masked]>
Date: Wed, 29 Oct 2003 10:02:20 +1100

Identrus, a global banking PKI body, defined two methods for web signing. One is defined as a Netscape style browser plug-in, the other defined as an abstract Java interface. It also requires the content that is being signed to be separately displayed, and the digest of the content to be calculated by the "trusted subsystem".

I personally think the best approach would be for a unified standard to be adopted by all browsers, invocable by all common scripts like JavaScript, regardless of what the underlying implementation of the signature layer might be. I believe both PKCS#7 and XML standards must be supported. Content-to-be-signed should be defined by MIME-type so if the browser needs to popup another screen, it can be properly display the content. Whether a separate popup should be displayed must be determined by signature layer based on the type of key being used to sign the content.

Regards
James

-----Original Message-----
From: Anders Rundgren [mailto:[email-masked]]
Sent: Wednesday, 29 October 2003 6:59 AM
To: Markus Lorch; [email-masked]
Subject: Re: Standards for Web-signing II

Markus,

XML Signature standard essentially define something like
CMS/PKCS #7 in XML.  The standard "talks" about the signing
process but does not define any interface between the browser
and the signature requester which is what is needed among
many things in order to achieve a web-signing standard.

But this one is just for starters, the browser-interface for
on-line certfication processes (which seem to be the future)
is also not standardized.  MSFT's Xenroll has no implementation
in Mozilla or Netscape.  Few serious systems for this reason
build on Xenroll but rather on proprietary solutions.  Xenroll
is also in my opinion an unsatisfactory solution as the GUI
should be the same for each CA rather than all over the map.

rgds
Anders

----- Original Message ----- 
From: "Markus Lorch" <[email-masked]>
To: "'Anders Rundgren'" <[email-masked]>; <[email-masked]>
Sent: Tuesday, October 28, 2003 20:01
Subject: RE: Standards for Web-signing II

Anders,

isn't the XML Signature a standard that can be used for this

see
Mark Bartel et al, "XML Signature Syntax and Processing", World Wide Web
Consortium Recommendation, February 2002

Markus

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Anders Rundgren
> Sent: Tuesday, October 28, 2003 8:47 AM
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: Standards for Web-signing II
> 
> 
> 
> The answer to my earlier request seems to be:
> 
> There are apparently no standards and nothing in the works either
> with respect to signing on-line data on the web using 
> Internet browsers.
> 
> Since web-signing is today [*] used by many, many, more people
> and organizations than there are users of signed e-email, I 
> remain puzzled.
> 
> Is the PKI community really just a bunch of "nerds", mostly
> out of touch with the needs of the market?  The question is open.
> 
> *] Like Scandinavian banks having > 0.5M of users.
> All current systems rely on entirely proprietary mechanisms.
> Most of the vendors even require NDAs for getting the documentation.
> 
> Anders Rundgren
> 
> 
> ----- Original Message -----
> From: "Anders Rundgren" <[email-masked]>
> To: <[email-masked]>; <[email-masked]>; 
> <[email-masked]>
> Sent: Tuesday, September 02, 2003 14:07
> Subject: [pki-tc] Standards for Web-signing
> 
> 
> Folks,
> I just wanted to know the status of possible standardization
> efforts regarding signing on-line forms etc. on web.  As web-signing
> is a core function of many e-governments when communicating
> with their citizens it seems that this should be standardized if
> not already is.
> 
> Pointers are welcome.  Off-list or on-list.
> 
> rgds
> Anders Rundgren
> 
> To unsubscribe from this mailing list (and be removed from 
> the roster of the OASIS TC), go to
> http://www.oasis-open.org/apps/org/workgroup/pki-tc/members/le
ave_workgroup.php.

---

From: "Anders Rundgren" <[email-masked]>
Date: Wed, 29 Oct 2003 07:37:40 +0100

>Identrus, a global banking PKI body, defined two methods for
>web signing. One is defined as a Netscape style
>browser plug-in, the other defined as an abstract Java interface. 

The Netscape plugin interface was dropped in IE V6 and Java
does not look like an MSFT favorite.  This was just a side note.

>It also requires the content that is being signed to be
>separately displayed, and the digest of the content to be
>calculated by the "trusted subsystem".

Identrus, is I guess one of these parties requiring NDA?

>I personally think the best approach would be for a unified standard to
>be adopted by all browsers, invocable by all common scripts like
>JavaScript, regardless of what the underlying implementation of the
>signature layer might be. 
>I believe both PKCS#7 and XML standards
>must be supported. Content-to-be-signed should be defined by
>MIME-type so if the browser needs to popup another screen, it
>can be properly display the content. Whether a separate popup
>should be displayed must be determined by signature layer based
>on the type of key being used to sign the content.

I agree!
Although I do believe on-line signing is still a field that needs a
little more research as it is really very different to off-line.

Anders

Regards
James

-----Original Message-----
From: Anders Rundgren [mailto:[email-masked]]
Sent: Wednesday, 29 October 2003 6:59 AM
To: Markus Lorch; [email-masked]
Subject: Re: Standards for Web-signing II

Markus,

rgds
Anders

----- Original Message ----- 
From: "Markus Lorch" <[email-masked]>
To: "'Anders Rundgren'" <[email-masked]>; <[email-masked]>
Sent: Tuesday, October 28, 2003 20:01
Subject: RE: Standards for Web-signing II

Anders,

see

Markus

ave_workgroup.php.

---

From: "Florian Oelmaier" <[email-masked]>
Date: Wed, 29 Oct 2003 11:41:01 +0100

> >Identrus, a global banking PKI body, defined two methods for web 
> >signing. One is defined as a Netscape style browser plug-in, 
> the other 
> >defined as an abstract Java interface.
> 

Identrus defined a MIME-type to be used within an <EMBED>- or an
<OBJECT>-tag to include the signing plugin into HTML-pages. What type of
plugin processes this tag is not of concern to the identrus
specification. Netscape plugins or IE native plugins: both plugin
architectures should be able to handle the defined tag.

-- 
Florian Oelmaier
SyTrust

---

From: "Anders Rundgren" <[email-masked]>
Date: Wed, 29 Oct 2003 14:06:35 +0100

I believe this is a very good opportunity to study how
"Real Standards" actually are made:

If a vendor has a nice browser add-in solution that it believes
is worth the title "standard", there are a number of ways to
pursue this such as:

- Submitting the solution as "input" to a standards process.
  Costly, time-consuming, and potentially dangerous as you
  have to give up the control (well, maybe not if you are a
  BIG enough vendor...)

- Make the code available for free download in order to
  spread the solution, and blocking competing efforts.
  A vey popular method indeed!

- Submitting the code to let's say Microsoft, Mozilla.org etc
  for free inclusion, and by that establishing a "de-facto" standard

However, Identrus is a bank-controlled operation and therefore
operate in the same way as banks regarding their technology.
I.e. by acting "possessive" and most of all being scared that
a competitor would ever be able to profit on the work done.

A similar thing is the EMV-card that surely could replace most
other PKI cards on the market, but since it is also owned by a
bank-controlled entity, they will probably never make the client
software downloadable, a preinstall in Windows, or make the
card purchasable in small quantities on the web by anybody, and
will therefore most likely fail to establish EMV as a "de-facto"
standard.

If bank executives ever go to the Cinema(?), or rent a video,
they should take a look on the movie "A beautiful mind"
while at the same time thinking on the establishment of
important e-infrastructures.  Unfortunately, when you get
a fresh view on things, you often fail to apply it to your
own backyard because that "is a different thing".  But
it isn't, the problems with establishing common e-standards
are pretty universal and so are the "workarounds".  Unless
you are Microsoft and actually can do whatever you want,
and most of the time it even get it to work fairly well.

Anders Rundgren

----- Original Message -----
From: "Florian Oelmaier" <[email-masked]>
To: "'Anders Rundgren'" <[email-masked]>; "'James Jing'" <[email-masked]>; "'Markus Lorch'" <[email-masked]>;
<[email-masked]>
Sent: Wednesday, October 29, 2003 11:41
Subject: RE: Standards for Web-signing II

--
Florian Oelmaier
SyTrust

---

From: Hans-Peter Schwebler <[email-masked]>
Date: Wed, 29 Oct 2003 15:53:29 +0100

James,

Identrus defined two methods for web signing (ISPI (Identrus Signing 
Plugin Interface ) and ISIL (Identrus Signing Interface Library)).
However, the latest version of the documentation allows for so called
standalone applications (e.g. Adobe Acrobat and Microsoft Office) to
use a "native" signature mechanism which, of course, needs to satisfy
a couple of requirements set be Identrus.

I just want to point this out. I don't want to comment on it because
I am not yet sure whether I like this move or not.

And Anders, yes of course, Identrus is such an organization that 
provides technical documents under NDA only. Unless they have
changed their policy on that in the last weeks.

Regards,
Hans-Peter 

James Jing wrote:
> signing. One is defined as a Netscape style browser plug-in, the 
> other defined as an abstract Java interface. It also requires the 
> content that is being signed to be separately displayed, and the 
> digest of the content to be calculated by the "trusted subsystem".
> 
> I personally think the best approach would be for a unified standard 
> to be adopted by all browsers, invocable by all common scripts like 
> signature layer might be. I believe both PKCS#7 and XML standards 
> must be supported. Content-to-be-signed should be defined by MIME-type 
> so if the browser needs to popup another screen, it can be properly 
> display the content. Whether a separate popup should be displayed must 
> be determined by signature layer based on the type of key being used 
> to sign the content.
> 
> Regards
> James

---

From: Stephen Kent <[email-masked]>
Date: Wed, 29 Oct 2003 09:56:16 -0500

>"Real Standards" actually are made:

since you obviously don't believe the IETF creates "real standards" 
and since this topic is not a PKIX work item, I suggest you take the 
"web-sigbing" discussion elsewhere.

Steve

---

From: "Florian Oelmaier" <[email-masked]>
Date: Wed, 29 Oct 2003 17:23:03 +0100

> However, Identrus is a bank-controlled operation and 
> therefore operate in the same way as banks regarding their 
> technology. I.e. by acting "possessive" and most of all being 
> scared that a competitor would ever be able to profit on the 
> work done.

We all know that acting "possessive" does not work really good on the
internet. After all a secrect shared by more than three people isnt a
secret anymore. If you need a hint at how the identrus Websigning works
you may look at
http://www.s-d.no/filer/manualer/Technical%20Description%203_1Rev1.pdf
and read the identrus section there.

-- 
Florian Oelmaier
SyTrust

---

From: "Anders Rundgren" <[email-masked]>
Date: Wed, 29 Oct 2003 17:29:20 +0100

>"web-sigbing" discussion elsewhere.

As the off-list response to "web-signing" has been pretty good, I
just need to figure out where to go next.

You did probably not read more than the first paragraph.  To go
through a "real standardization process" was ONE of the stated
alternatives.

Anders

---

From: Stephen Kent <[email-masked]>
Date: Wed, 29 Oct 2003 21:26:12 -0500

>through a "real standardization process" was ONE of the stated

if your off-list response was so good, then you should have no 
trouble moving this discussion elsewhere.

I read all of the traffic re the subject topic, and as I noted, it is 
off topic for this WG, as have been most of your messages threads.

steve

---

From: "Anders Rundgren" <[email-masked]>
Date: Thu, 30 Oct 2003 14:49:03 +0100

Apologizes Steven.   Last comment.  This one is actually a bit
interesting for any die-hard cryptographer.

Thanx Florian,

The manual to "Personal" is thick but leaves out all "hardcore" stuff like:

If MIME is "text/html" does it calculate hash of embedded objects?
Actually what algorithm does it use for cononicalization of HTML or
even for TXT?

And what happens if you use "PKCS7SIGNED_Attached" and
have MIME "text/html" and use embedded objects (IMGs)?  I don't
think I want to know!  It will probably explode and crash my hard-disk :-)
Or does it falsely just include the HTML disregarding WYSIWYS
completely?

My firm belief is that on-line signatures is a very different "animal"
compared to signed e-mails, and MUST be designed from the ground
and up in order to EVER work in an interoperable and useful manner.

So where do we go now?  To CEN/ISSS, W3C, OASIS, IETF or what?

Regards
Anders Rundgren

----- Original Message -----
From: "Florian Oelmaier" <[email-masked]>
To: "'Anders Rundgren'" <[email-masked]>; "'James Jing'" <[email-masked]>; "'Markus Lorch'" <[email-masked]>;
<[email-masked]>
Sent: Wednesday, October 29, 2003 17:23
Subject: RE: Standards for Web-signing II

--
Florian Oelmaier
SyTrust

---

From: "Anders Rundgren" <[email-masked]>
Date: Thu, 30 Oct 2003 17:41:04 +0100

Karl,

Thanx for the pointer!
However, although DSS indeed talks about the Web, Interfaces
and Signatures, this is AFAIU an entirely "programmatic"
web where things like WYSIWYS is of no importance.

To really screw up things, you need users and that calls for
something else.  Like a new standard :-)

Best
Anders

----- Original Message ----- 
From: "Karl Scheibelhofer" <[email-masked]>
To: "Anders Rundgren" <[email-masked]>; "Florian Oelmaier" <[email-masked]>; <[email-masked]>
Cc: "'James Jing'" <[email-masked]>; "'Markus Lorch'" <[email-masked]>
Sent: Thursday, October 30, 2003 17:14
Subject: Re: Standards for Web-signing II

as far as i know OASIS has started related efforts. see
http://www.oasis-open.org/committees/tc_home.php?wg_abbrev=dss

  Karl

--

Karl Scheibelhofer, IAIK - Graz University of Technology
Inffeldgasse 16a, 8010 Graz, Austria
Fax: +43 316 873 5520
http://jce.iaik.tugraz.at

----- Original Message ----- 
From: "Anders Rundgren" <[email-masked]>
To: "Florian Oelmaier" <[email-masked]>; <[email-masked]>
Cc: "'James Jing'" <[email-masked]>; "'Markus Lorch'"
<[email-masked]>
Sent: Thursday, October 30, 2003 2:49 PM
Subject: Re: Standards for Web-signing II

> To: "'Anders Rundgren'" <[email-masked]>; "'James Jing'"
<[email-masked]>; "'Markus Lorch'" <[email-masked]>;