Subject: RE: Signer certificate discovery for CRLs

From: "Stefan Santesson" <[email-masked]>
Date: Wed, 27 Oct 2004 14:26:29 +0100

Short reply.

> Are you claiming that this is only needed for indirect CRLs ?

No this is not just for indirect CRLs but it is most needed and obvious
there.

> This has never been demonstrated, and before knowing the solution, it
> would
> be nice to know what the problem is.

The issue has been explained at lest 4 or 5 times on this thread and it
would probably not do any good to do it yet another time. 
You have also demonstrated through your answers that you have understood
it quite well.

Short repetition of the stated pros and cons:

The SIA may work IF:
- You have a "repository" available through which you can find suitable
information or make a suitable query for certificates.
- You have enough defined rules and processing time and power to allow
local processing the information gathered to find and build the path to
the CRL issuer.
- The CRL signer is nominated through a certificate that is issued
directly by the certificate issuing CA (or it will be to complex to find
the path to the CRL issuer). 

The AIA may work IF:
- The client already supports AIA in certificates for path building and
have the capacity to extend this to use in CRLs
- The client support downloading and processing of a single certificate
file from the specified location.

The AIA have 2 main advantages over SIA.
1) You typically only get a single certificate response in a single
file. This is much lower complexity than a link to all certificates
issued by a CA.
2) SIA is constrained to nomination of CRL issuer through a certificate
issued by the certificate issuing CA. AIA is independent of how the path
to the CRL is built and thus more generic.

Stefan Santesson
Microsoft Security Center of Excellence (SCOE)

> -----Original Message-----
> From: Denis Pinkas [mailto:[email-masked]]
> Sent: den 27 oktober 2004 15:00
> To: Stefan Santesson
> Cc: pkix
> Subject: Re: Signer certificate discovery for CRLs
> 
> Stefan,
> 
> > I disagree,
>    So we disagree.
> 
> > The problem to determine that a CRL is the correct CRL for a
certificate
> > is a completely separate and independent problem to the issue to
> > discover a factual certification path to a particular CRL in order
to
> > validate its signature.
> 
> No. The issue is who provide that extension and in which case or
case(s).
> Then what kind of use RPs are expected to do with it.
> 
> We already have too many extensions where different people have
different
> interpretations of their use and thenafter justify an architecture by
the
> presence of that extension ! or because "nothing prevents to make a
given
> interpretation" of the document.
> 
> > These can, and probably should, be solved independently.
> 
> > The task to allow AIA as a CRL extension in its current form does
not
> > have to be on hold in the meanwhile. There are strong reasons enough
to
> > see it through.
> 
> > This relates to real practical problems. In our efforts, as
implementer,
> > to work with indirect CRLs,
> 
> Are you claiming that this is only needed for indirect CRLs ?
> 
> (i.e. for CRLs which include certificates issued by authorities other
than
> the CRL issuer).
> 
> > we must in some cases rely on either AIA in CRLs or a similar,
currently
>  > non-standardized method.
> 
> > SIA doesn't solve our needs.
> 
> This has never been demonstrated, and before knowing the solution, it
> would
> be nice to know what the problem is.
> 
> Denis
> 
>  > AIA does. It seems to me that other implementers have reached
> > the same conclusion.
> 
> 
> > /Stefan

---

From: "Santosh Chokhani" <[email-masked]>
Date: Wed, 27 Oct 2004 16:26:26 -0400

And, SIA for end certificate will add computational complexity.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Stefan Santesson
Sent: Wednesday, October 27, 2004 9:26 AM
To: Denis Pinkas
Cc: pkix
Subject: RE: Signer certificate discovery for CRLs

Short reply.

> would be nice to know what the problem is.

The issue has been explained at lest 4 or 5 times on this thread and it
would probably not do any good to do it yet another time. 
You have also demonstrated through your answers that you have understood it
quite well.

The SIA may work IF:
- You have a "repository" available through which you can find suitable
information or make a suitable query for certificates.
- You have enough defined rules and processing time and power to allow local
processing the information gathered to find and build the path to the CRL
issuer.
- The CRL signer is nominated through a certificate that is issued directly
by the certificate issuing CA (or it will be to complex to find the path to
the CRL issuer). 

The AIA may work IF:
- The client already supports AIA in certificates for path building and have
the capacity to extend this to use in CRLs
- The client support downloading and processing of a single certificate file
from the specified location.

The AIA have 2 main advantages over SIA.
1) You typically only get a single certificate response in a single file.
This is much lower complexity than a link to all certificates issued by a
CA.
2) SIA is constrained to nomination of CRL issuer through a certificate
issued by the certificate issuing CA. AIA is independent of how the path to
the CRL is built and thus more generic.

Stefan Santesson

certificate
to
case(s).
different
the
given
not
to
implementer,
than
currently
> would be nice to know what the problem is.
> 
> Denis
>

---

From: Denis Pinkas <[email-masked]>
Date: Thu, 28 Oct 2004 16:04:03 +0200

Santosh,

> And, SIA for end certificate will add computational complexity.

SIA, for this discussion, is not for end certificates, but for CA certificates.

Denis

---

From: "Santosh Chokhani" <[email-masked]>
Date: Thu, 28 Oct 2004 15:34:26 -0400

Denis,

Just show us how SIA (wherever you want to put it) is more efficient than
AIA for CRL signer.

-----Original Message-----
From: Denis Pinkas [mailto:[email-masked]] 
Sent: Thursday, October 28, 2004 10:04 AM
To: Santosh Chokhani
Cc: 'pkix'
Subject: Re: Signer certificate discovery for CRLs

Santosh,

> And, SIA for end certificate will add computational complexity.

SIA, for this discussion, is not for end certificates, but for CA
certificates.

Denis