Subject: Definitive source for abbreviations used in certificate DN's

From: Arshad Noor <[email-masked]>
Date: Thu, 28 Oct 2004 10:39:36 -0400

Can someone please point me to a definitive source document, 
that defines the official abbreviations used within X.509 digital 
certificate DN's?   For instance, which specific document 
specifies that the abbreviation S must be used for State, G (or 
is it GN?) must be used for GivenName, SN for Surname, etc.  
Thank you.

Arshad Noor
StrongAuth, Inc.

P.S.  I have looked at ITU-T's X.520 (02/2001) document and while 
it shows some abbreviations (CN, S, L, T, etc.) it does not elucidate 
all of them.

---

From: Steve Hanna <[email-masked]>
Date: Thu, 28 Oct 2004 11:32:55 -0400

RFC 2253 is a good source for this. However,
there is no exhaustive list. People make up
their own abbreviations all too often, which
causes interoperability problems. Really,
they should use dotted decimal notation to
give the OID, but that's not user-friendly.

Thanks,

Steve

Arshad Noor wrote:

> To unsubscribe from this mailing list (and be removed from the roster of the OASIS TC), go to http://www.oasis-open.org/apps/org/workgroup/pki-tc/members/leave_workgroup.php.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 28 Oct 2004 10:53:10 -0700

draft-ietf-ldapbis-dn, once approved for publication,
says that short names used in LDAP DN strings are the
same short names used elsewhere in LDAP to identify
the attribute type.  BCP 64 established a registry for
those short names at IANA:
   "Object Identifiers Descriptors" in
   http://www.iana.org/assignments/ldap-parameters

I note that short names, like OIDs they refer to, should
generally not be presented to the user.  Instead, some
localized string should be presented.

Kurt

At 08:32 AM 10/28/2004, Steve Hanna wrote:

>>Can someone please point me to a definitive source document, that defines the official abbreviations used within X.509 digital certificate DN's?   For instance, which specific document specifies that the abbreviation S must be used for State, G (or is it GN?) must be used for GivenName, SN for Surname, etc.  
>>Thank you.
>>Arshad Noor
>>StrongAuth, Inc.
>>P.S.  I have looked at ITU-T's X.520 (02/2001) document and while it shows some abbreviations (CN, S, L, T, etc.) it does not elucidate all of them.
>>