Subject: 3280 issue

From: Peter Sylvester <[email-masked]>
Date: Wed, 27 Oct 2004 14:19:28 +0200 (MEST)

In a directory which is protected by the same X509 hierarchy
it is sufficient that certificates and crls are the only 
objects (besides a trust anchor) that need to be protected
using a signature (authentoicity and integrity), since an
absence of certificats always leads to some error that can
be attributed to the repository.

In a situation with multiple paths, the absence of a CA cert
in the directory is something cannot be detected, i.e., if
some MIM or wahtever modifies the content of the transfer from
the directory, an theoretically existing cert path can simply
not be available without the possibility of detecting whether
this is intended or a failure of the directory (directory = 
whatever repository).

It seems necessary that something like signing a  
list of certificates containing all crosscerts towards
and another from other CAs is necessary to have the
analogy of a single object, i.e; to determine completeness.

---

From: "Santosh Chokhani" <[email-masked]>
Date: Wed, 27 Oct 2004 09:35:15 -0400

Peter,

This is not a 3280 issue.  This is how directories are deployed.  That is
why X.500 and LDAP can be run over TLS/SSL.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Peter Sylvester
Sent: Wednesday, October 27, 2004 8:19 AM
To: [email-masked]
Subject: 3280 issue

In a directory which is protected by the same X509 hierarchy
it is sufficient that certificates and crls are the only 
objects (besides a trust anchor) that need to be protected using a signature
(authentoicity and integrity), since an absence of certificats always leads
to some error that can be attributed to the repository.

In a situation with multiple paths, the absence of a CA cert
in the directory is something cannot be detected, i.e., if
some MIM or wahtever modifies the content of the transfer from the
directory, an theoretically existing cert path can simply not be available
without the possibility of detecting whether this is intended or a failure
of the directory (directory = 
whatever repository).