Subject: RFC4210 questions

From: <[email-masked]>
Date: Mon, 9 Oct 2006 13:11:45 +0200

Hi all,
 
I've got some questions dealing with RFC 4210.
 
First: In 4.4.1 CA Operator Actions the following is stated:
 
   "The "old with new" certificate must have a validity period starting
   at the generation time of the old key pair and ending at the expiry
   date of the old public key."
 
This sound prettey wrong to me, because at geneartion time of the OLD
key pair no NEW key exists to create the certificate (and the new
certificate doesn't exist either). Is this just a "typo" or is there
something I didn't understand the rigt way?
 
Second: Why is the proof of possession fpr encryption keys (4.3.2)
defined so comlicated? Wouldn't it be easier to encrypt something (e. g.
the hash of the ToBeSigned ;-) ) at the time the request ist generated?
In other words: Why is it not allowed to use the encryption key pair as
a signature key pair for that single time???
 
Best regards
 
Thomas Beckmann

---

From: "Denis Pinkas" <[email-masked]>
Date: Tue, 17 Oct 2006 17:38:14 +0200

Thomas,

I will only answer the first of your two questions.

The text from RFC 4210 is only describing what a CA should do, but does not say 
a word on how a relying party should use the information placed by the CA.

Two cases were considered.

A relying party has the "old with old" certificate and wants to move to 
the "new with new" certificate. For this, it will use both the "new with old" certificate 
and the "new with new" certificate.

A relying party has been directly installed with the "new by new" certificate, but still 
needs to verify certificates that were issued under the old key. For this, it will use the 
"old with new" certificate".
 
The current sentence states :

   The "old with new" certificate must have a validity period starting
   at the generation time of the old key pair and ending at the expiry
   date of the old public key.

The sentence is correct.

This illustrates the need to have a document which describes the use of these certificates.
This is part of my recent proposal to develop an RFC on Key Compromise, Rollover and Loss.

Denis

Hi all,

This sound prettey wrong to me, because at geneartion time of the OLD key pair no NEW key exists to create the certificate (and the new certificate doesn't exist either). Is this just a "typo" or is there something I didn't understand the rigt way?

Second: Why is the proof of possession fpr encryption keys (4.3.2) defined so comlicated? Wouldn't it be easier to encrypt something (e. g. the hash of the ToBeSigned ;-) ) at the time the request ist generated? In other words: Why is it not allowed to use the encryption key pair as a signature key pair for that single time???

Best regards

Thomas Beckmann

---

From: <[email-masked]>
Date: Wed, 18 Oct 2006 09:35:15 +0200

Denis,
 
it's a little tricky but I see where I was wrong. Thanks for that hint
:)
 
Best regards
 
Thomas

________________________________

	Von: [email-masked]
[mailto:[email-masked]] Im Auftrag von Denis Pinkas
	Gesendet: Dienstag, 17. Oktober 2006 17:38
	An: [email-masked]
	Betreff: Re: RFC4210 questions

	Thomas,

	The text from RFC 4210 is only describing what a CA should do,
but does not say 
	a word on how a relying party should use the information placed
by the CA.

	A relying party has the "old with old" certificate and wants to
move to 
	the "new with new" certificate. For this, it will use both the
"new with old" certificate 
	and the "new with new" certificate.
	 
	A relying party has been directly installed with the "new by
new" certificate, but still 
	needs to verify certificates that were issued under the old key.
For this, it will use the 
	"old with new" certificate".

	   The "old with new" certificate must have a validity period
starting

	   at the generation time of the old key pair and ending at the
expiry

	The sentence is correct.
	 
	This illustrates the need to have a document which describes the
use of these certificates.
	This is part of my recent proposal to develop an RFC on Key
Compromise, Rollover and Loss.
	 
	Denis
	 
________________________________

	Hi all,

	 
	   "The "old with new" certificate must have a validity period
starting
	   at the generation time of the old key pair and ending at the
expiry
	   date of the old public key."
	 
	This sound prettey wrong to me, because at geneartion time of
the OLD key pair no NEW key exists to create the certificate (and the
new certificate doesn't exist either). Is this just a "typo" or is there
something I didn't understand the rigt way?
	 
	Second: Why is the proof of possession fpr encryption keys
(4.3.2) defined so comlicated? Wouldn't it be easier to encrypt
something (e. g. the hash of the ToBeSigned ;-) ) at the time the
request ist generated? In other words: Why is it not allowed to use the
encryption key pair as a signature key pair for that single time???
	 
	Best regards
	 
	Thomas Beckmann
	 
________________________________