Subject: Re: New modules drafts -- proposed ASN.1 downgrade tutorial

From: Paul Hoffman <[email-masked]>
Date: Tue, 27 Jan 2009 13:23:05 -0800

In thinking about this a bit more:

- I agree with Alfred that it should be a separate document that covers all ASN.1 modules in (at least) the Security Area of the IETF.

- It is not needed if the eventual PKIX and S/MIME documents are Informational RFCs instead of Standards Track.

- Future document authors can pick whether they want to do their modules in 2002 or 1988 and the WGs can decide if they like the decision that the authors made.

Given that, I propose that someone other than Jim and I start such a "downgrade tutorial". I volunteer to review it, and I'm sure that some of the modules from Jim and my documents would be good fodder for examples in the new document.

--Paul Hoffman, Director
--VPN Consortium

---

From: "Carl Wallace" <[email-masked]>
Date: Wed, 28 Jan 2009 09:35:19 -0500

I volunteer to help write the document.  A few comments below.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Paul Hoffman
> Sent: Tuesday, January 27, 2009 4:23 PM
> To: [email-masked]; [email-masked]
> Subject: Re: New modules drafts -- proposed ASN.1 downgrade tutorial
> 
> 
> - I agree with Alfred that it should be a separate document 
> that covers all ASN.1 modules in (at least) the Security Area 
> of the IETF.

Do you in mind a draft that provides guidance on how to convert 2002
syntax into equivalent 1988 syntax or a document that includes 88 syntax
for all security area drafts?  The former seems worthwhile, I'm not sure
about the latter. 
 
> - It is not needed if the eventual PKIX and S/MIME documents 
> are Informational RFCs instead of Standards Track.
> 
> - Future document authors can pick whether they want to do 
> their modules in 2002 or 1988 and the WGs can decide if they 
> like the decision that the authors made.

Allowance of 88 syntax may make an "upgrade tutorial" component of the
draft nice too.
 
> Given that, I propose that someone other than Jim and I start 
> such a "downgrade tutorial". I volunteer to review it, and 
> I'm sure that some of the modules from Jim and my documents 
> would be good fodder for examples in the new document.
> 
> --Paul Hoffman, Director
> --VPN Consortium
> 
>

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 28 Jan 2009 09:13:58 -0800

At 9:35 AM -0500 1/28/09, Carl Wallace wrote:
>I volunteer to help write the document. 

Thank you! Who wants to help Carl?

>for all security area drafts?  The former seems worthwhile, I'm not sure

Only the former; sorry I wasn't clearer.

>Allowance of 88 syntax may make an "upgrade tutorial" component of the

That would certainly be useful as well.

--Paul Hoffman, Director
--VPN Consortium

---

From: "Charles W. Gardiner" <[email-masked]>
Date: Fri, 30 Jan 2009 11:53:26 -0500

>Thank you! Who wants to help Carl?

     I'd be glad to try.

Charlie Gardiner