Subject: I-D Action:draft-ietf-pkix-new-asn1-06.txt

From: [email-masked]
Date: Thu, 13 Aug 2009 06:15:01 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Public-Key Infrastructure (X.509) Working Group of the IETF.

	Title           : New ASN.1 Modules for PKIX
	Author(s)       : P. Hoffman, J. Schaad
	Filename        : draft-ietf-pkix-new-asn1-06.txt
	Pages           : 120
	Date            : 2009-08-13

The PKIX certificate format, and many associated formats, are
expressed using ASN.1.  The current ASN.1 modules conform to the 1988
version of ASN.1.  This document updates those ASN.1 modules to
conform to the 2002 version of ASN.1.  There are no bits-on-the-wire
changes to any of the formats; this is simply a change to the syntax.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-pkix-new-asn1-06.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Sean Turner <[email-masked]>
Date: Thu, 13 Aug 2009 16:52:45 -0400

Paul/Jim,

The change to noted in A.7 didn't get implemented in the Section 6.  If 
you're going to use the comment out method, then you need to comment out 
the "," at the end of the namedCurve line:

ECParameters ::= CHOICE {
   namedCurve      CURVE.&id({NamedCurve}) --,
                                           ^^ add this
   -- implicitCurve   NULL
     -- implicitCurve MUST NOT be used in PKIX
   -- specifiedCurve  SpecifiedCurve
     -- specifiedCurve MUST NOT be used in PKIX
     -- Details for specifiedCurve can be found in [X9.62]
     -- Any future additions to this CHOICE should be coordinated
     -- with ANSI X.9.
  }
  -- If you need to be able to decode ANSI X.9 parameter structures, then
  -- uncomment the implicitCurve and specificCurve above, and also
  -- uncomment the follow:
  --(WITH COMPONENTS {namedCurve PRESENT})

spt

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 13 Aug 2009 18:18:39 -0700

At 4:52 PM -0400 8/13/09, Sean Turner wrote:
>Paul/Jim,
>
>The change to noted in A.7 didn't get implemented in the Section 6.  If you're going to use the comment out method, then you need to comment out the "," at the end of the namedCurve line:
>

That was my fault for not checking if the changes went in. They are in the -07, particularly with the additional change you made above.

--Paul Hoffman, Director
--VPN Consortium