Subject: Re: [pkix] I-D Action:draft-ietf-sip-eku-08.txt

From: Sean Turner <[email-masked]>
Date: Tue, 20 Oct 2009 17:08:36 -0400

I skimmed this quickly: Is the extension critical or non-critical?  EKUs 
can be either, but if you define one you need to say which.

In Section 3:  r/an "Extended Key Usage" (EKU) attribute/an "Extended 
Key Usage" (EKU) extension

spt

[email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Session Initiation Protocol Working Group of the IETF.
> 
> 
> 	Title           : Using Extended Key Usage (EKU) for Session Initiation Protocol (SIP) X.509 Certificates
> 	Author(s)       : S. Lawrence, V. Gurbani
> 	Filename        : draft-ietf-sip-eku-08.txt
> 	Pages           : 8
> 	Date            : 2009-10-20
> 
> This memo documents an extended key usage (EKU) X.509 certificate
> extension for restricting the applicability of a certificate to use
> with a Session Initiation Protocol (SIP) service.  As such, in
> addition to providing rules for SIP implementations, this memo also
> provides guidance to issuers of certificates for use with SIP.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-sip-eku-08.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Sean Turner <[email-masked]>
Date: Tue, 20 Oct 2009 23:21:44 -0400

Scott Lawrence wrote:
> On Tue, 2009-10-20 at 17:08 -0400, Sean Turner wrote:
> Correct me if I'm wrong, but I thought that was a choice one made when
> constructing a certificate instance, not at the time you defined the
> value.

Yes my bad - improper firing of a synapse.

spt

---

From: "Scott Lawrence" <[email-masked]>
Date: Tue, 20 Oct 2009 17:37:17 -0400