Subject: [pkix] Research question: Witnessing by digital signature

From: Stephen Wilson <[email-masked]>
Date: Fri, 11 Jun 2010 06:01:19 +1000

Has any work been done in PKIX or elsewhere on formal witnessing of 
digital signatures?  And/or ... does anyone in the group know of real 
life instances where a digital signature is witnesses and attested to 
using another dig sig? 

Cheers,

Stephen Wilson
Managing Director
Lockstep Group

Phone +61 (0)414 488 851

www.lockstep.com.au <http://www.lockstep.com.au>
Lockstep Consulting provides independent specialist advice and analysis
on digital identity and privacy.  Lockstep Technologies develops unique
new smart ID solutions that enhance privacy and prevent identity theft.

---

From: "Henry B. Hotz" <[email-masked]>
Date: Thu, 10 Jun 2010 18:09:48 -0700

There was something signed into law by Bill Clinton (during his second term) in front of a bunch of TV cameras.  Does that count?

On Jun 10, 2010, at 1:01 PM, Stephen Wilson wrote:

> _______________________________________________
> pkix mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pkix

------------------------------------------------------
The opinions expressed in this message are mine,
not those of Caltech, JPL, NASA, or the US Government.
[email-masked], or [email-masked]

---

From: Peter Gutmann <[email-masked]>
Date: Fri, 11 Jun 2010 15:07:52 +1200

"Henry B. Hotz" <[email-masked]> writes:

>There was something signed into law by Bill Clinton (during his second term)
>in front of a bunch of TV cameras.  Does that count?

Since he revealed his password afterwards ("buddy"), probably not.

Peter.

---

From: Jorge López <[email-masked]>
Date: Fri, 11 Jun 2010 10:17:44 +0200

Hi,

Among other open issues, a technical one lies in the fact that currently
there is no signature policy standard or technical document that helped to
establish the dependences and relationships among several signatures to make
them legally binding. It would be the scenario of a witness or notary, who
must countersign a former signature to make the transaction
effective. This limitation was pointed out by ETSI in a technical
report published in 2003 [1]. To the best of my knowledge, little research
has been done in this direction [2].

Regards,

[1] ETSI TR 102 045 - Electronic Signatures and Infrastructures (ESI);
Signature policy for extended business model v1.1.1. European
Telecommunications
Standards Institute (ETSI), March 2003
[2] Jorge L. Hernandez-Ardieta, Ana I. Gonzalez-Tablas, Benjamin Ramos and
Arturo Ribagorda. Extended Electronic Signature Policies. 2nd ACM
International Conference on Security of Information and Networks (SIN 2009),
pp. 268--277, ACM Press. North Cyprus. 2009.

2010/6/10 Stephen Wilson <[email-masked]>

>
> Has any work been done in PKIX or elsewhere on formal witnessing of digital
> signatures?  And/or ... does anyone in the group know of real life instances
> where a digital signature is witnesses and attested to using another dig
> sig?
> Cheers,
>
> Stephen Wilson
> Managing Director
> Lockstep Group
>
> Phone +61 (0)414 488 851
>

---

From: "Denis Pinkas"<[email-masked]>
Date: Fri, 11 Jun 2010 10:54:25 +0200

Hi,

You are right: there is no signature policy standard or technical document that helped to establish the dependences and relationships among several signatures.

The current concept of "signature policy" applies to a single signature. 
If a document has multiple signatures, each one can be done under a different signature policy.

So the "missing" concept is a "document signature policy" (not to be confused with  a "signature policy") which would tell, 
how many electronic signatures are needed, which signature policies are acceptable for each one, whether they need to be parallel 
or embedded, which commitment types must be present, etc ...

This combination of criteria could be important and all these verifications are currently left to the application.
It is questionnable whether this should be standardized now or left to the application.

Denis

----- Message reçu ----- 
De : Jorge López 
À : Stephen Wilson 
Date : 2010-06-11, 10:17:44
Sujet : Re: [pkix] Research question: Witnessing by digital signature

Hi,

Among other open issues, a technical one lies in the fact that currently there is no signature policy standard or technical document that helped to establish the dependences and relationships among several signatures to make them legally binding. It would be the scenario of a witness or notary, who must countersign a former signature to make the transaction effective. This limitation was pointed out by ETSI in a technical report published in 2003 [1]. To the best of my knowledge, little research has been done in this direction [2].

Regards,

[1] ETSI TR 102 045 - Electronic Signatures and Infrastructures (ESI); Signature policy for extended business model v1.1.1. European Telecommunications
Standards Institute (ETSI), March 2003
[2] Jorge L. Hernandez-Ardieta, Ana I. Gonzalez-Tablas, Benjamin Ramos and Arturo Ribagorda. Extended Electronic Signature Policies. 2nd ACM International Conference on Security of Information and Networks (SIN 2009), pp. 268--277, ACM Press. North Cyprus. 2009.

Has any work been done in PKIX or elsewhere on formal witnessing of digital signatures?  And/or ... does anyone in the group know of real life instances where a digital signature is witnesses and attested to using another dig sig? 
Cheers,

Stephen Wilson
Managing Director
Lockstep Group

Phone +61 (0)414 488 851

---

From: Dino Esposito <[email-masked]>
Date: Fri, 11 Jun 2010 10:56:40 +0200

In Italy there are some official deeds to be filed to the tax authority 
that are digitally signed by the interested parts and then signed by a 
Business accountant as a sort of official seal. All the process does not 
need the physical meeting of the parts. All signatures have to be 
qualified and based on secure tokens (SSCD) as per European Directive on 
eSignatures
regards
Dino Esposito

On 11/06/2010 10.17, Jorge López wrote:
> Hi,
>
> Among other open issues, a technical one lies in the fact that 
> currently there is no signature policy standard or technical document 
> that helped to establish the dependences and relationships among 
> several signatures to make them legally binding. It would be the 
> scenario of a witness or notary, who must countersign a former 
> signature to make the transaction effective. This limitation was 
> pointed out by ETSI in a technical report published in 2003 [1]. To 
> the best of my knowledge, little research has been done in this 
> direction [2].
>
> Regards,
>
> [2] Jorge L. Hernandez-Ardieta, Ana I. Gonzalez-Tablas, Benjamin Ramos 
> and Arturo Ribagorda. Extended Electronic Signature Policies. 2nd ACM 
> International Conference on Security of Information and Networks (SIN 
> 2009), pp. 268--277, ACM Press. North Cyprus. 2009.
>
> 2010/6/10 Stephen Wilson <[email-masked] 
> <mailto:[email-masked]>>
>
>
>     Has any work been done in PKIX or elsewhere on formal witnessing
>     of digital signatures?  And/or ... does anyone in the group know
>     of real life instances where a digital signature is witnesses and
>     attested to using another dig sig?
>     Cheers,
>
>     Stephen Wilson
>     Managing Director
>     Lockstep Group
>
>     Phone +61 (0)414 488 851
>
>     <http://www.lockstep.com.au>
>     [email-masked] <mailto:[email-masked]>

---

From: Jorge López <[email-masked]>
Date: Fri, 11 Jun 2010 11:24:47 +0200

Regarding the standardization process, I plan to send an I-D (for an
Experimental RFC) to the S/MIME WG  (I was told that it was the most
appropriate WG for this matter) during the summer. You are right that it is
still to be seen if a proposal like this needs to be standardized...

Regards,

Jorge.

2010/6/11 Denis Pinkas <[email-masked]>

>  Hi,
>
> You are right: there is no signature policy standard or technical document
> that helped to establish the dependences and relationships among several
> signatures.
>
> So the "missing" concept is a "document signature policy" (not to be
> confused with  a "signature policy") which would tell,
> how many electronic signatures are needed, which signature policies are
> acceptable for each one, whether they need to be parallel
> *De :* Jorge López
> *À :* Stephen Wilson
> *Date :* 2010-06-11, 10:17:44
> *Sujet :* Re: [pkix] Research question: Witnessing by digital signature
>
>  Hi,
>
>> digital signatures?  And/or ... does anyone in the group know of real life
>> instances where a digital signature is witnesses and attested to using
>> another dig sig?
>> Cheers,
>>
>> Stephen Wilson
>> Managing Director
>> Lockstep Group
>>
>> Phone +61 (0)414 488 851
>>

---

From: Stefan Santesson <[email-masked]>
Date: Wed, 23 Jun 2010 10:46:44 +0200

A short note on this:

On 10-06-11 10:17 AM, "Jorge López" <[email-masked]> wrote:
> them legally binding

It is not the signature that is legally binding, it is the AGREEMENT
supported by that signature that is legally binding.

In most cases that agreement is legally binding regardless of whether it is
signed or not. The signature makes it easier to prove the existence of a
legally binding agreement but it is not the component that makes the
agreement legally binding.

This small detail is often overlooked when we are designing technical
standards.

/Stefan

---

From: Simon Tardell <[email-masked]>
Date: Wed, 23 Jun 2010 10:59:47 +0200

And as a corollary to that, witnessing a pen-and-paper signature is a
technical measure to make it easier to show that the signature was indeed
made by the correct person, given that pen-and-paper signatures are fairly
easy to forge. In the PKI case there are other measures that serve the same
purpose. I think it would be a mistake to mimic witnessing with PKI, at
least until you have analyzed what threat you try to counter. One such
threat would perhaps be duress.

Simon Tardell.

---

From: Jorge López <[email-masked]>
Date: Wed, 23 Jun 2010 13:20:10 +0200

I agree with you Stefan. I misued the words to express that. Just to clarify
myself, in the context I'm referring to, signatures are an instrument of
evidence regarding the authenticity of the document, understood authenticity
as a means of identifying the signatory but also indicating the signatory's
approval of the signed data.

But, sometimes, and in order to make some agreements and commitments made in
a signed document binding, it is mandatory that more than one signature is
present. As an example, imagine the case where some purchase order has to be
authorised by the purchase manager. The order should not be enforced until
such signature is present. IMO, currently there is no technical solution to
fulfill that in a seamlessly and generalistic manner.

Regards,

Jorge.

2010/6/23 Stefan Santesson <[email-masked]>

---

From: "Moudrick M. Dadashov" <[email-masked]>
Date: Wed, 23 Jun 2010 15:57:18 +0300

yes, the signature standards talk about signatures irrelevant to other 
signatures that might be an essential part of a signature itself.

So far it's up to application developer to provide "signature tree 
template" that can control the signature creation flow.

Thanks,
M.D.
cell: +370-699-26662

On 2010.06.23 14:20, Jorge López wrote:
> I agree with you Stefan. I misued the words to express that. Just to 
> clarify myself, in the context I'm referring to, signatures are an 
> instrument of evidence regarding the authenticity of the document, 
> understood authenticity as a means of identifying the signatory but 
> also indicating the signatory's approval of the signed data.
>
> But, sometimes, and in order to make some agreements and commitments 
> made in a signed document binding, it is mandatory that more than one 
> signature is present. As an example, imagine the case where some 
> purchase order has to be authorised by the purchase manager. The order 
> should not be enforced until such signature is present. IMO, currently 
> there is no technical solution to fulfill that in a seamlessly and 
> generalistic manner.
>
> Regards,
>
> Jorge.
>
> 2010/6/23 Stefan Santesson <[email-masked] 
> <mailto:[email-masked]>>
>
>     A short note on this:
>
>     On 10-06-11 10:17 AM, "Jorge López" <[email-masked]
>     <mailto:[email-masked]>> wrote: