Subject: [pkix] I-D Action: draft-ietf-pkix-pubkey-caps-07.txt

From: [email-masked]
Date: Tue, 15 May 2012 22:03:26 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Public-Key Infrastructure (X.509) Working Group of the IETF.

	Title           : S/MIME Capabilities for Public Key Definitions
	Author(s)       : Jim Schaad
	Filename        : draft-ietf-pkix-pubkey-caps-07.txt
	Pages           : 25
	Date            : 2012-05-15

   This document defines a set of Secure/Multipurpose Internet Mail
   Extensions (S/MIME) Capability types for ASN.1 encoding for the
   current set of public keys defined by the PKIX working group.  This
   facilitates the ability for a requester to specify information on the
   public keys and signature algorithms to be used in responses.  An
   example of where this is used is is detailed in Online Certificate
   Status Protocol Algorithm Agility (RFC 6277).

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-pkix-pubkey-caps-07.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-pkix-pubkey-caps-07.txt

The IETF datatracker page for this Internet-Draft is:
https://datatracker.ietf.org/doc/draft-ietf-pkix-pubkey-caps/

---

From: Martin Rex <[email-masked]>
Date: Wed, 16 May 2012 13:26:25 +0200 (MEST)

>       Filename        : draft-ietf-pkix-pubkey-caps-07.txt

I'm slighty confused:

  http://tools.ietf.org/html/draft-ietf-pkix-pubkey-caps-07#section-3.1

      DSAKeyCapabilities ::= CHOICE {
          keySizes         [0] SEQUENCE {
             minKeySize            DSAKeySize,
             maxKeySize            DSAKeySize OPTIONAL,
             maxSizeP              [1] INTEGER OPTIONAL,
             maxSizeQ              [2] INTEGER OPTIONAL,
             maxSizeG              [3] INTEGER OPTIONAL
          },
          keyParams        [1] pk-dsa.&Params
      }

      keyParams  contains the exact set of DSA for the key used to sign
         the message.  This field is provided for completeness and to
         match the fields for Elliptical Curve, however it is expected
         that usage of this field is extremely rare.

keyParams is not marked OPTIONAL, so what does "however it is expected that
usage of this field is extremely rare" mean?

Is the OPTIONAL tag missing, or is an explicit NULL supposed to indicate
that the field is unused?

-Martin

---

From: "Manger, James H" <[email-masked]>
Date: Wed, 16 May 2012 22:16:15 +1000

It is in a CHOICE. Presumably it is expected that keySizes is almost always chosen. 

--
James Manger

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Martin Rex
Sent: Wednesday, 16 May 2012 9:26 PM
To: [email-masked]
Subject: Re: [pkix] I-D Action: draft-ietf-pkix-pubkey-caps-07.txt

I'm slighty confused:

-Martin
_______________________________________________
pkix mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pkix

---

From: Martin Rex <[email-masked]>
Date: Wed, 16 May 2012 15:09:19 +0200 (MEST)

> It is in a CHOICE. Presumably it is expected that keySizes

Thanks for the pointer -- since the structure definition was not
in sight after reading the description of "keyParams",
I missed the CHOICE at the beginning.

> usage of this field is extremely rare" mean?

s/this field/this CHOICE/ might have provided enough redundancy
to prevent my confusion.

-Martin

---

From: "Jim Schaad" <[email-masked]>
Date: Wed, 16 May 2012 10:25:42 -0700

This update has been made to address some final IESG comments.

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Tuesday, May 15, 2012 10:03 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [pkix] I-D Action: draft-ietf-pkix-pubkey-caps-07.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
directories.
> This draft is a work item of the Public-Key Infrastructure (X.509) Working
> Group of the IETF.
>