Subject: [pkix] timestamp signature validation

From: Peter Sylvester <[email-masked]>
Date: Tue, 12 Mar 2013 11:10:13 +0100

Hi,

is a 3161 conformant timestamping client
supposed to verify attribute certficates
that are included in the ESSCertid?

Or, in other words, does someone knows
about any profile that prohibits a
TSA to include an ESScertid pointing to
an X.509 attribute certificate.

Peter

---

From: [email-masked] (Martin Rex)
Date: Tue, 12 Mar 2013 18:46:36 +0100 (CET)

> an X.509 attribute certificate.

Admittedly, I don't have the slightest clue what the term
"attribute certificate" refers to.

The ESSCertID in rfc3161 refers to the TSA signer certificate,
which was used to sign the rfc3161 timestamp.

   http://tools.ietf.org/html/rfc3161#page-8

   The time-stamp token MUST NOT contain any signatures other than the
   signature of the TSA.  The certificate identifier (ESSCertID) of the
   TSA certificate MUST be included as a signerInfo attribute inside a
   SigningCertificate attribute.

Which part of "SigningCertificate" is unclear to you?

-Martin

---

From: "Piyush Jain" <[email-masked]>
Date: Tue, 12 Mar 2013 11:16:21 -0700

For Martin:
Attribute Certificates profile http://www.ietf.org/rfc/rfc3281.txt 
ESSCertID can also refer to an attribute certificate which is used to convey
authorization information.

For Peter:
I have not come across a profile that mandates or prohibits use of attribute
certificates for time-stamping.

If you think about it, the RP needs to figure out if the TSA is trusted and
is authorized to sign the time-stamp responses. 
If RP can establish this with some out of band mechanism, there is no need
to even look at the attribute certificate.

However, if the environment dictates that authorization info is conveyed
using attribute certificates, then the RP must process and verify attribute
certificates.

But who uses attribute certificates anyway?

-Piyush

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Martin Rex
> Sent: Tuesday, March 12, 2013 10:47 AM
> To: Peter Sylvester
> Cc: [email-masked]'
> Subject: Re: [pkix] timestamp signature validation
> 
> Peter Sylvester wrote:
> >
> > is a 3161 conformant timestamping client supposed to verify attribute
> > certficates that are included in the ESSCertid?
> >
> > Or, in other words, does someone knows about any profile that
> > prohibits a TSA to include an ESScertid pointing to an X.509 attribute
> > certificate.
> 
> Admittedly, I don't have the slightest clue what the term "attribute
> certificate" refers to.
> 
> The ESSCertID in rfc3161 refers to the TSA signer certificate, which was
used
> to sign the rfc3161 timestamp.
> 
> _______________________________________________
> pkix mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pkix

---

From: Erwann Abalea <[email-masked]>
Date: Tue, 12 Mar 2013 19:19:30 +0100

2013/3/12 Martin Rex <[email-masked]>

> > an X.509 attribute certificate.

The only thing that makes me think that only public-key certificates can
*sign* TSA is a small phrase taken from the section 2.4.1 (request format):

   If the certReq field is present and set to true, the TSA's public key
   certificate that is referenced by the ESSCertID identifier inside a
   SigningCertificate attribute in the response MUST be provided by the
   TSA in the certificates field from the SignedData structure in that
   response.  That field may also contain other certificates.

But otherwise, nothing seems to prevent adding attribute certificates in
the CMS as additional certificates.

> "attribute certificate" refers to.

That's the second type of X.509 certificates. The first one is about
"public key certificates".

-- 
Erwann.

---

From: Erwann Abalea <[email-masked]>
Date: Tue, 12 Mar 2013 19:23:54 +0100

2013/3/12 Piyush Jain <[email-masked]>

> But who uses attribute certificates anyway?

At least one TSP in Czechoslovakia. With Qualified Certificates. The
attribute certificates is additional to the signer.

Other than that, I have never encountered attribute certificates in the
wild.

-- 
Erwann.

---

From: David Chadwick <[email-masked]>
Date: Tue, 12 Mar 2013 19:01:38 +0000

Here's a few I know about

Adobe did. It might still do.
Entrust PKI did. It might still do
Taiwan did. It might still do.

and our PERMIS software still gets thousands of downloads a year

David

On 12/03/2013 18:23, Erwann Abalea wrote:
>
> 2013/3/12 Piyush Jain <[email-masked] <mailto:[email-masked]>>
>
>

---

From: [email-masked] (Martin Rex)
Date: Tue, 12 Mar 2013 20:04:46 +0100 (CET)

> authorization information.

Thanks.

> to even look at the attribute certificate.

I also believe that rfc-3161 section-2.3 is clear _and_ complete:

  http://tools.ietf.org/html/rfc3161#section-2.3

The mere technical possibility to additionally name attribute certs
through ESSCertID (see http://tools.ietf.org/html/rfc2634#section-5.4.1),
besides the signer cert seems like a 6th wheel on the cart.

Frankly, even the use of ESSCertID looks like a 5th wheel on the cart to me.

My implementation of a TSA client and TimeStamped-CMS verifiers completely
ignore ESSCertID and use only the regular CMS signerInfo.

-Martin