Subject: [pkix] OID Processing betwee Intermediate CA and End Entity Certificates

From: "Ben Wilson" <[email-masked]>
Date: Fri, 8 Mar 2013 09:54:05 -0700

Do any of you know whether software should process a certificate chain
properly if I construct a policy OID arc (for SSL/TLS Server Certificates)
as follows?

Intermediate CA Policy OID :  

2.16.840.1.114412.1

End Entity Policy OID :

2.16.840.1.114412.1.1

Thanks,

Ben

---

From: Santosh Chokhani <[email-masked]>
Date: Fri, 8 Mar 2013 12:23:40 -0500

That depends on the status of the require explicit policy in the path validation state machine and user acceptable policy set.

At best, the chain is good for no certificate policies.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ben Wilson
Sent: Friday, March 08, 2013 11:54 AM
To: 'pkix'
Subject: [pkix] OID Processing betwee Intermediate CA and End Entity Certificates

Do any of you know whether software should process a certificate chain properly if I construct a policy OID arc (for SSL/TLS Server Certificates) as follows?
Intermediate CA Policy OID :

2.16.840.1.114412.1

End Entity Policy OID :

2.16.840.1.114412.1.1

Thanks,
Ben