Subject: [pkix] [Technical Errata Reported] RFC5912 (3626)

From: RFC Errata System <[email-masked]>
Date: Fri, 17 May 2013 03:34:32 -0700 (PDT)

The following errata report has been submitted for RFC5912,
"New ASN.1 Modules for the Public Key Infrastructure Using X.509 (PKIX)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5912&eid=3626

--------------------------------------
Type: Technical
Reported by: Carl Wallace <[email-masked]>

Section: 14

Original Text
-------------
   -- CRL number extension OID and syntax
   ext-CRLNumber EXTENSION ::= {SYNTAX
       INTEGER (0..MAX) IDENTIFIED BY id-ce-cRLNumber }
   id-ce-cRLNumber OBJECT IDENTIFIER ::= { id-ce 20 }

   CRLNumber ::= INTEGER (0..MAX)

Corrected Text
--------------
   -- CRL number extension OID and syntax
   CRLNumber ::= INTEGER  (0..MAX)

   ext-CRLNumber EXTENSION ::= {SYNTAX
       CRLNumber IDENTIFIED BY id-ce-cRLNumber }
   id-ce-cRLNumber OBJECT IDENTIFIER ::= { id-ce 20 }

Notes
-----
The CRLNumber extension was not defined to use the CRLNumber type.  It should use the CRLNumber type.  This is a corrected resubmission of an earlier errata submission that included an error.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5912 (draft-ietf-pkix-new-asn1-08)
--------------------------------------
Title               : New ASN.1 Modules for the Public Key Infrastructure Using X.509 (PKIX)
Publication Date    : June 2010
Author(s)           : P. Hoffman, J. Schaad
Category            : INFORMATIONAL
Source              : Public-Key Infrastructure (X.509)
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: "Jim Schaad" <[email-masked]>
Date: Fri, 17 May 2013 17:02:46 +0100

Totally reasonable - should be accepted.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> RFC Errata System
> Sent: Friday, May 17, 2013 11:35 AM
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: [pkix] [Technical Errata Reported] RFC5912 (3626)
> 
> The following errata report has been submitted for RFC5912, "New ASN.1
> Modules for the Public Key Infrastructure Using X.509 (PKIX)".
> 
> The CRLNumber extension was not defined to use the CRLNumber type.  It
> should use the CRLNumber type.  This is a corrected resubmission of an
> earlier errata submission that included an error.
> 
> Instructions:
> -------------
> This errata is currently posted as "Reported". If necessary, please use
"Reply
> All" to discuss whether it should be verified or rejected. When a decision
is
> reached, the verifying party (IESG) can log in to change the status and
edit the
> report, if necessary.
> Title               : New ASN.1 Modules for the Public Key Infrastructure
Using
> X.509 (PKIX)
> _______________________________________________
> pkix mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pkix

---

From: Stephen Kent <[email-masked]>
Date: Fri, 17 May 2013 15:31:53 -0400

I concur with Jim.

Steve
------

---

From: Stefan Santesson <[email-masked]>
Date: Thu, 30 May 2013 00:38:20 +0200

+1