Subject: [pkix] JSON Cleartext Signature - Non-WGLC

From: Anders Rundgren <[email-masked]>
Date: Wed, 18 Dec 2013 19:16:11 +0100

https://openkeystore.googlecode.com/svn/resources/trunk/docs/jcs.html

Although I have advocated for XML-based PKI protocol and formats, I have recently "defected" to the JSON camp.

My Android app required 200 000 lines  (!) of Apache XML support.
JSON made it possible replacing this "monstrosity" with some 3000 lines of not particularly complex code.

BTW, this was my first try with HTML5 instead of PDF.  It worked :-)
Well, only if you run an up-to-date browser of course...

Regards,
Anders

Source:
https://code.google.com/p/openkeystore/source/browse/library/trunk/src/org/webpki/json

---

From: Piyush Jain <[email-masked]>
Date: Mon, 23 Dec 2013 16:29:54 -0800

Is this a parallel effort to JWS which is being developed JOSE(
https://ietf.org/wg/jose/) working group?
If so, I am wondering why?

Regards
Piyush

On Wed, Dec 18, 2013 at 10:16 AM, Anders Rundgren <
[email-masked]> wrote:

> _______________________________________________
> pkix mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pkix
>

---

From: Anders Rundgren <[email-masked]>
Date: Tue, 24 Dec 2013 07:10:09 +0100

On 2013-12-24 01:29, Piyush Jain wrote:
> Is this a parallel effort to JWS which is being developed JOSE(https://ietf.org/wg/jose/) working group?

The JOSE group currently only works schemes that embeds the signed data in Base64
(in order to avoid canonicalization).

I have found out that you with _extremely_simple_code_ can nullify the
canonicalization argument and get a considerably nicer result for information-rich
systems (to which the original JOSE use-cases do not belong).

Talking about parallel efforts, the following is a challenger to PKIX's EST:
https://openkeystore.googlecode.com/svn/resources/trunk/docs/keygen2.html
It is heavily based on JCS:
https://openkeystore.googlecode.com/svn/resources/trunk/docs/keygen2.html#Sample.ProvisioningInitializationResponse

Regards
Anders

> 
> Regards
> Piyush
> 
> 
> On Wed, Dec 18, 2013 at 10:16 AM, Anders Rundgren <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     [email-masked] <mailto:[email-masked]>