Subject: [pkix] RFC8410 / RFC8037 incompatibility

From: Anders Rundgren <[email-masked]>
Date: Fri, 28 Aug 2020 17:00:20 +0200

Hi Crypto Experts,

Please pardon my ignorance regarding curve25519, but I ran into problems [*] trying to recreate the sample certificate:
https://tools.ietf.org/html/rfc8410#section-10.2

Reading
https://tools.ietf.org/html/rfc8037#section-3.2
indicates that signing using an ECDH key MUST NOT be doable as well.

Personally I don't see any use of a self-signed encryption certificate so maybe this is just a bad example...kind of edge case.

Regards,
Anders

*] java.security.InvalidKeyException: cannot identify EdDSA private key

---

From: Jim Schaad <[email-masked]>
Date: Fri, 28 Aug 2020 09:03:11 -0700

If you read the text, the certificate in 10.2 says it is self-issued not
self-signed.  The key used to sign the certificate is not the private key of
the public key in the certificate.  I don't remember off the top of my head
which of the EdDSA certs from that draft I used to do the signature.

jim

-----Original Message-----
From: pkix <[email-masked]> On Behalf Of Anders Rundgren
Sent: Friday, August 28, 2020 8:00 AM
To: [email-masked]
Subject: [pkix] RFC8410 / RFC8037 incompatibility

Hi Crypto Experts,

Please pardon my ignorance regarding curve25519, but I ran into problems [*]
trying to recreate the sample certificate:
https://tools.ietf.org/html/rfc8410#section-10.2

Reading

Personally I don't see any use of a self-signed encryption certificate so
maybe this is just a bad example...kind of edge case.

Regards,
Anders

_______________________________________________
pkix mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pkix

---

From: Anders Rundgren <[email-masked]>
Date: Fri, 28 Aug 2020 18:05:19 +0200

> which of the EdDSA certs from that draft I used to do the signature.

Thanx!

Anders

---

From: Michael StJohns <[email-masked]>
Date: Fri, 28 Aug 2020 12:57:49 -0400

Hi Jim -

For later reference, self-issued certs that are not self-signed 
generally have an authority key identifier pointing to the right key.

Mike

---

From: Jim Schaad <[email-masked]>
Date: Fri, 28 Aug 2020 10:40:36 -0700

This has been filed as an errata.

-----Original Message-----
From: pkix <[email-masked]> On Behalf Of Michael StJohns
Sent: Friday, August 28, 2020 9:58 AM
To: [email-masked]
Subject: Re: [pkix] RFC8410 / RFC8037 incompatibility

Hi Jim -

For later reference, self-issued certs that are not self-signed generally
have an authority key identifier pointing to the right key.

Mike

On 8/28/2020 12:03 PM, Jim Schaad wrote:
> If you read the text, the certificate in 10.2 says it is self-issued 
> not self-signed.  The key used to sign the certificate is not the 
> private key of the public key in the certificate.  I don't remember 
> off the top of my head which of the EdDSA certs from that draft I used to
do the signature.
> Please pardon my ignorance regarding curve25519, but I ran into 
> problems [*] trying to recreate the sample certificate:
> Personally I don't see any use of a self-signed encryption certificate 
> so maybe this is just a bad example...kind of edge case.
>
> Regards,
> Anders
>

---

From: "StJohns, Michael" <[email-masked]>
Date: Fri, 28 Aug 2020 14:00:55 -0400

Thanks!

On Fri, Aug 28, 2020 at 13:40 Jim Schaad <[email-masked]> wrote:

> > *] java.security.InvalidKeyException: cannot identify EdDSA private
>
> > key
>
> >
>