Subject: Two New Drafts

From: Ed Ellesson <[email-masked]>
Date: Thu, 07 Oct 1999 17:09:10 -0400

Hey y'all:  

These drafts are probably going to be rev'd one more time before the Wash
DC IETF deadline, so now is your chance to comment before we rev them
again. Thanks to Bob Moore for working so hard to get these out! 

**********************  

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Policy Framework Working Group of the IETF.

	Title		: Policy Framework LDAP Core Schema
	Author(s)	:  J. Strassner, E. Ellesson, R. Moore
	Filename	: draft-ietf-policy-core-schema-05.txt
	Pages		: 40
	Date		: 06-Oct-99
	
This document takes as its starting point the object-oriented
information model for representing policy information currently under
joint development in the Service Level Agreements (SLA) Policy working
group of the Distributed Management Task Force (DMTF) and in the
IETF's Policy Framework working group.  The IETF document defining
this information model is the 'Policy Framework Core Information
Model' [10].  This model defines two hierarchies of object classes:
structural classes representing policy information and control of
policies, and relationship classes that indicate how instances of the
structural classes are related to each other. In general, both of
these class hierarchies will need to be mapped to a particular data
store.

A URL for this Internet-Draft is:

http://www.ietf.org/internet-drafts/draft-ietf-policy-core-schema-05.txt

**********************

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Policy Framework Working Group of the IETF.

	Title		: Policy Framework Core Information Model
	Author(s)	: B. Moore, E. Ellesson, J. Strassner 
	Filename	: draft-ietf-policy-core-info-model-01.txt
	Pages		: 58
	Date		: 06-Oct-99
	
This document presents the object-oriented information model for
representing policy information currently under development as part of
the Common Information Model (CIM) activity in the Distributed
Management Task Force (DMTF).  This CIM model defines two hierarchies
of object classes:  structural classes representing policy information
and control of policies, and relationship classes that indicate how
instances of the structural classes are related to each other. A
companion document 'Policy Framework Core LDAP Schema' [9] defines the
mapping of this information model to a directory that uses LDAPv3 as
its access protocol.

A URL for this Internet-Draft is:

http://www.ietf.org/internet-drafts/draft-ietf-policy-core-info-model-01.txt

Regards, 

Ed Ellesson
Sr. Engineer, TCP/IP Technology Management
IBM Networking Software Products
Research Triangle Park, NC 
[email-masked]
919-254-4115

---

From: "Ryan Moats" <[email-masked]>
Date: Fri, 8 Oct 1999 13:47:20 -0500

Since we are having some internal mail problems,
my apologies if I'm lagging behind here.

I've read -05 of the schema and I have only the
following two comments:

1.  I think the security section correctly
captures what we talked about in Colorado back
in May, but my notes died in my June laptop
HD crash and I haven't been able to compare
them.  Can somebody with notes from CO verify
that this is indeed what we discussed under the
heading of "security"

2. In section 5.3, the reason the ABNF I
submitted had policyRule being contained by
policyGroup is that I remember seeing a weak
relationship between PolicyRule and PolicyGroup
in the information model.  Since that isn't
the case now (and maybe wasn't to begin with),
I am in favor of removing the "SUP" information
from structure rules 3 and 4 to allow implementers
extra flexibility.

Ryan

---

From: "Ryan Moats" <[email-masked]>
Date: Wed, 13 Oct 1999 13:39:16 -0500

It dawns on me (while working on a related
problem) that the ABNF in -05 needs the
following tweak:

Instead of using 1, 2, 3, etc. for the
structure rules, we should use placeholders:
<sr1>, <sr2>, etc.  Since structure rules
are numbered locally, we don't know what
will be available.  Placeholders solve
this (with text that says they should be
replaced with whatever integers are available
in a particular implementation).

Ryan