Subject: Re: Public domain source code

From: [email-masked] (Vernon Schryver)
Date: Wed, 14 Jan 1998 10:31:28 -0700

> >       Anybody knows any public domain source code for  PPP 
> > l2tp, pptp, PPP multilink.
> 
> I don't think there is any public domain code for the core of PPP, or
> even any Berkeley style licence material.  The best you could probably
> manage is GPLed code (no proprietory derived works, but can be bundled
> at the executable or shared library level with such works; source must be 
> supplied).  Look at the Linux code for the core PPP support at this 
> level of licence.
> 
> Public domain - you can treat it as though you wrote it.
> 
> Berkeley - you must acknowledge the true origins and clearly indicate
> changes - you must pass on the original disclaimer of warranty and licence.
> 
> GPL - as Berkeley, plus:  you must supply source code - you may not charge
> ...

What about Paul Mackerras's code?  Isn't it in one or more of the free
BSD implementations?  Doesn't he have BSD license on it?  The last
release note I have for it started with:

} From: [email-masked] (Paul Mackerras)
} Newsgroups: comp.protocols.ppp
} Subject: [ANNOUNCE] ppp-2.3.1 available
} Date: 14 Jul 1997 12:25:45 +1000
} Organization: Australian National University
} Message-ID: <[email-masked]>
} Reply-To: [email-masked]
 
} Some of you will have noticed a ppp-2.3.0 distribution in
} ftp://cs.anu.edu.au/pub/software/ppp.  At the time, my news access
} was broken, which is why I didn't post an announcement.
} 
} Since then, some people have reported bugs in ppp-2.3.0 and contributed
} enhancements.  A new version is now available as ppp-2.3.1.tar.gz in the
} usual place (ftp://cs.anu.edu.au/pub/software/ppp/).
} 
} The enhancements in ppp-2.3.1, compared to ppp-2.3.0, are:
} ...

Vernon Schryver,  [email-masked]

---

From: David Woolley <[email-masked]>
Date: Thu, 15 Jan 1998 08:11:54 +0000 (GMT)

> release note I have for it started with:

Yes.  I thought it was GPL, but it is actually Berkeley style, with various
copyright owners.