Subject: research for more details about COBS

From: Jean-Luc Triouleyre <[email-masked]>
Date: Thu, 18 Jun 1998 14:37:52 +0200

Dear,

I am working in a society dealing with Telecom devices designs.

We plan to introduce COBS mechanisms in our next version of our High Speed Serial Lines device before the end of this year ( many of our customers asked it).

So i went on the web in order to find more details about COBS; i read the IETF working group memo (november 97) about PPP Consistent Overhead Byte Stuffing and the Stuart David Cheshire Dissertation for his thesis.

I noticed that IETF memo expired in may 1998. So does it exists a new revision of the document ?

Does it also exists something more normative or a recommendation that presents COBS utilisation (what is mandatory, which kinds of evolution are possible, ...) and LCP format for the COBS configuration (at the initialisation of the communication, for renegociation, ...).

Thank you in advance for your help

Best regards

Jean-Luc

-------------------------

Jean-Luc TRIOULEYRE

T-SQWARE
6 Parc Ariane - Immeuble Mercure
Boulevard des Chenes
78284 GUYANCOURT Cedex
FRANCE

Email : [email-masked]
tel  : 33 (0) 1 39 44 67 59
fax : 33 (0) 1 39 44 29 30
-------------------------

---

From: James Carlson <[email-masked]>
Date: Thu, 18 Jun 1998 08:57:35 -0400

> We plan to introduce COBS mechanisms in our next version of our High
> Speed Serial Lines device before the end of this year ( many of our
> customers asked it).

I'd be very interested in hearing what details you could provide.
(Please send them to me rather than the list.)

> So i went on the web in order to find more details about COBS; i
> read the IETF working group memo (november 97) about PPP Consistent
> Overhead Byte Stuffing and the Stuart David Cheshire Dissertation
> for his thesis.
> 

There will be soon.  I'm working on it.  There are a few minor
modifications needed before it's published.

(If you have any suggestions, please feel free to write me with them.)

> Does it also exists something more normative or a recommendation
> that presents COBS utilisation (what is mandatory, which kinds of
> evolution are possible, ...) and LCP format for the COBS
> configuration (at the initialisation of the communication, for
> renegociation, ...).

Of course, there is also RFC 1661 which describes in particular how
LCP options are formatted and used.  Is this what you need?

(Any time I see the words "normative" and "recommendation," I think of
the ITU.  COBS isn't an ITU standard, nor do I expect it to become
one; it's an IETF working group project.)

In order for something to advance through the standards process, it's
required that actual implementations be made.  This is very different
from the way things are done with ITU, ANSI, et cetera.  See RFC 2026.

-- 
James Carlson, Consulting S/W Engineer  <[email-masked]>
IronBridge Networks / 55 Hayden Avenue  71.246W    Vox:  +1 781 402 8032
Lexington MA  02173-7999 / USA          42.423N    Fax:  +1 781 402 8092
"PPP Design and Debugging" ------------- http://id.wing.net/~carlson/ppp