Subject: PPPOE Doubts

From: "Arul J.P." <[email-masked]>
Date: Thu, 25 Oct 2001 13:18:18 +0530

Hi,

    Please clarify the following doubts.

   1. If PPPOE is used for service selection, wthether service
selection during PPP authentication is not necessary.

   2. If the service profile for the user is retrieved from the radius
server,
wthether the service name TAG present in PPPOE is used as the user
name is Access-Request packet.

   3. If PPPOE service name indicates the user has to be tunneled
to a corporate gateway, then is it correct to tunnel the user to
corporate gateway without authenticating the user.

   4. Please give an example for PPPOE service name tag if PPPOE
is used for service selection.

   5. Please give an example for PPP user name if PPP is used for
service selection.

Thanks and Regards,
Arul Mohan.

---
J.P. Arul Mohan
Senior Software Engineer
Phone No: 4330550   Extn: 339
email: [email-masked]

---

From: xiaolee <[email-masked]>
Date: Thu, 25 Oct 2001 17:37:3 +0800

// i doubt that whether the ppp supports service selection or not, as i know, it does not.
// in my opinion, it is good idea to do the service selection in the ppp protocol after the
// authentication if finished. u know, the ppp is so pop for a user to access the network.
// if we do so, pppoe, l2tp can all benefit from this.

// this may need more TLV for radius to be defined, while not a new user account to be used.

// it may need two steps authentication, first for dialing in the local access server, and 
// second for dialing in the remote access server.

// u can find what u want in the follow drafts:
// draft-penno-pppoe-ext-service-03.txt
// draft-penno-pppoe-ext-qos-00.txt

Thanks and Regards,
Arul Mohan.