Subject: Question on EAP

From: Xin Chen <[email-masked]>
Date: Tue, 10 Sep 2002 10:32:40 +0100

Dear all,
 
Sorry for those who get this twice. I am a starter of PPP and related
extentions. I have a question based on the case below,
 
An authenticator in a WLAN link uses EAP to authenticate terminals. The
authenticator uses AAA (radius or Diameter) to communicate with
authentication server. The authentication server is not only providing
authentication service but registration services. Once the authentication is
successful, the terminal will be considered registered with the network, and
services can be provided.
 
And the registration service of the authentication server needs to know the
user's status in the network (registered or not). Therefore, it relys on
some sort of information reported by the authenticator which is close to the
terminals
 
When the terminal powers off, we want the authenticator to detect this and
report to the authenitcation server that user is not registered anymore
(becuase user has turned off its terminal).
 
The question is does the current WLAN technologies and EAP protocol support
this operation. 
 
Regards
 
Xin Chen
Mobile Network Architecture
Fujitsu Laboratories of Europe LTD
Tel: +44 (0) 2086064453
Mobile: +44 (0)7775741020

---

From: "Jari Arkko (LMF)" <[email-masked]>
Date: Thu, 12 Sep 2002 08:51:41 +0200

This does not seem to be an EAP related function as such.
If the given link layer technology gives you an indication of "power
off" in some manner, then the access network or the authenticator
can send a RADIUS accounting stop or similar message to the
home network. So, I don't think EAP is involved. Both RADIUS
accounting and DIAMETER should be able to support such
notifications in the AAA space. I'm not sure how well WLAN
allows you to detect the power-off of a terminal and distinguish
it from temporary radio disturbances.

Jari
-----Original Message-----
From: Xin Chen [mailto:[email-masked]]
Sent: 10. syyskuuta 2002 12:33
To: [email-masked]'; [email-masked]'
Subject: Question on EAP

Dear all,

Sorry for those who get this twice. I am a starter of PPP and related extentions. I have a question based on the case below,

An authenticator in a WLAN link uses EAP to authenticate terminals. The authenticator uses AAA (radius or Diameter) to communicate with authentication server. The authentication server is not only providing authentication service but registration services. Once the authentication is successful, the terminal will be considered registered with the network, and services can be provided.

And the registration service of the authentication server needs to know the user's status in the network (registered or not). Therefore, it relys on some sort of information reported by the authenticator which is close to the terminals

When the terminal powers off, we want the authenticator to detect this and report to the authenitcation server that user is not registered anymore (becuase user has turned off its terminal).

The question is does the current WLAN technologies and EAP protocol support this operation. 

Regards

Xin Chen