Subject: RE: draft-purser-pppext-pppcn-00.txt

From: "Kevin Purser (QA/EMC)" <[email-masked]>
Date: Wed, 17 Sep 2003 09:40:04 -0500

Hello All,
> 
> 4.  Security Considerations
> 
>    Security considerations are not discussed in this memo.  However,
>    since the aim of this protocol is merely to reduce PPP negotiation
>    time by allowing the distinct negotiation phases to happen concur-
>    rently instead of in a serial fashion, there should not be 
> any addi-
>                                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
>    tional security risks introduced which are not already present in
>    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
>    [PPP].
> 
> No additional security risks? Really? How about revealing an 
> IP address
> before you have even authenticated the peer? Or accepting an unlimited
> number of IP packets waiting for some negotiation to complete?
> Neither of these significant security issues are present in RFC1661,
> and both represent leaks that can easily be abused. If anything, this
> draft _adds_ serious security risks.

Perhaps the text wasn't clear enough.  While the IP address may be "revealed" to the peer, it's of no consequence if packets sent by that peer will *not* be forwarded by the authenticating peer until *after* completing the auth phase, right?  And the sending of IP packets was really only a further optimization to the proposal, not a requirement.

Kev

> 
> -Ignacio
> 
> PS: In the future, please refrain from sending HTML messages. They are
> almost always unreadable, often due to specific sender's 
> personal choices
> like colors and font sizes. Use text messages instead, which 
> have always
> been (and always will be) readable.
>

---

From: James Carlson <[email-masked]>
Date: Wed, 17 Sep 2003 10:46:53 -0400

> Perhaps the text wasn't clear enough.  While the IP address may be "revealed" to the peer, it's of no consequence if packets sent by that peer will *not* be forwarded by the authenticating peer unt…

I agree with that.  The proposal doesn't omit the required security
steps, and IP addresses seem to me to be hardly something that could
be considered "secrets."

-- 
James Carlson, IP Systems Group                <[email-masked]>
Sun Microsystems / 1 Network Drive         71.234W   Vox +1 781 442 2084
MS UBUR02-212 / Burlington MA 01803-2757   42.497N   Fax +1 781 442 1677