Subject: [ppsp] FW: New Version Notification for draft-zong-ppsp-reqs-00

From: zongning 63316 <[email-masked]>
Date: Wed, 04 Mar 2009 15:23:07 +0800

Hi, Folks,
An initial draft of PPSP requirements:

draft-zong-ppsp-reqs-00.txt

has been uploaded to IETF website for our discussion during the coming PPSP bar BoF.
Any comments are welcome!

Best Regards
Ning Zong

******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or em
ail immediately and delete it!
 *****************************************************************************************

Subject: New Version Notification for draft-zong-ppsp-reqs-00
From: IETF I-D Submission Tool <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Tue, 03 Mar 2009 23:15:55 -0800 (PST)

A new version of I-D, draft-zong-ppsp-reqs-00.txt has been successfuly submitted by Ning Zong and posted to the IETF repository.

Filename:	 draft-zong-ppsp-reqs
Revision:	 00
Title:		 P2P Streaming Protocol (PPSP) Requirements
Creation_date:	 2009-03-03
WG ID:		 Independent Submission
Number_of_pages: 12

Abstract:
The Peer to Peer Streaming Protocol (PPSP) is a distributed real-time
data retrieval protocol in one-to-many communication.  This document
describes the requirements for the PPSP.

The IETF Secretariat.

---

From: Victor Pascual Ávila <[email-masked]>
Date: Wed, 4 Mar 2009 08:44:47 +0100

http://www.ietf.org/internet-drafts/draft-zong-ppsp-reqs-00.txt

On Wed, Mar 4, 2009 at 8:23 AM, zongning 63316 <[email-masked]> wrote:
> ---------- Forwarded message ----------
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp
>
>

-- 
Victor Pascual Ávila

---

From: "Yunfei Zhang" <[email-masked]>
Date: Wed, 4 Mar 2009 15:58:00 +0800

Dear all,
   An initial draft of PPSP requirements:
draft-zhang-ppsp-problem-statement-01.txt

is attached for our discussion during the coming PPSP bar BoF.The final 01 version is to be submitted by March 9th.Any comments are welcome!

  Best regards!
  Sincerely yours,
  Yunfei 
      2009-03-04
*****************************************************

Yunfei Zhang, Ph.D.

R&D, CHINA MOBILE COMMUNICATIONS CORPORATION

Tel: +86 10 158016966688 ext. 3247

Fax: +86 10 63601087

MOBILE: 1360-1032-119

*****************************************************

-------------------------------------------------------------
发件人：zongning 63316
发送日期：2009-03-04 15:23:52
收件人：[email-masked]
抄送：
主题：[ppsp] FW: New Version Notification for draft-zong-ppsp-reqs-00

Hi, Folks,

Best Regards
Ning Zong

------------------------------------------------------------
From:  IETF I-D Submission Tool <[email-masked]>
To:  [email-masked]
Subject:  New Version Notification for draft-zong-ppsp-reqs-00
Date:  Tue03 Mar 2009 23:15:55 -0800 (PST)

Abstract:

The IETF Secretariat.

------------------------------------------------------------
_______________________________________________
ppsp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

---

From: "Hui Zhang" <[email-masked]>
Date: Wed, 4 Mar 2009 20:43:41 -0500

Hi Yunfei and Ning,

Are your documents two versions of one proposal or two separate proposals?

Thanks,

Hui

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Yunfei Zhang
Sent: Wednesday, March 04, 2009 2:58 AM
To: [email-masked]
Subject: [ppsp] New Version Notification fordraft-zhang-ppsp-problem-statement-01

Dear all,

          

  Best regards!
  Sincerely yours,
  Yunfei 
      2009-03-04

Yunfei Zhang, Ph.D.

Fax: +86 10 63601087

MOBILE: 1360-1032-119

Hi, Folks,

Best Regards
Ning Zong

Abstract:

The IETF Secretariat.

---

From: "Hui Zhang" <[email-masked]>
Date: Wed, 4 Mar 2009 21:05:16 -0500

Thanks for the clarification, Yunfei.

Regards,

Hui

-----Original Message-----
From: Yunfei Zhang [mailto:[email-masked]] 
Sent: Wednesday, March 04, 2009 9:00 PM
To: Hui Zhang
Subject: Re: RE: [ppsp] New Version Notificationfordraft-zhang-ppsp-problem-statement-01

Hi Hui,
   One is problem statement and one is protocol requirements,3x!
 	　     

  Best regards!
  Sincerely yours,
  Yunfei 
      2009-03-05

Yunfei Zhang, Ph.D.

Fax: +86 10 63601087

MOBILE: 1360-1032-119

-------------------------------------------------------------
发件人：Hui Zhang
发送日期：2009-03-05 09:44:16
收件人：Yunfei Zhang; [email-masked]
抄送：
主题：RE: [ppsp] New Version Notificationfordraft-zhang-ppsp-problem-statement-01

Hi Yunfei and Ning,

Thanks,

Hui

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Yunfei Zhang
Sent: Wednesday, March 04, 2009 2:58 AM
To: [email-masked]
Subject: [ppsp] New Version Notification fordraft-zhang-ppsp-problem-statement-01

Dear all,

          

  Best regards!
  Sincerely yours,
  Yunfei 
      2009-03-04

Yunfei Zhang, Ph.D.

Fax: +86 10 63601087

MOBILE: 1360-1032-119

Hi, Folks,

Best Regards
Ning Zong

Abstract:

The IETF Secretariat.

---

From: yunfei zhang <[email-masked]>
Date: Thu, 5 Mar 2009 11:53:23 +0800

Dear all,
   An initial draft of comparison of pplive and ppstream protocol by
measurement for PPSP is availalbe in IETF website:

http://www.ietf.org/internet-drafts/draft-zhang-ppsp-protocol-comparison-measurement-00.txt
This is to be discussed during the coming PPSP bar BoF.Any comments are
welcome!

                                   Yunfei

2009/3/4, Yunfei Zhang <[email-masked]>:
> is attached for our discussion during the coming PPSP bar BoF.The final 01
> version is to be submitted by March 9th.Any comments are welcome!
>
>
>
>
>
> Best regards!
> Sincerely yours,
> Yunfei
>      2009-03-04
> This email and its attachments contain confidential information from
> HUAWEI, which is intended only for the person or entity whose address is
> listed above. Any use of the information contained herein in any way
> (including, but not limited to, total or partial disclosure, reproduction,
> or dissemination) by persons other than the intended recipient(s) is
> prohibited. If you receive this e-mail in error, please notify the sender by
> phone or em
> A new version of I-D, draft-zong-ppsp-reqs-00.txt has been successfuly
> submitted by Ning Zong and posted to the IETF repository.
>

---

From: "Softgear Ko" <[email-masked]>
Date: Thu, 5 Mar 2009 13:20:52 +0900

Hello, Ning Zong.

A tracker/DHT gives initial list of peers to new peer. initial peer is
bootstrap peer in P2PSIP language, I think. Because a tracker/DHT may not
have whole peer list in one (P2P Streaming) channel, a tracker/DHT gives
part of whole peers in a channel as bootstrap peers. What peer does become a
bootstrap peer? What peer should a tracker/DHT maintain as bootstrap peer
for a channel? 

There are a mechanism to construct a topology(proximity)-aware overlay using
measurement. Why don't you define measurement messages or other topology
optimization related messages in PPSP? 

I think HTTP or RTSP can replace PPSP Transmission protocol. How do you
think?

Don't we need to consider NAT problem?

BTW, what "bar" stands for in "bar BOF"? - I'm sorry about my stupid
question. :-)

Best Regards,
Softgear Ko

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
zongning 63316
Sent: Wednesday, March 04, 2009 4:23 PM
To: [email-masked]
Subject: [ppsp] FW: New Version Notification for draft-zong-ppsp-reqs-00

Hi, Folks,

has been uploaded to IETF website for our discussion during the coming PPSP
bar BoF.
Any comments are welcome!

Best Regards
Ning Zong

****************************************************************************
**************
 This email and its attachments contain confidential information from
HUAWEI, which is intended only for the person or entity whose address is
listed above. Any use of the information contained herein in any way
(including, but not limited to, total or partial disclosure, reproduction,
or dissemination) by persons other than the intended recipient(s) is
prohibited. If you receive this e-mail in error, please notify the sender by
phone or em ail immediately and delete it!
 
****************************************************************************
*************

---

From: zongning 63316 <[email-masked]>
Date: Thu, 05 Mar 2009 13:04:28 +0800

see in-line.

----- 原邮件 -----
发件人: Softgear Ko <[email-masked]>
日期: 星期四, 三月 5日, 2009 下午12:21
主题: RE: [ppsp] FW: New Version Notification for draft-zong-ppsp-reqs-00
收件人: 'zongning 63316' <[email-masked]>, [email-masked]

> have whole peer list in one (P2P Streaming) channel, a tracker/DHT 
> givespart of whole peers in a channel as bootstrap peers. What 
> peer does become a

ans: This is currently an implementation issue of tracker. I think some performance metric, e.g. online time could be one option for bootstrap peer selection. Anyway, PPSP doesn't focus on how to choose initial peers. The channle manager in P2P streaming usage on RELOAD may consider this as the function of channel manager.

> measurement. Why don't you define measurement messages or other 
> topologyoptimization related messages in PPSP? 
>

ans: PPSP may employ some topology optimizing approach, such as ALTO, or measurement. It will discuss more next in PPSP BoF.
 
> I think HTTP or RTSP can replace PPSP Transmission protocol. How 

ans: IMO, before we can clearly see a protocol particularly suitable for P2P streaming, we will leave transmission issue for the next phase of PPSP following PPSP signaling.
 
> Don't we need to consider NAT problem?

ans: We will.

> BTW, what "bar" stands for in "bar BOF"? - I'm sorry about my stupid

bar BoF means a BoF hold in a bar so that everyone can also enjoy some drink. Am I right :)

> (including, but not limited to, total or partial disclosure, 
> reproduction,or dissemination) by persons other than the intended 
> recipient(s) is

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 5 Mar 2009 14:56:41 +0800

Dear Softgear,
   Thanks for your comments.You propose many intersting issues we want to solve in PPSP.I try to make some clarification on your questions.
1)Bootstrap node is the one who introduces other nodes to enter the P2P system.In this sense,Tracker itself act as bootstrap node instead of those inital audience nodes.Tracker needn't provide other nodes for bootstrap nodes.Rather it provides other nodes with some exisiting nodes who hold the requested content.
2)Your suggestion on developing topology-aware p2p streaming protocol is very interesting.In fact,we mentioned this point in the last PPSP bar bof in last IETF meeting.We have two means to do this.
First,through ALTO service.ALTO WG is to develop some topology-aware mechnisms in IETF.Therefore PPSP will define the interface with ALTO that can learn topology-aware information;
Second.through measurement as you suggested.In fact we are planing to develop mechanisms in PPSP.Welcome to contriubte in this point in PPSP.
3) No,we have stated in problem statement draft(draft-zhang-ppsp-problem-statement-01.txt) that RTSP 
is a signaling protocol in client/server streaming.It's not transmission protocol. As for the below RTP/UDP/TCP transmission protocol, it has some equivalence with PPSP transmission protocol. 
As for PPSP transmission protocol,there are two level of problems:
   First,evaluating the current transmission protocols such as RTP,UDP or TCP to use in p2p streaming envirnment;
   Second, because UDP is more and more popular in p2p streaming,it may cause internet collasp as predicted by S.Floyd some ten years ago considering the traffic share of p2p streaming in Internet.Therefore we are thinking about developing a one-to-many transmission protocol to balance self-constraince(TCP) and aggressiveness(UDP) to maximize the transmission efficency in P2P streaming.
4)We need to consider NAT problem.However P2PSIP has had a good exploration in this issue.We can reuse the fruite in PPSP.
5)Bar is just bar,but it doesn't mean we have the BOF in the bar:)It means the BOF meeting is not a formal one.
Many thanks for your comments.Wish to see you in SF.

                        Yunfei

zhangyunfei
2009-03-05

发件人： Softgear Ko
发送时间： 2009-03-05 12:20:58
收件人： 'zongning 63316'; [email-masked]
抄送： 
主题： Re: [ppsp] FW: New Version Notification for draft-zong-ppsp-reqs-00

Hello,  Ning  Zong.

Best  Regards,
Softgear  Ko

-----Original  Message-----

Hi,  Folks,

Best  Regards
Ning  Zong

---

From: "Softgear Ko" <[email-masked]>
Date: Thu, 5 Mar 2009 17:25:51 +0900

Hello, Yunfei.

Thank you for answer, Yunfei and Ning Zong.

1) In P2PSIP language (p2psip-concepts-02), I think Tracker act as a bootstrap server because Tracker itself does not join P2P streaming overlay network. Tracker gives initial audience nodes. The initial nodes may be not a optimal peer. New peer will get more peer from initial peers. Therefore, initial node is a bootstrap peer. But, this is a literal point. I understand what you said.

2) ALTO is interesting. However, I think standardizing and deploying will take long time. IMO, we have to look for other topology-aware mechanisms.

3) I think RTP/UDP is enough for a live streaming because live streaming requires realtime constraint. For VoD, I have no idea.

4) NAT solution in P2PSIP does not reflect topology enough, I think.

- Softgear Ko.

From: zhangyunfei [mailto:[email-masked]] 
Sent: Thursday, March 05, 2009 3:57 PM
To: Softgear Ko; 'zongning 63316'; [email-masked]
Subject: Re: Re: [ppsp] FW: New Version Notification for draft-zong-ppsp-reqs-00

Dear Softgear,

                        Yunfei
________________________________________
zhangyunfei
2009-03-05
________________________________________
发件人： Softgear Ko
发送时间： 2009-03-05 12:20:58
收件人： 'zongning 63316'; [email-masked]
抄送： 
主题： Re: [ppsp] FW: New Version Notification for draft-zong-ppsp-reqs-00
 
Hello,  Ning  Zong.

 

 
Best  Regards,
Softgear  Ko
 
-----Original  Message-----
 
Hi,  Folks,

 
Best  Regards
Ning  Zong

---

From: "Yunfei Zhang" <[email-masked]>
Date: Thu, 5 Mar 2009 16:58:53 +0800

Please check the inline.

-------------------------------------------------------------
发件人：Softgear Ko
发送日期：2009-03-05 16:25:50
收件人：'zhangyunfei'; 'zongning 63316'; [email-masked]
抄送：
主题：RE: Re: [ppsp] FW: New Version Notification fordraft-zong-ppsp-reqs-00

Hello, Yunfei.

Reply:In fact,I have a draft on P2P Traffic Localization by Traceroute and 2-Means Classification(http://www.ietf.org/internet-drafts/draft-zhang-alto-traceroute-02.txt) using measurment means to achieve this.It's efficient and needn't infrastructure support.Pls refer to it for more detail.

3) I think RTP/UDP is enough for a live streaming because live streaming requires realtime constraint. For VoD, I have no idea.
Reply:In p2p streaming,we basically use signaling protocol to ensure realtime just as done in RTSP.So there is a less constraint on transmission protocol to do tasks ensuring realtime.However other tasks such as how to balance between using empty bandwidth resource efficiently (UDP)and avoiding using bandwidth too aggressively(TCP)esp. in one-to-many communication envirnment where there is more probability for the network to be collapsed than one-to-one communcation if we mainly use UDP.

4) NAT solution in P2PSIP does not reflect topology enough, I think.
 Reply:I agree with it and we will consider it in PPSP.

- Softgear Ko.
Many thanks for your comments.

Dear Softgear,

                        Yunfei
 
Hello,  Ning  Zong.

 

 
Best  Regards,
Softgear  Ko
 
-----Original  Message-----
 
Hi,  Folks,

 
Best  Regards
Ning  Zong

---

From: "Hui Zhang" <[email-masked]>
Date: Thu, 5 Mar 2009 22:20:09 -0500

Ning,

That's a well-written draft, and thanks for getting PPSP work statement
much clearer!

My main comment is on the scope of PPSP defined from this requirement
draft.
>From my understanding, the requirements give a wide scope that PPSP
tries to standardize for P2P streaming services.
For example, "PPSP General Requirements" seems to ask for a special
overlay topology construction and maintenance protocol (like Chord for
P2PSIP), which might not be one thing PPSP has to standardize;
"PPSP Signaling Requirements" seems to ask for PPSP message header
definition (like TCP header definition), but is it only for peer-to-peer
information exchange or also includes that for peer-to-tracker
information exchange; "PPSP Transmission Requirements" gives a quite
special performance requirement for the transmission protocol but do we
know any available protocol can give such guarantees?; "PPSP Security
Requirements" further 
touches some internal security mechanism that might be hard to
standardize.

So can we have a miniature set of the requirements that defines what are
the basic PPSP components to be standardized (e.g., the PPSP message
headers, the user registration protocol, etc)? of course your draft
gives an excellent candidate list to start this discussion.

Regards,

Hui

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
zongning 63316
Sent: Wednesday, March 04, 2009 2:23 AM
To: [email-masked]
Subject: [ppsp] FW: New Version Notification for draft-zong-ppsp-reqs-00

Hi, Folks,

has been uploaded to IETF website for our discussion during the coming
PPSP bar BoF.
Any comments are welcome!

Best Regards
Ning Zong

************************************************************************
******************
 This email and its attachments contain confidential information from
HUAWEI, which is intended only for the person or entity whose address is
listed above. Any use of the information contained herein in any way
(including, but not limited to, total or partial disclosure,
reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please
notify the sender by phone or em
ail immediately and delete it!
 
************************************************************************
*****************

---

From: zongning 63316 <[email-masked]>
Date: Fri, 06 Mar 2009 11:39:13 +0800

Dear Zhang,
Thank you for your comments. I do think that some requirements are still need to be refined.
As for the "PPSP General Requirements", we don't want to define special overlay protocol. What is in my mind right now is that a data-driven model among peers can form a mesh, avoiding the single point failure and alleviating the churn problem. We can reuse this data-driven model in PPSP.
"PPSP transmission requirements" and "PPSP security" need a lot of further work. I just try to draw some candidates for consideration, some of them may not be suitable for standardization and some requirements are still missing here. Contributions are kindly invited especially in these areas.
Hope to see you in SF as well.

Best Regards
Ning Zong 

----- 原邮件 -----
发件人: Hui Zhang <[email-masked]>
日期: 星期五, 三月 6日, 2009 上午11:25
主题: RE: [ppsp] FW: New Version Notification for draft-zong-ppsp-reqs-00
收件人: zongning 63316 <[email-masked]>, [email-masked]

> Ning,
> 
> That's a well-written draft, and thanks for getting PPSP work 
> statementmuch clearer!
> 
> recipient(s) is prohibited. If you receive this e-mail in error, 
> pleasenotify the sender by phone or em