Subject: [ppsp] questions about dsn introduction draft

From: 马涛 <[email-masked]>
Date: Fri, 20 Mar 2009 02:53:02 +0800

Hi,
     I feel interested in the DSN introduction draft. I think DSN is very
important and promising, but I have some questions about this draft, and I
would appreciate the answer and help.
1 in the Figure 1-dsn architecture, there is distributed cache in the
service enablersublayer.As far as I know, now cache is application-specific,
it speaks the specific protocol according to the application. But here cache
are separated from the application sub-layer and makes the applications
transparent. If the application is a Bittorrent file sharing, how can the
distributed cache serve this application or how can it cache the files ?
2 How can the DSN reflect the manageable and operatable characteristics?Does
it mean the same thing as manageable and operatable P2P?or what differences?
3 If DSN wants to manage the P2P applications, does it also consider the way
to control P2P traffic like ALTO WG?
4 In section 5 "multiple DSN implementations", what does this mean?
Different carriers or protocols?
Best regards,
Tao Ma,
Beijing University of Post and Telecommunications, Mobile life and new media
Lab

---

From: "Yunfei Zhang" <[email-masked]>
Date: Fri, 20 Mar 2009 17:23:13 +0800

Thanks  Tao  for  your  comments.Please  see  inline.
  　          

   Best  regards!
   Sincerely  yours,
   Yunfei  
           2009-03-20
*****************************************************

Yunfei  Zhang,  Ph.D.

R&D,  CHINA  MOBILE  COMMUNICATIONS  CORPORATION

Tel:  +86  10  158016966688  ext.  3247

Fax:  +86  10  63601087

MOBILE:  1360-1032-119

*****************************************************

-------------------------------------------------------------
发件人：马涛
发送日期：2009-03-20  02:53:05
收件人：[email-masked]
抄送：[email-masked];  张春红;  [email-masked]
主题：[ppsp]questions  about  dsn  introduction  draft

Hi,

We'd like to extract the basic cache functions in this module,such as cache replacement strategies,
storage functions and content consistent ensurance, which may be common to different applications.
Applications can choose part or all of the service enabler capabilities to develop their own services.

2  How  can  the  DSN  reflect  the  manageable  and  operatable  characteristics?Does
it  mean  the  same  thing  as  manageable  and  operatable  P2P?or  what  differences?
Well,this is a good question.They are of same meanings.In the operators'view,"manageable and operatable"
refer to both network and services.In the network level,topics such as how to maintain a predictable traffic
 under p2p envirnments,how to enhance the p2p network management beyond basic node management are all options to discuss.
In the service level,how to run a DSN-inside service to realize user management,service management with a good 
business model in billing and charging in distributed computing envirnments are our interests.Of courese for a specific service like
VoIP or streaming,there are some extra specific manageable  and  operatable  characteristics.
Note that the  manageable  and  operatable  characteristics are NOT necessary requirement for PPSP.
Rather this is a DSN vision. 

3  If  DSN  wants  to  manage  the  P2P  applications,  does  it  also  consider  the  way
to  control  P2P  traffic  like  ALTO  WG?
We have similar considerations where you can find our drafts in ALTO WG(draft-zhang-alto-attp-00)for 
more details.Also we have some other means to deal with this problem,such as node localization and clustering 
by themselves(draft-zhang-alto-traceroute-00)which is different from ALTO means.

4  In  section  5  "multiple  DSN  implementations",  what  does  this  mean?
Different  carriers  or  protocols?
We'd like to have a common protocol stack for DSN and based on this there are different carriers or ISPs to 
run DSN-inside services.

Best  regards,
Tao  Ma,