Subject: [ppsp] Comments to draft-zhang-ppsp-protocol-comparison-measurement

From: Song Haibin <[email-masked]>
Date: Tue, 17 Mar 2009 12:10:09 +0800

Hi,

I think the measurement draft is a very great start to discuss the ppsp
signaling protocol. Here are some comments.

(1) Section 2, bullet 1, I didn't find any figure of the system structure in
this draft. Is it the same with Figure 3 in the problem statement draft? A
figure of the system structure will be of great help to understand the
protocol interactions.

(2) Section 2, bullet 2, I think it is very important to describe each of
the functions for signaling messages in this draft. From those descriptions,
we may finally find where to start the standardization of the ppsp signaling
protocol. IMHO, with reading so many materials and long time discussion, I
think the peer list and the data chunk information exchange between peers is
a good starting point.

(3) Section 2, bullet 6, I think the differences between the "application
layer p2p transportation" and "new p2p suitable transport protocol" should
be clarified.

(4) Section 2, bullet 7, I think it is a great topic to discuss the mobility
impacts on streaming, because it becomes more and more popular to use your
mobile phones to access the streaming service nowadays. 

(5). Section 3, paragraph 3, it is said "For each udp packet, it is
reasonable to assume that each packet is a completed protocol message". Are
there any fragmentations for the protocol messages?

(6) Figure 1, it seems that each connection between peers must be notified
to the tracker at first. Is it a common schema utilized by pplive and other
p2p streaming applications?

In a word, this draft is really good.

Best Regards,
Haibin
Skype: alexsonghw

---

From: "zhangyunfei" <[email-masked]>
Date: Wed, 18 Mar 2009 10:05:37 +0800

Thanks,Haibin.Please see inline about the reply.

zhangyunfei
2009-03-17

发件人： Song Haibin
发送时间： 2009-03-17 12:23:40
收件人： [email-masked]
抄送： 
主题： [ppsp] Comments to draft-zhang-ppsp-protocol-comparison-measurement

Hi,

No,they are not the same.I try to add one figure to show the strucutre.
(2)  Section  2,  bullet  2,  I  think  it  is  very  important  to  describe  each  of
the  functions  for  signaling  messages  in  this  draft.  From  those  descriptions,
we  may  finally  find  where  to  start  the  standardization  of  the  ppsp  signaling
protocol.  IMHO,  with  reading  so  many  materials  and  long  time  discussion,  I
think  the  peer  list  and  the  data  chunk  information  exchange  between  peers  is
a  good  starting  point.
Yes,I have some description on functions  for  signaling  messages  in problem statement draft.
I agree with you on the starting point of PPSP.

(3)  Section  2,  bullet  6,  I  think  the  differences  between  the  "application
layer  p2p  transportation"  and  "new  p2p  suitable  transport  protocol"  should
be  clarified.
Okay,I will clarify it in the following version.In fact we discuss a little of this in the problem statement
draft about the one-to-many transport protocol.

(4)  Section  2,  bullet  7,  I  think  it  is  a  great  topic  to  discuss  the  mobility
impacts  on  streaming,  because  it  becomes  more  and  more  popular  to  use  your
mobile  phones  to  access  the  streaming  service  nowadays.  
Totally agree with you.We have done some research work on studying the current p2p streaming systems
like pplive and ppstream to see how well the video plays when the peer moves.

(5).  Section  3,  paragraph  3,  it  is  said  "For  each  udp  packet,  it  is
reasonable  to  assume  that  each  packet  is  a  completed  protocol  message".  Are
there  any  fragmentations  for  the  protocol  messages?
No,there arenot any fragmentations for UDP protocol message according to our measurement.

(6)  Figure  1,  it  seems  that  each  connection  between  peers  must  be  notified
to  the  tracker  at  first.  Is  it  a  common  schema  utilized  by  pplive  and  other
p2p  streaming  applications?
No,this is a phenomena we observed in the begining of last year.This is not a necessary step.

Best  Regards,
Haibin
Skype:  alexsonghw

_______________________________________________
ppsp  mailing  list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

---

From: "zhangyunfei" <[email-masked]>
Date: Wed, 18 Mar 2009 13:53:12 +0800

As for signaling part,pplive uses its proprietary protocol based on UDP/TCP.
The message is already sequencely listed.
Thanks for your comments.

                      Yunfei 

zhangyunfei
2009-03-18

发件人： Ping Pan
发送时间： 2009-03-18 12:00:41
收件人： zhangyunfei
抄送： 
主题： Re: [ppsp] Comments todraft-zhang-ppsp-protocol-comparison-measurement

Good draft.

BTW, what is the protocol PPlive signaling running on? HTTP? SOAP? TCP? It's not clear in the draft.

You have parsed the message types. Do you have the messaging sequence too?

Thanks!

- Ping

2009/3/17 zhangyunfei <[email-masked]>

?
?

zhangyunfei
2009-03-17

发件人： Song Haibin
发送时间： 2009-03-17?12:23:40
收件人： [email-masked]
抄送： 
主题： [ppsp] Comments to draft-zhang-ppsp-protocol-comparison-measurement
?
Hi,
?
I ?think ?the ?measurement ?draft ?is ?a ?very ?great ?start ?to ?discuss ?the ?ppsp
signaling ?protocol. ?Here ?are ?some ?comments.
?
(1) ?Section ?2, ?bullet ?1, ?I ?didn't ?find ?any ?figure ?of ?the ?system ?structure ?in
this ?draft. ?Is ?it ?the ?same ?with ?Figure ?3 ?in ?the ?problem ?statement ?draft? ?A
figure ?of ?the ?system ?structure ?will ?be ?of ?great ?help ?to ?understand ?the
protocol ?interactions.
?
No,they are not the same.I try to add one figure to show the strucutre.
(2) ?Section ?2, ?bullet ?2, ?I ?think ?it ?is ?very ?important ?to ?describe ?each ?of
the ?functions ?for ?signaling ?messages ?in ?this ?draft. ?From ?those ?descriptions,
we ?may ?finally ?find ?where ?to ?start ?the ?standardization ?of ?the ?ppsp ?signaling
protocol. ?IMHO, ?with ?reading ?so ?many ?materials ?and ?long ?time ?discussion, ?I
think ?the ?peer ?list ?and ?the ?data ?chunk ?information ?exchange ?between ?peers ?is
a ?good ?starting ?point.
Yes,I have some description on functions ?for ?signaling ?messages??in problem statement draft.
I agree with you on the starting point of PPSP.
?
(3) ?Section ?2, ?bullet ?6, ?I ?think ?the ?differences ?between ?the ?"application
layer ?p2p ?transportation" ?and ?"new ?p2p ?suitable ?transport ?protocol" ?should
be ?clarified.
Okay,I will clarify it in the following version.In fact we discuss a little of this in the problem statement
draft about the one-to-many transport protocol.
?
(4) ?Section ?2, ?bullet ?7, ?I ?think ?it ?is ?a ?great ?topic ?to ?discuss ?the ?mobility
impacts ?on ?streaming, ?because ?it ?becomes ?more ?and ?more ?popular ?to ?use ?your
mobile ?phones ?to ?access ?the ?streaming ?service ?nowadays. ?
Totally agree with you.We have done some research work on studying the current p2p streaming systems
like pplive and ppstream to see how well the video plays when the peer moves.
?
(5). ?Section ?3, ?paragraph ?3, ?it ?is ?said ?"For ?each ?udp ?packet, ?it ?is
reasonable ?to ?assume ?that ?each ?packet ?is ?a ?completed ?protocol ?message". ?Are
there ?any ?fragmentations ?for ?the ?protocol ?messages?
No,there arenot any fragmentations for UDP protocol message according to our measurement.
?
(6) ?Figure ?1, ?it ?seems ?that ?each ?connection ?between ?peers ?must ?be ?notified
to ?the ?tracker ?at ?first. ?Is ?it ?a ?common ?schema ?utilized ?by ?pplive ?and ?other
p2p ?streaming ?applications?
No,this is a phenomena we observed in the begining of last year.This is not a necessary step.
?
In ?a ?word, ?this ?draft ?is ?really ?good.
?
?
Best ?Regards,
Haibin
Skype: ?alexsonghw
?
?
?
_______________________________________________
ppsp ?mailing ?list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

---

From: Ping Pan <[email-masked]>
Date: Tue, 17 Mar 2009 22:59:31 -0700

Do you have the port number? Cannot find it from IANA.
Thanks!

- Ping

>  ------------------------------
>  zhangyunfei
> 2009-03-18
>  ------------------------------
>  *发件人：* Ping Pan
> *发送时间：* 2009-03-18 12:00:41
> *收件人：* zhangyunfei
> *抄送：*
> *主题：* Re: [ppsp] Comments
> todraft-zhang-ppsp-protocol-comparison-measurement
>
> Good draft.
>>  ------------------------------
>>  zhangyunfei
>> 2009-03-17
>>  ------------------------------
>>  *发件人：* Song Haibin
>> *发送时间：* 2009-03-17?12:23:40
>> *收件人：* [email-masked]
>> *抄送：*
>> *主题：* [ppsp] Comments to draft-zhang-ppsp-protocol-comparison-measurement
>> ?
>>  Hi,
>> ?

---

From: "zhangyunfei" <[email-masked]>
Date: Wed, 18 Mar 2009 17:02:50 +0800

The port number is variable ranging about from 1024 to 10000 and in many cases the port number is about 5000 to 6000.

zhangyunfei
2009-03-18

发件人： Ping Pan
发送时间： 2009-03-18 13:59:35
收件人： zhangyunfei
抄送： [email-masked]
主题： Re: Re: [ppsp] Commentstodraft-zhang-ppsp-protocol-comparison-measurement

Thanks!

- Ping

As for signaling part,pplive uses its proprietary protocol based on UDP/TCP.
The message is already sequencely listed.
Thanks for your comments.
?
????????????????????? Yunfei?
?

zhangyunfei
2009-03-18

发件人： Ping Pan
发送时间： 2009-03-18?12:00:41
收件人： zhangyunfei
抄送： 
主题： Re: [ppsp] Comments todraft-zhang-ppsp-protocol-comparison-measurement
?
Good draft. 

Thanks!

- Ping

?

zhangyunfei
2009-03-17

发件人： Song Haibin