Subject: [ppsp] ISP-friendly P2P streaming

From: Reza Rejaie <[email-masked]>
Date: Tue, 6 Apr 2010 01:17:13 -0700 (PDT)

Hi,

I was wondering whether there has been any discussion (or any interest) in
this working group on issues related to making P2P streaming application 
(especially live streaming) ISP friendly? Here by "ISP-friendly P2P 
streaming" I am referring to those mechanisms that try minimize the 
external traffic for individual ISPs

We have developed a couple of mesh-based ISP-friendly P2P streaming 
mechanisms and would be happy to provide more details if there is 
inetrest.

reza

---

From: "Djamel Sadok" <[email-masked]>
Date: Tue, 6 Apr 2010 08:23:14 -0200

Reza,

I think that there are some products based on caching P2P traffic to reduce
external traffic. I do not know how legal this is given CRM issues in
different countries.

I am curious to find out about your approach.

Djamel

On Tue, 6 Apr 2010 01:17:13 -0700 (PDT), Reza Rejaie wrote
> Hi,
> 
> I was wondering whether there has been any discussion (or any 
> interest) in this working group on issues related to making P2P 
> streaming application 
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp

--
GPRT - Grupo de Pesquisa em Redes de Computadores e Telecomunicacoes

---

From: "Y.J. Gu" <[email-masked]>
Date: Tue, 06 Apr 2010 18:55:26 +0800

Hi Reza,
I'm really interested in the issues and would be glad to learn the details.
Except for P2P caching, ALTO and DECADE may also help in P2P streaming
optimization, though in different ways. 
PPSP will interact with the work performed in other IETF WGs, e.g. P2PSIP,
ALTO and DECADE. Since P2P streaming optimization (or say ISP friendly) is
not a special problem for P2P streaming, instead it's a common issue to be
considered in P2P application, I don't think it will be in the scope of
PPSP.

Regards

Yingjie Gu

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Reza Rejaie
> Sent: Tuesday, April 06, 2010 4:17 PM
> To: [email-masked]
> Subject: [ppsp] ISP-friendly P2P streaming
> 
> 
> Hi,
> 
> interest) in this working group on issues related to making 
> P2P streaming application (especially live streaming) ISP 
> friendly? Here by "ISP-friendly P2P streaming" I am referring 
> to those mechanisms that try minimize the external traffic 
> for individual ISPs
> 
> We have developed a couple of mesh-based ISP-friendly P2P 
> streaming mechanisms and would be happy to provide more 
> details if there is inetrest.
> 
> reza

---

From: "Djamel Sadok" <[email-masked]>
Date: Tue, 6 Apr 2010 08:52:11 -0200

I think that whether the ISP-friendliness issue should become or not part of
the P2P streaming protocol depends mainly on the way was such optimization is
achieved.

IF one can structure "intelligently" the streaming to facilitate its
optimization then there is a clear need to consider such optimization as part
of this work.

Djamel

On Tue, 06 Apr 2010 18:55:26 +0800, Y.J. Gu wrote
> Except for P2P caching, ALTO and DECADE may also help in P2P 
> streaming optimization, though in different ways. PPSP will interact 
> with the work performed in other IETF WGs, e.g. P2PSIP, ALTO and 
> DECADE. Since P2P streaming optimization (or say ISP friendly) is 
> not a special problem for P2P streaming, instead it's a common issue 
> to be considered in P2P application, I don't think it will be in the 
> scope of PPSP.
> 
> Regards
> 
> Yingjie Gu
>

---

From: Enrico Marocco <[email-masked]>
Date: Tue, 6 Apr 2010 13:23:36 +0200

During the last ALTO meeting we had a short presentation about this:
http://www.ietf.org/proceedings/10mar/minutes/alto.html#streaming

Enrico

---

From: Volker Hilt <[email-masked]>
Date: Tue, 6 Apr 2010 08:54:41 -0400

Yes, I believe that to the extend it impacts the structure/protocol of 
the streaming application localization should be considered in PPSP. 
There is obviously a tie into ALTO as well for the exchange of 
localization information.

Thanks,

Volker

---

From: "zhangyunfei" <[email-masked]>
Date: Wed, 7 Apr 2010 10:04:02 +0800

I agree with Volker's opinion on this.There may be some optional fields in PPSP messages to fetch ISP or other geographical/regional inforamation for localizaiton.But the optimization operation can be envisioned to be done by ALTO.
In this case there may exist some extension requirements for ALTO to deal with more kinds of messages to realize traffic optimization.

BR
Yunfei

zhangyunfei
2010-04-07

发件人： Volker Hilt
发送时间： 2010-04-06 21:13:17
收件人： Djamel Sadok
抄送： [email-masked]
主题： Re: [ppsp] ISP-friendly P2P streaming

Thanks,

Volker

---

From: "Xiao, Lin (NSN - CN/Beijing)" <[email-masked]>
Date: Wed, 7 Apr 2010 10:27:41 +0800

IMO, ALTO is the best way to do any optimized peer selection. It has defined a method for P2P tracker to communicate with ALTO server as an ALTO client. The logical functionalities of PPSP and ALTO should be separated clearly,while they can work together very well. If there is any PPSP specific requirement for stream optimization, we can propose it to ALTO WG to solve.

Br
Lin

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of ext zhangyunfei
Sent: Wednesday, April 07, 2010 10:04 AM
To: Volker Hilt; Djamel Sadok
Cc: [email-masked]
Subject: Re: [ppsp] ISP-friendly P2P streaming

BR
Yunfei
 
________________________________

zhangyunfei
2010-04-07
________________________________

发件人： Volker Hilt

Thanks,
 
Volker

---

From: "DJamel H. Sadok" <[email-masked]>
Date: Wed, 7 Apr 2010 07:05:37 -0300 (BRT)

As far as peer selection is done, then I agree that it is within ALTOŽs 
scope. But what about other optimizations, did anyone think of putting 
information into the stream that could help its caching, or even prohibit 
its caching, etc.,, increase its caching probability for example, by 
informing its popularity level? may be even at the chunk level, etc...

In other words, we could see a P2P stream as not only a passive data 
stream but one that carries important and relevant information on how the 
P2P system may best handle it.

Djamel

On Wed, 7 Apr 2010, Xiao, Lin (NSN - CN/Beijing) wrote:

> ·¢ŒþÈË£º Volker Hilt
> ·¢ËÍÊ±Œä£º 2010-04-06 21:13:17
> ÊÕŒþÈË£º Djamel Sadok
> ³ËÍ£º [email-masked]
> Ö÷Ìâ£º Re: [ppsp] ISP-friendly P2P streaming
>

---

From: Reza Rejaie <[email-masked]>
Date: Wed, 7 Apr 2010 03:39:29 -0700 (PDT)

Thanks for the emails and suggestions. I am addressing a group of emails 
here.

- ISP-friendliness for *live* video can not be addressed by caching
due to the live nature of content.

- achieving isp-friendliness for live content is much more challenging than
for elastic content.

- There are different ways to achieve ISP-friendliness, either by
changing overlay connectivity or by changing packet scheduling.
Different approaches have different limitations on how much
reduction in traffic they can achieve.

Simple ideas (such as requiring each peer to establosh x% of connection
with other peers within the same ISP) would not be effective especially
for large ISPs where

One key point is that simply making the overlay localized within
each ISP does NOT work. If the overlay is too localized, existing 
scheduling schemes can not provide good quality. However, if overlay is 
not adequately localized, external traffic can not be effectively limited.

So ISP-friendliness can not be achieved (at least effectively) by good 
neighbor selection mechanism. Changes in packet scheduling is needed, and
those changes require coordination/siganling among peers and ISPs which
is something that can be of interest in this WG.

I can provide more details on these issues if there is interest.

reza

On Wed, 7 Apr 2010, Xiao, Lin (NSN - CN/Beijing) wrote:

> IMO, ALTO is the best way to do any optimized peer selection. It has defined
> a method for P2P tracker to communicate with ALTO server as an ALTO client.
> The logical functionalities of PPSP and ALTO should be separated
> clearly,while they can work together very well. If there is any PPSP
> specific requirement for stream optimization, we can propose it to ALTO WG
> to solve.
>  
>  
> Br
> Lin
> 
> ____________________________________________________________________________
> I agree with Volker's opinion on this.There may be some optional fields in
> PPSP messages to fetch ISP or other geographical/regional inforamation for
> localizaiton.But the optimization operation can be envisioned to be done by
> ALTO.
> In this case there may exist some extension requirements for ALTO to deal
> with more kinds of messages to realize traffic optimization.
>  
> BR
> Yunfei
>  
> 
> ____________________________________________________________________________
> zhangyunfei
> 2010-04-07
> 
> ____________________________________________________________________________
> 发件人： Volker Hilt

---

From: [email-masked]
Date: Thu, 8 Apr 2010 08:52:58 +0800

Hi Djamel
What do you mean by "putting information into the stream"?
I think the information should be carried by the PPSP signaling protocol.

BR
Lichun

"DJamel H. Sadok" <[email-masked]> 
发件人:  [email-masked]
2010-04-07 18:05

收件人
"Xiao, Lin (NSN - CN/Beijing)" <[email-masked]>
抄送
[email-masked]
主题
Re: [ppsp] ISP-friendly P2P streaming

Djamel

On Wed, 7 Apr 2010, Xiao, Lin (NSN - CN/Beijing) wrote:

> IMO, ALTO is the best way to do any optimized peer selection. It has 
defined a method for P2P tracker to communicate with ALTO server as an 
ALTO client. The logical functionalities of PPSP and ALTO should be 
separated clearly,while they can work together very well. If there is any 
PPSP specific requirement for stream optimization, we can propose it to 
ALTO WG to solve.
> I agree with Volker's opinion on this.There may be some optional fields 
in PPSP messages to fetch ISP or other geographical/regional inforamation 
for localizaiton.But the optimization operation can be envisioned to be 
done by ALTO.
> In this case there may exist some extension requirements for ALTO to 
deal with more kinds of messages to realize traffic optimization.
ppsp mailing list
[email-masked]

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: [email-masked]
Date: Thu, 8 Apr 2010 09:00:47 +0800

Interesting.
Do you have any reference about these issues?

BR
Lichun

Reza Rejaie <[email-masked]> 
发件人:  [email-masked]
2010-04-07 18:39

收件人

- achieving isp-friendliness for live content is much more challenging 
than
for elastic content.

reza

> IMO, ALTO is the best way to do any optimized peer selection. It has 
defined
> From: [email-masked] [mailto:[email-masked]] On Behalf Of 
ext
> I agree with Volker's opinion on this.There may be some optional fields 
in
> In this case there may exist some extension requirements for ALTO to 
deal
> >  I  think  that  whether  the  ISP-friendliness  issue  should  become 
 or
>  not  part  of
> >  the  P2P  streaming  protocol  depends  mainly  on  the  way  was 
 such
>  optimization  is
> >  achieved.
> >  
> >  IF  one  can  structure  "intelligently"  the  streaming  to 
 facilitate
>  its
> > >  with  the  work  performed  in  other  IETF  WGs,  e.g.  P2PSIP, 
 ALTO
>  and  
> > >  DECADE.  Since  P2P  streaming  optimization  (or  say  ISP 
 friendly)
>  is  
> > >  to  be  considered  in  P2P  application,  I  don't  think  it 
 will
>  be  in  the  
 
> > > >  I  was  wondering  whether  there  has  been  any  discussion 
 (or
>  any  
 
ppsp mailing list
[email-masked]

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 8 Apr 2010 09:40:55 +0800

Reza and Djamel's proposals sound interesting.The information assisting in chunk cache and selection(e.g.,scheduling)to achieve ISP-friendly P2P streaming seems interesting for PPSP although the scheduling opertion is out of scope.
I'd like to hear more details on the fields of such informations.

BR
Yunfei

zhangyunfei
2010-04-08

发件人： Reza Rejaie
发送时间： 2010-04-07 18:57:17
收件人： Xiao, Lin (NSN - CN/Beijing)
抄送： ext zhangyunfei; Volker Hilt; Djamel Sadok; [email-masked]
主题： Re: [ppsp] ISP-friendly P2P streaming

reza

---

From: "Y.J. Gu" <[email-masked]>
Date: Thu, 08 Apr 2010 11:45:31 +0800

Agree, the scheduling operation is not in scope,  the optional
ISP-friendliness fields in the PPSP Protocol is in the scope if the
mechanism can help ISP-friendliness.
I'm interested too, as I've said.
FYI, PPlive has a mechanism of chunk scheduling from P2P application
performance perspective. 
1) Consecutive chunk first, i.e. download the nearest chunk to what is
playing.
2) Rarest first, downloading the rarest chunk in the system, which may need
a statistic information from a Tracker.
3) anchor first, to guarantee quick channel swich. An anchor chunk can be
learn from description file.
 
When you mention packet scheduling, do you mean the mechanism like the above
ones? 

Regards

Yingjie Gu

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
zhangyunfei
Sent: Thursday, April 08, 2010 9:41 AM
To: Reza Rejaie; Xiao, Lin (NSN - CN/Beijing)
Cc: [email-masked]
Subject: Re: [ppsp] ISP-friendly P2P streaming

Reza and Djamel's proposals sound interesting.The information assisting in
chunk cache and selection(e.g.,scheduling)to achieve ISP-friendly P2P
streaming seems interesting for PPSP although the scheduling opertion is out
of scope.
I'd like to hear more details on the fields of such informations.
 
BR
Yunfei

  _____  

zhangyunfei
2010-04-08

  _____  

发件人： Reza Rejaie

Thanks  for  the  emails  and  suggestions.  I  am  addressing  a  group  of
emails  
here.
 
-  ISP-friendliness  for  *live*  video  can  not  be  addressed  by
caching
due  to  the  live  nature  of  content.
 
-  achieving  isp-friendliness  for  live  content  is  much  more
challenging  than
for  elastic  content.

Simple  ideas  (such  as  requiring  each  peer  to  establosh  x%  of
connection
with  other  peers  within  the  same  ISP)  would  not  be  effective
especially
for  large  ISPs  where

scheduling  schemes  can  not  provide  good  quality.  However,  if
overlay  is  
not  adequately  localized,  external  traffic  can  not  be  effectively
limited.
 
So  ISP-friendliness  can  not  be  achieved  (at  least  effectively)  by
good  
neighbor  selection  mechanism.  Changes  in  packet  scheduling  is
needed,  and
those  changes  require  coordination/siganling  among  peers  and  ISPs
which
is  something  that  can  be  of  interest  in  this  WG.

reza

>  From:  [email-masked]  [mailto:[email-masked]]  On  Behalf
Of  ext
>   >   I   think   that   whether   the   ISP-friendliness   issue   should
become   or
>   not   part   of
>   >   the   P2P   streaming   protocol   depends   mainly   on   the   way
was   such
facilitate
>   its
>   >   optimization   then   there   is   a   clear   need   to   consider
such
>   optimization   as   part
>   >   >   I'm   really   interested   in   the   issues   and   would   be
glad   to
>   learn   the   details.
>   >   >   streaming   optimization,   though   in   different   ways.
PPSP   will
>   interact   
>   >   >   with   the   work   performed   in   other   IETF   WGs,   e.g.
P2PSIP,   ALTO
>   and   
>   >   >   DECADE.   Since   P2P   streaming   optimization   (or   say
ISP   friendly)
>   is   
>   >   >   not   a   special   problem   for   P2P   streaming,   instead
it's   a
>   common   issue   
>   >   >   to   be   considered   in   P2P   application,   I   don't
think   it   will
>   >   >   >   I   was   wondering   whether   there   has   been   any
discussion   (or
>   >   GPRT   -   Grupo   de   Pesquisa   em   Redes   de   Computadores
e
>   Telecomunicacoes

---

From: "Xiao, Lin (NSN - CN/Beijing)" <[email-masked]>
Date: Thu, 8 Apr 2010 13:56:34 +0800

I'm not sure how the coordination/signaling among peers and ISPs is realized. It decides if this work can be implemented in PPSP tracker protocol or in PPSP peer protocol. So I'm very interested in learning more details about your solution. I guess it may be out of the current PPSP scope, but if we find PPSP is the most suitable place for the work than others (e.g., ALTO), we can consider to accept it when WG recharter.

Br
Lin

-----Original Message-----
From: ext Reza Rejaie [mailto:[email-masked]] 
Sent: Wednesday, April 07, 2010 6:39 PM
To: Xiao, Lin (NSN - CN/Beijing)
Cc: ext zhangyunfei; Volker Hilt; Djamel Sadok; [email-masked]
Subject: Re: [ppsp] ISP-friendly P2P streaming

Thanks for the emails and suggestions. I am addressing a group of emails here.

- ISP-friendliness for *live* video can not be addressed by caching due to the live nature of content.

- achieving isp-friendliness for live content is much more challenging than for elastic content.

- There are different ways to achieve ISP-friendliness, either by changing overlay connectivity or by changing packet scheduling.
Different approaches have different limitations on how much reduction in traffic they can achieve.

Simple ideas (such as requiring each peer to establosh x% of connection with other peers within the same ISP) would not be effective especially for large ISPs where

One key point is that simply making the overlay localized within each ISP does NOT work. If the overlay is too localized, existing scheduling schemes can not provide good quality. However, if overlay is not adequately localized, external traffic can not be effectively limited.

So ISP-friendliness can not be achieved (at least effectively) by good neighbor selection mechanism. Changes in packet scheduling is needed, and those changes require coordination/siganling among peers and ISPs which is something that can be of interest in this WG.

reza

On Wed, 7 Apr 2010, Xiao, Lin (NSN - CN/Beijing) wrote:

> defined a method for P2P tracker to communicate with ALTO server as an ALTO client.
> specific requirement for stream optimization, we can propose it to 
> ALTO WG to solve.
>  
>  
> Br
> Lin
> 
> Of ext zhangyunfei
> I agree with Volker's opinion on this.There may be some optional 
> fields in PPSP messages to fetch ISP or other geographical/regional 
> inforamation for localizaiton.But the optimization operation can be 
> envisioned to be done by ALTO.
> There  is  obviously  a  tie  into  ALTO  as  well  for  the  exchange  
> of localization  information.
>  
> Thanks,
>  
> Volker
>  
>  
>  
> Djamel  Sadok  wrote:
> > >  I'm  really  interested  in  the  issues  and  would  be  glad  
> > > to
>  learn  the  details.
> > >  streaming  optimization,  though  in  different  ways.  PPSP  
> > > will
>  interact

---

From: Reza Rejaie <[email-masked]>
Date: Thu, 8 Apr 2010 02:33:27 -0700 (PDT)

On Thu, 8 Apr 2010, Y.J. Gu wrote:

> Agree, the scheduling operation is not in scope,  the optional ISP-friendliness fields in the
> PPSP Protocol is in the scope if the mechanism can help ISP-friendliness.
> FYI, PPlive has a mechanism of chunk scheduling from P2P application performance perspective. 
> 1) Consecutive chunk first, i.e. download the nearest chunk to what is playing.
> 2) Rarest first, downloading the rarest chunk in the system, which may need a statistic
> information from a Tracker.
> 3) anchor first, to guarantee quick channel swich. An anchor chunk can be learn from description
> file.
>  
> When you mention packet scheduling, do you mean the mechanism like the above ones?
>  
yes, by scheduling I am reffering to the decision of which 
block/segment/packet to pll from each parent/neighbor

As for references, we have papers that are currently under submission, so it 
may not be appropriate to share them with the entire group at this point.

One of my collaborators or I should be able to present the problem, 
proposde solutions and its relevance to ietf at the next ieft meeting in 
July.

thanks,
reza
>  
>  
> 
> Regards
> 
> Yingjie Gu
> 
>  
> 
> _________________________________________________________________________________________________
> From: [email-masked] [mailto:[email-masked]] On Behalf Of zhangyunfei
> Reza and Djamel's proposals sound interesting.The information assisting in chunk cache and
> selection(e.g.,scheduling)to achieve ISP-friendly P2P streaming seems interesting for PPSP
> although the scheduling opertion is out of scope.
> _________________________________________________________________________________________________
> zhangyunfei
> 2010-04-08
> 
> _________________________________________________________________________________________________
> 发件人： Reza Rejaie
> >   >   I   think   that   whether   the   ISP-friendliness   issue   should   become   or
> >   not   part   of
> >   >   the   P2P   streaming   protocol   depends   mainly   on   the   way   was   such
> >   optimization   is
> >   >   achieved.
> >   >   
> >   >   IF   one   can   structure   "intelligently"   the   streaming   to   facilitate
> >   its
> >   >   optimization   then   there   is   a   clear   need   to   consider   such
> >   optimization   as   part
> >   >   of   this   work.
> >   >   
> >   >   Djamel
> >   >   
> >   >   
> >   >   On   Tue,   06   Apr   2010   18:55:26   +0800,   Y.J.   Gu   wrote
> >   >   >   Hi   Reza,
> >   >   >   I'm   really   interested   in   the   issues   and   would   be   glad   to
> >   learn   the   details.
> >   >   >   Except   for   P2P   caching,   ALTO   and   DECADE   may   also   help   in
>   P2P
> >   
> >   >   >   streaming   optimization,   though   in   different   ways.   PPSP   will
> >   interact   
> >   >   >   with   the   work   performed   in   other   IETF   WGs,   e.g.   P2PSIP,
>   ALTO
> >   and   
> >   >   >   DECADE.   Since   P2P   streaming   optimization   (or   say   ISP   friendly)
> >   is   
> >   >   >   not   a   special   problem   for   P2P   streaming,   instead   it's   a
> >   common   issue   
> >   >   >   to   be   considered   in   P2P   application,   I   don't   think   it   will
> >   be   in   the   
> >   >   >   scope   of   PPSP.
> >   >   >
> >   >   >   Regards
> >   >   >
> >   >   >   Yingjie   Gu
> >   >   >
> >   >   >   >   -----Original   Message-----
> >   >   >   >   From:   [email-masked]   [mailto:[email-masked]]   On   
> >   >   >   >   Behalf   Of   Reza   Rejaie
> >   >   >   >   Sent:   Tuesday,   April   06,   2010   4:17   PM
> >   >   >   >   To:   [email-masked]
> >   >   >   >   Subject:   [ppsp]   ISP-friendly   P2P   streaming
> >   >   >   >
> >   >   >   >
> >   >   >   >   Hi,
> >   >   >   >
> >   >   >   >   I   was   wondering   whether   there   has   been   any   discussion   (or
> >   any   
> >   >   >   >   interest)   in   this   working   group   on   issues   related   to
>   making
> >   
> >   >   >   >   P2P   streaming   application   (especially   live   streaming)   ISP   
> >   >   >   >   friendly?   Here   by   "ISP-friendly   P2P   streaming"   I   am
>   referring
> >   
> >   >   >   >   to   those   mechanisms   that   try   minimize   the   external   traffic
>   
> >   >   >   >   for   individual   ISPs
> >   >   >   >
> >   >   >   >   We   have   developed   a   couple   of   mesh-based   ISP-friendly   P2P
>   
> >   >   >   >   streaming   mechanisms   and   would   be   happy   to   provide   more   
> >   >   >   >   details   if   there   is   inetrest.
> >   >   >   >
> >   >   >   >   reza
> >   >   >   >   _______________________________________________
> >   >   >   >   ppsp   mailing   list
> >   >   >   >   [email-masked]
> >   >   >   >   https://www.ietf.org/mailman/listinfo/ppsp
> >   >   >   _______________________________________________
> >   >   >   ppsp   mailing   list
> >   >   >   [email-masked]
> >   >   >   https://www.ietf.org/mailman/listinfo/ppsp
> >   >   
> >   >   
> >   >   --
> >   >   GPRT   -   Grupo   de   Pesquisa   em   Redes   de   Computadores   e
> >   Telecomunicacoes
> >   >   
> >   >   _______________________________________________
> >   >   ppsp   mailing   list
> >   >   [email-masked]
> >   >   https://www.ietf.org/mailman/listinfo/ppsp
> >

---

From: "Djamel Sadok" <[email-masked]>
Date: Thu, 8 Apr 2010 09:12:50 -0200

yes the signaling could include more info that may affect intelligently the processingof associated chunks, caching in the case of VoD, per chunk or per whatever unit, third party advertising, etc..We could think of an intermediary AS or infra provider that may want to include its own advertising material and in return is willing to give more QoS to such streams. This could help improve the current P2P-operator conflicts.DjamelOn Thu, 8 Apr 2010 08:52:58 +0800, li.lichun1 wrote
> Hi Djamel
> What do you mean by "putting informationinto the stream"?
> I think the information should be carriedby the PPSP signaling protocol.
> 
> BR
> Lichun
> 
> 
>

 "DJamel H. Sadok"<[email-masked]> 
> å‘ä»¶äºº: [email-masked]
> 2010-04-07 18:05

> æ”¶ä»¶äºº "Xiao, Lin (NSN - CN/Beijing)"<[email-masked]>

> æŠ„é€ [email-masked]

> ä¸»é¢˜ Re: [ppsp] ISP-friendly P2P streaming

> 
> 
> 
> As far as peer selection is done, then I agree that it is within [UTF-8?]ALTOÅ½s
> > IMO, ALTO is the best way to do any optimized peer selection. It hasdefined a method for P2P tracker to communicate with ALTO server as anALTO client. The logical functionalities of PPSP and ALTO should be separatedclearly,while they can work together very well. If there is any PPSP specificrequirement for stream optimization, we can propose it to ALTO WG to solve.
> >
> >
> > Br
> > Lin
> >
> > From: [email-masked] [mailto:[email-masked]] On BehalfOf ext zhangyunfei
> > I agree with Volker's opinion on this.There may be some optional fieldsin PPSP messages to fetch ISP or other geographical/regional inforamationfor localizaiton.But the optimization operation can be envisioned to bedone by ALTO.
> > In this case there may exist some extension requirements for ALTOto deal with more kinds of messages to realize traffic optimization.
> >
> > BR
> > Yunfei
> >
> > [UTF-8?]Â·Â¢Å’Ã¾ÃˆÃ‹Â£Âº Volker Hilt
> > [UTF-8?]Â·Â¢Ã‹ÃÃŠÂ±Å’Ã¤Â£Âº 2010-04-06 21:13:17
> > [UTF-8?]ÃŠÃ•Å’Ã¾ÃˆÃ‹Â£Âº Djamel Sadok
> > ³ËÍ£º [email-masked]
> > Yes, I believe that to the extendit impacts the structure/protocol of
> > the streaming application localization shouldbe considered in PPSP.
> > There is obviously a tie into ALTOas well for the exchange of
> >> I think that whether the ISP-friendlinessissue should become or not part of
> >> the P2P streaming protocol dependsmainly on the way was such optimizationis
> >> achieved.
> >>
> >> IF one can structure "intelligently"the streaming to facilitate its
> >> optimization then there is a clearneed to consider such optimization aspart
> >> of this work.
> >>
> >> Djamel
> >>
> >>
> >> On Tue, 06 Apr 2010 18:55:26+0800, Y.J. Gu wrote
> >>> Hi Reza,
> >>> I'm really interested in theissues and would be glad to learnthe details.
> >>> Except for P2P caching, ALTOand DECADE may also help in P2P
> >>> streaming optimization, though indifferent ways. PPSP will interact
> >>> with the work performed in otherIETF WGs, e.g. P2PSIP, ALTO and
> >>> DECADE. Since P2P streaming optimization(or say ISP friendly) is
> >>> not a special problem for P2Pstreaming, instead it's a common issue
> >>> to be considered in P2P application,I don't think it will be in the
> >>> scope of PPSP.
> >>>
> >>> Regards
> >>>
> >>> Yingjie Gu
> >>>
> >>>> From: [email-masked] [mailto:[email-masked]]On
> >>>> Behalf Of Reza Rejaie
> >>>> Sent: Tuesday, April 06, 20104:17 PM
> >>>> To: [email-masked]
> >>>> Subject: [ppsp] ISP-friendly P2Pstreaming
> >>>>
> >>>>
> >>>> Hi,
> >>>>
> >>>> I was wondering whether therehas been any discussion (or any
> >>>> interest) in this working groupon issues related to making
> >>>> P2P streaming application (especiallylive streaming) ISP
> >>>> friendly? Here by "ISP-friendlyP2P streaming" I am referring
> >>>> to those mechanisms that tryminimize the external traffic
> >>>> for individual ISPs
> >>>>
> >>>> We have developed a coupleof mesh-based ISP-friendly P2P
> >>>> streaming mechanisms and wouldbe happy to provide more
> >> GPRT - Grupo de Pesquisa emRedes de Computadores e Telecomunicacoes
> >>
--------------------------------------------------------
ZTE Information Security Notice: The information 
contained in this mail is solely property of 
the sender's organization. This mail communication 
is confidential. Recipients named above are 
obligated to maintain secrecy and are not 
permitted to disclose the contents of this 
communication to 
others.
This email and any files transmitted with it 
are confidential and intended solely for the 
use of the individual or entity to whom 
they are addressed. If you have received this 
email in error please notify the originator 
of the message. Any views expressed in this 
message are those of the individual 
sender.
This message has been scanned for viruses and 
Spam by ZTE Anti-Spam 
system.

---

From: "Y.J. Gu" <[email-masked]>
Date: Fri, 09 Apr 2010 08:52:54 +0800

Great. I believe this will be an very interesting topic. And I hope to see the draft soon.

Regards

Yingjie Gu

> From: Reza Rejaie [mailto:[email-masked]] 
> Sent: Thursday, April 08, 2010 5:33 PM
> To: Y.J. Gu
> Cc: 'zhangyunfei'; 'Xiao, Lin (NSN - CN/Beijing)'; [email-masked]
> Subject: RE: [ppsp] ISP-friendly P2P streaming
> 
> 
> 
> > ISP-friendliness fields in the PPSP Protocol is in the 
> scope if the mechanism can help ISP-friendliness.
> > 2) Rarest first, downloading the rarest chunk in the 
> system, which may 
> > need a statistic information from a Tracker.
> > 3) anchor first, to guarantee quick channel swich. An 
> anchor chunk can 
> > be learn from description file.
> >  
> As for references, we have papers that are currently under 
> submission, so it may not be appropriate to share them with 
> the entire group at this point.
> 
> One of my collaborators or I should be able to present the 
> problem, proposde solutions and its relevance to ietf at the 
> next ieft meeting in July.
> 
> thanks,
> reza
> >  
> >  
> > 
> > Regards
> > 
> > Yingjie Gu
> > 
> >  
> > 
> > 
> > Of zhangyunfei
> > Reza and Djamel's proposals sound interesting.The information 
> > assisting in chunk cache and selection(e.g.,scheduling)to achieve 
> > ISP-friendly P2P streaming seems interesting for PPSP 
> > caching due  to  the  live  nature  of  content.
> >  
> > challenging  than for  elastic  content.
> >  
> > -  There  are  different  ways  to  achieve  
> ISP-friendliness,  either  
> > by changing  overlay  connectivity  or  by  changing  
packet  scheduling.
> > connection with  other  peers  within  the  same  ISP)  
> would  not  be  
> > effective  especially for  large  ISPs  where
> >  
> > One  key  point  is  that  simply  making  the  overlay  localized  
> > within each  ISP  does  NOT  work.  If  the  overlay  is  too  
> > localized,  existing scheduling  schemes  can  not  provide  good  
> > quality.  However,  if  overlay  is not  adequately  
localized,  external  traffic  can  not  be  effectively >  limited.
> >  
> > So  ISP-friendliness  can  not  be  achieved  (at  least  
> effectively)  
> > by  good neighbor  selection  mechanism.  Changes  in  packet  
> > scheduling  is  needed,  and those  changes  require  
> > coordination/siganling  among  peers  and  ISPs  which is  
> something  that  can  be  of  interest  in  this  WG.
> >  
> > >  clearly,while they can  work  together  very  well. If  
> there  is  
> > > any  PPSP
> > >  specific  requirement  for  stream  optimization,  we  
> can  propose  
> > > it  to  ALTO  WG
> > >  to  solve.
> > >   
> > >   
> > >  Br
> > >  Lin
> > >  
> > >  
> > > 
> > > Behalf  Of  ext
> > >  I  agree  with  Volker's  opinion  on  this.There  may  
> be  some  
> > > optional  fields  in
> > >  PPSP  messages  to  fetch  ISP  or  other  
geographical/regional  
> > > inforamation  for
> > >  localizaiton.But  the  optimization  operation  can  be  
> envisioned  
> > > to  be  done  by
> > >  ALTO.
> > >  Yes,   I   believe   that   to   the   extend   it   
impacts   the
> > >   structure/protocol   of
> > >  There   is   obviously   a   tie   into   ALTO   as   
well   for   
> > > the   exchange   of
> > >   >   I   think   that   whether   the   ISP-friendliness 
>   issue   
> > > should   become   or
> > >   not   part   of
> > >   >   the   P2P   streaming   protocol   depends   mainly 
>   on   the   
> > > way   was   such
> > >   optimization   is
> > >   >   achieved.
> > >   >
> > >   >   IF   one   can   structure   "intelligently"   the  
 streaming   
> > > to   facilitate
> > >   its
> > >   >   optimization   then   there   is   a   clear   need   to   
> > > consider   such
> > >   optimization   as   part
> > >   >   of   this   work.
> > >   >
> > >   >   Djamel
> > >   >
> > >   >
> > >   >   On   Tue,   06   Apr   2010   18:55:26   +0800,   
> Y.J.   Gu   
> > > wrote
> > >   >   >   Hi   Reza,
> > >   >   >   I'm   really   interested   in   the   issues   and   
> > > would   be   glad   to
> > >   learn   the   details.
> > >   >   >   Except   for   P2P   caching,   ALTO   and   
> DECADE   may   
> > > also   help   in
> >   P2P
> > >   
> > >   >   >   streaming   optimization,   though   in   different   
> > > ways.   PPSP   will
> > >   interact
> > >   >   >   with   the   work   performed   in   other   
IETF   WGs,   
> > > e.g.   P2PSIP,
> >   ALTO
> > >   and
> > >   >   >   DECADE.   Since   P2P   streaming   
optimization   (or   
> > > say   ISP   friendly)
> > >   is
> > >   >   >   not   a   special   problem   for   P2P   streaming,   
> > > instead   it's   a
> > >   common   issue
> > >   >   >   >   I   was   wondering   whether   there   has 
>   been   
> > > any   discussion   (or
> > >   any
> > >   >   >   >   interest)   in   this   working   group   
> on   issues   
> > > related   to
> >   making
> > >   
> > >   >   >   >   P2P   streaming   application   (especially 
>   live   
> > > streaming)   ISP
> > >   >   >   >   friendly?   Here   by   "ISP-friendly   P2P   
> > > streaming"   I   am
> >   referring
> > >   
> > >   >   >   >   to   those   mechanisms   that   try   
minimize   the   
> > > external   traffic
> >   
> > >   >   >   >   for   individual   ISPs
> > >   >   >   >
> > >   >   >   >   We   have   developed   a   couple   of   
mesh-based   
> > > ISP-friendly   P2P
> >   
> > >   >   >   >   streaming   mechanisms   and   would   be   
> happy   to   
> > > provide   more
> > >   >   GPRT   -   Grupo   de   Pesquisa   em   Redes   de   
> > > Computadores   e
> > >   Telecomunicacoes
> > >   >