Subject: [ppsp] Tracker vs. No-Tracker

From: Martin Stiemerling <[email-masked]>
Date: Tue, 26 Oct 2010 15:43:40 +0000

Hi all,

A question coming to my mind while reviewing the PS and the requirements WG drafts:

Both drafts make the assumption that a tracker based system is being standardized by the PPSP WG. Is this a valid assumption?

The point why I am asking this:

It does not make any difference from the peer protocol if the system uses a tracker or no tracker. 

So why do we prematurely conclude to rely on trackers? Isn't this orthogonal to the peer protocol?

E.g. from the requirements draft, Section 4.2:
   PPSP.TP.REQ-2: The PPSP peers MUST implement the PPSP tracker
   protocol for sending PPSP tracker queries and periodical peer status
   reports/updates to PPSP tracker and receiving the corresponding
   replies from tracker.

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: "David A. Bryan" <[email-masked]>
Date: Tue, 26 Oct 2010 12:07:47 -0400

A few thoughts...

There is currently a tracker protocol as well as a peer protocol as
charter milestones, and most of the early conversation discussed using
a centralized tracker. Many (most?) of the streaming systems today
have one.

One could of course eliminate that step. We discussed this some in
early conversations and the BoF. All you need to do is store the
chunk->peer mapping in a distributed fashion (likely a DHT). At least
in our peer protocol proposal, we have RELOAD already, so adding that
would be easy, but the bulk of the discussion and bulk of interested
parties wanted a tracker (and there was even a long conversation
between Cullen, Henning, many others I can't recall and myself at the
BoF that seemed to indicate the room felt that, at least at that
point, not only they wanted a tracker, but wanted to treat it as a
single logical entity (not distributed)).

I'd like to see the peer protocol done in such a way that a fully
distributed "tracker" (i.e., no tracker but among the peers) is
possible, BTW.

So I think it is still an open question of if you have to use it, but
the discussion certainly led to standardizing it and that is reflected
in the milestones, hence why I guess it is reflected in the documents.
Doesn't mean that perhaps we don't want to change them to make it more
clear you can do it without one, of course...

David

On Tue, Oct 26, 2010 at 11:43 AM, Martin Stiemerling
<[email-masked]> wrote:
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp
>

---

From: "Kang Heng WU" <[email-masked]>
Date: Wed, 27 Oct 2010 00:37:10 +0800

Hi Martin,
 
My comments are as follows.
 
Kent

________________________________

From: [email-masked] on behalf of Martin Stiemerling
Sent: Tue 10/26/2010 11:43 PM
To: [email-masked]
Subject: [ppsp] Tracker vs. No-Tracker

Hi all,

Kent: I think tracker is neccessary. It makes that the startup delay is small.

Kent: There are different good points between tracker and no-tracker(DHT) technologies. With tracker, the peer can get the information quickly. With DHT, the p2p system can grow in a large scable and be stable. I think that PPSP should support the two kinds. Tracker is in the baseline protocol. The no-tracker(DHT) is in the enhancement protocols. DHT belongs to the peer protocols.

  Martin

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
This message (including any attachments) is for the named
addressee(s)'s use only. It may contain sensitive, confidential,
private proprietary or legally privileged information intended for a
specific individual and purpose, and is protected by law. If you are
not the intended recipient, please immediately delete it and all copies
of it from your system, destroy any hard copies of it
and notify the sender. Any use, disclosure, copying, or distribution of
this message and/or any attachments is strictly prohibited.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: "zhangyunfei" <[email-masked]>
Date: Wed, 27 Oct 2010 11:21:13 +0800

Hi all,
   As discussed in the BOF, to the best of my understanding, the consensus is that the tracker is a logical centric functional entity，even it is realized in the distributed way, like DHT. 
   I mean that in the so called "non-tracker" practice, although there is no specific tracker server with a static IP address, each DHT peer takes part responsibility of the specific tracker server. In other words, in this senario, when a requesting peer A asks for a certain program/a certain viedo file, it issues request to certain DHT peer B who plays as the acting tracker responsible for the requested content. B replies a peerlist having the requested content.This procedure is what the tracker protocol involves and is the fundation of peer protocol which relys on the inforamtion conveyed by tracker protocol.
   So my suggestion is that although tracker protocol is orthogonal to the peer protocol, we need a tracker protocol even there is no specific tracker server.Comments are welcome.

BR
Yunfei

zhangyunfei
2010-10-27

发件人： Kang Heng WU
发送时间： 2010-10-27 00:37:39
收件人： Martin Stiemerling; [email-masked]
抄送： 
主题： Re: [ppsp] Tracker vs. No-Tracker

Hi Martin,

Kent

Hi all,

  Martin

This message (including any attachments) is for the named addressee(s)'s use only. It may contain sensitive, confidential, private proprietary or legally privileged information intended for a specific individual and purpose, and is protected by law. If you are not the intended recipient, please immediately delete it and all copies of it from your system, destroy any hard copies of it and notify the sender. Any use, disclosure, copying, or distribution of this message and/or any attachments is strictly prohi bited.

---

From: Martin Stiemerling <[email-masked]>
Date: Wed, 27 Oct 2010 12:43:02 +0000

Hi Bryan, all,

We are basically along the same lines:
- there is clearly the need to have a tracker protocol and to standardize the protocol
- the peer protocol should work with or without a tracker

However, my point is that the requirement PPSP.TP.REQ-2 is mandating to use the tracker protocol is wrong. This is definitely too strong, as an implementer of PPSP may not want to use the tracker protocol at all, for very good reasons.

It is anyhow questionable if the IETF can mandate how a peer is implemented. This is suggested by the requirements "The PPSP peers MUST implement". AFAIK, the PPSP WG is chartered to develop protocols but not to standardize a system. 

The charter says for the requirements draft:
"A "requirements" document that details the specific functional, operational and performance requirements of the two PPSP protocols"

There is no notion about a peer or system. This must be reflected in the requirements document. Otherwise it is operating outside the charter. 

Thanks and cheers

  Martin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> David A. Bryan
> Sent: Tuesday, October 26, 2010 6:08 PM
> To: Martin Stiemerling
> Cc: [email-masked]
> Subject: Re: [ppsp] Tracker vs. No-Tracker
> 
> A few thoughts...
> 
> > Both drafts make the assumption that a tracker based system is being
> standardized by the PPSP WG. Is this a valid assumption?
> >
> > NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road,
> London W3 6BL | Registered in England 2832014
> >
> >

---

From: Martin Stiemerling <[email-masked]>
Date: Wed, 27 Oct 2010 12:46:04 +0000

Hi Kent,

> Kent: I think tracker is neccessary. It makes that the startup delay is

It is necessary in your system design, but not per se. You can build a tracker-less system but still using the PPSP peer protocol. 

> Kent: There are different good points between tracker and no-
> tracker(DHT) technologies. With tracker, the peer can get the
> information quickly. With DHT, the p2p system can grow in a large
> scable and be stable. I think that PPSP should support the two kinds.

Yes, I also see that PPSP should support boths. This is the intention of my email to point out that mandating the usage of a tracker is not a good idea.

However, standardizing such tracker protocol is indeed a good idea. 

  Martin

---

From: Martin Stiemerling <[email-masked]>
Date: Wed, 27 Oct 2010 12:47:54 +0000

Yunfei,

Just to clarify:

I wasn't arguing that do not need the tracker protocol. 

I argue that we shall not mandate to use the tracker protocol, but let this open to whoever builds such a system .

I'm totally fine having a tracker protocol, but the requirements draft reads too strong IMHO with respect to mandating the usage of the protocol. 

  Martin

> From: zhangyunfei [mailto:[email-masked]]
> Sent: Wednesday, October 27, 2010 5:21 AM
> To: Kang Heng WU; Martin Stiemerling; [email-masked]; dbryan
> Subject: Re: Re: [ppsp] Tracker vs. No-Tracker
> 
> Hi all,
>    As discussed in the BOF, to the best of my understanding, the
> consensus is that the tracker is a logical centric functional
> entity，even it is realized in the distributed way, like DHT.
>    I mean that in the so called "non-tracker" practice, although there
> is no specific tracker server with a static IP address, each DHT peer
> takes part responsibility of the specific tracker server. In other
> words, in this senario, when a requesting peer A asks for a certain
> program/a certain viedo file, it issues request to certain DHT peer B
> who plays as the acting tracker responsible for the requested content.
> B replies a peerlist having the requested content.This procedure is
> what the tracker protocol involves and is the fundation of peer
> protocol which relys on the inforamtion conveyed by tracker protocol.
>    So my suggestion is that although tracker protocol is orthogonal to
> the peer protocol, we need a tracker protocol even there is no specific
> tracker server.Comments are welcome.
> 
> BR
> Yunfei
> 
> Tracker is in the baseline protocol. The no-tracker(DHT) is in the
> enhancement protocols. DHT belongs to the peer protocols.
> 
> 
> of it from your system, destroy any hard copies of it and notify the
> sender. Any use, disclosure, copying, or distribution of this message
> and/or any attachments is strictly prohi bited.

---

From: "Kang Heng WU" <[email-masked]>
Date: Wed, 27 Oct 2010 22:23:55 +0800

Hi Martin,

P2P system can run without a tracker. But this case makes the overall system unstable. 

For example, in a DHT scenario, when a peer starts, it joins a DHT network with its history peer list. But the P2P system is dynamic. If the peers in it history peer list are offline, the new coming peer cannot join the P2P network without tracker supporting. If avoiding this case occurs, we should assume several "always-online" peers in the P2P system. These "always-online" peers act as trackers.

Best,
Kent

-----Original Message-----
From: Martin Stiemerling [mailto:[email-masked]]
Sent: Wed 10/27/2010 8:46 PM
To: Kang Heng WU; [email-masked]
Subject: RE: Tracker vs. No-Tracker
 
Hi Kent,

  Martin

---

From: guyingjie 00107907 <[email-masked]>
Date: Thu, 28 Oct 2010 07:36:50 +0800

Hi Kent, 
Peers don't have to rely on history peerlist to join DHT system. A Bootstrap server can help peers to join the system. When a peer want to join the DHT system, it connects with Bootstrap server and the latter provides the peer with one/a set of active peer. The Bootstrap server is different from Tracker as it doesn't record or response to content request. The function of Bootstrap server can be completed by some always-online superpeer as y
ou mentioned, but they are not act as Tracker.

Best Regards
Y.J. GU

----- 原邮件 -----
发件人: Kang Heng WU <[email-masked]>
日期: 星期三, 十月 27日, 2010 下午10:22
主题: Re: [ppsp] Tracker vs. No-Tracker
收件人: Martin Stiemerling <[email-masked]>, [email-masked]

> For example, in a DHT scenario, when a peer starts, it joins a DHT 
> network with its history peer list. But the P2P system is dynamic. 
> If the peers in it history peer list are offline, the new coming 
> peer cannot join the P2P network without tracker supporting. If 
> avoiding this case occurs, we should assume several "always-
> online" peers in the P2P system. These "always-online" peers act 
> as trackers.
> 
> Best,
> Kent
> 
> > Kent: I think tracker is neccessary. It makes that the startup 
> delay is
> > small.
> 
> It is necessary in your system design, but not per se. You can 
> build a tracker-less system but still using the PPSP peer 
> protocol. 
> 
> > 
> > 
> Yes, I also see that PPSP should support boths. This is the 
> intention of my email to point out that mandating the usage of a 
> tracker is not a good idea.
> 
> NEC Europe Limited | Registered Office: NEC House, 1 Victoria 
> Road, London W3 6BL | Registered in England 2832014
> 
> 
> 
> not the intended recipient, please immediately delete it and all 
> copiesof it from your system, destroy any hard copies of it

---

From: Fabio Hecht <[email-masked]>
Date: Fri, 29 Oct 2010 10:43:12 +0200

I think it's a good idea to have separate peer and tracker protocols,
but any peer could also serve as a tracker, in case a DHT is used. In
addition, any peer should have a decent view of whatever they are
streaming.

As for bootstrapping, one could assume that the user can find the
address of a bootstrap peer in the desired network via a web page,
e-mail, Facebook etc. BitTorrent sort of works like that, in the sense
that HTTP is used to discover content and retrieve bootstrap
information.

Regards

Fabio

-- 
Fabio Hecht

University of Zurich - Department of Informatics (IfI)
Binzmühlestrasse 14 CH-8050 Zürich, Switzerland
Ph.: +41 44 6357129 / 6350892  Fax: +41 44 6356809
VoIP sip:[email-masked]

---

From: "zhangyunfei" <[email-masked]>
Date: Fri, 29 Oct 2010 16:46:08 +0800

+1. In case of DHT tracker system, there is still a tracker protocol used to negothiate between requesting peer and serving tracker peer.

Yunfei

zhangyunfei
2010-10-29

发件人： Fabio Hecht
发送时间： 2010-10-29 16:43:24
收件人： guyingjie 00107907
抄送： [email-masked]; Martin Stiemerling
主题： Re: [ppsp] Tracker vs. No-Tracker

Regards

Fabio

On  Thu,  2010-10-28  at  07:36  +0800,  guyingjie  00107907  wrote:
>  发件人:  Kang  Heng  WU   <[email-masked] >
>  收件人:  Martin  Stiemerling   <[email-masked] >,  [email-masked]
>  
>   >  Hi  Martin,
>   >  

--  
Fabio  Hecht

---

From: "David A. Bryan" <[email-masked]>
Date: Sat, 30 Oct 2010 21:11:27 -0400

For what it is worth, this was the decision we made in P2PSIP on the
bootstrap issue:

There are many, many ways to find the bootstrap peer, as Fabio
mentioned, so we did not specify one in the protocol, but rather left
it out of scope and only specified what you do once you have that
bootstrap peer. Personally, I'd want to do the same here. A
non-managed global streaming service (perhaps something more like the
way BT works today, with no provider) might use a web page or facebook
link. An ISP managed streaming service might do it via DHCP at boot
time. We want to enable both...

David