Subject: [ppsp] New Draft Notification for draft-chen-ppsp-sip-based-tracker-protocol-01

From: "chenweiyj" <[email-masked]>
Date: Tue, 26 Oct 2010 23:24:05 +0800

Dear all:
      There are two options to encode a PPSP Tracker Protocol: a binary encoding or text-based encoding like XML bodies conveyed
  in HTTP.  Both have pros and cons.  Text-based encoding protocol is easier for people to understand, but requires more space and bandwidth.  
Binary protocols are lighter in both bandwidth and processing, though are sometimes considered more difficult to understand.
      Which encoding approach is better is a pending problem.  Except the above analysis, which factors should be considered to decide that 
  problem?
      
     Besides, I propose a sip-based tracker protocol introduced in the new draft "draft-chen-ppsp-sip-based-tracker-protocol-01". Please
read the draft and give us your comments, thanks a lot.

Title           : SIP-based Tracker Protocol
	Author(s)       : W. Chen, et al.
	Filename        : draft-chen-ppsp-sip-based-tracker-protocol-01.txt
	Pages           : 15
	Date            : 2010-10-25

This draft introduces a kind of text-based encoding Tracker Protocol,
the SIP-based PPSP Tracker Protocol, which utilizes SIP message to
realize the functions of PPSP Tracker Protocol[1] and carries the
specific xml information mentioned in tracker protocol[1] messages in
SIP body.

A URL for this Internet-Draft is:
http://tools.ietf.org/html/draft-chen-ppsp-sip-based-tracker-protocol-01 
or
http://www.ietf.org/internet-drafts/draft-chen-ppsp-sip-based-tracker-protocol-01.txt

Regards！
Wei Chen

Research Institute of China Mobile
Email：[email-masked]
         [email-masked]
Mobile:+86-139-1166-1894
2010-10-26

---

From: "Kang Heng WU" <[email-masked]>
Date: Wed, 27 Oct 2010 00:49:24 +0800

Hi Wei Chen,
 
Because tracker is busy, I think that the binary format is good. 
 
For the performance issues, most of the trackers are implemented in UDP. The UDP spoofing should be considered. We discuss this problem in our draft, Survey of P2P File Downloading and Streaming Protocol. Its url is http://www.ietf.org/mail-archive/web/ppsp/current/msg00735.html .
 
PS
"For the performance issues, most of the trackers are implemented in UDP. The UDP spoofing should be considered. It is possible to spoof the source address of a UDP packet which is sent by different peers. For avoiding that this case occurs, the tracker calculates a connection ID and send it to the peer when the peer send "connect request". For example, if peeri spoofs peerj's address, but it does not know the connection id except that peeri sniffs the network. In the following connections, the tracker verifies the connection ID and ignores the request if the connection ID is not match. The connection ID can be generated in random."
 
Kent

________________________________

From: [email-masked] on behalf of chenweiyj
Sent: Tue 10/26/2010 11:24 PM
To: ppsp
Subject: [ppsp] New Draft Notification fordraft-chen-ppsp-sip-based-tracker-protocol-01

Dear all:

 

 

Regards!
Wei Chen
________________________________

Research Institute of China Mobile 
Email:[email-masked]
         [email-masked]
Mobile:+86-139-1166-1894
2010-10-26

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
This message (including any attachments) is for the named
addressee(s)'s use only. It may contain sensitive, confidential,
private proprietary or legally privileged information intended for a
specific individual and purpose, and is protected by law. If you are
not the intended recipient, please immediately delete it and all copies
of it from your system, destroy any hard copies of it
and notify the sender. Any use, disclosure, copying, or distribution of
this message and/or any attachments is strictly prohibited.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: Gyorgy Dan <[email-masked]>
Date: Tue, 26 Oct 2010 19:46:27 +0200

Dear Wei Chen and Kent,

A little input to binary vs. textual from Chapter 5.1 in
E.S. Raymond, "The art of UNIX programming", 2003.

"When you feel the urge to design a complex binary file format, or a
complex binary application protocol, it is generally wise to lie down
until the feeling passes. If performance is what you're worried about,
implementing compression on the text protocol stream either at some
level below or above the application protocol will give you a cleaner
and perhaps better-performing design than a binary protocol (text
compresses well, and quickly)."

This is not to say that binary protocols are evil, but a careful
consideration of the pros/cons/alternatives is necessary.

Best,
 György

On 2010.10.26. 18:49, Kang Heng WU wrote:
> For the performance issues, most of the trackers are implemented in UDP.
> The UDP spoofing should be considered. We discuss this problem in our
> draft, Survey of P2P File Downloading and Streaming Protocol. Its url is
> http://www.ietf.org/mail-archive/web/ppsp/current/msg00735.html .
>  
> PS
> "For the performance issues, most of the trackers are implemented in
> UDP. The UDP spoofing should be considered. It is possible to spoof the
> source address of a UDP packet which is sent by different peers. For
> avoiding that this case occurs, the tracker calculates a connection ID
> and send it to the peer when the peer send “connect request”. For
> example, if peeri spoofs peerj’s address, but it does not know the
> connection id except that peeri sniffs the network. In the following
> connections, the tracker verifies the connection ID and ignores the
> request if the connection ID is not match. The connection ID can be
> generated in random."
>  
> Kent
> ------------------------------------------------------------------------
> *From:* [email-masked] on behalf of chenweiyj
> *Sent:* Tue 10/26/2010 11:24 PM
> *To:* ppsp
> *Subject:* [ppsp] New Draft Notification
> fordraft-chen-ppsp-sip-based-tracker-protocol-01
> 
> Dear all:
>       There are two options to encode a PPSP Tracker Protocol: a binary
> encoding or text-based encoding like XML bodies conveyed
>   in HTTP.  Both have pros and cons.  Text-based encoding protocol
> is easier for people to understand, but requires more space and bandwidth.  
>       Which encoding approach is better is a pending problem.  Except
> the above analysis, which factors should be considered to decide that
>   problem?
>      
>      Besides, I propose a sip-based tracker protocol introduced in the
> new draft "draft-chen-ppsp-sip-based-tracker-protocol-01". Please
> ------------------------------------------------------------------------
> Email：[email-masked] <mailto:[email-masked]>
>          [email-masked] <mailto:[email-masked]>
> Mobile:+86-139-1166-1894
> 2010-10-26
>  
>  
>  
> 
> 
> ------------------------------------------------------------------------
> This message (including any attachments) is for the named addressee(s)'s
> use only. It may contain sensitive, confidential, private proprietary or
> legally privileged information intended for a specific individual and
> purpose, and is protected by law. If you are not the intended recipient,
> please immediately delete it and all copies of it from your system,
> destroy any hard copies of it and notify the sender. Any use,
> disclosure, copying, or distribution of this message and/or any
> attachments is strictly prohibited.
> ------------------------------------------------------------------------
> 
> 
> 
> 
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp

-- 
György Dán
School of Electrical Engineering
KTH Royal Institute of Technology
Stockholm, Sweden
http://www.ee.kth.se/~gyuri

---

From: Riccardo Bernardini <[email-masked]>
Date: Tue, 26 Oct 2010 20:20:48 +0200

> consideration of the pros/cons/alternatives is necessary.

I agree with that.  However, maybe in this case one should also  
consider the "performance" in terms of "effort needed for parsing."   
Parsing a binary format *could* (note the emphasis) be easier than a  
complex, maybe XML-based, text format.   I would say that it strongly  
depends on the applicative context if the computational effort  
necessary to process the text-based format is negligible, sensible or  
unbearable.

By the way, I am not saying that text protocols are evil...

>> Binary protocols are lighter in both bandwidth and processing,  
>> though are sometimes
>> considered more difficult to understand.

-- 
Riccardo Bernardini
DIEGM -- University of Udine
via delle Scienze 208
33100 Udine
Tel: +39-0432-55-8271
Fax: +39-0432-55-8251

----------------------------------------------------------------------
SEMEL (SErvizio di Messaging ELettronico) - CSIT -Universita' di Udine

---

From: guyingjie 00107907 <[email-masked]>
Date: Wed, 27 Oct 2010 08:53:19 +0800

Hi, As we all be aware of, both binary and text protocol has pros and cons. So it may be difficult to convince supporters of one protocol to give up their opinion just by theoretical analysis. 
In draft-gu-ppsp-tracker-protocol-02, we show the common messages encoding for both text and binary Tracker protocol. It seems that text encoding doesn't introduce so much overload as we thought.
BitTorrent also uses text based protocol. 

Best Regards
Y.J. GU

----- 原邮件 -----
发件人: Riccardo Bernardini <[email-masked]>
日期: 星期三, 十月 27日, 2010 上午2:21
主题: Re: [ppsp] New	Draft	Notification fordraft-chen-ppsp-sip-based-tracker-protocol-01
收件人: [email-masked]

> > complex binary application protocol, it is generally wise to lie 
> down> until the feeling passes. If performance is what you're 
> worried about,
> > level below or above the application protocol will give you a 
> cleaner> and perhaps better-performing design than a binary 
> protocol (text
> >  Gy?rgy
> >> connection id except that peeri sniffs the network. In the 
> following>> connections, the tracker verifies the connection ID 
> and ignores the
> >> is easier for people to understand, but requires more space and 
> bandwidth.>> Binary protocols are lighter in both bandwidth and 
> processing,  
> >> though are sometimes
> >>       Which encoding approach is better is a pending problem.  
> Except>> the above analysis, which factors should be considered to 
> decide that
> >>   problem?
> >>
> >> This draft introduces a kind of text-based encoding Tracker 
> Protocol,>> the SIP-based PPSP Tracker Protocol, which utilizes 
> SIP message to
> addressee(s)'s>> use only. It may contain sensitive, confidential, 
> private proprietary or
> >> purpose, and is protected by law. If you are not the intended 
> recipient,>> please immediately delete it and all copies of it 
> from your system,
> > Gy?rgy Dán