Subject: [ppsp] PPSP encoding

From: [email-masked]
Date: Thu, 29 Sep 2011 11:36:13 +0800

Hi Yingjie,

In your slides, tracker protocol uses XML encoding while peer protocol 
uses binary encoding. Both peer protocol and tracker protocol provide 
messages to convey peer list, content availability and status.
I think peer protocol and tracker protocol's message encodings can be and 
should be similar. That will make implementing PPSP easier and reduce 
resource consumption in peer.

BR
Lichun

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: "Yingjie Gu(yingjie)" <[email-masked]>
Date: Thu, 29 Sep 2011 13:11:40 +0800

Hi Lichun,

We had discussion at last meeting and also discussed at interim meeting at
last night.

Here is brief conclusion of the discussion.

There is no significant benefit by using HTTP as peer protocol. 

The reason to use HTTP as tracker protocol is that we hope it’s readable,
and usually it’s c/s mode. 

While for Peer protocol, readability is not the as important as Tracker
protocol.

Besides, in peer protocol, there is no clear role of client or server, every
peer could initiate a request. So HTTP may be not suitable in this case.

I guess there is a rough consensus that we should use binary in peer
protocol. But I would like to hear what the chairs think of. Do we get a
rough consensus on peer protocol encoding?

 

  _____  

Best Regards
Gu Yingjie

发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2011年9月29日 乐乐11:36
收件人: Yingjie Gu(yingjie); 'ppsp'
主题: PPSP encoding

Hi Yingjie, 

In your slides, tracker protocol uses XML encoding while peer protocol uses
binary encoding. Both peer protocol and tracker protocol provide messages to
convey peer list, content availability and status. 
I think peer protocol and tracker protocol's message encodings can be and
should be similar. That will make implementing PPSP easier and reduce
resource consumption in peer. 

BR 
Lichun

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is
solely property of the sender's organization. This mail communication is
confidential. Recipients named above are obligated to maintain secrecy and
are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended
solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the originator of the
message. Any views expressed in this message are those of the individual
sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: [email-masked]
Date: Thu, 29 Sep 2011 15:48:32 +0800

Hi Yingjie,

I am not saying we should use HTTP to transport peer protocol messages. I 
just suggest message encodings should be similar. 
But it will be good, if tracker protocol and peer protocol can use the 
same transport protocol. 

A peer is both a server and a client to other peers, no matter using 
HTTP-based peer protocol or not. A peer has to process incoming requests, 
and also sends requests. A peer could be a HTTP server and client at the 
same time if using HTTP-based peer protocol. Again, I am not suggesting we 
should use or not use HTTP.

Can we allow tracker/peer protocol to run on multiple transport protocols 
as each transport protocol has its advantages? 

Why readability is important for tracker protocol, but not important for 
peer protocol? 
I am not suggesting we should use txt encoding or binary encoding. I just 
suggest message encodings should be the same type.

BR
Lichun

"Yingjie Gu(yingjie)" <[email-masked]> 写于 2011-09-29 13:11:40:

> Hi Lichun,
> We had discussion at last meeting and also discussed at interim 
> meeting at last night.
> The reason to use HTTP as tracker protocol is that we hope it’s 
> readable, and usually it’s c/s mode. 
> While for Peer protocol, readability is not the as important as 
> Tracker protocol.
> Besides, in peer protocol, there is no clear role of client or 
> server, every peer could initiate a request. So HTTP may be not 
> suitable in this case.
> 
> protocol. But I would like to hear what the chairs think of. Do we 
> get a rough consensus on peer protocol encoding?
> 
> 
> 
> 
> 
> 
> 
> Best Regards
> Gu Yingjie
> 
> In your slides, tracker protocol uses XML encoding while peer 
> protocol uses binary encoding. Both peer protocol and tracker 
> protocol provide messages to convey peer list, content availability 
> and status. 
> I think peer protocol and tracker protocol's message encodings can 
> be and should be similar. That will make implementing PPSP easier 
> and reduce resource consumption in peer. 
> 
> 
> BR 
> Lichun
> 
> ZTE Information Security Notice: The information contained in this 
> mail is solely property of the sender's organization. This mail 
> communication is confidential. Recipients named above are obligated 
> to maintain secrecy and are not permitted to disclose the contents 
> of this communication to others.
> This email and any files transmitted with it are confidential and 
> intended solely for the use of the individual or entity to whom they
> are addressed. If you have received this email in error please 
> notify the originator of the message. Any views expressed in this 
> message are those of the individual sender.

---

From: Rui Cruz <[email-masked]>
Date: Thu, 29 Sep 2011 15:55:22 +0100

Dear Yingjie,

I tend to agree with Lichun in respect to the peer being both a serving and a client agent, irrespective of the protocol used for their signaling.
I our implementation, reflected in our proposed draft, the peer is a tiny HTTP server and client, implements the PPSP protocols for signaling over HTTP, as well as the media transfer protocol is over HTTP, and we are able to stream high quality media (including scalable media) even in harsh network conditions. 

---------------------------
Best Regards,

Prof. Rui Santos Cruz
Chairman
IEEE Portugal Section
Av. Prof. Dr. Aníbal Cavaco Silva, IST-TagusPark, Office 1-5, 2744-016 Porto Salvo, Portugal
+351 214 233 200 (ext 5044), +351.939 060 939 (mobile)
[email-masked] 
[email-masked]
[email-masked]
www.ieee-pt.org
Advancing technology for humanity.

On 29/09/2011, at 08:48, [email-masked] wrote:

> 
> Hi Yingjie, 
> 
> I am not saying we should use HTTP to transport peer protocol messages. I just suggest message encodings should be similar. 
> But it will be good, if tracker protocol and peer protocol can use the same transport protocol. 
> 
> A peer is both a server and a client to other peers, no matter using HTTP-based peer protocol or not. A peer has to process incoming requests, and also sends requests. A peer could be a HTTP server and client at the same time if using HTTP-based peer protocol. Again, I am not suggesting we should use or not use HTTP. 
> 
> Can we allow tracker/peer protocol to run on multiple transport protocols as each transport protocol has its advantages? 
> 
> 
> Why readability is important for tracker protocol, but not important for peer protocol? 
> I am not suggesting we should use txt encoding or binary encoding. I just suggest message encodings should be the same type. 
> 
> 
> BR 
> Lichun
> 
> 
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp

---

From: Arno Bakker <[email-masked]>
Date: Fri, 30 Sep 2011 10:26:05 +0200

Rui Cruz wrote:

> > I our implementation, reflected in our proposed draft, the peer is a tiny HTTP server and client, implements the 
> > PPSP protocols for signaling over HTTP, as well as the media transfer protocol is over HTTP, and we are able 
> > to stream high quality media (including scalable media) even in harsh network conditions. 
Hi 

I really question whether HTTP is the right choice. First, this means the system uses at least 2 TCP connections 
per pair of peers, where one would suffice to get bidirectional traffic. Moreover, one can question (and we do) 
whether TCP is the best suited transport layer protocol. It has fixed congestion control, so improvements like 
IETF's LEDBAT (=manage user's upload bandwidth such that P2P moves out of the way when the user e.g. 
uploads photos) are not possible. Furthermore, NAT traversal is complex, there is a high per-connection memory 
footprint and finally, it pays a price to offer facilities (in-order and reliable) that you do not necessarily 
need in a P2P protocol.

Hence, we have a strong preference for UDP. As put forward at the meeting, we would really like to hear
people's opinions on whether they prefer transport over "raw UDP" or would like PPSP to be a profile of RTP,
in the same way as Secure RTP. Like SRTP i.e., swift would add a layer below RTP that protects the content, 
and does P2P signalling, but which is transparent to the RTP consumer.

Regards,
      Arno

P.S. apologies for double post