Subject: [ppsp] FW: New Version Notification for draft-ietf-ppsp-reqs-04.txt

From: ZongNing <[email-masked]>
Date: Wed, 21 Sep 2011 03:25:37 +0000

Hi, Folks,

A new revision of PPSP requirements has been submitted (see attached file draft-ietf-ppsp-reqs-04.txt). The main modifications are:
1) incorporating the comments/suggestions from Johan, Arno, Lingli Deng.
2) updating reference items.

Please review and give comments (even just saying "I am fine with the new version...").
Thanks.

BR,
Ning Zong

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, September 21, 2011 11:10 AM
To: ZongNing
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; ZongNing
Subject: New Version Notification for draft-ietf-ppsp-reqs-04.txt

A new version of I-D, draft-ietf-ppsp-reqs-04.txt has been successfully submitted by Ning Zong and posted to the IETF repository.

Filename:	 draft-ietf-ppsp-reqs
Revision:	 04
Title:		 P2P Streaming Protocol (PPSP) Requirements
Creation date:	 2011-09-20
WG ID:		 ppsp
Number of pages: 14

Abstract:
   The objective of the PPSP work is to standardize the key signaling
   protocols that apply to tracker and peers in a Peer-to-Peer (P2P)
   streaming system.  These protocols are called PPSP.  This document
   enumerates the requirements for the PPSP, which should be considered
   when designing PPSP.

The IETF Secretariat

---

From: Arno Bakker <[email-masked]>
Date: Wed, 21 Sep 2011 09:32:30 +0200

Hi all

looks fine, just one small remark: in PPSP.TP.REQ-6 the term "smart 
tracker" is introduced with any further explanation. I think we need
to make the requirements for simple trackers and for smart trackers
more explicit.

Regards,
      Arno

---

From: ZongNing <[email-masked]>
Date: Thu, 29 Sep 2011 00:31:20 +0000

Hi, Arno,

Since there is no such definition like "simple tracker" and "smart tracker" in industry, I prefer not to define these terms in PPSP WG.
For a requirement draft, we can just use the words - "MUST", "SHOULD", "MAY" etc to differentiate which are necessary (for basic inter-op) and which are preferred. The real-world implementation will choose the appropriate functional set based on their design, rather than follow our requirements/definition of "simple tracker" and "smart tracker".
How do you think.

BR,
Ning Zong

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Arno Bakker
Sent: Wednesday, September 21, 2011 3:33 PM
To: [email-masked]
Subject: Re: [ppsp] FW: New Version Notification for draft-ietf-ppsp-reqs-04.txt

Hi all

Regards,
      Arno
_______________________________________________
ppsp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

---

From: Wesley Eddy <[email-masked]>
Date: Wed, 28 Sep 2011 22:17:23 -0400

> For a requirement draft, we can just use the words - "MUST", "SHOULD", "MAY" etc to differentiate which are necessary (for basic inter-op) and which are preferred. The real-world implementation wil…

Just speaking as an individual, I would agree with Arno.  If it doesn't
have a technical definition, then "smart tracker" is just a marketing
term and should be avoided in a requirements spec.

-- 
Wes Eddy
MTI Systems

---

From: ZongNing <[email-masked]>
Date: Thu, 29 Sep 2011 02:33:42 +0000

Hi, Wesley,

Just to be clear, you agree with Arno or me? It seems to me that you actually agree with me.

Here is Arno's opinion:
" I think we need to make the requirements for simple trackers and for smart trackers more explicit."

Here is my opinion:
" Since there is no such definition like "simple tracker" and "smart tracker" in industry, I prefer NOT to define these terms in PPSP WG. For a requirement draft, we can just use the words - "MUST", "SHOULD", "MAY" etc to differentiate which are necessary (for basic inter-op) and which are preferred."

BR,
Ning Zong

---

From: Wesley Eddy <[email-masked]>
Date: Wed, 28 Sep 2011 22:47:28 -0400

> " Since there is no such definition like "simple tracker" and "smart tracker" in industry, I prefer NOT to define these terms in PPSP WG. For a requirement draft, we can just use the words - "MUST"…

I think the options are to either:

- explicitly define simple versus smart trackers (as Arno suggested)

or

- think about dropping the "smart" terminology in the one place it
occurs (this may be what you're suggesting, with properties for smart
trackers as SHOULDs, but I wasn't sure that was exactly what you meant
or not)

-- 
Wes Eddy
MTI Systems

---

From: ZongNing <[email-masked]>
Date: Thu, 29 Sep 2011 03:06:40 +0000

See inline.

-----Original Message-----
From: Wesley Eddy [mailto:[email-masked]] 
Sent: Thursday, September 29, 2011 10:47 AM
To: ZongNing
Cc: [email-masked]
Subject: Re: [ppsp] FW: New Version Notification for draft-ietf-ppsp-reqs-04.txt

or

[ZN]: I mean dropping the "smart" term and using the SHOULDs.
I am not in favor of defining smart tracker by ourselves in requirement spec, as I haven't seen clear demarcation of simple tracker and smart tracker in industry (on the contrary, we do see clear role of peer and tracker in existing P2P applications). Please correct me, if anybody does see clear definition of smart tracker. Thanks.

BR,
Ning Zong

-- 
Wes Eddy
MTI Systems

---

From: Arno Bakker <[email-masked]>
Date: Thu, 29 Sep 2011 11:40:18 +0200

> I am not in favor of defining smart tracker by ourselves in requirement spec, as I haven't seen clear demarcation of simple tracker and smart tracker in industry (on the contrary, we do see clear r…

I'm fine with that.
     Arno