Subject: Re: [ppsp] 答复: Comments on draft-ietf-ppsp-reqs-03

From: Arno Bakker <[email-masked]>
Date: Mon, 19 Sep 2011 15:53:55 +0200

Hi all

if Ning Zong can incorporate the previous comments as promised,
and respond to the ones below (inline), I'm fine with the draft.

On 08/08/2011 08:45, Ning Zong wrote:
> 
> * PPSP.PP.REQ-1+2+4: I propose to allow more explicitly for a
> push-based model, where peers advocate their own chunk availability
> proactively, and state that the peer protocol MUST implement either
> pull-based, push-based or both.
> 
> [ZN]: We have paragraph on page 10 to describe the two modes of pull&  push
> information among peers.
> And I don't think it is necessary to state these modes in a formal
> requirement.
>

[AB]: Are you sure? I think we should make it explicit somewhere that
you do not have to implement CHUNK AVAIL request (i.e., PP.REQ-1) if you
are using a push-based model.

> 
> * PPSP.PP.REQ-6: Is phrased ambiguously at present IMHO. When read as
> "The peers MUST implement the peer protocol for chunk
> [availability] requests and responses among the peers before the
> streaming content is transmitted." it seems self-evident, one
> cannot request a chunk if one doesn't know what chunks the requestee
> has. Hence the requirement seems superfluous.
> 
> [ZN] This is not about chunk availability, but requesting the chunk itself.
> For example, peer A send this message to peer B to request a specific chunk,
> as well as its streaming capability information.
> This message is more like a session negotiation/description message (e.g.
> RTSP, SIP, etc).
>

[AB] It's probably me, but I still don't get it ;-(

> * PPSP.SEC.REQ-9: I propose to remove the part that requires
> reporting receiving bad content to the tracker. Reporting to the
> tracker would allow for false reporting by malicious peers and
> arbitrating these reports is very complex.
> 
> [ZN] Yunfei and Lingli Deng, what's your opinions on this?
> 

[AB] Have you heard anything from them?

Thanks,
     Arno

---

From: ZongNing <[email-masked]>
Date: Tue, 20 Sep 2011 01:57:04 +0000

Hi, Arno,

See inline.

-----Original Message-----
From: Arno Bakker [mailto:[email-masked]] 
Sent: Monday, September 19, 2011 9:54 PM
To: ZongNing
Cc: [email-masked]; '邓灵莉/denglingli'
Subject: Re: 答复: [ppsp] Comments on draft-ietf-ppsp-reqs-03

Hi all

[ZN] Thank you for your comments & I am working on a new revision now...

[ZN] I got your point. This makes sense. I will make it explicit somewhere in new revision.

[ZN] I try to make it clearer in new revision.

[ZN] Yes, and they will respond on this soon.

Thanks,
     Arno

---

From: Arno Bakker <[email-masked]>
Date: Tue, 20 Sep 2011 08:44:52 +0200

Hi

good. Looking forward to the new draft.

Regards,
     Arno

On 20/09/2011 04:54, 邓灵莉/denglingli wrote:
> Hi,Arno&  Ning
> 
> About REQ-9, we are OK with Arno's proposal.
> 
> The modified version would look like this:
> 
> PPSP.SEC.REQ-9: Integrity of the streaming content in PPSP MUST be
>     supported to provide a peer with the possibility to identify
>     inauthentic media content (undesirable modified by other entities
>     rather than its genuine source).  The corresponding checksum
>     distribution and verification scheme SHOULD
>     scale well in P2P streaming system and be robust against distrustful
>     trackers/peers.
> 

-- 
(faculty email system is being migrated, email address will remain
[email-masked])