Subject: FW: Spanning tree PDUs and VPLS

From: Anoop Ghanwani <[email-masked]>
Date: Mon, 14 Oct 2002 16:55:15 -0700

Is there a BCP for what a router should do when it receives
a spanning tree PDU?  Does it treat it like a multicast
frame and forward it to all ports on the VPLS?  Or does
it just filter these frames?

If the group hasn't discussed this issue, I'd be interested 
in hearing how vendors currently handle spanning tree PDUs.

-Anoop
--
Anoop Ghanwani - Lantern Communications - 408-521-6707

---

From: Ashwin Moranganti <[email-masked]>
Date: Tue, 15 Oct 2002 09:39:12 -0400

Anoop, 

VPLS will allow CEs to run STP. The STP frames will be tunneled, and will
forwarded to all ports on the VPLS

Ashwin

-----Original Message-----
From: Anoop Ghanwani [mailto:[email-masked]]
Sent: Monday, October 14, 2002 7:55 PM
To: [email-masked]'
Subject: FW: Spanning tree PDUs and VPLS

-Anoop

---

From: Anoop Ghanwani <[email-masked]>
Date: Tue, 15 Oct 2002 10:24:02 -0700

Ashwin,

Thanks for the information.

What happens in a point-to-multipoint topology?
The leaves don't talk to each other directly so what
happens when a spanning tree PDU is received from
a leaf node?

-Anoop

> From: Ashwin Moranganti [mailto:[email-masked]]
> Sent: Tuesday, October 15, 2002 6:39 AM
> To: 'Anoop Ghanwani'; [email-masked]'
> Subject: RE: Spanning tree PDUs and VPLS
> 
> 
> Anoop, 
>

---

From: Ashwin Moranganti <[email-masked]>
Date: Tue, 15 Oct 2002 13:56:31 -0400

Anoop, 

I believe, the current IETF VPLS drafts, do not support point-to-multipoint
topologies.

In MEF, there is a concept of point-to-multipoint Ethernet virtual circuit.
In which the broadcast, multicast and unicast packets from the leaf are
forwarded only to the root and not to other leaves.
But multicast, broadcast packets from the root are forwarded to all the
leaves.

Ashwin

-----Original Message-----
From: Anoop Ghanwani [mailto:[email-masked]]
Sent: Tuesday, October 15, 2002 1:24 PM
To: 'Ashwin Moranganti'; Anoop Ghanwani; [email-masked]'
Subject: RE: Spanning tree PDUs and VPLS

Ashwin,

-Anoop

---

From: Anoop Ghanwani <[email-masked]>
Date: Tue, 15 Oct 2002 11:02:37 -0700

Ashwin,

From a spanning tree standpoint, the VPLS acts 
like a hub.  However, I think P2MP would mess things 
up for the spanning tree because it doesn't quite 
behave like a hub -- a leaf sees spanning tree
PDUs from the root, but not from the other leaves.

Anyway, since the VPLS drafts don't support P2MP,
I guess we need not worry about this.

-Anoop

> Sent: Tuesday, October 15, 2002 10:57 AM
> To: 'Anoop Ghanwani'
> Cc: [email-masked]'

---

From: Du Wenhua <[email-masked]>
Date: Wed, 16 Oct 2002 12:09:25 +0800

Ashwin Moranganti,
    One qustion about run STP on VPLS.
    In the following diagram, surpose the AC between CE1 and PE1 is VLAN 100, the AC between CE2 and PE1 is VLAN 200, the  AC between CE3 and PE2 is VLAN 300.
    If CE1 and CE2 and CE3 have back door, CEs must run STP. 
    Because many STP protocols(PVST、MST) are associates VLANS with STP instances and carry this information in the BPDU. So how could Acess Networks and PEs deal with the  BPDU which is received from CE1 and will be forward to CE2 and CE3,  while the VLAN ID must be changed from 100 to 200 or 300?  Maybe one solution is, both the  Access networks and PEs must tunnel and forward the BPUD.
                          
  +-----+
  + CE1 +\
  +-----+ \                ...................
   VPLS A  \  -   /\-_   +----+           +----+    -   /\-_
            \/ \ /   \   |VPLS|           |VPLS|   / \ /   \     +-----+
             \ Access \--| PE1|--Service--| PE2+---\ Access \----| CE3 |
            /| Network | +----+  Provider +----+   | Network |   +-----+
           /  \       /    .     Backbone    .      \       /     VPLS A
  +-----+ /    -------     .      |          .       -------
  + CE2 +/                 .      |          .
  +-----+                  .    +----+       .
   VPLS A                  .....|VPLS|........
                                | PE3|
                                +----+

                                           Du Wenhua

>in hearing how vendors currently handle spanning tree PDUs.

= = = = = = = = = = = = = = = = = = = =

　　　　　　　　Du Wenhua
　　　　　　　　[email-masked]
　　　　　　　　　　2002-10-16

---
You are currently subscribed to ppvpn as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Du Wenhua <[email-masked]>
Date: Thu, 17 Oct 2002 10:54:50 +0800

Vach Kompella,

	   Thanks.
       Your reply has sovle the problem. But in practice, maybe ,there will exist two puzzles:
     (1)The access network , that is made up of some tradional ethernet switch, must tunnel the CE's BPDU(such as change the DMAC). Some of today's product don't surport this fearture;
     (2)In my following diagram, if these attachmetn circiurt tags are 100,200,100, and the two access network have backdoor ( this is found in carrier's reality network), how to run STP? 
                                                            --Du Wenhua

>The tags 100, 200, and 300, respectively, are used only on the access to
>provider link.  They get stripped.  Any per customer VLAN tags on the BPDUs
>remain (if you are using multiple per-VLAN STP instances, i.e., 802.1s, over a
>single VPLS, but there are additional complications).  So these tags 100, 200,
>or 300 do not show up in the inter-CE connectivity, as I envision it.
>
>-Vach
>
>> From: Joris wils [mailto:[email-masked]]
>> Sent: Wednesday, October 16, 2002 6:18 AM
>> To: [email-masked]'; Ashwin Moranganti
>> Cc: [email-masked]
>> Subject: RE: RE: Spanning tree PDUs and VPLS
>>
>>
>> Wenhua:
>>
>> If I understand you correctly, the VPLS is performing tag translation.  Are
>> you describing one VLAN, which uses the tag 100 at CE1/PE1, tag 200 at
>> CE2/PE2 and tag 300 at CE3/PE3.
>>
>> If yes, do the backdoor connections also perform tag translation?  If the
>> backdoor links do not perform tag translation, then you have an invalid
>> network, because the tags are not consistent.  If the backdoor links DO
>> perform tag translation, then there is no problem, because the tags in the
>> PVST and MST BPDUs will be translated regardless if they use the backdoor or
>> VPLS connection.
>>
>> From: Du Wenhua [mailto:[email-masked]]
>> Sent: Wednesday, October 16, 2002 12:09 AM
>> To: Ashwin Moranganti
>> Cc: [email-masked]
>> Subject: Re: RE: Spanning tree PDUs and VPLS
>>
>>
>> Ashwin Moranganti,
>>     In the following diagram, surpose the AC between CE1 and PE1 is VLAN
>> 100, the AC between CE2 and PE1 is VLAN 200, the  AC between CE3 and PE2 is
>> VLAN 300.
>>     Because many STP protocols(PVST、MST) are associates VLANS with STP
>> instances and carry this information in the BPDU. So how could Acess
>> Networks and PEs deal with the  BPDU which is received from CE1 and will be
>> forward to CE2 and CE3,  while the VLAN ID must be changed from 100 to 200
>> or 300?  Maybe one solution is, both the  Access networks and PEs must
>> tunnel and forward the BPUD.
>>
>>   +-----+
>>   + CE1 +\
>> You are currently subscribed to ppvpn as: [email-masked]
>> To unsubscribe send a blank email to
>> [email-masked]
>>
>>
>> ---
>> You are currently subscribed to ppvpn as: [email-masked]
>> To unsubscribe send a blank email to
>> [email-masked]

　　　　　　　　致
礼！

　　　　　　　　Du Wenhua
　　　　　　　　[email-masked]
　　　　　　　　　　2002-10-17