Subject: questions on draft-ietf-ppvpn-vr-mib-02.txt

From: Joan Cucchiara <[email-masked]>
Date: Thu, 10 Oct 2002 14:13:26 -0400

Hello,

A few questions and comments on the MIB.

1) Is the Internal Virtual Link used to connect to VRs in
the same PE, or is it a link between VRs in a different PEs?

2) Is there a one to many relationship between the vrTunnelIpAddress
and the Virtual Routers?

3) do you want any scalars to configure the number of VRs on
   the device?

4) regarding VPN-ID, have you considered adding some sort of
   mapping table to which is indexed by VPN-ID, VR?

5) Having a TC called VrIndexOrZero which is like the above but
   includes zero, where zero needs to be defined in the Description
   Clause of the objects
    
    * for VrConfigNextAvailableVrId have zero mean that no more VRs
      can be created.  (for example, if the device is out of resources)

    * for vrId have zero mean that VR 0 is the NULL VR.

6) Limit the vrName to fewer characters (32 is probably good, but
   could be bigger.  255 seems quite large).  This description
   should probably say these names need to be unique within the table.

7) vrAdminStatus: could testing be added here?

8) vrContextName - why is this a read-create and not a read-only?

9) vrType, not clear what this is, could more description be added?

10) (minor) please change the vrStat to be vrStatus 

11) RouterId should this be  2 objects ( AddressType and Address )
    (as in the INET-ADDRESS-MIB).

12) have you considered having the VrIfTable indexed by 
    vrId and vrIfIndex ?  (seems like a VR would want to quickly
    see all of its interfaces).

13) vrUp/vrDown traps need to contain a varbind.  The vrId is an index.

  Thanks, Joan

---

From: "Elwin Eliazer" <[email-masked]>
Date: Tue, 15 Oct 2002 15:28:13 -0700

Hi Joan,

Thanks for your very valid comments.
Excuse us for the delay in responding.
My responses are in-lined below.

Cheers,
Elwin.

-----Original Message-----
From: Joan Cucchiara [mailto:[email-masked]] 
Sent: Thursday, October 10, 2002 11:13 AM
To: [email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: questions on draft-ietf-ppvpn-vr-mib-02.txt

Hello,

Elwin> It is for VRs in the same PE.

Elwin> One to many is possible for the cases of tunnels having a 
Elwin> demultiplexing field.

Elwin> That will be nice to add.

Elwin> This could be for quick searching. Inverse VPN/VR table?? 
Elwin> Sure...That sounds okay. 

Elwin> Good suggestion.

Elwin> agreed.

Elwin> Sure.

Elwin> This allows the user to specify the VR context, or community,
Elwin> for the particular VR being created.  If it were read-only, this 
Elwin> would mean the device is creating the context for the VR.

Elwin> This has to be removed.

Elwin> will do.

Elwin> good point.

Elwin> No, a VR is identified by the community string itself.
Elwin> We are suggesting managing multiple instances of the
Elwin> "VrIfTable" using a model similar to that described in RFC2571.

Elwin> No, the vrId MAX-ACCESS is defined as accessible-for-notify.

  Thanks, Joan

---

From: "Elwin Eliazer" <[email-masked]>
Date: Tue, 15 Oct 2002 15:50:49 -0700

Resending it, to include the new mailing-list. Those who received it
already can ignore this.

Cheers,
Elwin.

-----Original Message-----
From: Elwin Eliazer 
Sent: Tuesday, October 15, 2002 3:29 PM
To: 'Joan Cucchiara'; [email-masked];
[email-masked]; [email-masked];
[email-masked]
Subject: RE: questions on draft-ietf-ppvpn-vr-mib-02.txt

Hi Joan,

Cheers,
Elwin.

-----Original Message-----
From: Joan Cucchiara [mailto:[email-masked]] 
Sent: Thursday, October 10, 2002 11:13 AM
To: [email-masked]; [email-masked];

Hello,

    

Elwin> Good suggestion.

Elwin> agreed.

Elwin> Sure.

Elwin> will do.

Elwin> good point.

  Thanks, Joan

---

From: "Elwin Eliazer" <[email-masked]>
Date: Tue, 15 Oct 2002 15:50:49 -0700

Cheers,
Elwin.

-----Original Message-----
From: Elwin Eliazer 
Sent: Tuesday, October 15, 2002 3:29 PM
To: 'Joan Cucchiara'; [email-masked];

Hi Joan,

Cheers,
Elwin.

-----Original Message-----
From: Joan Cucchiara [mailto:[email-masked]] 
Sent: Thursday, October 10, 2002 11:13 AM
To: [email-masked]; [email-masked];

Hello,

    

Elwin> Good suggestion.

Elwin> agreed.

Elwin> Sure.

Elwin> will do.

Elwin> good point.

  Thanks, Joan

---
You are currently subscribed to ppvpn as: [email-masked]
To unsubscribe send a blank email to [email-masked]