Subject: Labels per link...

From: "alok" <[email-masked]>
Date: Mon, 9 Dec 2002 18:19:11 +0530

Hi All

i need to know what is the standard implementation practice on labels for
multipoint interfaces.

If  i have an ethernet network between routers, P routers connected to
multiple P via ethernet...

is a label unique "per neighbour" or "per interface" in this case

for example, P-a, P-b and P-c are on the same ethernet LAN

can u have label 111 between P-a and P-b for egress trafficbetween a and b,
and 111 between P-a and P-c for egress traffic between a and c?

-rgds
Alok

---

From: "Gopal@Yahoo" <[email-masked]>
Date: Mon, 9 Dec 2002 16:26:31 -0800 (PST)

--- alok <[email-masked]> wrote:
> is a label unique +ACI-per neighbour+ACI- or
> +ACI-per interface+ACI- in this case

What is ACI?
In frame-mode, (local)Label is unique to a
router(LSR).

> and 111 between P-a and P-c for egress traffic

Yes.

If router-A is the Egress for a prefix, net-A and if
local label for Net-A is 111. Then rtr-A adv 111 to
both rtr-b and rtr-c.

Then, both rtr-b and rtr-c will have 111 as the
out-label for the prefix, net-A.

> 
> -rgds
> Alok
> 
> -------
> The MPLS-OPS Mailing List
> Subscribe/Unsubscribe: 
> http://www.mplsrc.com/mplsops.shtml
> Archive:
http://www.mplsrc.com/mpls-ops_archive.shtml

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com

---

From: nitin p <[email-masked]>
Date: Mon, 9 Dec 2002 17:09:51 -0800 (PST)

Gopal,

Adding to this discussion..
Don't we have the concept of having global and local
labels. Global when there is one label pool in a
router and all the interfaces are assigned labels from
this pool so label values at two interafces on the
same router will never be same.
Local, is the one in which each interface has it pool
of labels and two interface on the same box maight
have same label values.
Please correct me on this.

Thanks,
Nitin

--- "Gopal@Yahoo" <[email-masked]> wrote:
> > can u have label 111 between P-a and P-b for
> egress
> > trafficbetween a and b,

---

From: "Gopal@Yahoo" <[email-masked]>
Date: Mon, 9 Dec 2002 21:57:13 -0800 (PST)

Nitin, That is incorrect. Pls forward me if there is a
doc that supports your data.
In frame mode labels are unique to the router. There
is one big label space per router. Router assigns
labels to the prefixes in the routing table from this
space. 

If a prefix P is learned from neighbors on 2 different
interfaces(or we advertise to 2 neighbors on 2
differnt interfaces), router assigns one unique label
to that prefix(it is often refered as local label).

In label or local label = Label that router assigns to
a prefix. This label is one unique to the router, no
matter how many sources we learn from or, to how many
neighbors we advertise.

Out label or remote label(s) = label this router
received from the neighbors. there can be more than
one remote/out label for a prefix(advertised by
different neighbors).

You can play with your boxes to see this behaviour
indeed.

rgds,
gopal

--- nitin p <[email-masked]> wrote:
> > > i need to know what is the standard
> implementation
> > > practice on labels for
> > > multipoint interfaces.
> > > 
> > > If  i have an ethernet network between routers,
> P
> > > routers connected to