Subject: PMP> prtChannelEntry -> prtMarkerIndex

From: Schoenbach Andreas <[email-masked]>
Date: Wed, 20 Sep 2000 17:10:36 +0200

Hello,

I have three markers and two channels in my machine. 

I need to select which marker is printing the data from a channel.

(like prtChannelDefaultPageDescLangIndex).

Is this relation present or can you extend the mib?

Example:

prtChannelMarkerIndex OBJECT-TYPE
    SYNTAX     Integer32
    MAX-ACCESS read-write
    STATUS     current
    DESCRIPTION
        "The value of prtMarkerIndex  corresponding to the
         Marker for this channel.
        This marker defines the default marker  to be used for the print
data
         from this channel.
        Must be 1 or greater. -1 means unknown. -2 means auto-select "
    ::= { prtChannelEntry 11 }

Thanks,
[email-masked]

---

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 20 Sep 2000 09:32:52 -0700

Hi Andreas,

The relationship is not expressed in the Printer MIB.

The Printer MIB v2 has just completed Printer MIB WG
'last call' and has been sent to the IESG for final
Internet 'last call' and publication as a standards
track RFC.  Not really practical to add new objects
right now.

Cheers,
- Ira McDonald, consulting architect at Xerox and Sharp
  High North Inc
  (contributing editor to Printer MIB v2)

-----Original Message-----
From: Schoenbach Andreas [mailto:[email-masked]]
Sent: Wednesday, September 20, 2000 8:11 AM
To: [email-masked]
Subject: PMP> prtChannelEntry -> prtMarkerIndex

Hello,

Example:

Thanks,

---

From: "Wagner,William" <[email-masked]>
Date: Wed, 20 Sep 2000 13:00:18 -0400

Greetings:

The MIB model assumes that the channel drives the interpreter and the
interpreter somehow drives the marker through the system controller. There
is a relationship between channel and interpreter(s) in the
prtChannelCurrentJobCntlLangIndex, and the
prtChannelDefaultPageDescLangIndex objects.  You could define interpreters
with a fixed relationship to each marking engine. This would allow the
dynamic relation between channel and marking engine to be reported. 

William A. Wagner (Bill Wagner)
Director of Technology
Imaging Division
NETsilicon, Inc.
781-398-4588

-----Original Message-----
From: Schoenbach Andreas [mailto:[email-masked]]
Sent: Wednesday, September 20, 2000 11:11 AM
To: [email-masked]
Subject: PMP> prtChannelEntry -> prtMarkerIndex

Hello,

Example:

Thanks,

---

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 20 Sep 2000 12:51:14 -0700

Hi,

Thanks Bill - right - use multiple instances of (for
instance) a PostScript interpreter to represent each
different Marker - good solution.

Cheers,
- Ira McDonald

-----Original Message-----
From: Wagner,William [mailto:[email-masked]]
Sent: Wednesday, September 20, 2000 10:00 AM
To: 'Schoenbach Andreas'; [email-masked]
Subject: RE: PMP> prtChannelEntry -> prtMarkerIndex

Greetings:

-----Original Message-----
From: Schoenbach Andreas [mailto:[email-masked]]
Sent: Wednesday, September 20, 2000 11:11 AM
To: [email-masked]
Subject: PMP> prtChannelEntry -> prtMarkerIndex

Hello,

Example:

Thanks,

---

From: Schoenbach Andreas <[email-masked]>
Date: Thu, 21 Sep 2000 17:05:41 +0200

Thanks, for your suggestions.

I have 4 interpreters and 3 marker.  I will thus create 12 instances in the
prtInterpreterTable. -> O.K.

Do I need now 12 instances in the prtMarkerTable (with same index)?

Or sufficient 3 and I know 
prtInterpreterIndex => prtMarkerIndex
1,4,7,10            =>   1
2,5,8,11            =>   2
3,4,9,12            =>   3
???

-Andreas

	-----Ursprüngliche Nachricht-----
	Von:	McDonald, Ira [mailto:[email-masked]]
	Gesendet am:	Mittwoch, 20. September 2000 21:51
	An:	'Wagner,William'; 'Schoenbach Andreas'; [email-masked]
	Betreff:	RE: PMP> prtChannelEntry -> prtMarkerIndex

	Hi,

	Cheers,
	- Ira McDonald

	-----Original Message-----
	From: Wagner,William [mailto:[email-masked]]
	Sent: Wednesday, September 20, 2000 10:00 AM
	To: 'Schoenbach Andreas'; [email-masked]
	Subject: RE: PMP> prtChannelEntry -> prtMarkerIndex

	Greetings:

	The MIB model assumes that the channel drives the interpreter and
the
	interpreter somehow drives the marker through the system controller.
There
	is a relationship between channel and interpreter(s) in the
	prtChannelCurrentJobCntlLangIndex, and the
	prtChannelDefaultPageDescLangIndex objects.  You could define
interpreters
	with a fixed relationship to each marking engine. This would allow
the
	dynamic relation between channel and marking engine to be reported. 

	-----Original Message-----
	From: Schoenbach Andreas
[mailto:[email-masked]]
	Sent: Wednesday, September 20, 2000 11:11 AM
	To: [email-masked]
	Subject: PMP> prtChannelEntry -> prtMarkerIndex

	Hello,

	Example:

	prtChannelMarkerIndex OBJECT-TYPE
	    SYNTAX     Integer32
	    MAX-ACCESS read-write
	    STATUS     current
	    DESCRIPTION
	        "The value of prtMarkerIndex  corresponding to the
	         Marker for this channel.
	        This marker defines the default marker  to be used for the
print
	data
	         from this channel.
	        Must be 1 or greater. -1 means unknown. -2 means auto-select
"
	    ::= { prtChannelEntry 11 }

	Thanks,

---

From: "McDonald, Ira" <[email-masked]>
Date: Thu, 21 Sep 2000 12:21:17 -0700

Hi Andreas,

No just three Markers and use internal knowledge to map
them to Interpreters (and probably state it in the
'prtInterpreterDescription' object for each Interpreter).

Cheers,
- Ira McDonald

-----Original Message-----
From: Schoenbach Andreas [mailto:[email-masked]]
Sent: Thursday, September 21, 2000 8:06 AM
To: [email-masked]
Subject: RE: RE: PMP> prtChannelEntry -> prtMarkerIndex

-Andreas

	-----Ursprüngliche Nachricht-----
	Von:	McDonald, Ira [mailto:[email-masked]]
	Gesendet am:	Mittwoch, 20. September 2000 21:51
	An:	'Wagner,William'; 'Schoenbach Andreas'; [email-masked]
	Betreff:	RE: PMP> prtChannelEntry -> prtMarkerIndex

	Hi,

	Cheers,
	- Ira McDonald

	-----Original Message-----
	From: Wagner,William [mailto:[email-masked]]
	Sent: Wednesday, September 20, 2000 10:00 AM
	To: 'Schoenbach Andreas'; [email-masked]
	Subject: RE: PMP> prtChannelEntry -> prtMarkerIndex

	Greetings:

	-----Original Message-----
	From: Schoenbach Andreas

	Hello,

	Example:

	Thanks,