Subject: PMP> Updates for IANA Printer MIB

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 25 Jul 2005 09:03:10 -0700

Hi folks,                                          Monday (25 July 2005)

Below are proposed updates for missing 'out-of-band' values to three
textual conventions defined in the IANA-PRINTER-MIB.  These missing
'unknown(2)' values were technical errors in Printer MIB v1 (RFC 1759)
and Printer MIB v2 (RFC 3805).

These updates will allow the new Printer Port Monitor MIB to use a
syntax of PrtChannelTypeTC for the ppmPortProtocolType object (as
recently requested by Bert Wijnen).  These updates should also improve
interoperability among Printer MIB implementations (they are all the
appropriate default values).

After review, these additions should be sent to IANA for registration
in the IANA-PRINTER-MIB by our Designated Experts, Bert Wijnen and Harry
Lewis.

Comments?

Cheers,
- Ira (co-editor of Printer MIB v2)

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

------------------------------------------------------------------------

(1) PrtCoverStatusTC - add
        unknown(2),          -- Not in RFC 1759

(2) PrtChannelTypeTC - add
        unknown(2),          -- Not in RFC 1759

(3) PrtAlertGroupTC - delete

(4) PrtAlertGroupTC - add
        unknown(2),          -- Not in RFC 1759
        -- (2) is reserved for conformance information

---

From: Harry Lewis <[email-masked]>
Date: Tue, 26 Jul 2005 07:50:56 -0600

Does it make sense to have an alert in an "unknown" group? What is the 
reasoning?
This is my only question. The rest of the changes look good.
---------------------------------------------- 
Harry Lewis 
IBM STSM
Chairman - IEEE-ISTO Printer Working Group
http://www.pwg.org
IBM Printing Systems 
http://www.ibm.com/printers
303-924-5337
---------------------------------------------- 

"McDonald, Ira" <[email-masked]> 
Sent by: [email-masked]
07/25/2005 10:03 AM

To
"[email-masked]'" <[email-masked]>
cc

Subject
PMP> Updates for IANA Printer MIB

Comments?

Cheers,