Subject: RE: PMP> Updates for IANA Printer MIB

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 26 Jul 2005 17:02:38 +0200

Inline

Ira suggests these changes:
> ----------
> 
> (1) PrtCoverStatusTC - add
>         unknown(2),          -- Not in RFC 1759
> 
> (2) PrtChannelTypeTC - add
>         unknown(2),          -- Not in RFC 1759
> 
> (3) PrtAlertGroupTC - delete
> 

If we want to get rid of it, then we do NOT delete it.
That may break existing use (possibly existing use by 
people we do not know).

So the best way to get rid of it is to obsolete it.

> (4) PrtAlertGroupTC - add
>         unknown(2),          -- Not in RFC 1759
>         -- (2) is reserved for conformance information
> 

Hope this helps and can be agreed to.

Bert

---

From: "Bergman, Ron" <[email-masked]>
Date: Tue, 26 Jul 2005 08:25:59 -0700

I am not sure why we are now trying to make all these changes to the MIB.
A need was identified to add unknown(2) to PrtChannelTypeTC for the Port
Monitor MIB.  Expanding this request to other TCs is out of scope.  If a
need for these other enums occurs later on they can be added then.  In the
mean time, let's just fix the identified problem.

	Ron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of McDonald,
Ira
Sent: Monday, July 25, 2005 9:03 AM
To: [email-masked]'
Subject: PMP> Updates for IANA Printer MIB

Hi folks,                                          Monday (25 July 2005)

Below are proposed updates for missing 'out-of-band' values to three
textual conventions defined in the IANA-PRINTER-MIB.  These missing
'unknown(2)' values were technical errors in Printer MIB v1 (RFC 1759)
and Printer MIB v2 (RFC 3805).

These updates will allow the new Printer Port Monitor MIB to use a
syntax of PrtChannelTypeTC for the ppmPortProtocolType object (as
recently requested by Bert Wijnen).  These updates should also improve
interoperability among Printer MIB implementations (they are all the
appropriate default values).

After review, these additions should be sent to IANA for registration
in the IANA-PRINTER-MIB by our Designated Experts, Bert Wijnen and Harry
Lewis.

Comments?

Cheers,
- Ira (co-editor of Printer MIB v2)

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

------------------------------------------------------------------------

---

From: "McDonald, Ira" <[email-masked]>
Date: Tue, 26 Jul 2005 10:14:29 -0700

Hi Harry,
 
Please see my note to Bert about my typo.
 
But, yes, like ALL other textual conventions in IANA Printer MIB and Printer
MIB v2
it makes sense to define 'unknown' for the default value of a new row in the
table.
 
Cheers,
- Ira

-----Original Message-----
From: Harry Lewis [mailto:[email-masked]]
Sent: Tuesday, July 26, 2005 9:51 AM
To: McDonald, Ira
Cc: [email-masked]'
Subject: Re: PMP> Updates for IANA Printer MIB

Does it make sense to have an alert in an "unknown" group? What is the
reasoning? 
This is my only question. The rest of the changes look good. 
---------------------------------------------- 
Harry Lewis 
IBM STSM
Chairman - IEEE-ISTO Printer Working Group
http://www.pwg.org
IBM Printing Systems 
http://www.ibm.com/printers
303-924-5337
---------------------------------------------- 

"McDonald, Ira" <[email-masked]> 
Sent by: [email-masked] 

07/25/2005 10:03 AM 

To
"[email-masked]'" <[email-masked]> 

cc

Subject
PMP> Updates for IANA Printer MIB

Comments?

Cheers,