Subject: Re: PMP> RE: Need clarification on the definition of RFC 3805 'prtMarkerLi feCount' object

From: [email-masked]
Date: Sun, 24 Jul 2005 18:15:38 +0000

I agree with Ira's analysis with respect to  prtMarkerLifeCount when the identified unit is 'impressions(7)'. Indeed,  implementations of the several manufacturers I know of increment the impression count on blank impressions specified by the document data stream, whether duplex or simplex. There may be some difference in counting the last side of an  odd-number-of-sides document  printed duplex,  although typically it is not counted. The difference may be whether the last blank side goes though the marker twice.

If the unit were sheets, for example, implementations appear to count a sheet just once regardless of whether it is printed simplex or duplex; however, an argument could be made for counting  a duplex sheet twice at least for some duplexing configurations.The duplexer is regarded as part of the media path, separate from the marker. The duplexer may indeed enter the sheet into the marker twice.

However, I would like to see more standardization/documentation on the handing of color printers, and potential differences between single pass laser and multipass. Although private MIBs may handle it differently, the typical approach to Printer MIB objects is to specify four markers (for a CMYK machine). Is the prtMarkerLifeCount  for one color incremented if that color is not used on a particular impression? There undoubtedly are reasonable guidelines for this, but I haven't seen any documented.

Bill Wagner

-------------- Original message -------------- 

> Hi Tom, 
> 
> Sorry I missed this the first time around. Wasn't sent to PMP 
> mailing list, so it got killed by spam filters. 
> 
> The answer to your question is that both behaviors by duplex 
> printers on a single page job are historically correct 
> (increment by one or increment by two). But your question 
> only makes sense if the PrtMarkerCounterUnitTC chosen unit 
> is 'impressions(7)'. 
> 
> The principal use of PrtMarkerLifeCount is to record use of 
> the marker physical path. A duplex but blank back side 
> _probably_ still went through the duplex path and caused 
> wear on rollers, etc. 
> 
> There is new guidance here. In the PWG Imaging System Counters 
> spec (completed last call and soon to be formally approved), 
> a 'blank impression' MUST be counted in an overall 'Impressions' 
> counter (and also in the separate 'BlankImpressions' counter). 
> Therefore, the best practice for prtMarkerLifeCount using 
> impressions would now be to increment by TWO (not intuitive, 
> I know). 
> 
> Pete Zehler - please put in your two cents here, since it's 
> a question from Xerox - thanks. 
> 
> Cheers, 
> - Ira 
> 
> Ira McDonald (Musician / Software Architect) 
> Blue Roof Music / High North Inc 
> PO Box 221 Grand Marais, MI 49839 
> phone: +1-906-494-2434 
> email: [email-masked] 
> 
> > -----Original Message----- 
> > From: Silver, Thomas [mailto:[email-masked]] 
> > Sent: Sunday, July 24, 2005 8:38 AM 
> > To: [email-masked]; [email-masked]; 
> > [email-masked] 
> > Subject: RE: Need clarification on the definition of RFC 3805 
> > 'prtMarkerLifeCount' object 
> > 
> > 
> > Would you folks kindly respond to this issue please? 
> > Thanks, 
> > Tom 
> > 
> > -----Original Message----- 
> > From: Thomas Silver [mailto:[email-masked]] 
> > Sent: Friday, July 15, 2005 7:52 AM 
> > To: [email-masked]; [email-masked]; 
> > [email-masked] 
> > Cc: Silver, Thomas 
> > Subject: Need clarification on the definition of RFC 3805 
> > 'prtMarkerLifeCount' object 
> > 
> > Hi folks, 
> > 
> > Would you mind clarifying the definition of the 'prtMarkerLifeCount' 
> > object as defined by RFC 3805 - Printer MIB v2? 
> > 
> > I've spoken w/ some individuals who believe that the 
> > 'prtMarkerLifeCount' 
> > object is supposed to represent the total number of units 
> > marked by the 
> > imaging module (i.e. only increment the count by 1 whenever marks are 
> > put on a side of paper when units = impressions). Others believe that 
> > this object is supposed to represent the total number of units that 
> > degrade the life of the imaging module (i.e. blank sheets degrade the 
> > life of a print cartridge even though no marks were made on a side of 
> > paper, assuming units=impressions, and therefore need to be 
> > counted). In 
> > other words, on some duplex-enabled printers, if you submit a 
> > single-page document, the 'prtMarkerLifeCount' object will be 
> > incremented by a value of 2 while on other duplex-enabled 
> > printers, the 
> > 'prtMarkerLifeCount' object will be incremented by a value of 1. Which 
> > is correct? 
> > 
> > Thanks in advance for the clarification, 
> > 
> > Tom :-) 
> > 
> > System Engineer 
> > CWW/XDM/MMC Console Development 
> > XGS\GD&D\GD\SE&PM 
> > [email-masked] 
> > 8*222-7219/585-422-7219 
> >

---

From: [email-masked]
Date: Sun, 24 Jul 2005 18:21:56 +0000

I think this query brings up an interesting question about "author" references. Insofar as interest in an RFC or  PWG document may outlive the participation of the individual authors, would it be reasonable to put the working group/mailing list as an author and contact? Or at least to indicate that queries should be addressed to the WG mailing list?

Bill Wagner