Subject: PMP> RE: Need clarification on the definition of RFC 3805 'prtMarkerLifeCount' object

From: "Zehler, Peter" <[email-masked]>
Date: Mon, 25 Jul 2005 08:31:39 -0400

Ira,

Although both behaviors are historically correct I believe the object is
supposed to represent the total number of units that degrade the life of
the imaging module.  It is this definition that is embraced very
specifically by the "PWG Imaging System Counters Specification".  As you
know the total impressions explicitly includes blank impressions as well
as full color, highlight color and mono color impressions.  The counter
spec has standardized on the unit impression for marking at the service
level.  It is an implementation specific decision on how to map device
specific measurements of distance (e.g. feet), time (e.g. hours) or
characters to impression.

Pete

Peter Zehler 
XEROX 
Xerox Innovation Group 
Email: [email-masked] 
Voice:    (585) 265-8755 
FAX:      (585) 265-7441 
US Mail: Peter Zehler
Xerox Corp. 
        800 Phillips Rd. 
        M/S 128-25E 
Webster NY, 14580-9701 

-----Original Message-----
From: McDonald, Ira [mailto:[email-masked]] 
Sent: Sunday, July 24, 2005 12:23 PM
To: Silver, Thomas; McDonald, Ira; [email-masked];
[email-masked]; Zehler, Peter; [email-masked]'
Subject: RE: Need clarification on the definition of RFC 3805
'prtMarkerLifeCount' object

Hi Tom,

Sorry I missed this the first time around.  Wasn't sent to PMP mailing
list, so it got killed by spam filters.

The answer to your question is that both behaviors by duplex printers on
a single page job are historically correct (increment by one or
increment by two).  But your question only makes sense if the
PrtMarkerCounterUnitTC chosen unit is 'impressions(7)'.

The principal use of PrtMarkerLifeCount is to record use of the marker
physical path.  A duplex but blank back side _probably_ still went
through the duplex path and caused wear on rollers, etc.

There is new guidance here.  In the PWG Imaging System Counters spec
(completed last call and soon to be formally approved), a 'blank
impression' MUST be counted in an overall 'Impressions'
counter (and also in the separate 'BlankImpressions' counter).
Therefore, the best practice for prtMarkerLifeCount using impressions
would now be to increment by TWO (not intuitive, I know).

Pete Zehler - please put in your two cents here, since it's a question
from Xerox - thanks.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect) Blue Roof Music / High
North Inc PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: Silver, Thomas [mailto:[email-masked]]
> Sent: Sunday, July 24, 2005 8:38 AM
> To: [email-masked]; [email-masked]; 
> [email-masked]
> Subject: RE: Need clarification on the definition of RFC 3805 
> 'prtMarkerLifeCount' object
> 
> 
> Would you folks kindly respond to this issue please? 
> Thanks,
> Tom
> 
> -----Original Message-----
> From: Thomas Silver [mailto:[email-masked]]
> Sent: Friday, July 15, 2005 7:52 AM
> To: [email-masked]; [email-masked]; 
> [email-masked]
> Cc: Silver, Thomas
> Subject: Need clarification on the definition of RFC 3805 
> 'prtMarkerLifeCount' object
> 
> Hi folks,
> 
> Would you mind clarifying the definition of the 'prtMarkerLifeCount'
> object as defined by RFC 3805 - Printer MIB v2?
> 
> I've spoken w/ some individuals who believe that the 
> 'prtMarkerLifeCount'
> object is supposed to represent the total number of units marked by 
> the imaging module (i.e. only increment the count by 1 whenever marks 
> are put on a side of paper when units = impressions). Others believe 
> that this object is supposed to represent the total number of units 
> that degrade the life of the imaging module (i.e. blank sheets degrade

> the life of a print cartridge even though no marks were made on a side

> of paper, assuming units=impressions, and therefore need to be 
> counted). In other words, on some duplex-enabled printers, if you 
> submit a single-page document, the 'prtMarkerLifeCount' object will be

> incremented by a value of 2 while on other duplex-enabled printers, 
> the 'prtMarkerLifeCount' object will be incremented by a value of 1. 
> Which is correct?
> 
> Thanks in advance for the clarification,
> 
> Tom :-)
> 
> System Engineer
> CWW/XDM/MMC Console Development
> XGS\GD&D\GD\SE&PM
> [email-masked]
> 8*222-7219/585-422-7219
>

---

From: Harry Lewis <[email-masked]>
Date: Tue, 26 Jul 2005 21:09:08 -0600

How is a continuous forms device supposed to convert from feet to 
impressions? This does not sound feasible. This would imply shared 
knowledge, on a job basis, between the mechanism and the RIP. I think this 
is unlikely. Especially, during NPRO or forms alignment, it would likely 
become a totally arbitrary choice.
---------------------------------------------- 
Harry Lewis 
IBM STSM
Chairman - IEEE-ISTO Printer Working Group
http://www.pwg.org
IBM Printing Systems 
http://www.ibm.com/printers
303-924-5337
---------------------------------------------- 

"Zehler, Peter" <[email-masked]> 
Sent by: [email-masked]
07/25/2005 06:31 AM

To
"McDonald, Ira" <[email-masked]>, "Silver, Thomas" 
<[email-masked]>, Harry Lewis/Boulder/IBM@IBMUS, 
<[email-masked]>, <[email-masked]>
cc

Subject
PMP> RE: Need clarification on the definition of RFC 3805 
'prtMarkerLifeCount' object

Ira,

Pete

Peter Zehler 
XEROX 
Xerox Innovation Group 

-----Original Message-----
From: McDonald, Ira [mailto:[email-masked]] 
Sent: Sunday, July 24, 2005 12:23 PM
To: Silver, Thomas; McDonald, Ira; [email-masked];

Hi Tom,

Cheers,
- Ira