Subject: PMP> RE: Need clarification on the definition of RFC 3805 'prtMarkerLi feCount' object

From: "McDonald, Ira" <[email-masked]>
Date: Sun, 24 Jul 2005 09:22:52 -0700

Hi Tom,

Sorry I missed this the first time around.  Wasn't sent to PMP
mailing list, so it got killed by spam filters.

The answer to your question is that both behaviors by duplex
printers on a single page job are historically correct 
(increment by one or increment by two).  But your question
only makes sense if the PrtMarkerCounterUnitTC chosen unit
is 'impressions(7)'.

The principal use of PrtMarkerLifeCount is to record use of
the marker physical path.  A duplex but blank back side 
_probably_ still went through the duplex path and caused
wear on rollers, etc.

There is new guidance here.  In the PWG Imaging System Counters
spec (completed last call and soon to be formally approved),
a 'blank impression' MUST be counted in an overall 'Impressions'
counter (and also in the separate 'BlankImpressions' counter).
Therefore, the best practice for prtMarkerLifeCount using
impressions would now be to increment by TWO (not intuitive,
I know).

Pete Zehler - please put in your two cents here, since it's
a question from Xerox - thanks.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: Silver, Thomas [mailto:[email-masked]]
> Sent: Sunday, July 24, 2005 8:38 AM
> To: [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: Need clarification on the definition of RFC 3805
> 'prtMarkerLifeCount' object
> 
> 
> Would you folks kindly respond to this issue please? 
> Thanks,
> Tom 
> 
> -----Original Message-----
> From: Thomas Silver [mailto:[email-masked]] 
> Sent: Friday, July 15, 2005 7:52 AM
> To: [email-masked]; [email-masked];
> [email-masked]
> Cc: Silver, Thomas
> Subject: Need clarification on the definition of RFC 3805
> 'prtMarkerLifeCount' object
> 
> Hi folks,
> 
> Would you mind clarifying the definition of the 'prtMarkerLifeCount'
> object as defined by RFC 3805 - Printer MIB v2?
> 
> I've spoken w/ some individuals who believe that the
> 'prtMarkerLifeCount'
> object is supposed to represent the total number of units 
> marked by the
> imaging module (i.e. only increment the count by 1 whenever marks are
> put on a side of paper when units = impressions). Others believe that
> this object is supposed to represent the total number of units that
> degrade the life of the imaging module (i.e. blank sheets degrade the
> life of a print cartridge even though no marks were made on a side of
> paper, assuming units=impressions, and therefore need to be 
> counted). In
> other words, on some duplex-enabled printers, if you submit a
> single-page document, the 'prtMarkerLifeCount' object will be
> incremented by a value of 2 while on other duplex-enabled 
> printers, the
> 'prtMarkerLifeCount' object will be incremented by a value of 1. Which
> is correct?
> 
> Thanks in advance for the clarification,
> 
> Tom :-)
> 
> System Engineer
> CWW/XDM/MMC Console Development
> XGS\GD&D\GD\SE&PM
> [email-masked]
> 8*222-7219/585-422-7219
>

---

From: Harry Lewis <[email-masked]>
Date: Sun, 24 Jul 2005 17:26:28 -0600

It is actually a very interesting question if you seek a consistent answer 
for all prtMarkerCounterUnitTC types. The way we look at it for 
impressions and feet (the two most likely units) probably falls apart for 
characters. It makes sense to count a blank sheet-side because of wear due 
to path traversal but probably doesn't make sense to add a blank character 
to prtMarkerLifeCount (unit=character). Also, the role of a single "dot" 
is less absurd for characters than for impressions if we had to define 
what it means for the unit to be marked vs blank. So... the rule is to 
count blank(s) (impressions, feet etc.) and I suggest characters are an 
exception. 

For impressions (the unit you asked about), I agree with Ira (increment by 
2)  _unless_ the printer is capable of not recirculating single impression 
sheets within a duplex job.  I think most (cut-sheet) printers recirculate 
all sheets when the job is in duplex mode which, I'm sure, is the basis 
for Ira's answer. 
---------------------------------------------- 
Harry Lewis 
IBM STSM
Chairman - IEEE-ISTO Printer Working Group
http://www.pwg.org
IBM Printing Systems 
http://www.ibm.com/printers
303-924-5337
---------------------------------------------- 

"McDonald, Ira" <[email-masked]> 
07/24/2005 10:22 AM

To
"'Silver, Thomas'" <[email-masked]>, "McDonald, Ira" 
<[email-masked]>, Harry Lewis/Boulder/IBM@IBMUS, 
[email-masked], "'Zehler, Peter'" 
<[email-masked]>, "[email-masked]'" <[email-masked]>
cc

Subject
RE: Need clarification on the definition of RFC 3805 'prtMarkerLi feCount' 
object

Hi Tom,

Cheers,
- Ira