Subject: [proto-team] I-D Tracker Extensions

From: Brian E Carpenter <[email-masked]>
Date: Wed, 05 Apr 2006 11:26:00 +0200

PROTO team,

I hate to nag, but we have an item fairly high on the tool request
list called "Extensions to the I-D Tracker (to allow the working
group chairs to use the Tracker)". But before anything can happen,
we need your input.

- what new tracker states are needed?
- what new actions need to be available for WG chairs (and secretaries)?
- what's the minimum acceptable authorization model?
- will the WG chairs see the same view as the ADs, or will
it be a third view?

and no doubt other questions.

Also, important point, the IAB Chair and Executive Director will need
to be able to shepherd IAB drafts - presumably that can be included
at the same time?

      Brian

_______________________________________________
proto-team mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/proto-team

---

From: Allison Mankin <[email-masked]>
Date: Wed, 05 Apr 2006 04:21:21 -0700

Brian,

Henrik and I have done a few iterations of this with
Ray looking on, and as of yesterday Henrik is waiting for me 
to look at  the last one before we send it to the PROTO team.

We originally had a section in it on IAB and IRTF
drafts - I've suggested it be a separate document which
we should launch to those folks at the same time (Henrik?)
because the IAB and IRTF/IRSG are likely to have to hash 
their document state diagrams a bit and it would be nice
not to have to wait for them for all the work.

Allison

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 05 Apr 2006 15:22:59 +0200

> to look at  the last one before we send it to the PROTO team.

Excellent. I just don't want this to slip down the queue for
lack of requirements.
> not to have to wait for them for all the work.

Well, OK, but it would be good to get it all done as one effort.

Thanks

     Brian

---

From: Allison Mankin <[email-masked]>
Date: Wed, 05 Apr 2006 07:11:22 -0700

Brian,

> Excellent. I just don't want this to slip down the queue for

I'll ask Ray to speak to this - Henrik and I put this on a fast track
because Ray said this could be a high priority.  Are we still on
track, Ray?  

> Well, OK, but it would be good to get it all done as one effort.

My comment said launch at the same time.

Henrik, can we start up the second IAB/IRTF draft?  The final
section of markup I gave on our first draft is fine for that
short draft, and I can do a cut in there to refine it again, especially
needing to fix up the IRTF part, based on Aaron's process doc.  
I just think we need to run that doc in parallel.

Allison

---

From: Allison Mankin <[email-masked]>
Date: Wed, 05 Apr 2006 07:41:17 -0700

> Yes, we are in the process of prioritizing NSS development work and this 
> is a HiPri.
> BTW the doc seems to define new states but not actions.  Is that to be 
> left to NSS to determine?
> Ray

The way tracker updates have been done in the past is that the
the state names and the actions and behavior have been determined
by us.  The document does cover the actions where it talks about
about access groups, restrictions on some actions
and so on.  I think we probably have enough detail - we've tended
not to give any input on new user interface for new actions, just
feedback once it came in.  

But I hope that NSS will support a collaborative work style
for this update to the tracker as in previous large updates, with
a lot of interaction and feedback from a small group of early
users, including the PROTO team.

I think we should give the document to the rest of the team for
their review.  Henrik and I have been writing it.

> --------------040005040707050004000509
> Content-Type: text/html; charset=us-ascii
> Content-Transfer-Encoding: 7bit
> 
> <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
> <html>
> <head>
>   <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
>   <title></title>
> </head>
> <body bgcolor="#ffffff" text="#000000">
> <br>
> <br>
> Allison Mankin wrote:<br>
> <blockquote
>  cite="[email-masked]"
>  type="cite">
>   <pre wrap="">Brian,
> 
>   </pre>
>   <blockquote type="cite">
>     <pre wrap="">Allison Mankin wrote:
>     </pre>
>     <blockquote type="cite">
>       <pre wrap="">Brian,
> 
>       </pre>
>     </blockquote>
>     <pre wrap="">Excellent. I just don't want this to slip down the queue for
> lack of requirements.
>     </pre>
>   </blockquote>
>   <pre wrap=""><!---->
>   </pre>
> </blockquote>
> Yes, we are in the process of prioritizing NSS development work and
> this is a HiPri.<br>
> BTW the doc seems to define new states but not actions.&nbsp; Is that to be
> left to NSS to determine?<br>
> Ray<br>
> <blockquote
>  cite="[email-masked]"
>  type="cite">
>   <pre wrap="">
>   </pre>
>   <blockquote type="cite">
>     <blockquote type="cite">
>       <pre wrap="">We originally had a section in it on IAB and IRTF
>       </pre>
>     </blockquote>
>     <pre wrap="">Well, OK, but it would be good to get it all done as one effor
> t.
>     </pre>
>   </blockquote>
>   <pre wrap=""><!---->
>   </pre>
> </blockquote>
> </body>
> </html>
> --------------040005040707050004000509--

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 06 Apr 2006 10:01:43 +0200

Allison Mankin wrote:
...
> users, including the PROTO team.

Sure, for a highly interactive tool like this, feedback
on action buttons can only come when there's a prototype.
But don't the possible actions need to be defined at
an abstract level?

    Brian

---

From: Ray Pelletier <[email-masked]>
Date: Wed, 05 Apr 2006 10:30:13 -0400