Subject: [proto-team] Re: Adding IETF tracker support for IAB and IRTF document shepherds

From: David Meyer <[email-masked]>
Date: Wed, 10 May 2006 07:45:39 -0700

On Wed, May 10, 2006 at 07:14:32AM -0700, Allison Mankin wrote:
> Hi, IAB,
> 
> The PROTO team has drafted some proposed requirements for login access and
> tracking states for IAB and IRTF document shepherds using the IETF
> draft tracker.  We did this because there will be a big update to
> the tracker to allow WG Chair shepherds to log in and do their work
> in the tracker with new states supporting them (e.g. Working Group
> Last Call) and new underlying access control, and we thought it
> would make sense to provide support for you at the same time.
> 
> We've submitted a proto-team i-d, but until it pops out, you can find the
> text at:
> 
> http://www1.tools.ietf.org/wg/proto/draft-ietf-proto-iab-irtf-tracker-ext/draft-ietf-proto-iab-irtf-tracker-ext-00.txt
> 
> It's very short.  Could folks read it and give us feedback?  

	Allison/Henrik,

	Quick question on section 2.1: 

	It looks like the only transitions (Possible next states)
	available from the "Active IAB Document" state are
	"Parked IAB Document", "Dead". Seems like we should be
	able to transition to "In IAB Internal Last Call" from
	"Active IAB Document".  
	
	This is on the theory that a succesful IAB document would
	(roughly) follow the following states (with attendant
	poor ascii drawing; "permitted substates in the states
	following  "Active IAB Document" are shorthand for the
	first one; i.e., you can iterate around in the permitted
	substates; there are other transitions too, as you note):

                                             +---------------+
                                             |               |
                                            \|/              |
	 Active IAB Document --------> permitted substates --+
                                             |
                                             |
                +----------------------------+
                |
                |
                |
               \|/                           
         In IAB Internal Last Call --> permitted substates ---+
                                                              |
                +---------------------------------------------+
                |
               \|/ 
         In IAB Community Review   --> permitted substates ---+
                                                              |
                +---------------------------------------------+
                |
               \|/
	 RFC Ed Queue

	Or am I not understanding the notation used section 2.1?

	Thanks,

	--dmm

_______________________________________________
proto-team mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/proto-team

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 10 May 2006 17:57:56 +0200

Hi David,

> 	able to transition to "In IAB Internal Last Call" from

I think you're quite right.  Fixed in my source.

Regards,

	Henrik