Subject: RE: Definition of "External" Host

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 9 Oct 2002 07:29:11 -0400

> The sentence you quoted seems OK if the terms "management 
> authority" and
> "repository" are precisely defined. It is not a problem if 
> the repository is
> the whole TLD and the management authority is the TLD 
> registry operator.
> However, it is getting complicated when delegation of name 
> spaces occurs
> under the same TLD in 3rd level and up.
> 
> Maybe an example will help explain my point. Suppose we have 
> a TLD .tld with
> two 3rd level delegations del1.tld and del2.tld. So there are 
> three disjoint
> name spaces under .tld: del1.tld, del2.tld and anything else 
> under .tld.
> These three name spaces have different registration policies. 
> They may also
> share some common registration policies.
> 
> If I understand correctly, .tld, .del1.tld, and .del2.tld are 
> considered as
> three separate "repositories". If not, please ignore the rest of the
> message.

My contention is that they are all under the same ultimate management
authority and part of the same repository because they are all part of the
same TLD branch.

Think of it this way: should I or should I not be publishing glue records
for hosts registered under these domains?  If the answer is "yes", they are
not external hosts.  If the answer is "no", they are external hosts.

-Scott-

---

From: "Jim Fleming" <[email-masked]>
Date: Wed, 9 Oct 2002 08:07:15 -0500

----- Original Message ----- 
From: "Hollenbeck, Scott" <[email-masked]>
To: "'Liu, Hong'" <[email-masked]>; <[email-masked]>
Sent: Wednesday, October 09, 2002 6:29 AM
Subject: RE: Definition of "External" Host

> not external hosts.  If the answer is "no", they are external hosts.

Glue is the clue, but, it may not be that simple. You have to consider whether it is the
32-bit DNS or the 128-bit DNS. There are not many glue record services for the 32-bit DNS.
Also, if there are Mirrored Registries for the TLD in the 32-bit DNS, to prevent having
a single-point-of-corporate-failure, AND to allow transitions from a censored regime to
an open regime, then you might have a situation where one of the TLD Registries only has
a few SLD names, and the new TLD Registry could have all of those SLD names, plus all
of the new ones being added. Couple that with the 128-bit front-end Registry, with all of the
128-bit DNS AAAA Record Glue Control Services, and it is not so simple.

Glue is the clue...

128-bit DNS AAAA Record Flag Day Formats
2002:[IPv4]:[SDLL.OFFF.FFFF.TTTT]:[64-bit IPv8 or IPv16 Persistent Address]
[YMDD]:[IPv4]:[SDLL.OFFF.FFFF.TTTT]:[64-bit IPv8 or IPv16 Persistent Address]
1-bit to set the Reserved/Spare ("SNOOPY") bit in Fragment Offset [S]
1-bit to set the Don't Fragment (DF) bit [D]
2-bits to select 1 of 4 common TTL values (255, 128, 32, 8) [LL]
1-bit for Options Control [O]
7-bits to set the Identification Field(dst) [FFFFFFF]
4-bits to set the TOS(dst) Field [TTTT]
Default SDLL.OFFF.FFFF.TTTT = 0000.0000.0000.0000
FFF.FFFF.TTTT = GGG.SSSS.SSSS
http://www.ntia.doc.gov/ntiahome/domainname/130dftmail/unir.txt
IPv8
0QQQQGGGSSSSSSSS[32-bits][Port]
IPv16
0QQQQGGGSSSSSSSS[32-bits][Port]
1WWWWWWWSSSSSSSS[32-bits][Port]

Jim Fleming
2002:[IPv4]:000X:03DB:...IPv8 is closer than you think...IPv16 is even closer...
http://www.ietf.com
http://www.iana.org/assignments/ipv4-address-space
http://www.ntia.doc.gov/ntiahome/domainname/130dftmail/unir.txt
http://ipv8.dyndns.tv
http://ipv8.dyns.cx
http://ipv8.no-ip.com
http://ipv8.no-ip.biz
http://ipv8.no-ip.info
http://ipv8.myip.us
http://ipv8.dyn.ee
http://ipv8.community.net.au

---

From: Eric Brunner-Williams in Portland Maine <[email-masked]>
Date: Wed, 09 Oct 2002 20:48:45 -0400

Scott,

It appears to me that there is some confusion concerning the following:

	1. the existance distinct policies scoped to the presence
	   (or absence) of infix dots, viz:
	  	*.a.z	policy "az",
	   	*.b.z	policy "bz",
	   	*.z	policy " z",

	2. the delegation of authoritative publication requirements,
	    viz:
	    	existence of glue records for nameservers (aka "hosts"),

	3. distinct instances of EPP servers.

In the context of the channel capacity of a single BEEP session I discussed
the possibility of a single TCP connection servicing the command/response
exchanges of two EPP endpoints conducting transactions against distinct
registries. This was in an exchange with Sheer El-Showk, back in August of
'01. That is what caught my limited attention in this exchange -- operators
with multiple policies and possibly using some mechanism other than distinct
endpoints to distinguish between policy scopes.

Comments:

New.Net marketed infix dots without delegation, and some other operators
may similarly market infix w/o delegation. Utility arguements for infix
dots w/o delegation are outside of our scope. This is fortunate for me,
as I can't think of any off-hand.

The text in -5 (host) at 2.5 isn't quite consistent with the text at 3.2,
the first has "SHOULD be required only as needed", the second a "REQUIRED
only as needed". However, we missed the point of using stub zones to
obviate the need for glue NS records in a parent zone.

I'd appreciate it if the discussion were less hypothetical, and some of
the discussion conducted in master file format.

Eric