Subject: Re: ATM encap sequence number processing

From: "W. Mark Townsley" <[email-masked]>
Date: Wed, 30 Oct 2002 10:07:01 -0800

As the documents seem to be written now, your suggestions on sequencing will 
need to be applied and reconciled with the atm document, the frame relay 
document, the ethernet document, the hdlc document... etc.

Why not have a single place that defines the default control word used for PW 
over MPLS, together with the associated recommendations for how to handle the 
sequence numbers? If there is a special case for a specific PW type, it may be 
defined in a specific document, but I think we would be well-served by a base 
case defined in a single location.

- Mark

Yaakov Stein wrote:
> I have two comments regarding
> section 4.1.2. "Processing the sequence number"
> in the recently released draft-ietf-pwe3-atm-encap
> document.
> 
> 1) The following is stated
>   "If a packet passes the sequence number check,
>   or is in order then, it can be delivered immediately."
> where in order is defined as
>   "if the packet sequence number >= the expected sequence number"
> 
> This is contradiction with the later statement that
> reordering may be employed at the discretion of the receiver.
> 
> If the sequence number is > the expected sequence number
> and this packet is shipped out, reordering is no longer
> possible.
> 
> The wording should either read
>  "If a packet passes the sequence number check,
>   or is in order then, it MAY be delivered immediately."
> where the MAY refers to the case that reordering is not
> used.  Otherwise the condition could be changed to
>   "if the packet sequence number equals the expected sequence number"
> 
> In addition, the following is stated
>   "When an emulated VC is initially set up, the "expected sequence
>    number" associated with it MUST be initialized to 1."
> I assume that this means that the first sequence number transmitted
> should also be set to one. This may raise security issues.
> Perhaps it should be set to a random non-zero number.
> 
> Y(J)S
> 
> 
>

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 31 Oct 2002 00:02:20 +0000

W. Mark Townsley wrote:
> 
> As the documents seem to be written now, your suggestions on sequencing 
> will need to be applied and reconciled with the atm document, the frame 
> relay document, the ethernet document, the hdlc document... etc.
> 
> Why not have a single place that defines the default control word used 
> for PW over MPLS, together with the associated recommendations for how 
> to handle the sequence numbers? If there is a special case for a 
> specific PW type, it may be defined in a specific document, but I think 
> we would be well-served by a base case defined in a single location.
> 

Yaakov started in that direction with:

draft-stein-pwe3-controlword-00.txt

The inconsistencies that be points out should be corrected.

Initialising the sequence number is clean, but the worst that
will happen if it is omitted (which may be easier for some
implementations) is a short startup transient, which will
be quickly corrected. I see no reason to make it "MUST be
initialised to 1".

Stewart

> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 
>