Subject: RE: One for All was : RE: comments on draft-ietf-pwe3-requirements-03.txt

From: "Ron Cohen" <[email-masked]>
Date: Sun, 6 Oct 2002 17:08:18 +0200

I'd like to clarify my point here:

I think the right approach would be to have a thorough review of the
requirement document for packet/cell/circuit service emulation. Most
sections within the requirement document are applicable to all these
services. There should be a healthy balance between the generality of
the requirements and description of service specific issues. 

The service specific issues, for either the packet/cell/circuit service
emulation types, should be discussed in the service specific drafts. If
TDM circuit emulation requires another draft that detail TDM specific
issues, than this draft should only elaborate requirements that are
specific to TDM emulation.

Bottom line is that we should find the right process such that the
requirement document:

A. Covers all service types (packet/cell/circuit)
B. Advance without delay due to requirements that are service specific.

Regards
Ron

> Ron and all,
> I agree that a single document would be preferable because
> maintaining two separate requirements documents carries with 
> it some overhead both for the authors and for the readers.
> 
> On the other hand, if we decide to go on with two documents,
> (as seems to be the case) we should be ready to pay for this 
> overhead in full. E.g., relationships between the two 
> documents should be clearly stated in both, they should be 
> both checked for possible contradictions etc.
> 
> With best regards,
>                                    Sasha Vainshtein
> email:     [email-masked] <mailto:[email-masked]> 
> tel:       +972-3-7659993 (office)
>            +972-8-9254948 (res.)
>            +972-58-674833 (cell.)
>  
> 
> 
> > -----Original Message-----
> > From: Ron Cohen [mailto:[email-masked]]
> > Sent: Thursday, October 03, 2002 10:56 PM
> > To: [email-masked]; [email-masked]
> > Subject: One for All was : RE: [PWE3] comments on 
> > draft-ietf-pwe3-requirements-03.txt
> > 
> > 
> > 
> > I would prefer having a single requirement document that covers all
> > emulation service types, and not separate the TDM piece out. The 
> > requirement document may need to be cleaned up a bit, as Sasha 
> > remarked, but its basically ready. Service specific requirements and
> > the way they
> > are addressed should be handled in the service specific documents.
> > 
> > Ron
> > 
> > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]] On Behalf 
> > > Of Danny McPherson
> > > Sent: Thursday, October 03, 2002 7:15 PM
> > > To: [email-masked]
> > > Subject: Re: [PWE3] comments on
> draft-ietf-pwe3-requirements-03.txt
> > > 
> > > 
> > > 
> > > 
> > > > For my clarification, does it mean that we will have
> requirements
> > > > documents for each service separately?
> > > >
> > > > - TDM services
> > > > - Ethernet private line services
> > > 
> > > Packet/Cell/Frame/Base
> > > TDM (for lack of a more appropriate term?)
> > > 
> > > -danny
> > > 
> > > _______________________________________________
> > > pwe3 mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/pwe3
> > > 
> > 
> > 
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> > 
>

---

From: Max Riegel <[email-masked]>
Date: Sun, 06 Oct 2002 19:31:16 +0200

I agree, it doesn't make much sense to have a totally separate requirement 
draft for each service.
Already the current TDM requirements draft is based on the general pwe3 
requirements draft making references to the general pwe3 requirements where 
possible thus trying to focus on TDM specific requirements in addition to 
the requirements stated in pwe3-requirements.

My understanding of the process was that the TDM requirement draft was 
always aimed in addition to the pwe3-requirements draft for service 
specific issues.

Keeping problem spaces apart might help speeding up the agreement process.

Bye
Max

At 06.10.2002 17:08 +0200, Ron Cohen wrote:

> > > > Subject: Re: [PWE3] comments on draft-ietf-pwe3-requirements-03.txt
> > > >
> > > >
> > > >
> > > >
> > > > > For my clarification, does it mean that we will have requirements