Subject: [PWE3] I-D ACTION:draft-ietf-pwe3-arch-00.txt

From: [email-masked]
Date: Thu, 17 Oct 2002 07:34:27 -0400

- --NextPart

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Pseudo Wire Emulation Edge to Edge Working Group of the IETF.

	Title		: PWE3 Architecture
	Author(s)	: S. Bryant, P. Pate
	Filename	: draft-ietf-pwe3-arch-00.txt
	Pages		: 42
	Date		: 2002-10-16
	
This document describes an architecture for Pseudo Wire Emulation
Edge-to-Edge (PWE3).  It discusses the emulation of services (such as
Frame Relay, ATM, Ethernet TDM and SONET/SDH) over packet switched
networks (PSNs) using IP or MPLS.  It presents the architectural
framework for pseudo wires (PWs), defines terminology, specifies the
various protocol elements and their functions.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-pwe3-arch-00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-pwe3-arch-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-pwe3-arch-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

- --NextPart
Content-Type: Multipart/Alternative; Boundary="OtherAccess"

- --OtherAccess
Content-Type: Message/External-body;
	access-type="mail-server";
	server="[email-masked]"

---

From: Sasha Vainshtein <[email-masked]>
Date: Thu, 17 Oct 2002 18:47:41 +0200

Stewart and all,
Please see one brief comment inline.

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> -----Original Message-----
> From: Stewart Bryant [mailto:[email-masked]]
> Sent: Thursday, October 17, 2002 5:43 PM
> To: [email-masked]
> Subject: Re: FW: [PWE3] I-D ACTION:draft-ietf-pwe3-arch-00.txt
> 
> 
> Any appropriate feedback received by the 1st November
> will go into a revised draft to be submitted by
> 4th November.
> 
> My aim is that we discuss issues associated with
> draft-ietf-pwe3-arch-01.txt at Atlanta.
> 
> One particular item we would like feedback on is whether
> terminology lives in the arch draft or whether we develop
> draft-bryant-pwe3-terms-00.txt (or similar) into a WG
> document.
>
IMHO keeping the terminology and the architecture document
together has a definite practical advantage both for the readers
and for the editors. E.g., some terms can be really understood
only if illustrated by a reference model diagram etc. 
>
> Stewart
> 
> 
> 
> Danny McPherson wrote:
> > Folks,
> > Notice that this document is a superset of the framework & 
> > PLD documents.  We'd like to progress to WG Last Call just 
> > after the Atlanta meeting so please provide feedback ASAP.
> > 
> > Thanks!
> > 
> > -danny
> > 
> > ------- Forwarded Message
> > 
> > 
> > To: IETF-Announce: ;
> > Cc: [email-masked]
> > From: [email-masked]
> > Date: Thu, 17 Oct 2002 07:34:27 -0400
> > Subject: [PWE3] I-D ACTION:draft-ietf-pwe3-arch-00.txt
> > 
> > - --NextPart
> > 
> > Content-Type: text/plain
> > Content-ID:	<[email-masked]>
> > 
> > ENCODING mime
> > FILE /internet-drafts/draft-ietf-pwe3-arch-00.txt
> > 
> > - --OtherAccess
> > 	name="draft-ietf-pwe3-arch-00.txt";
> > 	site="ftp.ietf.org";
> > 	access-type="anon-ftp";
> > 	directory="internet-drafts"
> > 
> > Content-Type: text/plain
> > Content-ID:	<[email-masked]>
> > 
> > - --OtherAccess--
> > 
> > - --NextPart--
> > 
> > 
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> > 
> > ------- End of Forwarded Message
> > 
> > 
> > 
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> > 
> > 
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: Danny McPherson <[email-masked]>
Date: Thu, 17 Oct 2002 15:44:10 -0600

> I got the impression in Yokohama that we would have a 
> separate terminology document for the WG. Yours is the 
> only submission I am aware of.

That was the idea but the intention was simply to 
provide as single place to list all the terms.

I tend to agree that the arch document is the place 
to define terms not already defined in the requirements
document.

-danny

---

From: "Ron Cohen" <[email-masked]>
Date: Wed, 23 Oct 2002 00:26:47 +0200

Hi,

I have a small remark regarding the bit-stream text:

The current text reads:

3.3.3.  Bit-stream

   A bit-stream payload is created by capturing, transporting and
   replaying the bit pattern on the emulated wire, without taking
   advantage of any structure that, on inspection, may be visible within
   the relayed traffic (i.e. the internal structure has no effect on the
   fragmentation into packets).  The Encapsulation Layer submits an
   identical number of bits for transport in each PW-PDU.

I suggest to remove the last sentence. 

Here is the reason. When using SONET/SDH emulation for carrying
T1/E1/T3/E3 bit streams, the difference in clocks between the SONET/SDH
and the tributary clock may cause a packet to carry a different number
of bit stream payload bits. This does not require any knowledge of the
content of the bit stream, and therefore qualify as unstructured bit
stream delivery.

Thanks
Ron 

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Danny McPherson
> Sent: Thursday, October 17, 2002 5:25 PM
> To: [email-masked]
> Subject: FW: [PWE3] I-D ACTION:draft-ietf-pwe3-arch-00.txt
> 
> 
> 
> Folks,
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories. This draft is a work item of the 
> Pseudo Wire Emulation Edge to Edge Working Group of the IETF.
> 
> This document describes an architecture for Pseudo Wire 
> Emulation Edge-to-Edge (PWE3).  It discusses the emulation of 
> services (such as Frame Relay, ATM, Ethernet TDM and 
> SONET/SDH) over packet switched networks (PSNs) using IP or 
> MPLS.  It presents the architectural framework for pseudo 
> wires (PWs), defines terminology, specifies the various 
> protocol elements and their functions.
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username "anonymous" and a password of your e-mail 
> address. After logging in, type "cd internet-drafts" and then
> Below is the data which will enable a MIME compliant mail 
> reader implementation to automatically retrieve the ASCII 
> version of the Internet-Draft.
> 
> - --NextPart