Subject: Re: comments on draft-ietf-pwe3-requirements-03.txt

From: "W. Mark Townsley" <[email-masked]>
Date: Thu, 03 Oct 2002 08:03:44 +0200

Thomas D. Nadeau wrote:
> 
>>
>> 4.6.  Pseudo-Wire Traceroute
>>
>>    It can be desirable to know the exact path of a PW, especially for
>>    troubleshooting purpose. A PW emulation service MUST support PW
>>    traceroute.
>>
>> SB> Wow, you need to be very careful here. I think that if you
>> SB> only have access to a TDM circuit, figuring how it got
>> SB> across the PSN is pretty tough. It also breaks the transparancy
>> SB> of the wire. This needs to be re-written or deleted.
> 
> 
>         Given the operational requirements that I have seen,
> it is paramount for deployment of services to have a tracing/ping

Trace or ping, which one do we care most about? They tend to have very different 
implementation requirements, and lumping them together at the same level of 
requirement may not be fully respecting this.

> function before these folks will deploy PWs in their networks.
> I would be okay to change "MUST" to "SHOULD" if that would
> make you happy.
> 
>         --Tom

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 03 Oct 2002 08:41:15 +0100

>> <snip>

I would be fine with SHOULD.
MUST means put the project on hold until we find a solution
and depending on what you have in mind, it is not clear that
we have such a solution on the horizon.

When you say "know the exact path", who should know the exact
path and from what point of view?

1) A user on the wire
2) A user with access to the CE
3) A user with access to the PE

Stewart

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 03 Oct 2002 09:38:34 -0400

At 08:03 AM 10/3/2002 +0200, W. Mark Townsley wrote:

>Trace or ping, which one do we care most about? They tend to have very 
>different implementation requirements, and lumping them together at the 
>same level of requirement may not be fully respecting this.

         Both are important, CV is important to detect failures and the 
other (trace) to detect
where the failure occurred. Currently MPLS LSP ping integrates both, for 
example. So,
I think that we can change the text to something like:

         It can be desirable to verify the connection status between the edges
of a PW, thus a connection verification mechanism should be supported
by PWs.  This mechanism may also be used to enhance service level agreement
verification capabilities.  Connection verification as well as other 
alarming mechanisms
such as SNMP notifications can alert the operator that a PW has lost its 
remote
connection. In these cases, it is sometimes desirable to know the exact 
functional
path of a PW for  troubleshooting purposes, thus a PW emulation service should
support PW traceroute as well.

         --Tom

>>I would be okay to change "MUST" to "SHOULD" if that would

------------------------------------------------------------------------
Mathematics is the supreme nostalgia of our time.

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 03 Oct 2002 09:42:12 -0400

>3) A user with access to the PE

         An operator with access to a PE.

         --Tom