Subject: Re: Questions from draft-ietf-pwe3-control-protocol-01.txt

From: [email-masked]
Date: Mon, 10 Feb 2003 10:18:42 +0000

David,

Regarding point 3 below, the way the draft is written, it could be either 
one-to-one or n-to-one (although n-to-one is mandatory to support). Also, 
the draft only mentions SDU mode for encapsulation of AAL5 frames, but in 
fact this could also be done using PDU encapsulation, for the reasons 
discussed in the applicability sections of draft-ietf-pwe3-atm-encap-00.txt. 

I believe that draft-ietf-pwe3-control-protocol-01.txt should provide 
support for all of the ATM encap modes, whether mandatory or optional.

Best regards,

Matthew

-----------------------------------------
Matthew Bocci
Office of the CTO
Alcatel Fixed Networks Division
-----------------------------------------

David Clear <[email-masked]>
Sent by: [email-masked]
22/01/2003 23:28

        To:     "[email-masked]'" <[email-masked]>
        cc: 
        Subject:        [PWE3] Questions from draft-ietf-pwe3-control-protocol-01.txt

Hi.  A few questions I hope you can help with. 
[Frame Relay PW over MPLS] 
1. Section 4.1 references draft-ietf-pwe3-frame-encap-01.txt, but I can't 
seem to find that draft (nor an -00 version).  Has it been superceded by 
draft-ietf-pwe3-frame-relay-00.txt?
2. If LDP is used to signal a PW type of 0x0001 (Frame Relay DLCI), does 
that correspond to the "one-to-one" mode or "port mode" encapsulation 
(from draft-ietf-pwe3-frame-relay-00.txt (if that's the current one))?
[ATM PW over MPLS] 
3. Do LDP PW types 0x9 (ATM VCC cell transport) and 0xa (ATM VPC cell 
transport) refer to "one-to-one" mode or "n-to-one" mode encaps (from 
draft-ietf-pwe3-atm-encap-00.txt)?  Section 4.2.3 reads: "Every cell that 
is received... is encapsulated according to [10], ATM cell mode...", but 
"ATM cell mode" does not zero in on a specific section from atm-encap 
draft.  I figure it's n-to-one, but I would like confirmation.

Regards, 
David.

---

From: Sasha Vainshtein <[email-masked]>
Date: Tue, 11 Feb 2003 17:52:36 +0200

Luca and all,
A brief comment on draft-ietf-pwe3-control-protocol-01.txt.

Section 5.1. specificies that, when applicabple, the "Interface Parameters"
field must be used to validate that ... the ingress and egress
ports at the edges of the circuit, have the necessary capabilities to
interoperate with each other.

For CEP PWs (which, probably unintentionally, are still called CEM in the
draft), and, more generically, for all the TDM PWs, interoperability of 
ingress and egress ports definitely requires that they are of the same
bit rate. (This does not apply to frame- or cell-oriented PWs.) However,
the draft does not provide for encoding of the ports' bit rate as part of
the "Interface Parameters" field.

I also seem to remember that the WG discussed the possibility to maintain
the list of registered PW types in a separate document. Everybody seemed
to be in favor then; but I have not seen any development in this direction.
Did I miss something?

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

---

From: Luca Martini <[email-masked]>
Date: Tue, 11 Feb 2003 18:24:13 -0700

> the "Interface Parameters" field.

I have no objection to including an interface bit rate for CEM. please write a 
section for it and send it to me this week.

> to be in favor then; but I have not seen any development in this direction.
no, mark and I run out of time.
I can split this out now, it's not too much work.
( getting to split the control word out is however much more time consuming :-( )

Luca

---

From: Shahram Davari <[email-masked]>
Date: Thu, 13 Feb 2003 11:42:13 -0800

John,

> -----Original Message-----
> From: John Fischer [mailto:[email-masked]]
> Sent: Tuesday, February 11, 2003 8:57 AM
> To: [email-masked]'
> Subject: Re: [PWE3] Questions from
> draft-ietf-pwe3-control-protocol-01.txt
> 
> 
> Hi all,
> I would like to request the editors of this draft to make
> updates in several areas:
> 4.2 ATM
>     4.2.1 Describes the N:1 AAL5 mode.  Another section with 
> a description
>         of the 1:1 AAL5 PDU mode is needed.

My suggestion is to call them SDU mode and PDU mode rather than
1:1 or N:1 AAL5. Because to be honest you can't encapsulate Nx SDUs in a 
single packet.

>     4.2.3 Does this section intend to describe the 1:1 VCC, 1:1 VPC
>         encapsulation modes?  If so, it should clearly indicate so.
>         If not, it should specify N:1 and another section for 
> 1:1 cell mode
>         as well as new PW types should be added to the document.

I think this section looks generic and applies to both 1:1 and N:1 
cell modes. May be a sentence is needed to clarify.

> 
> In order to be clear, the list of PW types in section 5 should also be
> updated:
>                0x0002   ATM AAL5 VCC transport  <<< ADD N:1 IN NAME
>                0x0003   ATM transparent cell transport <<< 
> ADD N:1 IN NAME
>                0x0009   ATM VCC cell transport  <<< ADD 1:1 IN NAME
>                0x000A   ATM VPC cell transport  <<< ADD 1:1 IN NAME

Again I suggest SDU rather than N:1 AAL5 VCC . And there is a need for 3 other code points:

                0x000B   PDU frame transport  
                0x000C   N:1 ATM VCC cell transport  
                0x000D   N:1 ATM VPC cell transport 

My suggestion is to add one more codepoint for TDM too:

                0x000E   N:1 ATM VPC cell transport 

Yours,
-Shahram		

> Thanks,
> John
> 
> [email-masked] wrote:
> 
> > David,
> >
> > 1. Section 4.1 references 
> draft-ietf-pwe3-frame-encap-01.txt, but I can't
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: John Fischer <[email-masked]>
Date: Thu, 13 Feb 2003 14:49:37 -0500

Hi Shahram,
I agree.
John