Subject: Confusion in Header Processing

From: "Renwei Li" <[email-masked]>
Date: Thu, 20 Feb 2003 14:51:30 -0800

There is a confusion between [pwe3-control] draft and [pwe3-ether-encap]
draft with respect to header processing.

According to [pwe3-ether-encap], the header processing of L2 PDUs is
part of NSP functions which can be done at either of ingress PE and
egress PE (see Fig. 3). But according to [pwe3-control], if the header
of the transported L2 PDU is modified, it MUST be done at the egress LSR
only (see Section 3).

Two different drafts should be made consistent with each other, and I
think that [pwe3-ether-encap] makes more sense than [pwe3-control] with
respect to the above point.

Just 2 cents,

Renwei

---

From: "Tommy Long" <[email-masked]>
Date: Fri, 21 Feb 2003 18:48:30 -0500

To add a few more cents....

pwe3-ethernet-encap version 2 has a conflict on whether
"tag" mode has to contain a tag.

- bottom page 4
   "An ethernet PW can operate in one of two modes: "raw mode" or
"tagged
   mode".  In tagged mode, each frame MUST contain an 802.1Q VLAN tag,
   and the tag value is meaningful to the NSPs at the two PW endpoints"

- "3.1.2. Tagged Mode

   The ethernet frame may contain an 802.1Q tag, in this..."

Tommy Long
Allied Telesyn Networks

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Renwei Li
> Sent: Thursday, February 20, 2003 5:52 PM
> To: [email-masked]
> Subject: [PWE3] Confusion in Header Processing
> 
> 
> There is a confusion between [pwe3-control] draft and 
> [pwe3-ether-encap] draft with respect to header processing.
> 
> According to [pwe3-ether-encap], the header processing of L2 
> PDUs is part of NSP functions which can be done at either of 
> ingress PE and egress PE (see Fig. 3). But according to 
> [pwe3-control], if the header of the transported L2 PDU is 
> modified, it MUST be done at the egress LSR only (see Section 3).
> 
> Two different drafts should be made consistent with each 
> other, and I think that [pwe3-ether-encap] makes more sense 
> than [pwe3-control] with respect to the above point.
> 
> Just 2 cents,
> 
> Renwei
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: "Tommy Long" <[email-masked]>
Date: Mon, 24 Feb 2003 10:37:26 -0500

Hello Bob Barrett, hope all is well....

It appears to be required as you say below
to have the tag present for tag mode; 
just want any ambiguity removed.

As for raw mode, I read it that the system is VLAN-unaware
so there may or may not be a tag but there's little need
for the NSP to look for a TPID to determine whether the
tag is there or not.

You do bring up an interesting point about how
a PW should handle nested tags.....is this in scope
and if so is it tag mode and signaled with 
PW Type ="0x0004   Ethernet VLAN"?

Tommy

> From: Bob Barrett [mailto:[email-masked]] 
> Sent: Monday, February 24, 2003 7:42 AM
> To: Tommy Long; 'Renwei Li'; [email-masked]
> Subject: RE: [PWE3] Confusion in Header Processing
> 
> 
> Tommy
> 
> Isn't this resolved by the content of the type field?
> 
> I agree that the PWE3 spec should be unambiguous. Raw mode 
> requires a normal type field, tagged mode requires a VLAN type field.
> 
> Note that 802.1 is currently debating nested tagging.
> 
> Bob
> 
> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of Tommy Long
> Sent: Friday, February 21, 2003 11:48 PM
> To: 'Renwei Li'; [email-masked]
> Subject: RE: [PWE3] Confusion in Header Processing
> 
> 
>    "An ethernet PW can operate in one of two modes: "raw 
> mode" or "tagged
> > From: [email-masked] [mailto:[email-masked]] On Behalf Of 
> > Renwei Li
> > of the transported L2 PDU is modified, it MUST be done at 
> the egress 
> > LSR only (see Section 3).
> >
> other, and I 
> > think that [pwe3-ether-encap] makes more sense than [pwe3-control] 
> > with respect to the above point.
> >
> > Just 2 cents,
> >
> > Renwei