Subject: OAM/RM cell handling in martini draft

From: Shahram Davari <[email-masked]>
Date: Thu, 13 Feb 2003 12:04:00 -0800

Hi,
 
It seems that in case of PDU mode the draft says OAM/RM cells should be transported using
the ATM VCC cell mode. First of all it is not clear whether this means N:1 or 1:1 cell modes. Secondly
assuming that the intent is to use 1:1 cell mode, there is still a difference between 1:1 cell mode header
and PDU frame mode header. This means that some packets in an LSP have different format, which
makes the processing a bit complicated.
 
My suggestion is:
 
1) Either make the header format the same for 1:1 and PDU mode (just replace FRAG with PTI), or
2) Send the OAM/RM cells in PDU mode and redefine the M-bit to mean OAM/RM cell.
 
Yours,
Shahram

---

From: John Fischer <[email-masked]>
Date: Fri, 14 Feb 2003 11:41:59 -0500

Hi Shahram,
The intention is to use 1:1 VCC cell mode to send
the OAM/RM cell.  The header is as you suggest in
your point 1, "the same for 1:1 and PDU mode (just
replace FRAG with PTI)"

1:1 VCC AAL5 PDU
|M|V|Res|Frg|E|C|

1:1 VCC Cell
|M|V|Res| PTI |C|

where the Mode bit (M) is set to 0 if the packet
contains an ATM cell. If set to 1, the packet
contains an AAL5 payload.
John

> Shahram Davari wrote:

---

From: Shahram Davari <[email-masked]>
Date: Fri, 14 Feb 2003 08:47:43 -0800

Hi John,

My suggestion (1) was basically to make the PDU mode header
the same as cell mode header. Otherwise a single LSP would be
carrying a mix of two different modes (formats). The egress
processing is not trivial any more, meaning that the egress
can't statically parse the packet, rather the parsing needs to
be dynamic, meaning the meaning of the fields in the packet
now depend on a flag (ie, M).

Yours,
-Shahram 

> -----Original Message-----
> From: John Fischer [mailto:[email-masked]]
> Sent: Friday, February 14, 2003 11:42 AM
> To: Shahram Davari
> Cc: [email-masked]'
> Subject: Re: [PWE3] OAM/RM cell handling in martini draft
> 
> 
> Hi Shahram,
> > the ATM VCC cell mode. First of all it is not clear whether 
> this means
> > N:1 or 1:1 cell modes. Secondly
> > and PDU frame mode header. This means that some packets in 
> an LSP have
> > different format, which

---

From: John Fischer <[email-masked]>
Date: Fri, 14 Feb 2003 11:58:09 -0500

Hi Shahram,
This is the side effect of carrying cells on a fram mode
connection.  Yes, the Mode bit needs to be parsed, that's
why its there.
John