Subject: Re: PWE3 congestion

From: Luca Martini <[email-masked]>
Date: Tue, 11 Feb 2003 18:42:01 -0700

it sounds like a reasonable approach.
It would be nice to  point out somewhere that the several PW layer2 payloads 
assume 100% delivery , and therefore PW should probably be run over a PSN that 
can guarantee 100% frame delivery for the pw class of service.

Luca

Stewart Bryant wrote:
> I am looking at the congestion section of the arch
> revision (we need one). It seems to me that we can divide the
> problem up into two traffic classes:
> 
> o Traffic known (perhaps by SLA, perhaps by audit) to be TCP
> friendly
> 
> o Traffic of unknown provenance
> 
> In the former case we need do nothing. Natural packet discard
> will feed back to the transport layer, and the right things
> will happen. I include in this case IP over packet PW, and IP
> over ATM PW. I propose that the term "TCP friendly" be left
> sufficiently general that it covers any IETF transport (they
> are all supposed to be TCP friendly), and other similar
> transports such as TP4 (if it still exists).
> 
> For the "traffic of unknown provenance", it seems to me that
> <draft-ietf-tsvwg-tfrc-05.txt>
> could be used to calculate the maximum offered load, and
> the PE would then be required to maintain it's load below
> this rate (if necessary by shutting down PWs). The
> statistics needed to operate this algorithm look a bit
> daunting for a forwarding system, but presumably
> some stastical view of the counters, a priori knowledge
> of the bit rate etc would simplify things.
> 
> Has anyone elso looked at this, and does it seem like the
> right way to go?
> 
> Stewart
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: Chris Metz <[email-masked]>
Date: Wed, 12 Feb 2003 06:58:25 -0500

At 06:42 PM 2/11/2003 -0700, Luca Martini wrote:
>It would be nice to  point out somewhere that the several PW layer2 
>payloads assume 100% delivery , and therefore PW should probably be run 
>over a PSN that can guarantee 100% frame delivery for the pw class of service.

Does such a PSN operating a today's speeds exist :-)

Getting back to the notion of PWE3 congestion control I too am intrigued. 
The approach with TCP-style traffic operating over the PW is the correct 
one. Regarding traffic of unknown provenance the question would be how to 
implement the feedback loop so that the ingress PE is make aware of 
congestion and can take appropriate action. I am presuming we are not 
talking about encapsulating PWs in TCP/SCTP sessions between the PW 
end-points :-) so it seems we need what some sort of ABR-style closed loop?

Cheers ...