Subject: Comments on Martini PDU mode

From: Shahram Davari <[email-masked]>
Date: Fri, 7 Feb 2003 07:59:41 -0800

Dear colleagues,
 
As some of you may know, ATM Forum has recently approved a minor change to the PDU frame transport mode.
ATM Forum has changed the 2-bit FRAG field to a single field called UU-bit, that would be copied from the last
encapsulated ATM cell's header. The reasons for this change are as following:
 
1) Although PDU mode does not state explicitly what are the procedures for fragmentation at the ingress and de-fragmentation at the egress side, but it implicitly assumes that the AAL5 PDU is reassembled at the egress PE. It seems that for reducing the latency and for simplicity in processing, there is no need to reassemble the fragments at the egress PE. Rather each received fragment could be segmented to constituents ATM cells without waiting to reassemble the whole AAL5 frame. All known implementation of PDU mode behave as such.
 
2) Considering the above point, it seems that out of the currently defined values for FRAG:
 
"Frg (Fragmentation) Bits

       This field is used to support the fragmentation functionality
       described later in this section.
     - 11 Single Segment Message (Beginning and End of Message)
     - 10 Beginning of Message
     - 00 Continuation of Message
     - 01 End of Message "
 
The Beginning of Message (10) and the continuation of message (00) are not needed for the egress
processing. And therefore a single bit could be used to keep the transparency of the AAL5 EOM (End of Message).
This field could be called UU-bit and be copied from the header of the last cell of the fragment to the PW header.
 
I would like to propose changing the PDU mode in Martini draft to simplify the processing, reduce latency and buffering requirements at the egress PE. 
 
Yours,
Shahram Davari
Senior Product Research Engineer
R&D Research Ottawa
PMC-Sierra, Inc.
Phone: (613) 271-4018
Fax:   (613) 271-6468

---

From: Shahram Davari <[email-masked]>
Date: Fri, 7 Feb 2003 08:21:28 -0800

Dear colleagues,
 
I forgot to mention another important reason for such a proposed change:
 
3) As stated in the draft, Fragmentation is mainly used for preserving the ATM OAM cell position in respect to AAL5 composite cells. Reassembling the AAL5 PDU at the egress PE would cause repositioning of the OAM cells with respect to the AAL5 composite cells. Therefore to preserve OAM cells position, the egress should not reassemble the AAL5 PDU. And since no reassembling is required, there there is no need to identify beginning and middle of message.
 
Yours,
Shahram

-----Original Message-----
From: Shahram Davari 
Sent: Friday, February 07, 2003 11:00 AM
To: [email-masked]'
Subject: [PWE3] Comments on Martini PDU mode

Dear colleagues,

 

 

Yours,
Shahram Davari

---

From: [email-masked]
Date: Mon, 10 Feb 2003 09:53:35 +0000

Hi Shahram,

I agree with you. The individual fragments should never be reassembled at 
the egress side. The process is actually quite simple, as you describe. 

Best regards,

Matthew

-----------------------------------------
Matthew Bocci
Office of the CTO
Alcatel Fixed Networks Division
-----------------------------------------

Shahram Davari <[email-masked]>
Sent by: [email-masked]
07/02/2003 15:59

        To:     "[email-masked]'" <[email-masked]>
        cc: 
        Subject:        [PWE3] Comments on Martini PDU mode

Dear colleagues,
 
As some of you may know, ATM Forum has recently approved a minor change to 
the PDU frame transport mode.
ATM Forum has changed the 2-bit FRAG field to a single field called 
UU-bit, that would be copied from the last
encapsulated ATM cell's header. The reasons for this change are as 
following:
 
1) Although PDU mode does not state explicitly what are the procedures for 
fragmentation at the ingress and de-fragmentation at the egress side, but 
it implicitly assumes that the AAL5 PDU is reassembled at the egress PE. 
It seems that for reducing the latency and for simplicity in processing, 
there is no need to reassemble the fragments at the egress PE. Rather each 
received fragment could be segmented to constituents ATM cells without 
waiting to reassemble the whole AAL5 frame. All known implementation of 
PDU mode behave as such.
 
2) Considering the above point, it seems that out of the currently defined 
values for FRAG:

 
The Beginning of Message (10) and the continuation of message (00) are not 
needed for the egress
processing. And therefore a single bit could be used to keep the 
transparency of the AAL5 EOM (End of Message).
This field could be called UU-bit and be copied from the header of the 
last cell of the fragment to the PW header.
 
I would like to propose changing the PDU mode in Martini draft to simplify 
the processing, reduce latency and buffering requirements at the egress 
PE. 
 
Yours,
Shahram Davari

---

From: [email-masked]
Date: Mon, 10 Feb 2003 10:38:30 -0000

Shahram,  Like Matthew I also agree with you.....and your subsequent posting
(7 Feb) where you said the following makes this change forced anyway:

"3) As stated in the draft, Fragmentation is mainly used for preserving the
ATM OAM cell position in respect to AAL5 composite cells. Reassembling the
AAL5 PDU at the egress PE would cause repositioning of the OAM cells with
respect to the AAL5 composite cells. Therefore to preserve OAM cells
position, the egress should not reassemble the AAL5 PDU. And since no
reassembling is required, there there is no need to identify beginning and
middle of message."

regards, Neil

> From: [email-masked] [mailto:[email-masked]]
> Sent: 10 February 2003 09:54
> To: Shahram Davari
> Cc: [email-masked]'; [email-masked]
> Subject: Re: [PWE3] Comments on Martini PDU mode
> 
> 
> Hi Shahram,
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: Chris Metz <[email-masked]>
Date: Fri, 28 Feb 2003 15:45:18 -0500

At 08:21 AM 2/7/2003 -0800, Shahram Davari wrote:
>3) As stated in the draft, Fragmentation is mainly used for preserving the 
>middle of message.

Hey Shahram-
So to be clear, what is happening at the egress PE is that the no assembly 
of the original AAL5 PDU is taking place, correct?. How about the fragments 
of the original AAL5 PDU? If those are not being reassembled then what is 
happening? ... each constituent cell of the AAL5 PDU transmitted 
individually (and in order)?

Thanks for the clarification, cheers ...

>>1) Although PDU mode does not state explicitly what are the procedures 
>>for fragmentation at the ingress and de-fragmentation at the egress side, 
>>but it implicitly assumes that the AAL5 PDU is reassembled at the egress 
>>PE. It seems that for reducing the latency and for simplicity in 
>>processing, there is no need to reassemble the fragments at the egress 
>>PE. Rather each received fragment could be segmented to constituents ATM 
>>cells without waiting to reassemble the whole AAL5 frame. All known 
>>implementation of PDU mode behave as such.
>>
>>I would like to propose changing the PDU mode in Martini draft to 
>>simplify the processing, reduce latency and buffering requirements at the 
>>egress PE.
>>
>>Yours,
>>Shahram Davari

---

From: Shahram Davari <[email-masked]>
Date: Fri, 28 Feb 2003 12:48:58 -0800

Yes, the fragments will be chopped to individual cells and sent in order they arrive at the egress PE.
 
-Shahram

-----Original Message-----
From: Chris Metz [mailto:[email-masked]]
Sent: Friday, February 28, 2003 3:45 PM
To: Shahram Davari
Cc: Shahram Davari; [email-masked]'
Subject: RE: [PWE3] Comments on Martini PDU mode

Dear colleagues,

Hey Shahram-
So to be clear, what is happening at the egress PE is that the no assembly of the original AAL5 PDU is taking place, correct?. How about the fragments of the original AAL5 PDU? If those are not being reassembled then what is happening? ... each constituent cell of the AAL5 PDU transmitted individually (and in order)?

Yours,
Shahram

-----Original Message-----
From: Shahram Davari 
Sent: Friday, February 07, 2003 11:00 AM
To: [email-masked]'
Subject: [PWE3] Comments on Martini PDU mode

Dear colleagues,

 

 

Yours,
Shahram Davari