Subject: RE: pw establishment

From: "Busschbach, Peter B (Peter)" <[email-masked]>
Date: Thu, 28 Aug 2003 16:23:57 -0400

Manomugdha,

Most of your questions should be answered by draft-ietf-pwe3-control-protocol-03.txt. 

See further comments in-line

Peter

> -----Original Message-----
> From: manomugdha biswas [mailto:[email-masked]]
> Sent: Thursday, August 28, 2003 6:54 AM
> To: manomugdha biswas; [email-masked]
> Cc: [email-masked]
> Subject: [PWE3] pw establishment
> 
> 
>  Hi All,
>   I have two questions?
> 
> i) How the ATM connection (VCC and VPC) are
> distinguished?

The LDP Mapping message that is used to set up the PW contains a "PW type". For ATM encapsulation, this type field specifies whether it is a VCC or VPC. See draft-ietf-pwe3-iana-allocation-01.txt.

>    If I want to make a VPC then what things I have to
> do and if I want to make a VCC then what I have to do?

Somehow the two PEs need to find out that they need to set up a PW to carry one or more VPCs or VCCs. How this happens is outside the scope of PWE3. In general it would happen through provisioning by the operator or through the reception of signaling messages from adjacent ATM switches.

Once the PEs know about the PW that needs to be set up and the VPCs and/or VCCs that are mapped onto that PW, establishment of the PW is straightforward. It is described in draft-ietf-pwe3-control-protocol-03.txt.

> 
> It will be great help if you please clarify the above.
> 
> II) what are the necessary steps to setup a PW
>   (Pseudowire)??
>   
>   Are the following steps below right way to do it ??
>   
>   1. Establish LDP session (using Hellow packet)
>   2. Establish LSP in bi-directional mode (using RSVP
> Path
>   Message).

No, the current proposal is to use targeted LDP to set up two LSPs that together form one PW.

>   
>   Manomugdha
>  
> 
> 
> =====
> Manomugdha Biswas
> 
> ______________________________________________________________
> __________
> Yahoo! India Promos: Win TVs, Bikes, DVD players & more!
> Go to http://in.promos.yahoo.com
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: manomugdha biswas <[email-masked]>
Date: Fri, 29 Aug 2003 15:35:51 +0100 (BST)

Hi, 
 I need some clarification on the following lines:

No, the current proposal is to use targeted LDP to
 set up two LSPs that together form one PW.

For example: 
I want to simulate the following topology:

  Ethernet  ---------   MPLS      ---------  
 ----------|   PE    |-----------|   PE    |
           |  Ingress|   PW      |  Igress |
           |  Router |           |  Router |
            ---------             ---------

I want to send an ethernet packet through PE which
then encapsulates the packet and sends it through PSN
(here it is MPLS). In this case what are the necessary
steps to setup the PW?

Please tell me the steps with the necessary message
types (targeted) to be used.

In draft "draft-ietf-pwe3-control-protocol-03.txt" 
section 5. LDP

The PW label bindings are distributed using the LDP
downstream
   unsolicited mode described in [1]. The PEs will
establish an LDP
   session using the Extended Discovery mechanism
described in [1,
   section 2.4.2 and 2.5].

This para says that PEs will establish an LDP session
using Targeted Hello Message.

Now what next we need to do to setup PW? Is it another
round of PDU exchange (Label Request and Label
Mapping)?

Thanks,
Manomugdha

 --- "Busschbach, Peter B (Peter)"
<[email-masked]> wrote: > Manomugdha,
> The LDP Mapping message that is used to set up the
> PW contains a "PW type". For ATM encapsulation, this
> type field specifies whether it is a VCC or VPC. See
> draft-ietf-pwe3-iana-allocation-01.txt.
> 
> Somehow the two PEs need to find out that they need
> to set up a PW to carry one or more VPCs or VCCs.
> How this happens is outside the scope of PWE3. In
> general it would happen through provisioning by the
> operator or through the reception of signaling
> messages from adjacent ATM switches.
> 
> Once the PEs know about the PW that needs to be set
> up and the VPCs and/or VCCs that are mapped onto
> that PW, establishment of the PW is straightforward.
> It is described in
> draft-ietf-pwe3-control-protocol-03.txt.
> 
> > 
> No, the current proposal is to use targeted LDP to
> set up two LSPs that together form one PW.
> 
> >   
> >   Manomugdha
> >  
> > 
> > 
> > =====
> > Manomugdha Biswas
> > 
> >
>

=====
Manomugdha Biswas

________________________________________________________________________
Yahoo! India Promos: Win TVs, Bikes, DVD players & more!
Go to http://in.promos.yahoo.com