Subject: Ethernet PW question

From: Shahram Davari <[email-masked]>
Date: Tue, 16 Sep 2003 07:56:09 -0700

Hi,
 
The Ethernet draft says:
 
   "In both modes, the service-delimiting tag values have only local
   significance, i.e., are meaningful only at a particular PE-CE
   interface.  When tagged mode is used, the PE that receives a frame
   from the PW may rewrite the tag value, or may strip the tag entirely,
   or may leave the tag unchanged, depending on its configuration.  When
   raw mode is used, the PE that receives a frame may or may not need to
   add a service-delimiting tag before transmitting the frame to the CE;
   however it may not rewrite or remove any tags which are already
   present."

Shouldn't the last sentence be:
 
however it MUST not rewrite or remove any tags which are already present.

Thanks,
-Shahram

---

From: Shahram Davari <[email-masked]>
Date: Wed, 17 Sep 2003 08:34:37 -0700

Thanks Eric,

Could we then change it to MUST not.

Thanks,
-Shahram

>-----Original Message-----
>From: Eric Rosen [mailto:[email-masked]]
>Sent: Wednesday, September 17, 2003 9:31 AM
>To: Shahram Davari
>Cc: [email-masked]'
>Subject: Re: [PWE3] Ethernet PW question 
>
>
>
>>> it may not rewrite or remove any tags which are already present."
>
>Shahram> Shouldn't  the last  sentence be:  however it  MUST 
>not  rewrite or
>Shahram> remove any tags which are already present. 
>
>I think  that "may not"  and "must not"  are synonymous in  
>English, however
>"MUST NOT" would probably the the most easily understood way 
>of saying it. 
>

---

From: [email-masked]
Date: Wed, 17 Sep 2003 23:21:32 +0100

Eric/Shahram,

'may' and 'must' don't have the same strength in Engish IMO.  'May' implies
something as being 'at discretion' (ie optional), whereas 'must' implies it
is mandatory.

regards, Neil

> Sent: 17 September 2003 14:31
> To: Shahram Davari
> Cc: [email-masked]'
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>