Subject: I-D ACTION:draft-vain-stein-pwe3-satop-00.txt

From: [email-masked]
Date: Thu, 04 Sep 2003 14:48:52 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: Structure-Agnostic TDM over Packet (SAToP)
	Author(s)	: S. Vainshtein, J. Stein
	Filename	: draft-vain-stein-pwe3-satop-00.txt
	Pages		: 15
	Date		: 2003-9-4
	
This document describes a pseudowire encapsulation for TDM (T1, E1, T3, 
E3) bit-streams that disregards any structure that may be imposed on 
these streams, in particular the structure imposed by the standard TDM 
framing [G.704].

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-vain-stein-pwe3-satop-00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-vain-stein-pwe3-satop-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-vain-stein-pwe3-satop-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Sasha Vainshtein <[email-masked]>
Date: Sat, 6 Sep 2003 11:16:38 +0200

Hi all,
As agreed at the Vienna PWE3 session,Yaakov and I have submitted
a common draft describing encapsulation of unstructured (the new
slang in "structure-agnostic") TDM bit-streams as PWs.

We hereby ask to accept this document as a WG item on the Standards Track.

----------------------------------------------------------------------------
--------
With best regards,
                          Sasha Vainshtein and Yaakov Stein
email:   [email-masked] 
         [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, September 04, 2003 8:49 PM
> Cc: [email-masked]
> Subject: [PWE3] I-D ACTION:draft-vain-stein-pwe3-satop-00.txt
> 
>

---

From: Shahram Davari <[email-masked]>
Date: Mon, 8 Sep 2003 08:25:19 -0700

Hi,

I also support adapting it as a WG draft.

-Shahram

>From: Max Riegel [mailto:[email-masked]]
>Sent: Monday, September 08, 2003 11:04 AM
>To: PWE3 WG (E-mail)
>Cc: Stewart Bryant (E-mail); Danny McPherson (E-mail); 
>[email-masked];
>[email-masked]
>Subject: Re: FW: [PWE3] I-D ACTION:draft-vain-stein-pwe3-satop-00.txt
>
>
>At 06.09.2003 11:16 +0200, Sasha Vainshtein wrote:
>
>Even if there exist some open technical issues I would 
>strongly support to 
>adopt this contribution as WG item. Taken the list of editors and 
>contributors I would assume that we can reach working group 
>consensus for a 
>solution for unstructured TDM emulation based on this contribution.
>
>Bye
>Max
>
>_______________________________________________
>pwe3 mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: [email-masked]
Date: Wed, 10 Sep 2003 09:49:38 +0100

I too support this becoming a working group draft, and would like to 
convey my thanks to Yaakov and Sasha for pulling this together. Nice work!
Tim

Luca Martini <[email-masked]>
Sent by: [email-masked]
10-Sep-2003 12:41 AM

        To:     "PWE3 WG (E-mail)" <[email-masked]>
        cc:     Shahram Davari <[email-masked]>, "'Max Riegel'" 
<[email-masked]>, "Stewart Bryant (E-mail)" 
<[email-masked]>, "Danny McPherson (E-mail)" <[email-masked]>, 
[email-masked], [email-masked]
        Subject:        Re: FW: [PWE3] I-D ACTION:draft-vain-stein-pwe3-satop-00.txt

I also agree that this draft should be adopted as a WG document.

Shahram Davari wrote:
>>>We hereby ask to accept this document as a WG item on the 
>>
>>Standards Track.
>>
>>>>E3) bit-streams that disregards any structure that may be 
>>
>>imposed on
>>

---

From: Sasha Vainshtein <[email-masked]>
Date: Wed, 10 Sep 2003 12:35:26 +0200

Amnon
Thank you for supporting the draft.
Please see also some inline comments to your proposals.

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> From: Amnon Ilan [mailto:[email-masked]]
> Sent: Wednesday, September 10, 2003 11:09 AM
> To: 'Luca Martini'; 'PWE3 WG (E-mail)'
> Cc: 'Shahram Davari'; 'Max Riegel'; 'Stewart Bryant 
> (E-mail)'; 'Danny McPherson (E-mail)'; Sasha Vainshtein; 
> [email-masked]
> Subject: RE: [PWE3] I-D ACTION:draft-vain-stein-pwe3-satop-00.txt
> 
> 
> Hi, 
> 
> I support adapting this draft, but I think there 
> should be some clarification regarding the limitations 
> of the unstructured service. 
> You may add to the introduction paragraph some sentence 
> saying that for structured TDM links (G.704) it is highly 
> recommended to use a structured method (TDMoIP or CESoPSN). 
> The main reason for that is that a loss of framing is a 
> severe situation, and working in unstructured mode makes 
> framing more vulnerable 
>
[Sasha] I think that unstructured TDM emulation provides
sufficient ability to diminish risk of OOF condition at the CE
due to packet loss in the PSN by appropriate generation of 
replacement data. E.g., for E1 emulation, replacement of the 
lost packet with the last received one effectively prevents 
OOF in the CE if the payload size is a multiple of 128 bytes 
(the period of the E1 FAS). Maybe this should be explicitly 
noted in the draft.

T1 is less sensitive to lost packets for OOF and AIS detection 
(see G.706 for details). 

Note also that the draft requires the CE-bound IWF to receive
a configurable number of **consecutive** packets prior to starting 
playout of TDM data. With proper configuration, this improves 
the chance that the CE will acquire frame synchronization at 
the beginning of playout.
>
> (the framing bits are carried across 
> the PSN and can be affected by network PDV, packet loss or 
> clock sync problems). 
>
[Sasha] I do not think that framing can be affected by the network
PDV unless you differentiate between the packets that arrived too
late to be played out and lost packets (the draft explicitly states
that such packets are treated as lost). 
I am not sure I fully understand what you mean by 
"clock sync" problems and their possible effect on
OOF at the CE.
>
>In a structured service the framing 
> bits are local.
> 
[Sasha] This is, of course, absolutely correct. However, this creates
some problems as well as solves some other. E.g., 
- the CE will never detect any errors in the emulated service 
  (unless the trunk link connecting it to the PE is faulty); 
- you cannot use such useful features as T1 FDL (often used by the SPs
  to download configuration to the CEs)
- an invalidating condition detected at one endpoint of the PW is not 
  necessarily transferred to the other end (CESoPSN provides for such 
  an option!) etc.
In other words, structured TDM emulation is neither better nor worse
than unstructured: they pursue different objectives and have different
(albeit not disjoint!) areas of applicability. In particular,
if the CE application expects a "wire-like" behavior of the emulated 
service, this is simpler to achieve with unstructured emulation without
sacrificing (under reasonable conditions) the service availability. 
These considerations should be probably reflected in the Applicability 
Statement as well as in the PWE3 TDM requirements document.
> Amnon.
... snipped to the end ...

---

From: "Amnon Ilan" <[email-masked]>
Date: Thu, 11 Sep 2003 15:57:44 +0200

Sasha, 

Please see my comments inline.

Amnon.

> From: Sasha Vainshtein [mailto:[email-masked]]
> Sent: Wed 10 September 2003 12:35
> To: [email-masked]'
> (E-mail)'; 'Danny McPherson (E-mail)'; [email-masked]; 
> 'Luca Martini'; 'PWE3 WG (E-mail)'
[Amnon] E1 multiframe (CAS or CRC) is 512 bytes. 
In order to support this you need to change the payload size to 
512 bytes and, of-course, make the replacement method a must in 
the draft.

> "clock sync" problems and their possible effect on
[Amnon] If clocks on both sides are not synced, you end up with jbuff 
overflow or underflow. The structured methods ensures that framing 
will not be effected by it.

>   (unless the trunk link connecting it to the PE is faulty);
[Amnon] There are statistics for jbuff status and peer connectivity that 
can give hints to problems in the emulated service.
Looks to me like a wrong attitude: making the service more vulnerable just 
in order to be able to have maximum error reports.
This looks similar to your discussion regarding the control protocol 
of PPP over PWs: you can give a better service to the control protocol 
(or make it local as here) and the link is more stable. The trade off is 
that you do not get the full\correct error detection functionality.
 
>   to download configuration to the CEs)
[Amnon] T1 FDL can be supported in structured methods (e.g. HDLC mode in 
TDMoIP).

>   necessarily transferred to the other end (CESoPSN provides for such 
[Amnon] Can you clarify. What is an invalidating condition?

> sacrificing (under reasonable conditions) the service availability.
[Amnon] Here we get to some subjective views. IMHO unstructured service 
is more vulnerable and more dependent on specific implementations of 
replacement algorithms and clock synchronization. Hence, I still think 
there should be some sentence on that in the SAToP draft.

---

From: "Yaakov Stein" <[email-masked]>
Date: Thu, 11 Sep 2003 18:47:35 +0300

> replacement algorithms and clock synchronization. Hence, I 
> still think there should be some sentence on that in the SAToP draft.

Actually, we were thinking about a statement detailing
the limitations, but I guess we thought it too controversial.

I suggest that in the next version we add a statement
regarding the limitations of structure-agnostic transport,
and pointers to the two (informational) structured drafts.

Y(J)S

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 12 Sep 2003 08:21:18 -0400

I also strongly support making this a WG draft.  In the next revision, I 
would like to see the language Yaakov proposes below.

Cheers,
Andy

----------

---

From: "Uri Rotshtein" <[email-masked]>
Date: Mon, 15 Sep 2003 15:10:53 +0300

Hi,

I would also recommend adopting this draft as WG item. For all this CES market we should close the standard ASAP.
This draft can open a door to interoperability between the various players in the CES market.

Uri.

-----Original Message-----
From: Sasha Vainshtein [mailto:[email-masked]]
Sent: Saturday, September 06, 2003 12:17 PM
To: PWE3 WG (E-mail)
Cc: Stewart Bryant (E-mail); Danny McPherson (E-mail); Yaakov Stein
(E-mail); Akiva Sadovski; Israel Sasson; Tim Frost (E-mail); Prayson
Pate (E-mail); E. T. Metz (E-mail)
Subject: FW: [PWE3] I-D ACTION:draft-vain-stein-pwe3-satop-00.txt

Hi all,

---

From: "Yaakov Stein" <[email-masked]>
Date: Thu, 25 Sep 2003 14:11:01 +0300

Stewart and the WG, 

Thanks to all who suffered with us through the long years
of waiting for an agreed upon TDM draft,
and especially to all those who expressed support for
our present effort in this direction.

Sasha and I will make a few minor changes based
on comments received, and will release an initial draft-ietf
version next week.

This version will incorporate some text on when structure-agnostic
transport is sufficient and when not, and will have a FFS section.

Thereafter we will individually submit updated versions
of our structured drafts.

Y(J)S

> From: Stewart Bryant [mailto:[email-masked]]
> Sent: Tuesday, September 23, 2003 9:22 PM
> To: PWE3 WG (E-mail); Yaakov Stein
> Cc: Alexander Vainshtein
> Sash and Yaakov
> Danny and I agree that there is WG concenus for this to become a
> WG draft.
> 
> Thanks for pulling this together.
> 
> Stewart
> 
> Sasha Vainshtein wrote:
> 
> > Hi all,

---

From: Sasha Vainshtein <[email-masked]>
Date: Thu, 25 Sep 2003 17:27:41 +0200

Hi all,
I'd like to add a special "thank you" to Danny who has suffered 
two TDM design teams on the way to an agreed upon TDM draft.

With best regards,
                                   Sasha Vainshtein

> From: Yaakov Stein [mailto:[email-masked]]
> Sent: Thursday, September 25, 2003 1:11 PM
> To: [email-masked]; PWE3 WG (E-mail)
> Cc: Sasha Vainshtein
> Subject: RE: FW: [PWE3] I-D ACTION:draft-vain-stein-pwe3-satop-00.txt
> 
> 
> Stewart and the WG, 
> 
> > Subject: Re: FW: [PWE3] I-D 
> ACTION:draft-vain-stein-pwe3-satop-00.txt
> > 
> > 
> > Sash and Yaakov
> >