Subject: Another Ethernet PW question

From: "Marichetty, Venkatesan" <[email-masked]>
Date: Fri, 19 Sep 2003 12:31:53 -0400

Hi All,
 
   I have a couple of similar questions. Can somebody please answer them?
 
1.  In section 3.1.2 (draft-ietf-pwe3-ethernet-encap-03.txt) it's been
stated that in tagged mode every frame must have a "service-delimiting" VLAN
tag. Consider the scenario, when PE receives a frame from CE which already
has a VLAN tag (placed by CE) which is not a "service-delimiting" tag. In
this situation, is PE supposed to add a "service-delimiting" VLAN tag on top
of the CE VLAN tag?
 
2. How to identify a "service-delimiting" VLAN tag? Is it expected that the
user will configure at PE, for ex, list of tags as  "service-delimiting"
tags and based on the encapsulation mode determine whether to strip it (raw)
or keep it (tagged)?
 
thanks
Mari

-----Original Message-----
From: Shahram Davari [mailto:[email-masked]]
Sent: Thursday, September 18, 2003 2:21 PM
To: [email-masked]'
Subject: [PWE3] Another Ethernet PW question

Hi,
 
Imagine the following scenario.
 
A customer tells the its service provider:
 
Send all my Ethernet packets with VLAN = X to Dest A
Send all my Ethernet packets with VLAN = Y to Dest B
Send all my Ethernet packets without any VLAN to Dest C
 
Is this VLAN tag considered to be service-delimiting tag? if so then what
about
packets without VLAN tag? how should they be treated in tagged mode? should
a configured VLAN tag be added to them before encapsulating is MPLS?
 
Thanks,
_________________________________________ 
Shahram Davari, B.Eng., M.A.Sc. 
Senior Product Research Engineer 
PMC-Sierra, Inc. 
Tel: (613)271-4018 
Fax: (613)271-6468 
MailTo: [email-masked] 
__________________________________________

---

From: "Yongjun Im" <[email-masked]>
Date: Sat, 20 Sep 2003 12:28:00 +0900

----- Original Message ----- 
  From: [email-masked] 
  To: [email-masked]' 
  Sent: Friday, September 19, 2003 3:21 AM
  Subject: [PWE3] Another Ethernet PW question

  Hi,

  Is this VLAN tag considered to be service-delimiting tag? if so then what about
  packets without VLAN tag? how should they be treated in tagged mode? should
  a configured VLAN tag be added to them before encapsulating is MPLS?

  > The draft says like below:
     If an ethernet PW is operating in tagged mode, every frame sent on
     the PW MUST have a service-delimiting VLAN tag.  If the frame as
     received by the PE from the CE does not have a service-delimiting
     VLAN tag, the PE must prepend the frame with a dummy VLAN tag before
     sending the frame on the PW.
     Actually I'm not clear about the meaning of "service-delimiting" and "non-service
     delimiting". For instance, if PE is an L3 switch, which does L3 lookup without
     doing L2(ethernet mac) switching, is supposed to support pwe3 functionality,
     then do we still need to tell "service-delimiting" tag from "non-service-delimiting one?
     In that case, I believe that tagged mode means "service-delimiting" and raw mode means 
     "non-service-delimiting". So in raw-mode we should not , we just need to pass it through 
     PW tunnel transparently without determining whether an incoming Ethernet frame has any VLAN tag

  Thanks,

---

From: Shahram Davari <[email-masked]>
Date: Mon, 22 Sep 2003 08:22:35 -0700

Hi Eric,

I believe if a port is of the type that uses service delimiting tag (SDT),
then all frames without SDT (except L2 control frames), are assumed to belong
to a default (or configured if you wish) SDT.

Here is what MEF (Metro Ethernet Forum) is standardizing:

"The EVC for a Service Frame MUST be identified by the Customer Edge VLAN ID (CE-VLAN
ID). There are 4095 CE-VLAN IDs numbered 1 through 4095. The CE-VLAN ID for a Service
Frame with an IEEE 802.1Q tag MUST be the value of the VLAN ID, if not 0, in the tag.
Untagged and priority tagged Service Frames MUST have the same CE-VLAN ID whose value
MUST be configurable to any value in the range 1, 2, ., 4094."

Yours,
-Shahram

>From: Eric Rosen [mailto:[email-masked]]
>Sent: Friday, September 19, 2003 3:35 PM
>To: Marichetty, Venkatesan
>Cc: [email-masked]'
>Subject: Re: [PWE3] Another Ethernet PW question 
>
>
>
>> How to identify a "service-delimiting" VLAN tag? 
>
>I think the model is the following.  A particular interface is 
>configured to
>be one of two kinds: 
>
>- uses service delimiting tags
>
>- doesn't use service delimiting tags
>
>If it  is of the  first kind, then  the VLAN tag  which is 
>seen  on ethernet
>frames received over that interface  is a service delimiting 
>tag.  Each such
>tag may  be thought of  as corresponding to  a different 
>customer.   I think
>that the  only untagged  traffic received  on that port  will 
>be  SP control
>traffic. 
>
>> Consider the scenario, when PE receives  a frame from CE 
>which already has
>> a VLAN tag (placed by CE) which is not a 
>"service-delimiting" tag.  In
>> this situation, is  PE supposed to add a  
>"service-delimiting" VLAN tag on
>> top of the CE VLAN tag? 
>
>Since the  frame was  received without a  service-delimiting 
>tag,  and since
>frames must carry service-delimiting tags  on tagged mode pws, 
>the answer is
>yes. I value of the tag to be put on would need to be 
>configured, I think. 
>
>
>
>
>
>
>_______________________________________________
>pwe3 mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: Ali Sajassi <[email-masked]>
Date: Mon, 22 Sep 2003 10:55:50 -0700

>to a default (or configured if you wish) SDT.

Yes, the untagged traffic from user can contain both user control and data 
traffic. The PE uses a default VLAN (per port/UNI) for the untagged traffic 
and thus using this default VLAN, it can index the corresponding filtering 
database.

-Ali

---

From: Shahram Davari <[email-masked]>
Date: Mon, 22 Sep 2003 10:59:11 -0700

Hi Ali,

 however, if multiple UNIs are getting muxed over the same PW, then tagged-mode PW can be used (since each UNI can be identified by service-delimiting tag imposed by the PE).

-Ali 
 
But in this case, a separate MPLS tag could be added to each UNI to distinguish between them at the egress PE. 
Since as the draft says, service-delimiting tags have only local significance at each UNI, then the only reason to use
tagged mode is that the ingress PE can't strip the service delimiting tag, and it is left to the egress PE.
 
Yours,
-Shahram

---

From: Shahram Davari <[email-masked]>
Date: Mon, 22 Sep 2003 11:06:29 -0700

Hi Ali,

Do you know what happens to the L2 control frames? Which PW they should
go to?

-Shahram

>From: Ali Sajassi [mailto:[email-masked]]
>Sent: Monday, September 22, 2003 1:56 PM
>To: Shahram Davari; [email-masked]'; Marichetty, Venkatesan
>Cc: [email-masked]'
>Subject: RE: [PWE3] Another Ethernet PW question 
>
>
>>"The EVC for a Service Frame MUST be identified by the 
>Customer Edge VLAN 
>>ID (CE-VLAN
>>ID). There are 4095 CE-VLAN IDs numbered 1 through 4095. The 
>CE-VLAN ID 
>>for a Service
>>Frame with an IEEE 802.1Q tag MUST be the value of the VLAN 
>ID, if not 0, 
>>in the tag.
>>Untagged and priority tagged Service Frames MUST have the 
>same CE-VLAN ID 
>>whose value

---

From: Ali Sajassi <[email-masked]>
Date: Mon, 22 Sep 2003 12:24:39 -0700

Hi Shahram,

At 10:59 AM 9/22/2003 -0700, Shahram Davari wrote:
>Hi Ali,
>  however, if multiple UNIs are getting muxed over the same PW, then 
> tagged-mode PW can be used (since each UNI can be identified by 
> service-delimiting tag imposed by the PE).
>
>-Ali
>
>But in this case, a separate MPLS tag could be added to each UNI to 
>distinguish between them at the egress PE.

Yes, we can use a separate PW for each UNI. But I was just giving an 
example that if a single PW needs to be used, then you can do that by using 
tagged-mode PW and adding a service-delimiting tag for each UNI.
>Since as the draft says, service-delimiting tags have only local 
>significance at each UNI, then the only reason to use

Service-delimiting tags do have only local significance at each PE which 
means a) these tags can get over-written by ingress or egress PE before 
indexing the filtering database and b) can get stripped before sending the 
traffic through the UNI.

-Ali

---

From: Ali Sajassi <[email-masked]>
Date: Mon, 22 Sep 2003 12:34:21 -0700

>Do you know what happens to the L2 control frames? Which PW they should

In case of muxed UNI, there are two options here.
1) to send out the control frames transparently over a set of PWs that are 
associated with untagged frames. For multipoint services, this set of PWs 
needs to be a super set of PWs associated with other customer tagged frames.

2) terminated customer control frames by having the PE peer with the CE and 
then generate the control frames on a per VLAN basis. In other words, then 
control frames goes as tagged frames. In this case, no additional set of 
PWs is needed to carry the control frames.

To better understand the second case, take a look at the PE model in 
section 16.9 of the latest 802.1ad draft. I think, Mick is doing a great 
job in writing this document.

-Ali