Subject: Ethernet Question

From: Shahram Davari <[email-masked]>
Date: Tue, 23 Sep 2003 10:55:43 -0700

Hi,
 
The Ethernet draft says a VLAN tag received by a PE from CE could be a service-delimiting tag (SDT) or a Private tag.
Could there be a scenario in which the VLAN tag is both SDT and Private? For example could there be a case that a
customer has different VLANs for its departments and each department is located in a different site. In that case could the
customer ask the provider:
 
Send all my traffic with my private VLAN A to Dest X
Send all my traffic with my VLAN B to Dest Y
 
And if the answer is yes, then how are the control packets treated? are they multicast to all sites?
 
Any insights?
 
Thanks,

__________________________________________ 
Shahram Davari, B.Eng., M.A.Sc. 
Senior Product Research Engineer 
PMC-Sierra, Inc. 
Tel: (613)271-4018 
Fax: (613)271-6468 
MailTo: [email-masked] 
__________________________________________

---

From: Shahram Davari <[email-masked]>
Date: Tue, 23 Sep 2003 11:22:55 -0700

Hi,
 
Another question. Are the Service delimiting tags unique per-port or per-platform?
 
Thanks,
-Shahram

-----Original Message-----
From: Shahram Davari 
Sent: Tuesday, September 23, 2003 1:56 PM
To: [email-masked]'
Subject: [PWE3] Ethernet Question

Hi,

 
 
Any insights?
 
Thanks,

---

From: Ali Sajassi <[email-masked]>
Date: Tue, 23 Sep 2003 17:00:47 -0700

At 10:55 AM 9/23/2003 -0700, Shahram Davari wrote:
>Hi,
>
>The Ethernet draft says a VLAN tag received by a PE from CE could be a 
>service-delimiting tag (SDT) or a Private tag.
>customer has different VLANs for its departments and each department is 
>located in a different site. In that case could the

First this example only applies to VPWs and not VPLS since you don't make 
use of MAC addresses in forwarding decision. Second, once you use VLAN tag 
to select a forwarder, then that tag by definition is a service-delimiter 
tag. Third, the spec doesn't talk about "private tag" but instead 
non-service-delimiter tag. If you question is that whether a customer VLAN 
tag can be used both by the customer itself and the service provider to 
select the appropriate filtering database, then the answer is yes.

>they multicast to all sites?

Given that this is a VPWS service (and not VPLS), then the untagged traffic 
(both control and data) can be tunneled between two sites if needed.

-Ali

---

From: Ali Sajassi <[email-masked]>
Date: Tue, 23 Sep 2003 17:51:16 -0700

>Another question. Are the Service delimiting tags unique per-port or 

By platform, I am assuming you mean PE (and not CE :-)

The answer is Yes :-) it can be for either.
If the PE has the ability to do VLAN-translation, then it can be per port 
but if it doesn't, then it can be per PE. It should be noted that the later 
requires co-ordination of VLAN tags with customers.

-Ali

---

From: Shahram Davari <[email-masked]>
Date: Wed, 24 Sep 2003 08:55:43 -0700

Hi Ali,

-----Original Message-----
From: Ali Sajassi [mailto:[email-masked]]
Sent: Tuesday, September 23, 2003 8:01 PM
To: Shahram Davari; [email-masked]'
Subject: Re: [PWE3] Ethernet Question

Hi,

First this example only applies to VPWs and not VPLS since you don't make use of MAC addresses in forwarding decision. 
 Second, once you use VLAN tag to select a forwarder, then that tag by definition is a service-delimiter tag. Third, the spec doesn't talk about "private tag" but instead non-service-delimiter tag. If you question is that whether a customer VLAN tag can be used both by the customer itself and the service provider to select the appropriate filtering database, then the answer is yes.

Given that this is a VPWS service (and not VPLS), then the untagged traffic (both control and data) can be tunneled between two sites if needed.  
 
But there is only one instance of control protocols for the entire customer network, which are all untagged.
So it seems the correct behavior is to multicast it to all sites. In your suggestion how can the customer exchange
control protocols with other sites?
 
Yours,
-Shahram

-Ali

Any insights?
 
Thanks,

---

From: Ali Sajassi <[email-masked]>
Date: Wed, 24 Sep 2003 10:47:38 -0700

>
>But there is only one instance of control protocols for the entire 
>customer network, which are all untagged.

It depends what the customer wants to do. If the customer is trying to 
connect its sites with a service similar to FR or ATM, then he wants to 
have PtP connectivity among its sites. In such scenarios, the CEs are 
routers and each VLAN can serve as a sub-interface for that CE router. 
However, if the customer wants to connect its sites with a multipoint 
service (e.g., VPLS) and use a muxed UNI, then if the CEs are bridges, then 
the provider has two options in handling the control messages as described 
in my previous emails.

Cheers,
Ali

---

From: "Prabakaran T Sampath" <[email-masked]>
Date: Wed, 24 Sep 2003 13:19:49 +0530

Hi,

In my understanding service delimiting tags(SDT) no need to be unique
per-port or per-platform.
The case which you are describing about sending different VLAN's from the CE
is possible
means then the SDT no need to be unique.

Thanks and regards,
Prabakaran T.S.
Future Software Limited,
480-481, Anna Salai,
Chennai - 600035, India.
Web: www.futsoft.com
email: [email-masked]
Off Phone: 91-44-24330550 - Extn: 413
--------------------------------------------------------

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of Shahram
Davari
  Sent: Tuesday, 23 September 2003 11:53 PM
  To: Shahram Davari; [email-masked]'
  Subject: RE: [PWE3] Ethernet Question

  Hi,

  Another question. Are the Service delimiting tags unique per-port or
per-platform?

  Thanks,
  -Shahram
    -----Original Message-----
    From: Shahram Davari
    Sent: Tuesday, September 23, 2003 1:56 PM
    To: [email-masked]'
    Subject: [PWE3] Ethernet Question

    Hi,

    The Ethernet draft says a VLAN tag received by a PE from CE could be a
service-delimiting tag (SDT) or a Private tag.
    Could there be a scenario in which the VLAN tag is both SDT and Private?
For example could there be a case that a
    customer has different VLANs for its departments and each department is
located in a different site. In that case could the
    customer ask the provider:

    And if the answer is yes, then how are the control packets treated? are
they multicast to all sites?

    Any insights?

    Thanks,

***************************************************************************
This message is proprietary to Future Software Limited (FSL) 
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information 
and should not be circulated or used for any purpose other than for 
what it is intended. 

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. 
FSL accepts no responsibility for loss or damage arising from 
the use of the information transmitted by this email including
damage from virus.
***************************************************************************

---

From: Eric Rosen <[email-masked]>
Date: Thu, 25 Sep 2003 10:02:39 -0400

Most of these  questions really have to do with how  a service provider sets
up an  ethernet-based VPWS service  to do what  the customer needs  done.  I
think that is beyond the scope of the drafts; there are many ways a provider
can set up his service, using either tagged mode or raw mode.