Subject: RE: Draft Satop: T1 payload

From: "Yaakov Stein" <[email-masked]>
Date: Mon, 8 Sep 2003 07:51:24 +0300

Ron, 

> Sasha, 
> 
> I think you took the wrong approach in specifying T1 payload. Your
> original suggestion of adding one byte that holds the 193th bit was
> better. 

I fully agree. 193 was our original suggestion.
However, an early draft that circulated generated
complaints from people who wanted all payload sizes to
divide by four. 

> The approach in the current draft doesn't allow granularity of
> less than 1ms, which I think is problematic for low end to end delay
> applications.

Actually 192 IS less than 1 ms. 193 isn't.  ;)

> The T1 payload specification is also problematic to applications that
> want to translate information from/to SONET emulation. The basic
> structure that holds an equivalent of frame size is broken in the
> current draft specification.

This is SAToP, and by Structure Agnostic we mean just that.
We don't know about structure or frame sizes.

If you care about T1 framing then you should use one of the
other specifications (CESoPSN or TDMoIP) which will be submitted
as informational.

Y(J)S

---

From: Sasha Vainshtein <[email-masked]>
Date: Thu, 11 Sep 2003 15:06:00 +0200

Ron,
I understand your concerns wrt limitations of the SAToP draft 
when it comes to packetization latency for T1 (it cannot be
a multiple of 125 ultraseconds unless it is not also a
multiple of 1 millisecond). 

The earlier method you refer to includes an NSP acting as
a G.802/Annex 2 mapper (mapping unstructured T1 to 
fractional E1) and a PW carrying 25*DS0 (the result of 
this mapping) over the PSN. This method allows any 
packetization latency that is a multiple of 125 
ultraseconnds as well as simplifies interworking 
with certain CEP-VT PWs. However, IMO its logical 
place is in the "structured" draft - even if it 
does not require understanding of T1 structure, 
and I intend to retain it in the "purely structured" 
draft I have been invited to submit.

Hopefully this answers your questions/doubts.

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> -----Original Message-----
> From: Ron Cohen [mailto:[email-masked]]
> Sent: Sunday, September 07, 2003 8:02 PM
> To: Sasha Vainshtein; 'PWE3 WG (E-mail)'
> Cc: 'Stewart Bryant (E-mail)'; 'Danny McPherson (E-mail)'; 
> 'Yaakov Stein (E-mail)'; Akiva Sadovski; Israel Sasson; 'Tim 
> Frost (E-mail)'; 'Prayson Pate (E-mail)'; 'E. T. Metz (E-mail)'
> Subject: Draft Satop: T1 payload
> 
> 
> Sasha, 
> 
> better. The approach in the current draft doesn't allow granularity of
> Regards
> Ron
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On 
> > Behalf Of Sasha Vainshtein
> > Sent: Saturday, September 06, 2003 2:17 AM
> > To: PWE3 WG (E-mail)
> > Cc: Stewart Bryant (E-mail); Danny McPherson (E-mail); Yaakov 
> > Stein (E-mail); Akiva Sadovski; Israel Sasson; Tim Frost 
> > (E-mail); Prayson Pate (E-mail); E. T. Metz (E-mail)
> > Subject: FW: [PWE3] I-D ACTION:draft-vain-stein-pwe3-satop-00.txt
> > 
> > 
> > Hi all,
> > As agreed at the Vienna PWE3 session,Yaakov and I have submitted
> > a common draft describing encapsulation of unstructured (the new
> > slang in "structure-agnostic") TDM bit-streams as PWs.
> > 
> > We hereby ask to accept this document as a WG item on the 
> > Standards Track.
> > 
> > --------------------------------------------------------------
> > --------------
> > --------
> > With best regards,
> >                           Sasha Vainshtein and Yaakov Stein
> > email:   [email-masked] 
> >          [email-masked]
> > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]
> > > Sent: Thursday, September 04, 2003 8:49 PM
> > > Cc: [email-masked]
> > > Subject: [PWE3] I-D ACTION:draft-vain-stein-pwe3-satop-00.txt
> > > 
> > > 
> > > A New Internet-Draft is available from the on-line 
> > > Internet-Drafts directories.
> > > 
> > > 
> > > 	Title		: Structure-Agnostic TDM over Packet (SAToP)
> > > 	Author(s)	: S. Vainshtein, J. Stein
> > > 	Filename	: draft-vain-stein-pwe3-satop-00.txt
> > > 	Pages		: 15
> > > 	Date		: 2003-9-4
> > > 	
> > > This document describes a pseudowire encapsulation for TDM 
> > > (T1, E1, T3, 
> > > E3) bit-streams that disregards any structure that may be 
> > imposed on 
> > > these streams, in particular the structure imposed by the 
> > > standard TDM 
> > > framing [G.704].
> > > 
> > > A URL for this Internet-Draft is:
> > > 
> http://www.ietf.org/internet-drafts/draft-vain-stein-pwe3-satop-00.txt
> > 
> > To remove yourself from the IETF Announcement list, send a 
> message to 
> > ietf-announce-request with the word unsubscribe in the body 
> > of the message.
> > 
> > Internet-Drafts are also available by anonymous FTP. Login 
> > with the username
> > "anonymous" and a password of your e-mail address. After logging in,
> > type "cd internet-drafts" and then
> > 	"get draft-vain-stein-pwe3-satop-00.txt".
> > 
> > A list of Internet-Drafts directories can be found in
> > http://www.ietf.org/shadow.html 
> > or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> > 
> > 
> > Internet-Drafts can also be obtained by e-mail.
> > 
> > Send a message to:
> > 	[email-masked].
> > In the body type:
> > 	"FILE /internet-drafts/draft-vain-stein-pwe3-satop-00.txt".
> > 	
> > NOTE:	The mail server at ietf.org can return the document in
> > 	MIME-encoded form by using the "mpack" utility.  To use this
> > 	feature, insert the command "ENCODING mime" before the "FILE"
> > 	command.  To decode the response(s), you will need "munpack" or
> > 	a MIME-compliant mail reader.  Different MIME-compliant 
> > mail readers
> > 	exhibit different behavior, especially when dealing with
> > 	"multipart" MIME messages (i.e. documents which have been split
> > 	up into multiple messages), so check your local documentation on
> > 	how to manipulate these messages.
> > 		
> > 		
> > Below is the data which will enable a MIME compliant mail reader
> > implementation to automatically retrieve the ASCII version of the
> > Internet-Draft.
> > 
> 
>

---

From: "Ron Cohen" <[email-masked]>
Date: Thu, 11 Sep 2003 09:15:54 -0700

Sasha,

> draft I have been invited to submit.

Why shouldn't we have the same format, packet sizes, etc for both
structured and unstructured? The difference should be whether framing
bits position is known within the bit stream.

To clarify, I support making this draft a WG draft. Technical issues
should be resolved regardless.

Ron

P.S. what are ultraseconds?
 
> > implementation to automatically retrieve the ASCII version of the

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3