Subject: Draft Satop: T1 payload

From: "Ron Cohen" <[email-masked]>
Date: Sun, 7 Sep 2003 11:01:58 -0700

Sasha, 

I think you took the wrong approach in specifying T1 payload. Your
original suggestion of adding one byte that holds the 193th bit was
better. The approach in the current draft doesn't allow granularity of
less than 1ms, which I think is problematic for low end to end delay
applications.

The T1 payload specification is also problematic to applications that
want to translate information from/to SONET emulation. The basic
structure that holds an equivalent of frame size is broken in the
current draft specification.

Regards
Ron

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Sasha Vainshtein
> Sent: Saturday, September 06, 2003 2:17 AM
> To: PWE3 WG (E-mail)
> Cc: Stewart Bryant (E-mail); Danny McPherson (E-mail); Yaakov 
> Stein (E-mail); Akiva Sadovski; Israel Sasson; Tim Frost 
> (E-mail); Prayson Pate (E-mail); E. T. Metz (E-mail)
> Subject: FW: [PWE3] I-D ACTION:draft-vain-stein-pwe3-satop-00.txt
> 
> 
> Hi all,
> As agreed at the Vienna PWE3 session,Yaakov and I have submitted
> a common draft describing encapsulation of unstructured (the new
> slang in "structure-agnostic") TDM bit-streams as PWs.
> 
> We hereby ask to accept this document as a WG item on the 
> Standards Track.
> 
> --------------------------------------------------------------
> --------------
> --------
> With best regards,
>                           Sasha Vainshtein and Yaakov Stein
> email:   [email-masked] 
>          [email-masked]
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Thursday, September 04, 2003 8:49 PM
> > Cc: [email-masked]
> > Subject: [PWE3] I-D ACTION:draft-vain-stein-pwe3-satop-00.txt
> > 
> > 
> > A New Internet-Draft is available from the on-line 
> > Internet-Drafts directories.
> > 
> > 
> > 	Title		: Structure-Agnostic TDM over Packet (SAToP)
> > 	Author(s)	: S. Vainshtein, J. Stein
> > 	Filename	: draft-vain-stein-pwe3-satop-00.txt
> > 	Pages		: 15
> > 	Date		: 2003-9-4
> > 	
> > This document describes a pseudowire encapsulation for TDM 
> > (T1, E1, T3, 
> > E3) bit-streams that disregards any structure that may be 
> imposed on 
> > these streams, in particular the structure imposed by the 
> > standard TDM 
> > framing [G.704].
> > 
> > A URL for this Internet-Draft is:
> > 
http://www.ietf.org/internet-drafts/draft-vain-stein-pwe3-satop-00.txt
> 
> To remove yourself from the IETF Announcement list, send a message to 
> ietf-announce-request with the word unsubscribe in the body 
> of the message.
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-vain-stein-pwe3-satop-00.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-vain-stein-pwe3-satop-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

---

From: Max Riegel <[email-masked]>
Date: Mon, 08 Sep 2003 17:04:19 +0200

At 06.09.2003 11:16 +0200, Sasha Vainshtein wrote:

>We hereby ask to accept this document as a WG item on the Standards Track.

Even if there exist some open technical issues I would strongly support to 
adopt this contribution as WG item. Taken the list of editors and 
contributors I would assume that we can reach working group consensus for a 
solution for unstructured TDM emulation based on this contribution.

Bye
Max

> > E3) bit-streams that disregards any structure that may be imposed on

---

From: Alex Conta <[email-masked]>
Date: Fri, 12 Sep 2003 13:56:31 -0400

I and Bill Bartholomay (Transwitch) reviewed this draft and we feel that 
it should be adopted as a WG draft.

As technical comments:

Alex Conta

Section 5.
The payload size for E3, T3 is 1024. while for E1, T1 is 256 and 
respectively 192. Could the payload be:  E1, T1 = 256, and E3, T3 = 1024?

Bill Bartholomay (Transwitch)

I reviewed the SAToP document. It is well written and covers
the issues. One minor point is that DS3 uses a framed alternating
10 pattern to indicate AIS (see ANSI-T1.107-1995). Detection and
replacement in the CE-bound direction (6.2.2) could be supported
as an option, though as defined DS3 AIS would be passed along
as valid data in the PW (L bit). Just the generation of DS3 AIS
may prove useful in overcoming SAToP Defects (6.3).

Thanks,
Alex Conta

Sasha Vainshtein wrote:

> ----------------------------------------------------------------------------
> --------
> With best regards,

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 23 Sep 2003 19:22:07 +0100

Sash and Yaakov

Danny and I agree that there is WG concenus for this to become a
WG draft.

Thanks for pulling this together.

Stewart