Subject: Re: Ethernet Raw mode encapsulation

From: Eric Rosen <[email-masked]>
Date: Thu, 01 Apr 2004 13:33:07 -0500

> As per section 4.4 Ethernet of PWE3-CTRL, Ethernet frame (untagged) should
> be encapsulated with "ethernet raw mode". 

I think  sections 4.3 and  4.4 are mistaken  in requiring the use  of tagged
mode or raw mode for one or another ethernet application.  

> how does Ethernet raw mode PW can have non-service-delimiting tag, as this
> mode is only for Ethernet frame not the frame with VLAN tags

There is no  reason why raw mode  should not be used to  carry customer VLAN
tags.

---

From: "Ramalingam, Swaminathan (Swaminathan)" <[email-masked]>
Date: Mon, 5 Apr 2004 14:31:35 +0530

Eric,
Thanks for the reply. See inline.

Thanks,
Swami

>-----Original Message-----
>From: Eric Rosen [mailto:[email-masked]]
>Sent: Friday, April 02, 2004 12:03 AM
>To: Ramalingam, Swaminathan (Swaminathan)
>Cc: [email-masked]
>Subject: Re: [PWE3] Ethernet Raw mode encapsulation 
>
>
>

Is this mean, service de-limiting tags *ALWAYS* used to select an PW in
tagged mode and
NSDTs are *ALWAYS* used to select an PW in raw mode ?

>There is no  reason why raw mode  should not be used to  carry 

I too see no reason other than an overhead of 4 bytes in the payload. 
In case, if we use raw mode for VLAN frame, as per section 3.1.2,

"In both modes, non-service-delimiting tags are passed transparently
across the PW as part of the payload."

CE-VLAN tag needs to be mapped to an PW but MPLS data still need to carry 
the CE-VLAN tag (even when one-to-one mapping of CE-VLAN <-> an PW)

Pl. clarify if am wrong.

Thanks,
Swami