Subject: [PWE3] Re: IANA Allocation of New PW Type

From: Luca Martini <[email-masked]>
Date: Tue, 07 Jun 2005 22:15:33 -0600

Gerry,

Sorry , I was on vacation , and did not catch up to all my e-mails yet.
I'll consider this a last call comment ( CCing the pwe3 list )

If there is no objection the allocation will be:

 0x001A  Header-compressed packets      

However can you please send me a more descriptive one line description ?
What kind of packet ? what header is compressed ?

Thanks.
Luca

Ash, Gerald R (Jerry), ALABS wrote:

>Luca,
>Mark,
>
>I haven't heard back from you on this.  As suggested by Stewart Bryant
>and Andy Malis, could you please add the requested PW type value to the
>IANA allocation draft:
>
>PW type      Description
>0x00??       Header-compressed packets
>
>Thanks,
>Regards,
>Jerry
>
>-----Original Message-----
>From: Ash, Gerald R (Jerry), ALABS 
>Sent: Monday, May 23, 2005 1:12 PM
>To: Luca Martini; 'W. Mark Townsley'
>Cc: Ash, Gerald R (Jerry), ALABS; 'Stewart Bryant'; Danny McPherson;
>Colin Perkins; Malis, Andrew G.
>Subject: RE: IANA Allocation of New PW Type
>
>Mark,
>Luca,
>
>Per the email exchange below with Stewart Bryant, could you please add
>the following request for a PW type value to the IANA allocation draft
>http://ietf.org/internet-drafts/draft-ietf-pwe3-iana-allocation-09.txt:
>
>PW type      Description
>0x00??       Header-compressed packets
>
>This is as requested in Section 2.1 of "Protocol Extensions for Header
>Compression over MPLS"
>http://ietf.org/internet-drafts/draft-ash-avt-hc-over-mpls-protocol-00.t
>xt.
>
>Thanks,
>Regards,
>Jerry Ash
>
>-----Original Message-----
>From: Stewart Bryant [mailto:[email-masked]] 
>Sent: Monday, May 23, 2005 12:08 PM
>To: Ash, Gerald R (Jerry), ALABS
>Cc: Danny McPherson; Colin Perkins; Malis, Andrew G.; Luca Martini
>Subject: Re: IANA Allocation of New PW Type
>
>Ash, Gerald R (Jerry), ALABS wrote:
>
>  
>
>>Hi Stewart, Danny,
>>
>>We're having some discussion on the AVT list regarding assignment of a
>>new PW type as required in "Protocol Extensions for Header Compression
>>over MPLS"
>>
>>    
>>
>http://ietf.org/internet-drafts/draft-ash-avt-hc-over-mpls-protocol-00.t
>xt.
>  
>
>>In the final paragraph of Section 2.1 it says:
>>"This document requires the allocation of a new PW type to support the
>>PW signaling defined in Section 5.1 of [PW-SIG].  The PW type is a
>>15-bit parameter assigned by IANA, as specified in the [IANA]
>>    
>>
>registry.
>  
>
>>The C bit is set equal to 1 for this signaling."
>>
>>The question is who assigns the PW type value, should it be done in
>>    
>>
>the
>  
>
>>HC over MPLS draft itself, or done by IANA, as specified in Section
>>    
>>
>2.1
>  
>
>>of the iana-allocation draft
>>
>>    
>>
>http://ietf.org/internet-drafts/draft-ietf-pwe3-iana-allocation-09.txt.
>  
>
>>Perhaps another alternative is to define the PW type value in the
>>iana-allocation draft?
>>    
>>
>
>When the IANA draft completes (soon) it will cause a registry to be set
>up and IANA will allocate the numbers. Consensus values will be
>allocated
>as a result of an IANA considerations section in an RFC, but you may
>ask for a FCFS value as soon as you have a draft.
>
>However that is not set up yet, and so I suggest that you ask the
>IANA draft editors (Mark Townsley and Luca Martini) to add the
>value to the IANA draft. It would be helpful if you told them
>the exact text of the line that you wanted adding to that draft.
>
>Regards
>
>Stewart
> 
>  
>
>>Your guidance will be appreciated.
>>
>>Thanks,
>>Regards,
>>Jerry
>>    
>>
>
>  
>

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Ash, Gerald R \(Jerry\), ALABS" <[email-masked]>
Date: Wed, 8 Jun 2005 12:16:05 -0500

Hi Luca,

> I have 2 questions:
>
> Is this draft going to be a WG document in AVT soon?

Protocol extensions for header compression over MPLS (current draft at
http://ietf.org/internet-drafts/draft-ash-avt-hc-over-mpls-protocol-00.t
xt) are underway, and chartering of this work in the AVT working group
has been submitted for approval with the following milestone:
Dec 05: Submit any extensions for RTP HC on MPLS networks for Proposed
Standard

I'm hopeful (and I think it's reasonable) that by IETF-63 the milestone
will be added to the AVT charter and the draft will be accepted as an
AVT WG draft (no guarantee of course :-)

> How about "Transport header compressed packet"  for the PW type 
> description?

Yes, I think that's good.

Thanks,
Jerry

---

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 8 Jun 2005 18:14:12 +0200

Stewart, 

> 
> How does it differ from Y.1414?
> 

Y.1414 is a multiplexed stream, 
Jerry is proposing the encapsulation 
of single header-compressed VoIP streams.

As I mentioned in a previous email,
this should also apply to other (non-VoIP)
header compressed packets as well.

Y(J)S

---

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 8 Jun 2005 17:29:46 +0200

Jerry, 

I was just wondering why all compressed-header cases should be a single
PW type, 
and not separate types for cTCP (1144), IPHC (2507), cRTP (2508), and
ROHC (3095).

By lumping them all together, we are essentially stating that 
the native service is IP, and that the header compression 
is an NSP to be performed before encapsulation.
If so this work doesn't really need to be specified here at all,
and the PW type is 0x000B.

On the other hand, if we are saying that the compressed-header
packets belong to some other native network type, 
then it is within our scope (although perhaps not defined in our
charter),
but it would seem to be necessary to uniquely identify the 
type of the forwarder.

Y(J)S