Subject: [PWE3] draft-martini-pwe3-pw-switching-03.txt as WG draft?

From: Stewart Bryant <[email-masked]>
Date: Mon, 06 Jun 2005 23:16:34 +0100

The authors of

draft-martini-pwe3-pw-switching-03.txt

have asked that the draft be adopted as a WG draft.

What is the consensus of the PWE3 WG?

- Stewart

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Mustapha Aissaoui" <[email-masked]>
Date: Tue, 7 Jun 2005 11:36:56 -0400

I support making this draft a WG document.

Mustapha.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Stewart Bryant
Sent: Monday, June 06, 2005 6:17 PM
To: pwe3
Subject: [PWE3] draft-martini-pwe3-pw-switching-03.txt as WG draft?

The authors of

- Stewart

---

From: "Mark Lewis" <[email-masked]>
Date: Tue, 7 Jun 2005 17:05:37 +0100

I support this.

Mark

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Stewart Bryant
> Sent: 06 June 2005 23:17
> To: pwe3

---

From: Rahul Aggarwal <[email-masked]>
Date: Tue, 7 Jun 2005 12:48:39 -0700 (PDT)

Hi Stewart,

> What is the consensus of the PWE3 WG?

The above draft is one of the candidate solutions in the MH-PW solution
space.

To quote you and Danny from your email that described the way forward
after the discussion on draft-raggarwa-rsvpte-pw:

"The issue then becomes one of how to move forward.

There are a number of candidate signaling protocols, and
we propose that we set a limit of three weeks before the
next IETF (i.e. -00 cutoff) for any further candidate
proposals to address the MS-PW signaling requirements.

Evaluating the candidate signaling protocols and testing the
consensus of the WG on the best way to proceed will be
the major work item at the next IETF.

Stewart/Danny"

The above implies that *no* candidate signaling solution will be
adopted by the WG in the domain of MH-PWs till all the candidate
signaling protocols are discussed in the next IETF.

So let us first discuss all the MH-PW signaling solutions
and the applicability of each before deciding which one to adopt and for
which set of requirements. Until then this draft or other drafts in the
MH-PW solution space, should not be adopted as WG documents.

Thanks,
rahul

---

From: Luca Martini <[email-masked]>
Date: Tue, 07 Jun 2005 22:45:31 -0600

Rahul,

This draft really has no relation to the automatic placing of PW along a 
path. It does not offer any solution in that respect other then manual 
provisioning.
This is the basis for Interworking the control plane of many PWs , such 
as L2TPv3 , LDP( FEC 128/129) , and static PWs.
If the WG where to adopt a PW signaling method based on some other 
protocol ( say, maybe RSVP ;-) ) I would definitely add a section to 
include such protocol  as one of the protocols used to setup a PW.

Regardless of what protocol we choose to signal multi hop PWs , we must 
have a document that defines the control plane signaling Interworking 
between different PW setup protocols.

Luca

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 8 Jun 2005 12:51:57 -0400

Rahul,

	Our draft does not concern itself with signaling; its based
on static provisioning. We can add whatever signaling protocols
the PWE3 WG endorses in the future.

	--Tom

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 20 Jun 2005 14:56:21 +0100

Let me see if I can summarise the discussion.

Given some external mechnaism for creating a multi-hop
PW, draft-martini-pwe3-pw-switching-03.txt describes
how the FEC128, FEC129 and L2TPV3 PW signalling
mechanisms exchange parameters between the PW segments.
FEC128, FEC129 and L2TPV3 are extablished signalling
mechanisms that can be expected to exist for some
considerable time.

There seems to be quite strong support for adopting
the draft in this strictly limited context.

That said, it seems to me that the draft name and
title do not match the scope and content and really
ought to be changed so distingish this work from
the work on the dynamic creation of multi-hop PWs.

The work on the dynamic siganalling of multi-hop PWs
will be addressed at the next IETF, and all dynamicly
siganlled PWs are off the table until then. The deadline
for proposals is -00 cutoff Paris IETF.

One group that disagree with the adoption of this
draft is from the group that wish to use RSVP to
signal multi-hop PWs. However as far as I can see they
have not yet described how to interwork FEC128, FEC129
and L2TPV3 PWs, and I would address three questions
to that group:

1) How will you interwork with the existing PW
signalling protocols?

2) When I have two statically configured PWs, setup
using one of the existing protocols, and I wish to
connect them together, how will that work in your model?

3) Given the adoption of this draft how will that
prevent you from using RSVP as a mechanism to
dynamically signal PWs?

We also have some sage advise from Neil saying that
it is going to be very hard to make this work, and we
should note his concerns.

- Stewart

---

From: "Vach Kompella" <[email-masked]>
Date: Tue, 14 Jun 2005 15:02:12 -0700

I support it.

-Vach 

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Stewart Bryant
> Sent: Monday, June 06, 2005 3:17 PM
> To: pwe3